Fix man page to note that 'crc' format uses Sum32
This commit is contained in:
parent
3c14d841f3
commit
323456b2a5
31
star-1.5.1-crc.patch
Normal file
31
star-1.5.1-crc.patch
Normal file
@ -0,0 +1,31 @@
|
|||||||
|
diff --git a/star/cpiohdr.c b/star/cpiohdr.c
|
||||||
|
index 9c7a774..2785661 100644
|
||||||
|
--- a/star/cpiohdr.c
|
||||||
|
+++ b/star/cpiohdr.c
|
||||||
|
@@ -536,7 +536,9 @@ cpio_checkswab(ptb)
|
||||||
|
}
|
||||||
|
|
||||||
|
/*
|
||||||
|
- * This simple sum is used for the SYSvr4 file content CRC
|
||||||
|
+ * This simple sum is used for the SYSvr4 file content checksum. This is
|
||||||
|
+ * implemented like Sum32 algorithm.
|
||||||
|
+ *
|
||||||
|
* Use Int32_t to implement the same behavior as the AT&T cpio command.
|
||||||
|
*/
|
||||||
|
LOCAL Int32_t
|
||||||
|
diff --git a/star/star.1 b/star/star.1
|
||||||
|
index 95b202c..a931a6f 100644
|
||||||
|
--- a/star/star.1
|
||||||
|
+++ b/star/star.1
|
||||||
|
@@ -913,9 +913,9 @@ archive format because of its limited portability.
|
||||||
|
.B crc
|
||||||
|
This format is similar to the
|
||||||
|
.B asc
|
||||||
|
-cpio format but in addition uses a simple byte based checksum called
|
||||||
|
+cpio format but in addition uses a simple byte based checksum called here as
|
||||||
|
.BR CRC .
|
||||||
|
-Try to avoid the
|
||||||
|
+This algorithm is simple Sum32 -- not a polynomial CRC. Try to avoid the
|
||||||
|
.B crc
|
||||||
|
archive format because of its limited portability.
|
||||||
|
|
@ -24,6 +24,8 @@ Patch6: star-1.5.1-manpagereferences.patch
|
|||||||
Patch7: star-1.5.1-multivolsigsegv.patch
|
Patch7: star-1.5.1-multivolsigsegv.patch
|
||||||
# do not crash when xattrs are not set on all files (#861848)
|
# do not crash when xattrs are not set on all files (#861848)
|
||||||
Patch8: star-1.5.1-selinux-segfault.patch
|
Patch8: star-1.5.1-selinux-segfault.patch
|
||||||
|
# note that the H=crc format uses Sum32 algorithm, not CRC
|
||||||
|
Patch9: star-1.5.1-crc.patch
|
||||||
|
|
||||||
License: CDDL
|
License: CDDL
|
||||||
Group: Applications/Archiving
|
Group: Applications/Archiving
|
||||||
@ -47,6 +49,7 @@ and can restore individual files from the archive. Star supports ACL.
|
|||||||
%patch6 -p1 -b .references
|
%patch6 -p1 -b .references
|
||||||
%patch7 -p1 -b .multivol
|
%patch7 -p1 -b .multivol
|
||||||
%patch8 -p1 -b .selinux-segfault
|
%patch8 -p1 -b .selinux-segfault
|
||||||
|
%patch9 -p1 -b .crc
|
||||||
cp -a star/all.mk star/Makefile
|
cp -a star/all.mk star/Makefile
|
||||||
iconv -f iso_8859-1 -t utf-8 AN-1.5 >AN-1.5_utf8
|
iconv -f iso_8859-1 -t utf-8 AN-1.5 >AN-1.5_utf8
|
||||||
mv AN-1.5_utf8 AN-1.5
|
mv AN-1.5_utf8 AN-1.5
|
||||||
@ -128,6 +131,7 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
* Thu Oct 18 2012 Pavel Raiskup <praiskup@redhat.com> - 1.5.1-10
|
* Thu Oct 18 2012 Pavel Raiskup <praiskup@redhat.com> - 1.5.1-10
|
||||||
- do not crash during extracting if extended attributes are not set on all
|
- do not crash during extracting if extended attributes are not set on all
|
||||||
archived files (#861848)
|
archived files (#861848)
|
||||||
|
- note in man page that H=crc format uses Sum32 algorithm (FIPS refuses CRC)
|
||||||
|
|
||||||
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-9
|
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-9
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
Loading…
Reference in New Issue
Block a user