Fix segfault on restore default acl (rhbz#1567836)

This commit is contained in:
vdanek 2018-08-01 13:36:02 +02:00 committed by Pavel Raiskup
parent cd948226b1
commit 1421199b13
2 changed files with 21 additions and 1 deletions

View File

@ -0,0 +1,13 @@
--- acl_unix.c 2018-08-01 12:01:04.218237606 +0200
+++ star-1.5.3/star/acl_unix.c 2014-03-31 19:44:46.000000000 +0200
@@ -505,7 +505,7 @@
}
if (info->f_xflags & XF_ACL_DEFAULT) {
- ssize_t len = strlen(info->f_acl_access) + 2;
+ ssize_t len = strlen(info->f_acl_default) + 2;
if (len > aclps.ps_size) {
if (aclps.ps_path == acltext) {

View File

@ -7,7 +7,7 @@
Summary: An archiving tool with ACL support
Name: star
Version: 1.5.3
Release: 13%{?dist}
Release: 14%{?dist}
License: CDDL
Group: Applications/Archiving
URL: http://freecode.com/projects/star
@ -48,6 +48,9 @@ Patch10: star-1.5.3-star-mk.patch
# ~> downstream
Patch11: star-1.5.3-pax-X-option.patch
# Fix segfault on restore default acl (rhbz#1567836)
Patch12: star-1.5.3-default-acl.patch
BuildRequires: libattr-devel libacl-devel libtool libselinux-devel
BuildRequires: e2fsprogs-devel
@ -110,6 +113,7 @@ restoring files from a backup), and tar (an archiving program).
%patch9 -p1 -b .ssh-by-default
%patch10 -p1 -b .bug-config-1.5.3
%patch11 -p1 -b .pax-X
%patch12 -p1 -b .default-acl
# disable single "fat" binary
cp -a star/all.mk star/Makefile
@ -233,6 +237,9 @@ fi
%{_sysconfdir}/rmt
%changelog
* Wed Aug 01 2018 Vaclav Danek <vdanek@redhat.com> - 1.5.3-14
- Fix segfault on restore default acl (rhbz#1567836)
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.3-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild