man/help: fix man-page-day objections
Resolves: #948866 Version: 1.5.2-1
This commit is contained in:
parent
d210852f74
commit
0f4f931f95
96
star-1.5.2-man-page-day.patch
Normal file
96
star-1.5.2-man-page-day.patch
Normal file
@ -0,0 +1,96 @@
|
|||||||
|
diff --git a/star/pax.c b/star/pax.c
|
||||||
|
index 8130109..9a2fb18 100644
|
||||||
|
--- a/star/pax.c
|
||||||
|
+++ b/star/pax.c
|
||||||
|
@@ -266,9 +266,11 @@ usage(ret)
|
||||||
|
error("\t-c\t\tinvert matching rules\n");
|
||||||
|
error("\t-d\t\tdo not descend directories\n");
|
||||||
|
error("\t-f nm\t\tuse 'nm' as tape instead of stdin/stdout\n");
|
||||||
|
+ error("\t-H\t\tsame as -L but follow only symlinks passed on the command line\n");
|
||||||
|
error("\t-i\t\tdo interactive creation/extraction/renaming\n");
|
||||||
|
error("\t-k\t\tkeep existing files\n");
|
||||||
|
error("\t-l\t\tlink files rather than copying them\n");
|
||||||
|
+ error("\t-L\t\tfollow symlinks, archive and dump the files they point to\n");
|
||||||
|
error("\t-n\t\tone match per pattern only\n");
|
||||||
|
error("\t-o\t\toptions (none specified with SUSv2 / UNIX-98)\n");
|
||||||
|
error("\t-p string\tset privileges\n");
|
||||||
|
diff --git a/star/spax.1 b/star/spax.1
|
||||||
|
index 79e2b99..b17dc05 100644
|
||||||
|
--- a/star/spax.1
|
||||||
|
+++ b/star/spax.1
|
||||||
|
@@ -282,6 +282,9 @@ except that the order of presentation of the
|
||||||
|
and
|
||||||
|
.B \-s
|
||||||
|
options is significant.
|
||||||
|
+
|
||||||
|
+See also the "OTHER OPTIONS" section.
|
||||||
|
+
|
||||||
|
.PP
|
||||||
|
The following options shall be supported:
|
||||||
|
.TP
|
||||||
|
@@ -3246,7 +3249,7 @@ existing files). As stated, it prevents any overwriting, even if
|
||||||
|
the target file is older than the source. This version adds more
|
||||||
|
granularity of options to solve this problem by introducing the
|
||||||
|
.BI "\-o invalid=" option
|
||||||
|
-\-specifically the UTF-8 action. (Note that an
|
||||||
|
+\- specifically the UTF-8 action. (Note that an
|
||||||
|
existing file that is named with a UTF-8 encoding is still subject
|
||||||
|
to overwriting in this case. The
|
||||||
|
.B \-k
|
||||||
|
@@ -4206,10 +4209,16 @@ field.
|
||||||
|
End of quoted text from the POSIX.1-2001 standard.
|
||||||
|
. \" .SH RETURNS
|
||||||
|
. \" .SH ERRORS
|
||||||
|
-.SH OPTIONS
|
||||||
|
+.SH OTHER OPTIONS
|
||||||
|
The following
|
||||||
|
.I "other options
|
||||||
|
-are implemented as extension to the POSIX standard:
|
||||||
|
+are implemented as extension to the POSIX standard. Note that some other
|
||||||
|
+non-POSIX options are mentioned in \fI\-help\fR and \fI-xhelp\fR output
|
||||||
|
+- these are also supported in
|
||||||
|
+.BR spax (1)
|
||||||
|
+and are well described in
|
||||||
|
+.BR star (1)
|
||||||
|
+manual page.
|
||||||
|
.TP
|
||||||
|
.B \-help
|
||||||
|
Prints a summary of the most important options for
|
||||||
|
@@ -4225,6 +4234,11 @@ and exits.
|
||||||
|
Prints the
|
||||||
|
.B spax
|
||||||
|
version number string and exists.
|
||||||
|
+.TP
|
||||||
|
+.B \-do-statistics
|
||||||
|
+Print statistic messages at the end of a
|
||||||
|
+.BR spax (1)
|
||||||
|
+run.
|
||||||
|
|
||||||
|
.SH EXAMPLES
|
||||||
|
.SH ENVIRONMENT
|
||||||
|
diff --git a/star/star.1 b/star/star.1
|
||||||
|
index 3ccd35d..0c88793 100644
|
||||||
|
--- a/star/star.1
|
||||||
|
+++ b/star/star.1
|
||||||
|
@@ -3025,7 +3025,7 @@ The bug in old
|
||||||
|
versions that cause a reversal of a space and a NULL byte
|
||||||
|
in the checksum field is not repeated.
|
||||||
|
If you want to have signed checksums you have to specify the
|
||||||
|
-.I \-singed\-checksum
|
||||||
|
+.I \-signed\-checksum
|
||||||
|
option too.
|
||||||
|
If you want directories not to be archived in order to be compatible
|
||||||
|
to very old historic tar archives, you need to specify the
|
||||||
|
diff --git a/star/star.c b/star/star.c
|
||||||
|
index fe9d984..e895898 100644
|
||||||
|
--- a/star/star.c
|
||||||
|
+++ b/star/star.c
|
||||||
|
@@ -1132,7 +1132,7 @@ xusage(ret)
|
||||||
|
error("\t-no-xheader\tdo not read or write extended headers regardless of format\n");
|
||||||
|
error("\t-meta\t\tuse inode metadata only (omit file content)\n");
|
||||||
|
error("\t-xmeta\t\textract meta files\n");
|
||||||
|
- error("\t-dupmeta\tuse inode metadata in dump mode if only ctime is newer\n");
|
||||||
|
+ error("\t-dumpmeta\tuse inode metadata in dump mode if only ctime is newer\n");
|
||||||
|
error("\t-keep-old-files,-k\tkeep existing files\n");
|
||||||
|
error("\t-refresh-old-files\trefresh existing files, don't create new files\n");
|
||||||
|
error("\t-refresh\trefresh existing files, don't create new files\n");
|
@ -23,6 +23,12 @@ Patch6: star-1.5.1-selinux-segfault.patch
|
|||||||
# note that the H=crc format uses Sum32 algorithm, not CRC
|
# note that the H=crc format uses Sum32 algorithm, not CRC
|
||||||
Patch7: star-1.5.1-crc.patch
|
Patch7: star-1.5.1-crc.patch
|
||||||
|
|
||||||
|
# fix man-page-day objections
|
||||||
|
# ~> proposed upstream:
|
||||||
|
# https://lists.berlios.de/pipermail/star-developers/2013-April/000027.html
|
||||||
|
# ~> #948866
|
||||||
|
Patch8: star-1.5.2-man-page-day.patch
|
||||||
|
|
||||||
License: CDDL
|
License: CDDL
|
||||||
Group: Applications/Archiving
|
Group: Applications/Archiving
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
@ -44,6 +50,8 @@ and can restore individual files from the archive. Star supports ACL.
|
|||||||
%patch5 -p1 -b .references
|
%patch5 -p1 -b .references
|
||||||
%patch6 -p1 -b .selinux-segfault
|
%patch6 -p1 -b .selinux-segfault
|
||||||
%patch7 -p1 -b .crc
|
%patch7 -p1 -b .crc
|
||||||
|
%patch8 -p1 -b .man-page-day
|
||||||
|
|
||||||
cp -a star/all.mk star/Makefile
|
cp -a star/all.mk star/Makefile
|
||||||
iconv -f iso_8859-1 -t utf-8 AN-1.5 >AN-1.5_utf8
|
iconv -f iso_8859-1 -t utf-8 AN-1.5 >AN-1.5_utf8
|
||||||
mv AN-1.5_utf8 AN-1.5
|
mv AN-1.5_utf8 AN-1.5
|
||||||
@ -124,6 +132,7 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
* Wed Apr 10 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-1
|
* Wed Apr 10 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-1
|
||||||
- rebase to most up2date upstream tarball, remove patches already upstream, fix
|
- rebase to most up2date upstream tarball, remove patches already upstream, fix
|
||||||
code movements in patches (#928758)
|
code movements in patches (#928758)
|
||||||
|
- fix man-page-day objections (private #948866)
|
||||||
|
|
||||||
* Thu Mar 21 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.1-12
|
* Thu Mar 21 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.1-12
|
||||||
- package also the 'scpio' utility (#771926)
|
- package also the 'scpio' utility (#771926)
|
||||||
|
Loading…
Reference in New Issue
Block a user