upgrade 1.5a65-1
This commit is contained in:
parent
4207e019c1
commit
0e2de46074
@ -1 +1 @@
|
|||||||
star-1.5a64.tar.gz
|
star-1.5a65.tar.bz2
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
6260d361bf22ac718262efd37ac875bb star-1.5a64.tar.gz
|
8beb0c4a7baaa95ae71d1310e415392f star-1.5a65.tar.bz2
|
||||||
|
@ -1,25 +1,42 @@
|
|||||||
--- star-1.5/star/pax.mk.selinux 2005-08-12 11:06:56.000000000 +0200
|
diff --git a/conf/configure.in b/conf/configure.in
|
||||||
+++ star-1.5/star/pax.mk 2005-08-12 11:07:46.000000000 +0200
|
--- a/conf/configure.in
|
||||||
@@ -17,6 +17,7 @@
|
+++ b/conf/configure.in
|
||||||
CPPOPTS += -DUSE_LARGEFILES
|
@@ -312,6 +312,15 @@ if test "$ac_cv_header_attr_xattr_h" = y
|
||||||
CPPOPTS += -DUSE_ACL
|
LIBS="$ac_save_LIBS"
|
||||||
CPPOPTS += -DUSE_XATTR
|
fi
|
||||||
+CPPOPTS += -DWITH_SELINUX
|
|
||||||
CPPOPTS += -DUSE_FFLAGS
|
|
||||||
CPPOPTS += -DPAX
|
|
||||||
CFILES= pax.c header.c cpiohdr.c xheader.c xattr.c \
|
|
||||||
@@ -35,7 +36,7 @@
|
|
||||||
checkerr.h dumpdate.h bitstring.h
|
|
||||||
#LIBS= -lunos
|
|
||||||
#LIBS= -lschily -lc /usr/local/lib/gcc-gnulib
|
|
||||||
-LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET)
|
|
||||||
+LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_SELINUX)
|
|
||||||
XMK_FILE= spaxman.mk
|
|
||||||
|
|
||||||
###########################################################################
|
+AC_CHECK_HEADERS(selinux/selinux.h)
|
||||||
--- star-1.5/star/Makefile.selinux 2005-08-12 11:08:26.000000000 +0200
|
+if test "$ac_cv_header_selinux_selinux_h" = yes; then
|
||||||
+++ star-1.5/star/Makefile 2005-08-12 11:09:13.000000000 +0200
|
+ AC_CHECKING(for SELinux support)
|
||||||
@@ -24,6 +24,7 @@
|
+ AC_CHECK_LIB(selinux, is_selinux_enabled, lib_selinux="-lselinux -lattr")
|
||||||
|
+ ac_save_LIBS="$LIBS"
|
||||||
|
+ LIBS="$LIBS $lib_selinux"
|
||||||
|
+ AC_CHECK_FUNCS(is_selinux_enabled)
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
dnl Checks for OS madness.
|
||||||
|
AC_BROKEN_LINUX_EXT2_FS_H
|
||||||
|
AC_BROKEN_SRC_LINUX_EXT2_FS_H
|
||||||
|
@@ -327,5 +336,6 @@ AC_SUBST(scsi_lib)
|
||||||
|
AC_SUBST(lib_acl)
|
||||||
|
AC_SUBST(lib_acl_test)
|
||||||
|
AC_SUBST(lib_attr)
|
||||||
|
+AC_SUBST(lib_selinux)
|
||||||
|
|
||||||
|
AC_OUTPUT(rules.cnf)
|
||||||
|
diff --git a/conf/rules.cnf.in b/conf/rules.cnf.in
|
||||||
|
--- a/conf/rules.cnf.in
|
||||||
|
+++ b/conf/rules.cnf.in
|
||||||
|
@@ -9,3 +9,5 @@ LIB_CRYPT= @lib_crypt@
|
||||||
|
LIB_ACL= @lib_acl@
|
||||||
|
LIB_ACL_TEST= @lib_acl_test@
|
||||||
|
LIB_ATTR = @lib_attr@
|
||||||
|
+LIB_SELINUX = @lib_selinux@
|
||||||
|
+
|
||||||
|
diff --git a/star/Makefile b/star/Makefile
|
||||||
|
--- a/star/Makefile
|
||||||
|
+++ b/star/Makefile
|
||||||
|
@@ -24,6 +24,7 @@ CPPOPTS += -DSET_CTIME -DFIFO -DUSE_MMAP
|
||||||
CPPOPTS += -DUSE_LARGEFILES
|
CPPOPTS += -DUSE_LARGEFILES
|
||||||
CPPOPTS += -DUSE_ACL
|
CPPOPTS += -DUSE_ACL
|
||||||
CPPOPTS += -DUSE_XATTR
|
CPPOPTS += -DUSE_XATTR
|
||||||
@ -27,43 +44,39 @@
|
|||||||
CPPOPTS += -DUSE_FFLAGS
|
CPPOPTS += -DUSE_FFLAGS
|
||||||
CPPOPTS += -DCOPY_LINKS_DELAYED
|
CPPOPTS += -DCOPY_LINKS_DELAYED
|
||||||
CPPOPTS += -DSTAR_FAT
|
CPPOPTS += -DSTAR_FAT
|
||||||
@@ -43,7 +44,7 @@
|
@@ -43,7 +44,7 @@ HFILES= star.h starsubs.h dirtime.h xta
|
||||||
checkerr.h dumpdate.h bitstring.h
|
checkerr.h dumpdate.h bitstring.h
|
||||||
#LIBS= -lunos
|
#LIBS= -lunos
|
||||||
#LIBS= -lschily -lc /usr/local/lib/gcc-gnulib
|
#LIBS= -lschily -lc /usr/local/lib/gcc-gnulib
|
||||||
-LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET)
|
-LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET)
|
||||||
+LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_SELINUX)
|
+LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_SELINUX)
|
||||||
XMK_FILE= Makefile.man starformatman.mk scpioman.mk gnutarman.mk \
|
XMK_FILE= Makefile.man starformatman.mk scpioman.mk gnutarman.mk \
|
||||||
spaxman.mk suntarman.mk
|
spaxman.mk suntarman.mk Makefile.dfl
|
||||||
|
|
||||||
--- star-1.5/star/star.c.selinux 2005-08-12 11:09:41.000000000 +0200
|
diff --git a/star/cpio.mk b/star/cpio.mk
|
||||||
+++ star-1.5/star/star.c 2005-08-12 11:12:28.000000000 +0200
|
--- a/star/cpio.mk
|
||||||
@@ -40,6 +40,10 @@
|
+++ b/star/cpio.mk
|
||||||
#endif
|
@@ -18,6 +18,7 @@ CPPOPTS += -DUSE_LARGEFILES
|
||||||
#include "dumpdate.h"
|
CPPOPTS += -DUSE_ACL
|
||||||
|
CPPOPTS += -DUSE_XATTR
|
||||||
|
CPPOPTS += -DUSE_FFLAGS
|
||||||
|
+CPPOPTS += -DWITH_SELINUX
|
||||||
|
CFILES= cpio.c header.c cpiohdr.c xheader.c xattr.c \
|
||||||
|
list.c extract.c create.c append.c diff.c restore.c \
|
||||||
|
remove.c star_unix.c acl_unix.c acltext.c fflags.c \
|
||||||
|
@@ -34,7 +35,7 @@ HFILES= star.h starsubs.h dirtime.h xta
|
||||||
|
checkerr.h dumpdate.h bitstring.h
|
||||||
|
#LIBS= -lunos
|
||||||
|
#LIBS= -lschily -lc /usr/local/lib/gcc-gnulib
|
||||||
|
-LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET)
|
||||||
|
+LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_SELINUX)
|
||||||
|
XMK_FILE= scpioman.mk
|
||||||
|
|
||||||
+#ifdef WITH_SELINUX
|
###########################################################################
|
||||||
+int selinux_enabled=0;
|
diff --git a/star/extract.c b/star/extract.c
|
||||||
+#endif
|
--- a/star/extract.c
|
||||||
+
|
+++ b/star/extract.c
|
||||||
EXPORT int main __PR((int ac, char **av));
|
@@ -209,6 +209,16 @@ extract(vhname)
|
||||||
LOCAL void star_create __PR((int ac, char *const *av));
|
|
||||||
LOCAL void checkdumptype __PR((GINFO *gp));
|
|
||||||
@@ -358,6 +362,11 @@
|
|
||||||
comerr("Panic cannot set back effective uid.\n");
|
|
||||||
}
|
|
||||||
my_uid = geteuid();
|
|
||||||
+
|
|
||||||
+#ifdef WITH_SELINUX
|
|
||||||
+ selinux_enabled=is_selinux_enabled()>0;
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
/*
|
|
||||||
* WARNING: We now are no more able to open a new remote connection
|
|
||||||
* unless we have been called by root.
|
|
||||||
--- star-1.5/star/extract.c.selinux 2005-08-12 11:12:39.000000000 +0200
|
|
||||||
+++ star-1.5/star/extract.c 2005-08-12 11:15:17.000000000 +0200
|
|
||||||
@@ -209,6 +209,16 @@
|
|
||||||
if (prblockno)
|
if (prblockno)
|
||||||
(void) tblocks(); /* set curblockno */
|
(void) tblocks(); /* set curblockno */
|
||||||
|
|
||||||
@ -80,9 +93,116 @@
|
|||||||
if (finfo.f_xflags & XF_BAD_META) {
|
if (finfo.f_xflags & XF_BAD_META) {
|
||||||
if (!void_bad(&finfo))
|
if (!void_bad(&finfo))
|
||||||
break;
|
break;
|
||||||
--- star-1.5/star/starsubs.h.selinux 2005-08-12 11:15:44.000000000 +0200
|
diff --git a/star/gnutar.mk b/star/gnutar.mk
|
||||||
+++ star-1.5/star/starsubs.h 2005-08-12 11:16:46.000000000 +0200
|
--- a/star/gnutar.mk
|
||||||
@@ -293,6 +293,11 @@
|
+++ b/star/gnutar.mk
|
||||||
|
@@ -18,6 +18,7 @@ CPPOPTS += -DUSE_LARGEFILES
|
||||||
|
CPPOPTS += -DUSE_ACL
|
||||||
|
CPPOPTS += -DUSE_XATTR
|
||||||
|
CPPOPTS += -DUSE_FFLAGS
|
||||||
|
+CPPOPTS += -DWITH_SELINUX
|
||||||
|
CFILES= gnutar.c header.c cpiohdr.c xheader.c xattr.c \
|
||||||
|
list.c extract.c create.c append.c diff.c restore.c \
|
||||||
|
remove.c star_unix.c acl_unix.c acltext.c fflags.c \
|
||||||
|
@@ -34,7 +35,7 @@ HFILES= star.h starsubs.h dirtime.h xta
|
||||||
|
checkerr.h dumpdate.h bitstring.h
|
||||||
|
#LIBS= -lunos
|
||||||
|
#LIBS= -lschily -lc /usr/local/lib/gcc-gnulib
|
||||||
|
-LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET)
|
||||||
|
+LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_SELINUX)
|
||||||
|
XMK_FILE= gnutarman.mk
|
||||||
|
|
||||||
|
###########################################################################
|
||||||
|
diff --git a/star/pax.mk b/star/pax.mk
|
||||||
|
--- a/star/pax.mk
|
||||||
|
+++ b/star/pax.mk
|
||||||
|
@@ -17,6 +17,7 @@ CPPOPTS += -DSET_CTIME -DFIFO -DUSE_MMAP
|
||||||
|
CPPOPTS += -DUSE_LARGEFILES
|
||||||
|
CPPOPTS += -DUSE_ACL
|
||||||
|
CPPOPTS += -DUSE_XATTR
|
||||||
|
+CPPOPTS += -DWITH_SELINUX
|
||||||
|
CPPOPTS += -DUSE_FFLAGS
|
||||||
|
CPPOPTS += -DPAX
|
||||||
|
CFILES= pax.c header.c cpiohdr.c xheader.c xattr.c \
|
||||||
|
@@ -35,7 +36,7 @@ HFILES= star.h starsubs.h dirtime.h xta
|
||||||
|
checkerr.h dumpdate.h bitstring.h
|
||||||
|
#LIBS= -lunos
|
||||||
|
#LIBS= -lschily -lc /usr/local/lib/gcc-gnulib
|
||||||
|
-LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET)
|
||||||
|
+LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_SELINUX)
|
||||||
|
XMK_FILE= spaxman.mk
|
||||||
|
|
||||||
|
###########################################################################
|
||||||
|
diff --git a/star/star.c b/star/star.c
|
||||||
|
--- a/star/star.c
|
||||||
|
+++ b/star/star.c
|
||||||
|
@@ -40,6 +40,10 @@ static char sccsid[] =
|
||||||
|
#endif
|
||||||
|
#include "dumpdate.h"
|
||||||
|
|
||||||
|
+#ifdef WITH_SELINUX
|
||||||
|
+int selinux_enabled=0;
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
EXPORT int main __PR((int ac, char **av));
|
||||||
|
LOCAL void star_create __PR((int ac, char *const *av));
|
||||||
|
LOCAL void checkdumptype __PR((GINFO *gp));
|
||||||
|
@@ -358,6 +362,11 @@ main(ac, av)
|
||||||
|
comerr("Panic cannot set back effective uid.\n");
|
||||||
|
}
|
||||||
|
my_uid = geteuid();
|
||||||
|
+
|
||||||
|
+#ifdef WITH_SELINUX
|
||||||
|
+ selinux_enabled=is_selinux_enabled()>0;
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
/*
|
||||||
|
* WARNING: We now are no more able to open a new remote connection
|
||||||
|
* unless we have been called by root.
|
||||||
|
diff --git a/star/star.mk b/star/star.mk
|
||||||
|
--- a/star/star.mk
|
||||||
|
+++ b/star/star.mk
|
||||||
|
@@ -19,6 +19,7 @@ CPPOPTS += -DUSE_ACL
|
||||||
|
CPPOPTS += -DUSE_XATTR
|
||||||
|
CPPOPTS += -DUSE_FFLAGS
|
||||||
|
CPPOPTS += -DCOPY_LINKS_DELAYED
|
||||||
|
+CPPOPTS += -DWITH_SELINUX
|
||||||
|
CFILES= star.c header.c cpiohdr.c xheader.c xattr.c \
|
||||||
|
list.c extract.c create.c append.c diff.c restore.c \
|
||||||
|
remove.c star_unix.c acl_unix.c acltext.c fflags.c \
|
||||||
|
@@ -35,7 +36,7 @@ HFILES= star.h starsubs.h dirtime.h xta
|
||||||
|
checkerr.h dumpdate.h bitstring.h
|
||||||
|
#LIBS= -lunos
|
||||||
|
#LIBS= -lschily -lc /usr/local/lib/gcc-gnulib
|
||||||
|
-LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET)
|
||||||
|
+LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_SELINUX)
|
||||||
|
XMK_FILE= Makefile.man starformatman.mk
|
||||||
|
|
||||||
|
###########################################################################
|
||||||
|
diff --git a/star/star_fat.mk b/star/star_fat.mk
|
||||||
|
--- a/star/star_fat.mk
|
||||||
|
+++ b/star/star_fat.mk
|
||||||
|
@@ -27,6 +27,7 @@ CPPOPTS += -DUSE_XATTR
|
||||||
|
CPPOPTS += -DUSE_FFLAGS
|
||||||
|
CPPOPTS += -DCOPY_LINKS_DELAYED
|
||||||
|
CPPOPTS += -DSTAR_FAT
|
||||||
|
+CPPOPTS += -DWITH_SELINUX
|
||||||
|
CFILES= star_fat.c header.c cpiohdr.c xheader.c xattr.c \
|
||||||
|
list.c extract.c create.c append.c diff.c restore.c \
|
||||||
|
remove.c star_unix.c acl_unix.c acltext.c fflags.c \
|
||||||
|
@@ -43,7 +44,7 @@ HFILES= star.h starsubs.h dirtime.h xta
|
||||||
|
checkerr.h dumpdate.h bitstring.h
|
||||||
|
#LIBS= -lunos
|
||||||
|
#LIBS= -lschily -lc /usr/local/lib/gcc-gnulib
|
||||||
|
-LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET)
|
||||||
|
+LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_SELINUX)
|
||||||
|
XMK_FILE= Makefile.man starformatman.mk scpioman.mk gnutarman.mk \
|
||||||
|
spaxman.mk suntarman.mk Makefile.dfl
|
||||||
|
|
||||||
|
diff --git a/star/starsubs.h b/star/starsubs.h
|
||||||
|
--- a/star/starsubs.h
|
||||||
|
+++ b/star/starsubs.h
|
||||||
|
@@ -293,6 +293,11 @@ extern BOOL get_number __PR((char *keywo
|
||||||
extern BOOL get_xattr __PR((register FINFO *info));
|
extern BOOL get_xattr __PR((register FINFO *info));
|
||||||
extern BOOL set_xattr __PR((register FINFO *info));
|
extern BOOL set_xattr __PR((register FINFO *info));
|
||||||
extern void free_xattr __PR((star_xattr_t **xattr));
|
extern void free_xattr __PR((star_xattr_t **xattr));
|
||||||
@ -94,9 +214,30 @@
|
|||||||
#endif
|
#endif
|
||||||
|
|
||||||
/*
|
/*
|
||||||
--- star-1.5/star/xattr.c.selinux 2005-08-12 11:17:12.000000000 +0200
|
diff --git a/star/suntar.mk b/star/suntar.mk
|
||||||
+++ star-1.5/star/xattr.c 2005-08-12 11:21:01.000000000 +0200
|
--- a/star/suntar.mk
|
||||||
@@ -159,6 +159,29 @@
|
+++ b/star/suntar.mk
|
||||||
|
@@ -18,6 +18,7 @@ CPPOPTS += -DUSE_LARGEFILES
|
||||||
|
CPPOPTS += -DUSE_ACL
|
||||||
|
CPPOPTS += -DUSE_XATTR
|
||||||
|
CPPOPTS += -DUSE_FFLAGS
|
||||||
|
+CPPOPTS += -DWITH_SELINUX
|
||||||
|
CFILES= suntar.c header.c cpiohdr.c xheader.c xattr.c \
|
||||||
|
list.c extract.c create.c append.c diff.c restore.c \
|
||||||
|
remove.c star_unix.c acl_unix.c acltext.c fflags.c \
|
||||||
|
@@ -34,7 +35,7 @@ HFILES= star.h starsubs.h dirtime.h xta
|
||||||
|
checkerr.h dumpdate.h bitstring.h
|
||||||
|
#LIBS= -lunos
|
||||||
|
#LIBS= -lschily -lc /usr/local/lib/gcc-gnulib
|
||||||
|
-LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET)
|
||||||
|
+LIBS= -ldeflt -lrmt -lschily $(LIB_ACL) $(LIB_ATTR) $(LIB_SOCKET) $(LIB_SELINUX)
|
||||||
|
XMK_FILE= suntarman.mk
|
||||||
|
|
||||||
|
###########################################################################
|
||||||
|
diff --git a/star/xattr.c b/star/xattr.c
|
||||||
|
--- a/star/xattr.c
|
||||||
|
+++ b/star/xattr.c
|
||||||
|
@@ -159,6 +159,29 @@ fail:
|
||||||
#endif /* USE_XATTR */
|
#endif /* USE_XATTR */
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -126,7 +267,7 @@
|
|||||||
/* ARGSUSED */
|
/* ARGSUSED */
|
||||||
EXPORT BOOL
|
EXPORT BOOL
|
||||||
set_xattr(info)
|
set_xattr(info)
|
||||||
@@ -171,6 +194,10 @@
|
@@ -171,6 +194,10 @@ set_xattr(info)
|
||||||
return (TRUE);
|
return (TRUE);
|
||||||
|
|
||||||
for (xap = info->f_xattr; xap->name != NULL; xap++) {
|
for (xap = info->f_xattr; xap->name != NULL; xap++) {
|
||||||
@ -137,36 +278,3 @@
|
|||||||
if (setxattr(info->f_name, xap->name, xap->value,
|
if (setxattr(info->f_name, xap->name, xap->value,
|
||||||
xap->value_len, 0) != 0) {
|
xap->value_len, 0) != 0) {
|
||||||
if (!errhidden(E_SETXATTR, info->f_name)) {
|
if (!errhidden(E_SETXATTR, info->f_name)) {
|
||||||
--- star-1.5/conf/configure.in.selinux 2005-08-12 11:04:08.000000000 +0200
|
|
||||||
+++ star-1.5/conf/configure.in 2005-08-12 11:05:22.000000000 +0200
|
|
||||||
@@ -312,6 +312,15 @@
|
|
||||||
LIBS="$ac_save_LIBS"
|
|
||||||
fi
|
|
||||||
|
|
||||||
+AC_CHECK_HEADERS(selinux/selinux.h)
|
|
||||||
+if test "$ac_cv_header_selinux_selinux_h" = yes; then
|
|
||||||
+ AC_CHECKING(for SELinux support)
|
|
||||||
+ AC_CHECK_LIB(selinux, is_selinux_enabled, lib_selinux="-lselinux -lattr")
|
|
||||||
+ ac_save_LIBS="$LIBS"
|
|
||||||
+ LIBS="$LIBS $lib_selinux"
|
|
||||||
+ AC_CHECK_FUNCS(is_selinux_enabled)
|
|
||||||
+fi
|
|
||||||
+
|
|
||||||
dnl Checks for OS madness.
|
|
||||||
AC_BROKEN_LINUX_EXT2_FS_H
|
|
||||||
AC_BROKEN_SRC_LINUX_EXT2_FS_H
|
|
||||||
@@ -327,5 +336,6 @@
|
|
||||||
AC_SUBST(lib_acl)
|
|
||||||
AC_SUBST(lib_acl_test)
|
|
||||||
AC_SUBST(lib_attr)
|
|
||||||
+AC_SUBST(lib_selinux)
|
|
||||||
|
|
||||||
AC_OUTPUT(rules.cnf)
|
|
||||||
--- star-1.5/conf/rules.cnf.in.selinux 2005-08-12 11:05:53.000000000 +0200
|
|
||||||
+++ star-1.5/conf/rules.cnf.in 2005-08-12 11:06:12.000000000 +0200
|
|
||||||
@@ -9,3 +9,5 @@
|
|
||||||
LIB_ACL= @lib_acl@
|
|
||||||
LIB_ACL_TEST= @lib_acl_test@
|
|
||||||
LIB_ATTR = @lib_attr@
|
|
||||||
+LIB_SELINUX = @lib_selinux@
|
|
||||||
+
|
|
||||||
|
48
star.spec
48
star.spec
@ -3,15 +3,14 @@
|
|||||||
%endif
|
%endif
|
||||||
Summary: An archiving tool with ACL support
|
Summary: An archiving tool with ACL support
|
||||||
Name: star
|
Name: star
|
||||||
Version: 1.5a64
|
Version: 1.5a65
|
||||||
Release: 2
|
Release: 1
|
||||||
URL: http://www.fokus.gmd.de/research/cc/glone/employees/joerg.schilling/private/star.html
|
Source: ftp://ftp.berlios.de/pub/star/alpha/%{name}-%{version}.tar.bz2
|
||||||
Source: ftp://ftp.fokus.gmd.de/pub/unix/star/alpha/%{name}-%{version}.tar.gz
|
|
||||||
Patch0: star-1.5-newMake.patch
|
Patch0: star-1.5-newMake.patch
|
||||||
Patch2: star-1.5-nofsync.patch
|
Patch2: star-1.5-nofsync.patch
|
||||||
Patch3: star-1.5-davej.patch
|
Patch3: star-1.5-davej.patch
|
||||||
Patch4: star-1.5-selinux.patch
|
Patch4: star-1.5-selinux.patch
|
||||||
License: GPL
|
License: CDDL 1.0
|
||||||
Group: Applications/Archiving
|
Group: Applications/Archiving
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
BuildRequires: libattr-devel libacl-devel libtool libselinux-devel autoconf213
|
BuildRequires: libattr-devel libacl-devel libtool libselinux-devel autoconf213
|
||||||
@ -39,8 +38,13 @@ done
|
|||||||
cp -f /usr/share/libtool/config.sub conf/config.sub
|
cp -f /usr/share/libtool/config.sub conf/config.sub
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export CFLAGS="$RPM_OPT_FLAGS"
|
export COPTOPT="$RPM_OPT_FLAGS"
|
||||||
|
export MAKEPROG=gmake
|
||||||
|
# Autoconfiscate
|
||||||
(cd conf; autoconf-2.13)
|
(cd conf; autoconf-2.13)
|
||||||
|
# Disable fat binary
|
||||||
|
(cd star; rm Makefile; cp all.mk Makefile)
|
||||||
|
|
||||||
make %{?_smp_mflags} PARCH=%{_target_cpu} CPPOPTX="-DNO_FSYNC" \
|
make %{?_smp_mflags} PARCH=%{_target_cpu} CPPOPTX="-DNO_FSYNC" \
|
||||||
K_ARCH=%{_target_cpu} \
|
K_ARCH=%{_target_cpu} \
|
||||||
CONFFLAGS="%{_target_platform} --prefix=%{_prefix} \
|
CONFFLAGS="%{_target_platform} --prefix=%{_prefix} \
|
||||||
@ -52,28 +56,32 @@ make %{?_smp_mflags} PARCH=%{_target_cpu} CPPOPTX="-DNO_FSYNC" \
|
|||||||
--mandir=%{_mandir} --infodir=%{_infodir}" < /dev/null
|
--mandir=%{_mandir} --infodir=%{_infodir}" < /dev/null
|
||||||
|
|
||||||
%install
|
%install
|
||||||
|
export MAKEPROG=gmake
|
||||||
rm -rf ${RPM_BUILD_ROOT}
|
rm -rf ${RPM_BUILD_ROOT}
|
||||||
mkdir -p ${RPM_BUILD_ROOT}/%{_mandir}/man1
|
mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1
|
||||||
%makeinstall RPM_INSTALLDIR=${RPM_BUILD_ROOT} PARCH=%{_target_cpu} K_ARCH=%{_target_cpu} < /dev/null
|
%makeinstall RPM_INSTALLDIR=${RPM_BUILD_ROOT} PARCH=%{_target_cpu} K_ARCH=%{_target_cpu} < /dev/null
|
||||||
rm -rf $RPM_BUILD_ROOT/usr/share/man
|
rm -rf $RPM_BUILD_ROOT/usr/share/man
|
||||||
mv $RPM_BUILD_ROOT/usr/man $RPM_BUILD_ROOT/usr/share/man
|
mv $RPM_BUILD_ROOT/usr/man $RPM_BUILD_ROOT%{_mandir}
|
||||||
|
|
||||||
# XXX Nuke unpackaged files.
|
# XXX Nuke unpackaged files.
|
||||||
( cd ${RPM_BUILD_ROOT}
|
( cd ${RPM_BUILD_ROOT}
|
||||||
|
rm -f .%{_prefix}%{_sysconfdir}/default/rmt
|
||||||
rm -f .%{_bindir}/mt
|
rm -f .%{_bindir}/mt
|
||||||
rm -f .%{_bindir}/smt
|
rm -f .%{_bindir}/smt
|
||||||
rm -f .%{_bindir}/tartest
|
rm -f .%{_bindir}/tartest
|
||||||
rm -f .%{_bindir}/tar
|
rm -f .%{_bindir}/tar
|
||||||
rm -f .%{_bindir}/gnutar
|
rm -f .%{_bindir}/gnutar
|
||||||
rm -f .%{_bindir}/scpio
|
rm -f .%{_bindir}/scpio
|
||||||
|
rm -f .%{_bindir}/star_fat
|
||||||
rm -f .%{_bindir}/star_sym
|
rm -f .%{_bindir}/star_sym
|
||||||
rm -f .%{_bindir}/suntar
|
rm -f .%{_bindir}/suntar
|
||||||
|
rm -rf .%{_prefix}%{_sysconfdir}
|
||||||
rm -rf .%{_prefix}/include
|
rm -rf .%{_prefix}/include
|
||||||
rm -rf .%{_prefix}/lib
|
rm -rf .%{_prefix}/lib
|
||||||
rm -rf .%{_mandir}/man5
|
rm -rf .%{_mandir}/man5
|
||||||
rm -rf .%{_mandir}/man3
|
rm -rf .%{_mandir}/man3
|
||||||
rm -rf .%{_mandir}/man1/{tartest,rmt,gnutar,scpio,smt,suntar}.1*
|
rm -rf .%{_mandir}/man1/{tartest,rmt,gnutar,scpio,smt,suntar,match}.1*
|
||||||
rm -rf .%{_prefix}/sbin
|
rm -rf .%{_sbindir}
|
||||||
)
|
)
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
@ -82,14 +90,26 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%doc README AN* COPYING README.ACL README.crash README.largefiles README.linux
|
%doc README AN* COPYING README.ACL README.crash README.largefiles README.linux
|
||||||
%doc README.otherbugs README.pattern README.posix-2001 README.SSPM STARvsGNUTAR
|
%doc README.otherbugs README.pattern README.posix-2001 README.SSPM
|
||||||
|
%doc STARvsGNUTAR
|
||||||
%doc STATUS.alpha TODO
|
%doc STATUS.alpha TODO
|
||||||
%{_bindir}/*star
|
%{_bindir}/star
|
||||||
|
%{_bindir}/ustar
|
||||||
%{_bindir}/spax
|
%{_bindir}/spax
|
||||||
%{_bindir}/star_fat
|
%{_mandir}/man1/star.1*
|
||||||
%{_mandir}/man1/*.1.gz
|
%{_mandir}/man1/spax.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Aug 26 2005 Peter Vrabec <pvrabec@redhat.com> 1.5a65-1
|
||||||
|
- upgrade 1.5a65-1 made by Horst H. von Brand <vonbrand@inf.utfsm.cl>
|
||||||
|
- Source URL changed, no homepage now
|
||||||
|
- License changed from GPL to CDDL 1.0
|
||||||
|
- Define MAKEPROG=gmake like the Gmake.linux script does
|
||||||
|
- Disable fat binary as per star/Makefile, update star-1.5-selinux.patch for
|
||||||
|
the various *.mk files used in that case
|
||||||
|
- Axe /usr/share/man/man1/match.1*, /usr/etc/default/rmt too
|
||||||
|
- Explicit listing in %files, allow for compressed or plain manpages
|
||||||
|
|
||||||
* Fri Aug 26 2005 Peter Vrabec <pvrabec@redhat.com>
|
* Fri Aug 26 2005 Peter Vrabec <pvrabec@redhat.com>
|
||||||
- do not remove star_fat
|
- do not remove star_fat
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user