29 lines
945 B
Diff
29 lines
945 B
Diff
From 075519bceca7a8f4fa28a0b7c538f2f50d552d13 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Pavel=20B=C5=99ezina?= <pbrezina@redhat.com>
|
|
Date: Thu, 26 Nov 2020 14:56:08 +0100
|
|
Subject: [PATCH 18/18] configure: check for stdatomic.h
|
|
|
|
Recent autofs patches adds dependency on automic_uint/_Atomic type from C11
|
|
standard. This is supported in both gcc and clang for a long time now.
|
|
|
|
Reviewed-by: Alexey Tikhonov <atikhono@redhat.com>
|
|
---
|
|
configure.ac | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 1af1d1785..0d24c4b35 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -42,6 +42,7 @@ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES])
|
|
AM_CONDITIONAL([HAVE_GCC], [test "$ac_cv_prog_gcc" = yes])
|
|
|
|
AC_CHECK_HEADERS(stdint.h dlfcn.h)
|
|
+AC_CHECK_HEADERS([stdatomic.h],,AC_MSG_ERROR([C11 atomic types are not supported]))
|
|
AC_CONFIG_HEADER(config.h)
|
|
|
|
AC_CHECK_TYPES([errno_t], [], [], [[#include <errno.h>]])
|
|
--
|
|
2.21.3
|
|
|