- Version 0.3.1
- includes previous release patches
This commit is contained in:
parent
abd724acaf
commit
9797cfd950
@ -1 +1 @@
|
||||
sssd-0.3.0.tar.gz
|
||||
sssd-0.3.1.tar.gz
|
||||
|
@ -1,37 +0,0 @@
|
||||
>From 8dcfa62361fd6ed0fe6babf7c24702dbc53729ae Mon Sep 17 00:00:00 2001
|
||||
From: Sumit Bose <sbose@redhat.com>
|
||||
Date: Wed, 8 Apr 2009 11:42:02 +0200
|
||||
Subject: [PATCH] Add a LSB header to the initscript
|
||||
|
||||
---
|
||||
server/sysv/sssd | 14 ++++++++++++++
|
||||
1 files changed, 14 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/server/sysv/sssd b/server/sysv/sssd
|
||||
index c1364b9..9facb44 100644
|
||||
--- a/server/sysv/sssd
|
||||
+++ b/server/sysv/sssd
|
||||
@@ -9,6 +9,20 @@
|
||||
# basis to provide client auditing and policy services for projects
|
||||
# like FreeIPA.
|
||||
#
|
||||
+### BEGIN INIT INFO
|
||||
+# Provides: sssd
|
||||
+# Required-Start: $remote_fs $time
|
||||
+# Should-Start: $syslog
|
||||
+# Should-Stop: $null
|
||||
+# Required-Stop: $null
|
||||
+# Short-Description: System Security Services Daemon
|
||||
+# Description: Provides a set of daemons to manage access to remote directories
|
||||
+# and authentication mechanisms. It provides an NSS and PAM
|
||||
+# interface toward the system and a pluggable backend system to
|
||||
+# connect to multiple different account sources. It is also the
|
||||
+# basis to provide client auditing and policy services for projects
|
||||
+# like FreeIPA.
|
||||
+### END INIT INFO
|
||||
|
||||
RETVAL=0
|
||||
prog="sssd"
|
||||
--
|
||||
1.6.0.6
|
||||
|
@ -1,60 +0,0 @@
|
||||
From 948c47122cca0897e824dee064b3640c40b83ca6 Mon Sep 17 00:00:00 2001
|
||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||
Date: Mon, 13 Apr 2009 12:55:07 -0400
|
||||
Subject: [PATCH] Build fixes for RPM packaging of SSSD
|
||||
|
||||
We were missing several BuildRequires for the autotools. Also, we
|
||||
were linking against two external libraries in the common code
|
||||
that we do not actually use.
|
||||
---
|
||||
common/collection/Makefile.am | 2 +-
|
||||
common/ini/Makefile.am | 2 +-
|
||||
sssd.spec | 4 ++++
|
||||
3 files changed, 6 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/common/collection/Makefile.am b/common/collection/Makefile.am
|
||||
index a47f8f9..c47327d 100644
|
||||
--- a/common/collection/Makefile.am
|
||||
+++ b/common/collection/Makefile.am
|
||||
@@ -16,4 +16,4 @@ include_HEADERS = collection.h collection_tools.h
|
||||
# Build unit test
|
||||
noinst_PROGRAMS = collection_ut
|
||||
collection_ut_SOURCES = collection_ut.c
|
||||
-collection_ut_LDADD = libcollection.la -lm -lz
|
||||
+collection_ut_LDADD = libcollection.la
|
||||
diff --git a/common/ini/Makefile.am b/common/ini/Makefile.am
|
||||
index 962172f..7b5324d 100644
|
||||
--- a/common/ini/Makefile.am
|
||||
+++ b/common/ini/Makefile.am
|
||||
@@ -16,4 +16,4 @@ include_HEADERS = ini_config.h
|
||||
# Build unit test
|
||||
noinst_PROGRAMS = ini_config_ut
|
||||
ini_config_ut_SOURCES = ini_config_ut.c
|
||||
-ini_config_ut_LDADD = libini_config.la -lm -lz ../collection/libcollection.la
|
||||
\ No newline at end of file
|
||||
+ini_config_ut_LDADD = libini_config.la ../collection/libcollection.la
|
||||
diff --git a/sssd.spec b/sssd.spec
|
||||
index 88da56f..31e18f7 100644
|
||||
--- a/sssd.spec
|
||||
+++ b/sssd.spec
|
||||
@@ -24,6 +24,9 @@ Requires(postun): /sbin/service
|
||||
### Build Dependencies ###
|
||||
|
||||
BuildRequires: autoconf
|
||||
+BuildRequires: automake
|
||||
+BuildRequires: libtool
|
||||
+BuildRequires: m4
|
||||
BuildRequires: popt-devel
|
||||
BuildRequires: libtalloc-devel
|
||||
BuildRequires: libtevent-devel
|
||||
@@ -35,6 +38,7 @@ BuildRequires: openldap-devel
|
||||
BuildRequires: pam-devel
|
||||
BuildRequires: nss-devel
|
||||
BuildRequires: nspr-devel
|
||||
+BuildRequires: pcre-devel
|
||||
|
||||
%description
|
||||
Provides a set of daemons to manage access to remote directories and
|
||||
--
|
||||
1.6.0.6
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
b6b93c71f8907af5c66ca561d24b052c sssd-0.3.0.tar.gz
|
||||
c46bcc028e10c7da3fd0057a038a023f sssd-0.3.1.tar.gz
|
||||
|
@ -4,7 +4,6 @@ activeServices = nss, dp, pam
|
||||
|
||||
[services/nss]
|
||||
description = NSS Responder Configuration
|
||||
timeout = 150
|
||||
# the following prevents sssd for searching for the root user/group in
|
||||
# all domains (you can add here a comma separated list of system accounts are
|
||||
# always going to be /etc/passwd users, or that you want to filter out)
|
||||
@ -13,20 +12,17 @@ filterUsers = root
|
||||
|
||||
[services/dp]
|
||||
description = Data Provider Configuration
|
||||
timeout = 150
|
||||
|
||||
[services/pam]
|
||||
description = PAM Responder Configuration
|
||||
timeout = 150
|
||||
|
||||
[services/info]
|
||||
description = InfoPipe Configuration
|
||||
timeout = 150
|
||||
|
||||
[services/monitor]
|
||||
description = Service Monitor Configuration
|
||||
sbusTimeout = 150
|
||||
servicePingTime = 300
|
||||
#if a backend is particularly slow you can raise this timeout here
|
||||
sbusTimeout = 30
|
||||
|
||||
[domains]
|
||||
description = Domains served by SSSD
|
||||
@ -91,3 +87,6 @@ description = Domains served by SSSD
|
||||
; provider = proxy
|
||||
; libName = ldap
|
||||
; libPath = libnss_ldap.so.2
|
||||
;
|
||||
#if a backend is particularly slow you can raise this timeout here
|
||||
; timeout = 60
|
||||
|
15
sssd.spec
15
sssd.spec
@ -1,6 +1,6 @@
|
||||
Name: sssd
|
||||
Version: 0.3.0
|
||||
Release: 2%{?dist}
|
||||
Version: 0.3.1
|
||||
Release: 1%{?dist}
|
||||
Group: Applications/System
|
||||
Summary: System Security Services Daemon
|
||||
|
||||
@ -13,12 +13,10 @@ Source1: sssd.conf.default
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
|
||||
### Patches ###
|
||||
Patch100: 0001-Add-a-LSB-header-to-the-initscript.patch
|
||||
Patch101: 0001-Build-fixes-for-RPM-packaging-of-SSSD.patch
|
||||
|
||||
### Dependencies ###
|
||||
|
||||
Requires: libldb >= 0.9.3
|
||||
Requires: libldb = 0.9.3
|
||||
|
||||
Requires(preun): initscripts chkconfig
|
||||
Requires(postun): /sbin/service
|
||||
@ -53,9 +51,6 @@ services for projects like FreeIPA.
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch100 -p1 -b .lsb_init
|
||||
%patch101 -p1 -b .build_fixes
|
||||
|
||||
%build
|
||||
|
||||
# common
|
||||
@ -143,6 +138,10 @@ if [ $1 -ge 1 ] ; then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Mon Apr 13 2009 Simo Sorce <ssorce@redhat.com> - 0.3.1-1
|
||||
- Version 0.3.1
|
||||
- includes previous release patches
|
||||
|
||||
* Mon Apr 13 2009 Simo Sorce <ssorce@redhat.com> - 0.3.0-2
|
||||
- Try to fix build adding automake as an explicit BuildRequire
|
||||
- Add also a couple of last minute patches from upstream
|
||||
|
Loading…
Reference in New Issue
Block a user