sssd-2.6.0-1: Rebase to latest upstream release
This commit is contained in:
parent
1f7c03c1eb
commit
879ffa1b7c
File diff suppressed because it is too large
Load Diff
@ -1,277 +0,0 @@
|
|||||||
From 5a9a2f53ff44b1bd25a6de7c4ba91c709b63b0ba Mon Sep 17 00:00:00 2001
|
|
||||||
From: Alexey Tikhonov <atikhono@redhat.com>
|
|
||||||
Date: Fri, 18 Jun 2021 13:17:19 +0200
|
|
||||||
Subject: [PATCH] TOOLS: replace system() with execvp() to avoid execution of
|
|
||||||
user supplied command
|
|
||||||
|
|
||||||
A flaw was found in SSSD, where the sssctl command was vulnerable
|
|
||||||
to shell command injection via the logs-fetch and cache-expire
|
|
||||||
subcommands. This flaw allows an attacker to trick the root user
|
|
||||||
into running a specially crafted sssctl command, such as via sudo,
|
|
||||||
to gain root access. The highest threat from this vulnerability is
|
|
||||||
to confidentiality, integrity, as well as system availability.
|
|
||||||
|
|
||||||
:fixes: CVE-2021-3621
|
|
||||||
---
|
|
||||||
src/tools/sssctl/sssctl.c | 39 ++++++++++++++++-------
|
|
||||||
src/tools/sssctl/sssctl.h | 2 +-
|
|
||||||
src/tools/sssctl/sssctl_data.c | 57 +++++++++++-----------------------
|
|
||||||
src/tools/sssctl/sssctl_logs.c | 32 +++++++++++++++----
|
|
||||||
4 files changed, 73 insertions(+), 57 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/tools/sssctl/sssctl.c b/src/tools/sssctl/sssctl.c
|
|
||||||
index 2997dbf968acdd0b9821f726414f8ae1cf34b5d8..8adaf30910e13ea9e7c8ab8b151920c4f307427b 100644
|
|
||||||
--- a/src/tools/sssctl/sssctl.c
|
|
||||||
+++ b/src/tools/sssctl/sssctl.c
|
|
||||||
@@ -97,22 +97,36 @@ sssctl_prompt(const char *message,
|
|
||||||
return SSSCTL_PROMPT_ERROR;
|
|
||||||
}
|
|
||||||
|
|
||||||
-errno_t sssctl_run_command(const char *command)
|
|
||||||
+errno_t sssctl_run_command(const char *const argv[])
|
|
||||||
{
|
|
||||||
int ret;
|
|
||||||
+ int wstatus;
|
|
||||||
|
|
||||||
- DEBUG(SSSDBG_TRACE_FUNC, "Running %s\n", command);
|
|
||||||
+ DEBUG(SSSDBG_TRACE_FUNC, "Running '%s'\n", argv[0]);
|
|
||||||
|
|
||||||
- ret = system(command);
|
|
||||||
+ ret = fork();
|
|
||||||
if (ret == -1) {
|
|
||||||
- DEBUG(SSSDBG_CRIT_FAILURE, "Unable to execute %s\n", command);
|
|
||||||
ERROR("Error while executing external command\n");
|
|
||||||
return EFAULT;
|
|
||||||
- } else if (WEXITSTATUS(ret) != 0) {
|
|
||||||
- DEBUG(SSSDBG_CRIT_FAILURE, "Command %s failed with [%d]\n",
|
|
||||||
- command, WEXITSTATUS(ret));
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ if (ret == 0) {
|
|
||||||
+ /* cast is safe - see
|
|
||||||
+ https://pubs.opengroup.org/onlinepubs/9699919799/functions/exec.html
|
|
||||||
+ "The statement about argv[] and envp[] being constants ... "
|
|
||||||
+ */
|
|
||||||
+ execvp(argv[0], discard_const_p(char * const, argv));
|
|
||||||
ERROR("Error while executing external command\n");
|
|
||||||
- return EIO;
|
|
||||||
+ _exit(1);
|
|
||||||
+ } else {
|
|
||||||
+ if (waitpid(ret, &wstatus, 0) == -1) {
|
|
||||||
+ ERROR("Error while executing external command '%s'\n", argv[0]);
|
|
||||||
+ return EFAULT;
|
|
||||||
+ } else if (WEXITSTATUS(wstatus) != 0) {
|
|
||||||
+ ERROR("Command '%s' failed with [%d]\n",
|
|
||||||
+ argv[0], WEXITSTATUS(wstatus));
|
|
||||||
+ return EIO;
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
|
|
||||||
return EOK;
|
|
||||||
@@ -132,11 +146,14 @@ static errno_t sssctl_manage_service(enum sssctl_svc_action action)
|
|
||||||
#elif defined(HAVE_SERVICE)
|
|
||||||
switch (action) {
|
|
||||||
case SSSCTL_SVC_START:
|
|
||||||
- return sssctl_run_command(SERVICE_PATH" sssd start");
|
|
||||||
+ return sssctl_run_command(
|
|
||||||
+ (const char *[]){SERVICE_PATH, "sssd", "start", NULL});
|
|
||||||
case SSSCTL_SVC_STOP:
|
|
||||||
- return sssctl_run_command(SERVICE_PATH" sssd stop");
|
|
||||||
+ return sssctl_run_command(
|
|
||||||
+ (const char *[]){SERVICE_PATH, "sssd", "stop", NULL});
|
|
||||||
case SSSCTL_SVC_RESTART:
|
|
||||||
- return sssctl_run_command(SERVICE_PATH" sssd restart");
|
|
||||||
+ return sssctl_run_command(
|
|
||||||
+ (const char *[]){SERVICE_PATH, "sssd", "restart", NULL});
|
|
||||||
}
|
|
||||||
#endif
|
|
||||||
|
|
||||||
diff --git a/src/tools/sssctl/sssctl.h b/src/tools/sssctl/sssctl.h
|
|
||||||
index 0115b2457c48bb0b8ad8ef8fd20d6fc81bdb58b4..599ef65196fcae6454cd5b46aa7a2cf6e7cbba73 100644
|
|
||||||
--- a/src/tools/sssctl/sssctl.h
|
|
||||||
+++ b/src/tools/sssctl/sssctl.h
|
|
||||||
@@ -47,7 +47,7 @@ enum sssctl_prompt_result
|
|
||||||
sssctl_prompt(const char *message,
|
|
||||||
enum sssctl_prompt_result defval);
|
|
||||||
|
|
||||||
-errno_t sssctl_run_command(const char *command);
|
|
||||||
+errno_t sssctl_run_command(const char *const argv[]); /* argv[0] - command */
|
|
||||||
bool sssctl_start_sssd(bool force);
|
|
||||||
bool sssctl_stop_sssd(bool force);
|
|
||||||
bool sssctl_restart_sssd(bool force);
|
|
||||||
diff --git a/src/tools/sssctl/sssctl_data.c b/src/tools/sssctl/sssctl_data.c
|
|
||||||
index 8d79b977fdb63fd6c6c925538230bb4ca74a103b..bf2291341668590f4c600237593ea1fd8fe4e4dc 100644
|
|
||||||
--- a/src/tools/sssctl/sssctl_data.c
|
|
||||||
+++ b/src/tools/sssctl/sssctl_data.c
|
|
||||||
@@ -105,15 +105,15 @@ static errno_t sssctl_backup(bool force)
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
- ret = sssctl_run_command("sss_override user-export "
|
|
||||||
- SSS_BACKUP_USER_OVERRIDES);
|
|
||||||
+ ret = sssctl_run_command((const char *[]){"sss_override", "user-export",
|
|
||||||
+ SSS_BACKUP_USER_OVERRIDES, NULL});
|
|
||||||
if (ret != EOK) {
|
|
||||||
ERROR("Unable to export user overrides\n");
|
|
||||||
return ret;
|
|
||||||
}
|
|
||||||
|
|
||||||
- ret = sssctl_run_command("sss_override group-export "
|
|
||||||
- SSS_BACKUP_GROUP_OVERRIDES);
|
|
||||||
+ ret = sssctl_run_command((const char *[]){"sss_override", "group-export",
|
|
||||||
+ SSS_BACKUP_GROUP_OVERRIDES, NULL});
|
|
||||||
if (ret != EOK) {
|
|
||||||
ERROR("Unable to export group overrides\n");
|
|
||||||
return ret;
|
|
||||||
@@ -158,8 +158,8 @@ static errno_t sssctl_restore(bool force_start, bool force_restart)
|
|
||||||
}
|
|
||||||
|
|
||||||
if (sssctl_backup_file_exists(SSS_BACKUP_USER_OVERRIDES)) {
|
|
||||||
- ret = sssctl_run_command("sss_override user-import "
|
|
||||||
- SSS_BACKUP_USER_OVERRIDES);
|
|
||||||
+ ret = sssctl_run_command((const char *[]){"sss_override", "user-import",
|
|
||||||
+ SSS_BACKUP_USER_OVERRIDES, NULL});
|
|
||||||
if (ret != EOK) {
|
|
||||||
ERROR("Unable to import user overrides\n");
|
|
||||||
return ret;
|
|
||||||
@@ -167,8 +167,8 @@ static errno_t sssctl_restore(bool force_start, bool force_restart)
|
|
||||||
}
|
|
||||||
|
|
||||||
if (sssctl_backup_file_exists(SSS_BACKUP_USER_OVERRIDES)) {
|
|
||||||
- ret = sssctl_run_command("sss_override group-import "
|
|
||||||
- SSS_BACKUP_GROUP_OVERRIDES);
|
|
||||||
+ ret = sssctl_run_command((const char *[]){"sss_override", "group-import",
|
|
||||||
+ SSS_BACKUP_GROUP_OVERRIDES, NULL});
|
|
||||||
if (ret != EOK) {
|
|
||||||
ERROR("Unable to import group overrides\n");
|
|
||||||
return ret;
|
|
||||||
@@ -296,40 +296,19 @@ errno_t sssctl_cache_expire(struct sss_cmdline *cmdline,
|
|
||||||
void *pvt)
|
|
||||||
{
|
|
||||||
errno_t ret;
|
|
||||||
- char *cmd_args = NULL;
|
|
||||||
- const char *cachecmd = SSS_CACHE;
|
|
||||||
- char *cmd = NULL;
|
|
||||||
- int i;
|
|
||||||
|
|
||||||
- if (cmdline->argc == 0) {
|
|
||||||
- ret = sssctl_run_command(cachecmd);
|
|
||||||
- goto done;
|
|
||||||
+ const char **args = talloc_array_size(tool_ctx,
|
|
||||||
+ sizeof(char *),
|
|
||||||
+ cmdline->argc + 2);
|
|
||||||
+ if (!args) {
|
|
||||||
+ return ENOMEM;
|
|
||||||
}
|
|
||||||
+ memcpy(&args[1], cmdline->argv, sizeof(char *) * cmdline->argc);
|
|
||||||
+ args[0] = SSS_CACHE;
|
|
||||||
+ args[cmdline->argc + 1] = NULL;
|
|
||||||
|
|
||||||
- cmd_args = talloc_strdup(tool_ctx, "");
|
|
||||||
- if (cmd_args == NULL) {
|
|
||||||
- ret = ENOMEM;
|
|
||||||
- goto done;
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
- for (i = 0; i < cmdline->argc; i++) {
|
|
||||||
- cmd_args = talloc_strdup_append(cmd_args, cmdline->argv[i]);
|
|
||||||
- if (i != cmdline->argc - 1) {
|
|
||||||
- cmd_args = talloc_strdup_append(cmd_args, " ");
|
|
||||||
- }
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
- cmd = talloc_asprintf(tool_ctx, "%s %s", cachecmd, cmd_args);
|
|
||||||
- if (cmd == NULL) {
|
|
||||||
- ret = ENOMEM;
|
|
||||||
- goto done;
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
- ret = sssctl_run_command(cmd);
|
|
||||||
-
|
|
||||||
-done:
|
|
||||||
- talloc_free(cmd_args);
|
|
||||||
- talloc_free(cmd);
|
|
||||||
+ ret = sssctl_run_command(args);
|
|
||||||
|
|
||||||
+ talloc_free(args);
|
|
||||||
return ret;
|
|
||||||
}
|
|
||||||
diff --git a/src/tools/sssctl/sssctl_logs.c b/src/tools/sssctl/sssctl_logs.c
|
|
||||||
index 9ff2be05b61108414462d6e17a2c4c4887907a59..ebb2c4571caec487d29ff2d5ceaee1561e845506 100644
|
|
||||||
--- a/src/tools/sssctl/sssctl_logs.c
|
|
||||||
+++ b/src/tools/sssctl/sssctl_logs.c
|
|
||||||
@@ -31,6 +31,7 @@
|
|
||||||
#include <ldb.h>
|
|
||||||
#include <popt.h>
|
|
||||||
#include <stdio.h>
|
|
||||||
+#include <glob.h>
|
|
||||||
|
|
||||||
#include "util/util.h"
|
|
||||||
#include "tools/common/sss_process.h"
|
|
||||||
@@ -230,6 +231,7 @@ errno_t sssctl_logs_remove(struct sss_cmdline *cmdline,
|
|
||||||
{
|
|
||||||
struct sssctl_logs_opts opts = {0};
|
|
||||||
errno_t ret;
|
|
||||||
+ glob_t globbuf;
|
|
||||||
|
|
||||||
/* Parse command line. */
|
|
||||||
struct poptOption options[] = {
|
|
||||||
@@ -253,8 +255,20 @@ errno_t sssctl_logs_remove(struct sss_cmdline *cmdline,
|
|
||||||
|
|
||||||
sss_signal(SIGHUP);
|
|
||||||
} else {
|
|
||||||
+ globbuf.gl_offs = 4;
|
|
||||||
+ ret = glob(LOG_PATH"/*.log", GLOB_ERR|GLOB_DOOFFS, NULL, &globbuf);
|
|
||||||
+ if (ret != 0) {
|
|
||||||
+ DEBUG(SSSDBG_CRIT_FAILURE, "Unable to expand log files list\n");
|
|
||||||
+ return ret;
|
|
||||||
+ }
|
|
||||||
+ globbuf.gl_pathv[0] = discard_const_p(char, "truncate");
|
|
||||||
+ globbuf.gl_pathv[1] = discard_const_p(char, "--no-create");
|
|
||||||
+ globbuf.gl_pathv[2] = discard_const_p(char, "--size");
|
|
||||||
+ globbuf.gl_pathv[3] = discard_const_p(char, "0");
|
|
||||||
+
|
|
||||||
PRINT("Truncating log files...\n");
|
|
||||||
- ret = sssctl_run_command("truncate --no-create --size 0 " LOG_FILES);
|
|
||||||
+ ret = sssctl_run_command((const char * const*)globbuf.gl_pathv);
|
|
||||||
+ globfree(&globbuf);
|
|
||||||
if (ret != EOK) {
|
|
||||||
ERROR("Unable to truncate log files\n");
|
|
||||||
return ret;
|
|
||||||
@@ -269,8 +283,8 @@ errno_t sssctl_logs_fetch(struct sss_cmdline *cmdline,
|
|
||||||
void *pvt)
|
|
||||||
{
|
|
||||||
const char *file;
|
|
||||||
- const char *cmd;
|
|
||||||
errno_t ret;
|
|
||||||
+ glob_t globbuf;
|
|
||||||
|
|
||||||
/* Parse command line. */
|
|
||||||
ret = sss_tool_popt_ex(cmdline, NULL, SSS_TOOL_OPT_OPTIONAL, NULL, NULL,
|
|
||||||
@@ -280,13 +294,19 @@ errno_t sssctl_logs_fetch(struct sss_cmdline *cmdline,
|
|
||||||
return ret;
|
|
||||||
}
|
|
||||||
|
|
||||||
- cmd = talloc_asprintf(tool_ctx, "tar -czf %s %s", file, LOG_FILES);
|
|
||||||
- if (cmd == NULL) {
|
|
||||||
- ERROR("Out of memory!");
|
|
||||||
+ globbuf.gl_offs = 3;
|
|
||||||
+ ret = glob(LOG_PATH"/*.log", GLOB_ERR|GLOB_DOOFFS, NULL, &globbuf);
|
|
||||||
+ if (ret != 0) {
|
|
||||||
+ DEBUG(SSSDBG_CRIT_FAILURE, "Unable to expand log files list\n");
|
|
||||||
+ return ret;
|
|
||||||
}
|
|
||||||
+ globbuf.gl_pathv[0] = discard_const_p(char, "tar");
|
|
||||||
+ globbuf.gl_pathv[1] = discard_const_p(char, "-czf");
|
|
||||||
+ globbuf.gl_pathv[2] = discard_const_p(char, file);
|
|
||||||
|
|
||||||
PRINT("Archiving log files into %s...\n", file);
|
|
||||||
- ret = sssctl_run_command(cmd);
|
|
||||||
+ ret = sssctl_run_command((const char * const*)globbuf.gl_pathv);
|
|
||||||
+ globfree(&globbuf);
|
|
||||||
if (ret != EOK) {
|
|
||||||
ERROR("Unable to archive log files\n");
|
|
||||||
return ret;
|
|
||||||
--
|
|
||||||
2.31.1
|
|
||||||
|
|
@ -1,43 +0,0 @@
|
|||||||
From 9e47b63e4fe5c17b1fb308ce98a5f04ce5b5624b Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Pavel=20B=C5=99ezina?= <pbrezina@redhat.com>
|
|
||||||
Date: Mon, 6 Sep 2021 13:48:06 +0200
|
|
||||||
Subject: [PATCH] configure: do not unset PYTHON_PREFIX and PYTHON_EXEC_PREFIX
|
|
||||||
|
|
||||||
Recent changes in autoconf changed location of directories from:
|
|
||||||
|
|
||||||
```
|
|
||||||
checking for /usr/bin/python3 script directory... ${prefix}/lib/python3.9/site-packages
|
|
||||||
checking for /usr/bin/python3 extension module directory... ${exec_prefix}/lib64/python3.9/site-packages
|
|
||||||
```
|
|
||||||
|
|
||||||
to
|
|
||||||
|
|
||||||
```
|
|
||||||
checking for /usr/bin/python3 script directory... ${PYTHON_PREFIX}/lib/python3.10/site-packages
|
|
||||||
checking for /usr/bin/python3 extension module directory... ${PYTHON_EXEC_PREFIX}/lib64/python3.10/site-packages
|
|
||||||
```
|
|
||||||
|
|
||||||
However, we unset these variables in SSS_CLEAN_PYTHON_VARIABLES and
|
|
||||||
therefore the correct prefix is not applied anymore during installation.
|
|
||||||
|
|
||||||
Reviewed-by: Pawel Polawski <ppolawsk@redhat.com>
|
|
||||||
---
|
|
||||||
src/external/python.m4 | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/external/python.m4 b/src/external/python.m4
|
|
||||||
index 1738f9f8f..6a6283511 100644
|
|
||||||
--- a/src/external/python.m4
|
|
||||||
+++ b/src/external/python.m4
|
|
||||||
@@ -73,7 +73,7 @@ AC_DEFUN([SSS_CLEAN_PYTHON_VARIABLES],
|
|
||||||
[
|
|
||||||
unset pyexecdir pkgpyexecdir pythondir pgkpythondir
|
|
||||||
unset PYTHON PYTHON_CFLAGS PYTHON_LIBS PYTHON_INCLUDES
|
|
||||||
- unset PYTHON_PREFIX PYTHON_EXEC_PREFIX PYTHON_VERSION PYTHON_CONFIG
|
|
||||||
+ unset PYTHON_VERSION PYTHON_CONFIG
|
|
||||||
|
|
||||||
dnl removed cached variables, required for reusing of AM_PATH_PYTHON
|
|
||||||
unset am_cv_pathless_PYTHON ac_cv_path_PYTHON am_cv_python_version
|
|
||||||
--
|
|
||||||
2.31.1
|
|
||||||
|
|
51
sssd.spec
51
sssd.spec
@ -14,6 +14,16 @@
|
|||||||
%global child_attrs 4750
|
%global child_attrs 4750
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
%if 0%{?fedora} >= 34
|
||||||
|
%global build_kcm_renewals 1
|
||||||
|
%global krb5_version 1.19.1
|
||||||
|
%elif 0%{?rhel} >= 8
|
||||||
|
%global build_kcm_renewals 1
|
||||||
|
%global krb5_version 1.18.2
|
||||||
|
%else
|
||||||
|
%global build_kcm_renewals 0
|
||||||
|
%endif
|
||||||
|
|
||||||
# we don't want to provide private python extension libs
|
# we don't want to provide private python extension libs
|
||||||
%define __provides_exclude_from %{python3_sitearch}/.*\.so$
|
%define __provides_exclude_from %{python3_sitearch}/.*\.so$
|
||||||
|
|
||||||
@ -26,17 +36,14 @@
|
|||||||
%global samba_package_version %(rpm -q samba-devel --queryformat %{version}-%{release})
|
%global samba_package_version %(rpm -q samba-devel --queryformat %{version}-%{release})
|
||||||
|
|
||||||
Name: sssd
|
Name: sssd
|
||||||
Version: 2.5.2
|
Version: 2.6.0
|
||||||
Release: 7%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: System Security Services Daemon
|
Summary: System Security Services Daemon
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
URL: https://github.com/SSSD/sssd/
|
URL: https://github.com/SSSD/sssd/
|
||||||
Source0: https://github.com/SSSD/sssd/releases/download/2.5.2/sssd-2.5.2.tar.gz
|
Source0: https://github.com/SSSD/sssd/releases/download/2.6.0/sssd-2.6.0.tar.gz
|
||||||
|
|
||||||
### Patches ###
|
### Patches ###
|
||||||
Patch0001: 0001-Basics-of-subid-ranges-support-for-IPA-provider.patch
|
|
||||||
Patch0002: 0002-TOOLS-replace-system-with-execvp.patch
|
|
||||||
Patch0003: 0003-configure-do-not-unset-PYTHON_PREFIX-and-PYTHON_EXEC.patch
|
|
||||||
|
|
||||||
### Dependencies ###
|
### Dependencies ###
|
||||||
|
|
||||||
@ -76,10 +83,8 @@ BuildRequires: findutils
|
|||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: gdm-pam-extensions-devel
|
BuildRequires: gdm-pam-extensions-devel
|
||||||
BuildRequires: gettext-devel
|
BuildRequires: gettext-devel
|
||||||
BuildRequires: glib2-devel
|
|
||||||
# required for p11_child smartcard tests
|
# required for p11_child smartcard tests
|
||||||
BuildRequires: gnutls-utils
|
BuildRequires: gnutls-utils
|
||||||
BuildRequires: jansson-devel
|
|
||||||
BuildRequires: keyutils-libs-devel
|
BuildRequires: keyutils-libs-devel
|
||||||
BuildRequires: krb5-devel
|
BuildRequires: krb5-devel
|
||||||
BuildRequires: libcmocka-devel >= 1.0.0
|
BuildRequires: libcmocka-devel >= 1.0.0
|
||||||
@ -95,6 +100,8 @@ BuildRequires: libtalloc-devel
|
|||||||
BuildRequires: libtdb-devel
|
BuildRequires: libtdb-devel
|
||||||
BuildRequires: libtevent-devel
|
BuildRequires: libtevent-devel
|
||||||
BuildRequires: libtool
|
BuildRequires: libtool
|
||||||
|
BuildRequires: libunistring
|
||||||
|
BuildRequires: libunistring-devel
|
||||||
BuildRequires: libuuid-devel
|
BuildRequires: libuuid-devel
|
||||||
BuildRequires: libxml2
|
BuildRequires: libxml2
|
||||||
BuildRequires: libxslt
|
BuildRequires: libxslt
|
||||||
@ -123,6 +130,9 @@ BuildRequires: systemd-devel
|
|||||||
BuildRequires: systemtap-sdt-devel
|
BuildRequires: systemtap-sdt-devel
|
||||||
BuildRequires: uid_wrapper
|
BuildRequires: uid_wrapper
|
||||||
BuildRequires: po4a
|
BuildRequires: po4a
|
||||||
|
%if %{build_kcm_renewals}
|
||||||
|
BuildRequires: krb5-libs >= %{krb5_version}
|
||||||
|
%endif
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Provides a set of daemons to manage access to remote directories and
|
Provides a set of daemons to manage access to remote directories and
|
||||||
@ -197,13 +207,13 @@ Requires: sssd-common = %{version}-%{release}
|
|||||||
Requires: python3-sss = %{version}-%{release}
|
Requires: python3-sss = %{version}-%{release}
|
||||||
Requires: python3-sssdconfig = %{version}-%{release}
|
Requires: python3-sssdconfig = %{version}-%{release}
|
||||||
Requires: libsss_certmap = %{version}-%{release}
|
Requires: libsss_certmap = %{version}-%{release}
|
||||||
|
# required by sss_analyze
|
||||||
|
Requires: python3-systemd
|
||||||
|
Requires: python3-click
|
||||||
Recommends: sssd-dbus
|
Recommends: sssd-dbus
|
||||||
|
|
||||||
%description tools
|
%description tools
|
||||||
Provides userspace tools for manipulating users, groups, and nested groups in
|
Provides several administrative tools:
|
||||||
SSSD when using id_provider = local in /etc/sssd/sssd.conf.
|
|
||||||
|
|
||||||
Also provides several other administrative tools:
|
|
||||||
* sss_debuglevel to change the debug level on the fly
|
* sss_debuglevel to change the debug level on the fly
|
||||||
* sss_seed which pre-creates a user entry for use in kickstarts
|
* sss_seed which pre-creates a user entry for use in kickstarts
|
||||||
* sss_obfuscate for generating an obfuscated LDAP password
|
* sss_obfuscate for generating an obfuscated LDAP password
|
||||||
@ -225,11 +235,8 @@ Requires: sssd-common = %{version}-%{release}
|
|||||||
%{?python_provide:%python_provide python3-sss}
|
%{?python_provide:%python_provide python3-sss}
|
||||||
|
|
||||||
%description -n python3-sss
|
%description -n python3-sss
|
||||||
Provides python3 module for manipulating users, groups, and nested groups in
|
Provides python3 bindings:
|
||||||
SSSD when using id_provider = local in /etc/sssd/sssd.conf.
|
* function for retrieving list of groups user belongs to
|
||||||
|
|
||||||
Also provides several other useful python3 bindings:
|
|
||||||
* function for retrieving list of groups user belongs to.
|
|
||||||
* class for obfuscation of passwords
|
* class for obfuscation of passwords
|
||||||
|
|
||||||
%package -n python3-sss-murmur
|
%package -n python3-sss-murmur
|
||||||
@ -470,7 +477,9 @@ Library to map certificates to users based on rules
|
|||||||
Summary: An implementation of a Kerberos KCM server
|
Summary: An implementation of a Kerberos KCM server
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Requires: sssd-common = %{version}-%{release}
|
Requires: sssd-common = %{version}-%{release}
|
||||||
Requires: krb5-libs >= 1.19.1
|
%if %{build_kcm_renewals}
|
||||||
|
Requires: krb5-libs >= %{krb5_version}
|
||||||
|
%endif
|
||||||
%{?systemd_requires}
|
%{?systemd_requires}
|
||||||
|
|
||||||
%description kcm
|
%description kcm
|
||||||
@ -512,6 +521,7 @@ autoreconf -ivf
|
|||||||
|
|
||||||
%make_build all docs runstatedir=%{_rundir}
|
%make_build all docs runstatedir=%{_rundir}
|
||||||
|
|
||||||
|
%py3_shebang_fix src/tools/analyzer/sss_analyze.py
|
||||||
sed -i -e 's:/usr/bin/python:/usr/bin/python3:' src/tools/sss_obfuscate
|
sed -i -e 's:/usr/bin/python:/usr/bin/python3:' src/tools/sss_obfuscate
|
||||||
|
|
||||||
%check
|
%check
|
||||||
@ -841,6 +851,7 @@ done
|
|||||||
%{_sbindir}/sss_debuglevel
|
%{_sbindir}/sss_debuglevel
|
||||||
%{_sbindir}/sss_seed
|
%{_sbindir}/sss_seed
|
||||||
%{_sbindir}/sssctl
|
%{_sbindir}/sssctl
|
||||||
|
%{python3_sitelib}/sssd/
|
||||||
%{_mandir}/man8/sss_obfuscate.8*
|
%{_mandir}/man8/sss_obfuscate.8*
|
||||||
%{_mandir}/man8/sss_override.8*
|
%{_mandir}/man8/sss_override.8*
|
||||||
%{_mandir}/man8/sss_debuglevel.8*
|
%{_mandir}/man8/sss_debuglevel.8*
|
||||||
@ -926,7 +937,6 @@ done
|
|||||||
%{_unitdir}/sssd-kcm.socket
|
%{_unitdir}/sssd-kcm.socket
|
||||||
%{_unitdir}/sssd-kcm.service
|
%{_unitdir}/sssd-kcm.service
|
||||||
%{_mandir}/man8/sssd-kcm.8*
|
%{_mandir}/man8/sssd-kcm.8*
|
||||||
%{_libdir}/%{name}/libsss_secrets.so
|
|
||||||
|
|
||||||
%if 0%{?rhel}
|
%if 0%{?rhel}
|
||||||
%pre common
|
%pre common
|
||||||
@ -1002,6 +1012,9 @@ fi
|
|||||||
%systemd_postun_with_restart sssd.service
|
%systemd_postun_with_restart sssd.service
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Oct 14 2021 Pavel Březina <pbrezina@redhat.com> - 2.6.0-1
|
||||||
|
- Rebase to SSSD 2.6.0
|
||||||
|
|
||||||
* Tue Sep 21 2021 Iker Pedrosa <ipedrosa@redhat.com> - 2.5.2-7
|
* Tue Sep 21 2021 Iker Pedrosa <ipedrosa@redhat.com> - 2.5.2-7
|
||||||
- Solve compilation problem with autoconf
|
- Solve compilation problem with autoconf
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user