New upstream release 1.8.2
- https://fedorahosted.org/sssd/wiki/Releases/Notes-1.8.2 - Several fixes to case-insensitive domain functions - Fix for GSSAPI binds when the keytab contains unrelated principals - Fixed several segfaults - Workarounds added for LDAP servers with unreadable RootDSE - SSH knownhostproxy will no longer enter an infinite loop preventing login - The provided SYSV init script now starts SSSD earlier at startup and stops it later during shutdown - Assorted minor fixes for issues discovered by static analysis tools
This commit is contained in:
parent
d023298922
commit
77acf296a2
1
.gitignore
vendored
1
.gitignore
vendored
@ -26,3 +26,4 @@ sssd-1.2.91.tar.gz
|
||||
/sssd-1.8.0beta3.tar.gz
|
||||
/sssd-1.8.0.tar.gz
|
||||
/sssd-1.8.1.tar.gz
|
||||
/sssd-1.8.2.tar.gz
|
||||
|
@ -1,25 +0,0 @@
|
||||
From b3671769f57521c4eeef850a4963e320f170082c Mon Sep 17 00:00:00 2001
|
||||
From: Jakub Hrozek <jhrozek@redhat.com>
|
||||
Date: Fri, 16 Mar 2012 09:36:38 -0400
|
||||
Subject: [PATCH] Fix uninitialized variable
|
||||
|
||||
---
|
||||
src/providers/ldap/ldap_common.c | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/src/providers/ldap/ldap_common.c b/src/providers/ldap/ldap_common.c
|
||||
index d5dc4a0af5590bbe6f8d474095c6094582deb542..949244183c0db7b8e576c7b3c5e63e2bb35cb39f 100644
|
||||
--- a/src/providers/ldap/ldap_common.c
|
||||
+++ b/src/providers/ldap/ldap_common.c
|
||||
@@ -1598,7 +1598,7 @@ errno_t list_missing_attrs(TALLOC_CTX *mem_ctx,
|
||||
}
|
||||
|
||||
if (k == 0) {
|
||||
- *missing = NULL;
|
||||
+ *missing_attrs = NULL;
|
||||
} else {
|
||||
/* Terminate the list */
|
||||
missing[k] = NULL;
|
||||
--
|
||||
1.7.7.6
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
8f5e88fbdc8edeba7bc816da3448b726 sssd-1.8.1.tar.gz
|
||||
9971ee7acf5e47a01377a1da451e2216 sssd-1.8.2.tar.gz
|
||||
|
18
sssd.spec
18
sssd.spec
@ -15,8 +15,8 @@
|
||||
%global ldb_version 1.1.4
|
||||
|
||||
Name: sssd
|
||||
Version: 1.8.1
|
||||
Release: 9%{?dist}
|
||||
Version: 1.8.2
|
||||
Release: 10%{?dist}
|
||||
Group: Applications/System
|
||||
Summary: System Security Services Daemon
|
||||
License: GPLv3+
|
||||
@ -26,8 +26,6 @@ BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
|
||||
### Patches ###
|
||||
|
||||
Patch0001: 0001-Fix-uninitialized-variable.patch
|
||||
|
||||
Patch1001: FED01-Change-Kerberos-credential-cache-default-loca.patch
|
||||
|
||||
### Dependencies ###
|
||||
@ -458,6 +456,18 @@ fi
|
||||
%postun -n libipa_hbac -p /sbin/ldconfig
|
||||
|
||||
%changelog
|
||||
* Mon Apr 09 2012 Stephen Gallagher <sgallagh@redhat.com> - 1.8.2-10
|
||||
- New upstream release 1.8.2
|
||||
- https://fedorahosted.org/sssd/wiki/Releases/Notes-1.8.2
|
||||
- Several fixes to case-insensitive domain functions
|
||||
- Fix for GSSAPI binds when the keytab contains unrelated principals
|
||||
- Fixed several segfaults
|
||||
- Workarounds added for LDAP servers with unreadable RootDSE
|
||||
- SSH knownhostproxy will no longer enter an infinite loop preventing login
|
||||
- The provided SYSV init script now starts SSSD earlier at startup and stops
|
||||
it later during shutdown
|
||||
- Assorted minor fixes for issues discovered by static analysis tools
|
||||
|
||||
* Mon Mar 26 2012 Stephen Gallagher <sgallagh@redhat.com> - 1.8.1-9
|
||||
- Don't duplicate libsss_autofs.so in two packages
|
||||
- Set explicit package contents instead of globbing
|
||||
|
Loading…
Reference in New Issue
Block a user