Resolves: rhbz#752495 - Crash when apply settings
This commit is contained in:
parent
dd4aa148dd
commit
50d0fe5c94
@ -0,0 +1,35 @@
|
|||||||
|
From cc1bae136c35b0a72c0e39928b0be414e182d375 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jakub Hrozek <jhrozek@redhat.com>
|
||||||
|
Date: Thu, 10 Nov 2011 12:36:26 +0100
|
||||||
|
Subject: [PATCH] configAPI: Fix removing in old domain when saving a new
|
||||||
|
domain
|
||||||
|
|
||||||
|
---
|
||||||
|
src/config/SSSDConfig.py | 4 ++--
|
||||||
|
1 files changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/config/SSSDConfig.py b/src/config/SSSDConfig.py
|
||||||
|
index 87b1d63..6858ce4 100644
|
||||||
|
--- a/src/config/SSSDConfig.py
|
||||||
|
+++ b/src/config/SSSDConfig.py
|
||||||
|
@@ -1760,7 +1760,7 @@ class SSSDConfig(SSSDChangeConf):
|
||||||
|
domain.oldname = None;
|
||||||
|
|
||||||
|
sectionname = 'domain/%s' % name
|
||||||
|
- section_subtree = self.findOpts(self.opts, 'section', sectionname)
|
||||||
|
+ (no, section_subtree) = self.findOpts(self.opts, 'section', sectionname)
|
||||||
|
|
||||||
|
if name not in self.list_domains():
|
||||||
|
self.add_section(sectionname, []);
|
||||||
|
@@ -1768,7 +1768,7 @@ class SSSDConfig(SSSDChangeConf):
|
||||||
|
for option in self.options(sectionname):
|
||||||
|
if option['type'] == 'option':
|
||||||
|
if option['name'] not in domain.get_all_options():
|
||||||
|
- self.delete_option_subtree(section_subtree, 'option', option['name'], True)
|
||||||
|
+ self.delete_option_subtree(section_subtree['values'], 'option', option['name'], True)
|
||||||
|
|
||||||
|
for option,value in domain.get_all_options().items():
|
||||||
|
if (type(value) == list):
|
||||||
|
--
|
||||||
|
1.7.7
|
||||||
|
|
28
sssd.spec
28
sssd.spec
@ -15,7 +15,7 @@
|
|||||||
|
|
||||||
# Determine the location of the LDB modules directory
|
# Determine the location of the LDB modules directory
|
||||||
%global ldb_modulesdir %(pkg-config --variable=modulesdir ldb)
|
%global ldb_modulesdir %(pkg-config --variable=modulesdir ldb)
|
||||||
%global ldb_version 1.1.3
|
%global ldb_version 1.1.0
|
||||||
|
|
||||||
Name: sssd
|
Name: sssd
|
||||||
Version: 1.6.3
|
Version: 1.6.3
|
||||||
@ -28,7 +28,7 @@ Source0: https://fedorahosted.org/released/sssd/%{name}-%{version}.tar.gz
|
|||||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||||
|
|
||||||
### Patches ###
|
### Patches ###
|
||||||
|
Patch0001: 0001-configAPI-Fix-removing-in-old-domain-when-saving-a-n.patch
|
||||||
|
|
||||||
### Dependencies ###
|
### Dependencies ###
|
||||||
|
|
||||||
@ -151,8 +151,28 @@ used by Python applications.
|
|||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
|
# Update timestamps on the files touched by a patch, to avoid non-equal
|
||||||
|
# .pyc/.pyo files across the multilib peers within a build, where "Level"
|
||||||
|
# is the patch prefix option (e.g. -p1)
|
||||||
|
# Taken from specfile for python-simplejson
|
||||||
|
UpdateTimestamps() {
|
||||||
|
Level=$1
|
||||||
|
PatchFile=$2
|
||||||
|
|
||||||
|
# Locate the affected files:
|
||||||
|
for f in $(diffstat $Level -l $PatchFile); do
|
||||||
|
# Set the files to have the same timestamp as that of the patch:
|
||||||
|
touch -r $PatchFile $f
|
||||||
|
done
|
||||||
|
}
|
||||||
|
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
|
for p in %patches ; do
|
||||||
|
%__patch -p1 -i $p
|
||||||
|
UpdateTimestamps -p1 $p
|
||||||
|
done
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoreconf -ivf
|
autoreconf -ivf
|
||||||
%configure \
|
%configure \
|
||||||
@ -356,8 +376,8 @@ fi
|
|||||||
%postun -n libipa_hbac -p /sbin/ldconfig
|
%postun -n libipa_hbac -p /sbin/ldconfig
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Wed Nov 09 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.6.3-2
|
* Thu Nov 10 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.6.3-2
|
||||||
- Rebuild for new version of libldb
|
- Resolves: rhbz#752495 - Crash when apply settings
|
||||||
|
|
||||||
* Fri Nov 04 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.6.3-1
|
* Fri Nov 04 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.6.3-1
|
||||||
- New upstream release 1.6.3
|
- New upstream release 1.6.3
|
||||||
|
Loading…
Reference in New Issue
Block a user