New upstream release 1.9.0 beta 3
- https://fedorahosted.org/sssd/wiki/Releases/Notes-1.9.0beta3 - Add a new PAC responder for dealing with cross-realm Kerberos trusts - Terminate idle connections to the NSS and PAM responders
This commit is contained in:
parent
2cb25205a4
commit
058cfb833c
1
.gitignore
vendored
1
.gitignore
vendored
@ -30,3 +30,4 @@ sssd-1.2.91.tar.gz
|
||||
/sssd-1.8.3.tar.gz
|
||||
/sssd-1.9.0beta1.tar.gz
|
||||
/sssd-1.9.0beta2.tar.gz
|
||||
/sssd-1.9.0beta3.tar.gz
|
||||
|
@ -1,28 +0,0 @@
|
||||
From 6adec5daccb1b942c9bb284df11792f50c564ee2 Mon Sep 17 00:00:00 2001
|
||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||
Date: Mon, 18 Jun 2012 10:04:11 -0400
|
||||
Subject: [PATCH] Fix typo breaking DIR cache detection
|
||||
|
||||
---
|
||||
src/util/sss_krb5.h | 2 --
|
||||
1 file changed, 2 deletions(-)
|
||||
|
||||
diff --git a/src/util/sss_krb5.h b/src/util/sss_krb5.h
|
||||
index 4f2e67a7ff41e11bb2e6273196a74aecca626d3e..d56b3bdd53f6ff15cd0ac027e248c96d0775cded 100644
|
||||
--- a/src/util/sss_krb5.h
|
||||
+++ b/src/util/sss_krb5.h
|
||||
@@ -41,11 +41,9 @@
|
||||
#define KERBEROS_PWEXPIRE_WARNING_TIME (7 * 24 * 60 * 60)
|
||||
#define KEYTAB_CLEAN_NAME keytab_name ? keytab_name : "default"
|
||||
|
||||
-#if 0
|
||||
#if defined HAVE_KRB5_CC_CACHE_MATCH && defined HAVE_KRB5_CC_GET_FULL_NAME
|
||||
#define HAVE_KRB5_DIRCACHE 1
|
||||
#endif
|
||||
-#endif
|
||||
|
||||
const char * KRB5_CALLCONV sss_krb5_get_error_message (krb5_context,
|
||||
krb5_error_code);
|
||||
--
|
||||
1.7.10.2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
76063afcf4994ec45319c6d053544153 sssd-1.9.0beta2.tar.gz
|
||||
3fab7090b965d9debc389274d5ab7a09 sssd-1.9.0beta3.tar.gz
|
||||
|
20
sssd.spec
20
sssd.spec
@ -16,18 +16,16 @@
|
||||
|
||||
Name: sssd
|
||||
Version: 1.9.0
|
||||
Release: 7%{?dist}.beta2
|
||||
Release: 8%{?dist}.beta3
|
||||
Group: Applications/System
|
||||
Summary: System Security Services Daemon
|
||||
License: GPLv3+
|
||||
URL: http://fedorahosted.org/sssd/
|
||||
Source0: https://fedorahosted.org/released/sssd/%{name}-%{version}beta2.tar.gz
|
||||
Source0: https://fedorahosted.org/released/sssd/%{name}-%{version}beta3.tar.gz
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
|
||||
### Patches ###
|
||||
|
||||
Patch0001: 0001-Fix-typo-breaking-DIR-cache-detection.patch
|
||||
|
||||
### Dependencies ###
|
||||
|
||||
Conflicts: selinux-policy < 3.10.0-46
|
||||
@ -93,6 +91,7 @@ BuildRequires: gettext-devel
|
||||
BuildRequires: pkgconfig
|
||||
BuildRequires: glib2-devel
|
||||
BuildRequires: findutils
|
||||
BuildRequires: samba4-devel >= samba4-4.0.0-59beta2
|
||||
|
||||
%description
|
||||
Provides a set of daemons to manage access to remote directories and
|
||||
@ -200,7 +199,7 @@ UpdateTimestamps() {
|
||||
done
|
||||
}
|
||||
|
||||
%setup -q -n %{name}-1.8.92
|
||||
%setup -q -n %{name}-1.8.93
|
||||
|
||||
for p in %patches ; do
|
||||
%__patch -p1 -i $p
|
||||
@ -223,8 +222,7 @@ autoreconf -ivf
|
||||
--disable-static \
|
||||
--disable-rpath \
|
||||
--with-test-dir=/dev/shm \
|
||||
--enable-all-experimental-features \
|
||||
--with-unicode-lib=glib2
|
||||
--enable-all-experimental-features
|
||||
|
||||
make %{?_smp_mflags} all docs
|
||||
|
||||
@ -324,6 +322,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libexecdir}/%{servicename}/sssd_autofs
|
||||
%{_libexecdir}/%{servicename}/sssd_ssh
|
||||
%{_libexecdir}/%{servicename}/sssd_sudo
|
||||
%{_libexecdir}/%{servicename}/sssd_pac
|
||||
|
||||
%{_libdir}/%{name}/libsss_ipa.so
|
||||
%{_libdir}/%{name}/libsss_krb5.so
|
||||
@ -366,6 +365,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
/%{_lib}/libnss_sss.so.2
|
||||
/%{_lib}/security/pam_sss.so
|
||||
%{_libdir}/krb5/plugins/libkrb5/sssd_krb5_locator_plugin.so
|
||||
%{_libdir}/krb5/plugins/authdata/sssd_pac_plugin.so
|
||||
%{_mandir}/man8/pam_sss.8*
|
||||
%{_mandir}/man8/sssd_krb5_locator_plugin.8*
|
||||
|
||||
@ -491,6 +491,12 @@ fi
|
||||
%postun -n libipa_hbac -p /sbin/ldconfig
|
||||
|
||||
%changelog
|
||||
* Mon Jun 25 2012 Stephen Gallagher <sgallagh@redhat.com> - 1.9.0-8.beta3
|
||||
- New upstream release 1.9.0 beta 3
|
||||
- https://fedorahosted.org/sssd/wiki/Releases/Notes-1.9.0beta3
|
||||
- Add a new PAC responder for dealing with cross-realm Kerberos trusts
|
||||
- Terminate idle connections to the NSS and PAM responders
|
||||
|
||||
* Wed Jun 20 2012 Stephen Gallagher <sgallagh@redhat.com> - 1.9.0-7.beta2
|
||||
- Switch unicode library from libunistring to Glib
|
||||
- Drop unnecessary explicit Requires on keyutils
|
||||
|
Loading…
Reference in New Issue
Block a user