Update to 2.4.0
- Autodetect the minimum key strength from the system security level. - Disallow setting a key strength below the system minimum. - Drop upstreamed patches Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
2d2b0c221f
commit
61a444b785
1
.gitignore
vendored
1
.gitignore
vendored
@ -16,3 +16,4 @@
|
||||
/sscg-2.3.1.tar.xz
|
||||
/sscg-2.3.2.tar.xz
|
||||
/sscg-2.3.3.tar.xz
|
||||
/sscg-2.4.0.tar.xz
|
||||
|
@ -1,56 +0,0 @@
|
||||
From df9da4099d1f50f014ee46a19b77f20a1551d260 Mon Sep 17 00:00:00 2001
|
||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||
Date: Mon, 17 Sep 2018 09:58:25 -0400
|
||||
Subject: [PATCH] Generate manpage
|
||||
|
||||
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
||||
---
|
||||
meson.build | 22 +++++++++++++++++++++-
|
||||
1 file changed, 21 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 4763caec12a2ad96726d1de78d29233ec7b4d8f5..8a2daa60f722605746dd2c37901e05ad78a88710 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -5,11 +5,11 @@ project('sscg', 'c',
|
||||
'c_std=gnu99',
|
||||
'warning_level=1',
|
||||
'b_asneeded=true',
|
||||
],
|
||||
license : 'MIT',
|
||||
- meson_version : '>=0.36.0')
|
||||
+ meson_version : '>=0.40.0')
|
||||
|
||||
cc = meson.get_compiler('c')
|
||||
test_cflags = [
|
||||
'-Wpointer-arith',
|
||||
'-Wmissing-declarations',
|
||||
@@ -149,5 +149,25 @@ cdata.set('version', meson.project_version())
|
||||
configure_file(
|
||||
input : 'config.h.in',
|
||||
output : 'config.h',
|
||||
configuration : cdata)
|
||||
|
||||
+# Generate a manpage from the POPT documentation
|
||||
+help2man = find_program('help2man')
|
||||
+
|
||||
+manpage = custom_target('manpage',
|
||||
+ output : 'sscg.8',
|
||||
+ capture : true,
|
||||
+ command : [
|
||||
+ help2man,
|
||||
+ '-s', '8',
|
||||
+ '-n', 'Tool for generating x.509 certificates',
|
||||
+ '-N',
|
||||
+ sscg,
|
||||
+ ],
|
||||
+ install : true,
|
||||
+ build_by_default : true,
|
||||
+ install_dir : join_paths(
|
||||
+ get_option('prefix'),
|
||||
+ get_option('mandir'),
|
||||
+ 'man8'),
|
||||
+)
|
||||
--
|
||||
2.19.0
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (sscg-2.3.3.tar.xz) = c3229057575ced4ed0c196f8ba92e9ee78f7e27c448f48c21f4fc908618ea7fc5d27edfd02b23b9d2614d6058575a28458094562e2b4ef5b7b58ce62bbf30efa
|
||||
SHA512 (sscg-2.4.0.tar.xz) = 804f24889a9cc3d514e4a52b7dd9e01e5d9b8286c39ce68e24f7a665ade56545be6871da7f60e39f8ebb36674a51588fce85321455f825cc5c2ce4f365f52489
|
||||
|
14
sscg.spec
14
sscg.spec
@ -8,8 +8,8 @@
|
||||
|
||||
|
||||
Name: sscg
|
||||
Version: 2.3.3
|
||||
Release: 4%{?dist}
|
||||
Version: 2.4.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Simple SSL certificate generator
|
||||
|
||||
License: BSD
|
||||
@ -25,9 +25,6 @@ BuildRequires: meson
|
||||
BuildRequires: ninja-build
|
||||
BuildRequires: help2man
|
||||
|
||||
# Patches
|
||||
Patch0001: 0001-Generate-manpage.patch
|
||||
|
||||
|
||||
%description
|
||||
A utility to aid in the creation of more secure "self-signed"
|
||||
@ -61,6 +58,13 @@ false signatures from the service certificate.
|
||||
%{_mandir}/man8/%{name}.8*
|
||||
|
||||
%changelog
|
||||
* Tue Nov 27 2018 Stephen Gallagher <sgallagh@redhat.com> - 2.4.0-1
|
||||
- Update to 2.4.0
|
||||
- Autodetect the minimum key strength from the system security level.
|
||||
- Disallow setting a key strength below the system minimum.
|
||||
|
||||
- Drop upstreamed patches
|
||||
|
||||
* Mon Sep 17 2018 Stephen Gallagher <sgallagh@redhat.com> - 2.3.3-4
|
||||
- Add a manpage.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user