Fix incorrect help description for --client-key-file
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
18cda55e48
commit
589df37363
29
0001-Fix-help-message-for-client-key-file.patch
Normal file
29
0001-Fix-help-message-for-client-key-file.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
From 3754c48ec570c5c08fa05c46a31b00e961abbf96 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||||
|
Date: Fri, 13 Dec 2019 11:51:43 -0500
|
||||||
|
Subject: [PATCH] Fix help message for --client-key-file
|
||||||
|
|
||||||
|
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
||||||
|
---
|
||||||
|
src/sscg.c | 5 ++---
|
||||||
|
1 file changed, 2 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/sscg.c b/src/sscg.c
|
||||||
|
index 02e690860e092d4f154c74cd2eaf03ac0392f31b..035e89882e85ad07e4bf60f62cc95509bf2e31a9 100644
|
||||||
|
--- a/src/sscg.c
|
||||||
|
+++ b/src/sscg.c
|
||||||
|
@@ -737,9 +737,8 @@ main (int argc, const char **argv)
|
||||||
|
&client_key_file,
|
||||||
|
0,
|
||||||
|
_ ("Path where the client's private key will be stored. "
|
||||||
|
- "(default is client-file with a .key suffix, if "
|
||||||
|
- "--client-file was passed, otherwise this file will not "
|
||||||
|
- "be generated.)"),
|
||||||
|
+ "(default is the client-file, if --client-file was passed, "
|
||||||
|
+ "otherwise this file will not be generated.)"),
|
||||||
|
NULL,
|
||||||
|
},
|
||||||
|
|
||||||
|
--
|
||||||
|
2.23.0
|
||||||
|
|
10
sscg.spec
10
sscg.spec
@ -9,7 +9,7 @@
|
|||||||
|
|
||||||
Name: sscg
|
Name: sscg
|
||||||
Version: 2.6.0
|
Version: 2.6.0
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Simple SSL certificate generator
|
Summary: Simple SSL certificate generator
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -27,6 +27,9 @@ BuildRequires: help2man
|
|||||||
BuildRequires: clang
|
BuildRequires: clang
|
||||||
|
|
||||||
|
|
||||||
|
Patch0001: 0001-Fix-help-message-for-client-key-file.patch
|
||||||
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
A utility to aid in the creation of more secure "self-signed"
|
A utility to aid in the creation of more secure "self-signed"
|
||||||
certificates. The certificates created by this tool are generated in a
|
certificates. The certificates created by this tool are generated in a
|
||||||
@ -36,7 +39,7 @@ up a full PKI environment and without exposing the machine to a risk of
|
|||||||
false signatures from the service certificate.
|
false signatures from the service certificate.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%autosetup
|
%autosetup -p1
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -59,6 +62,9 @@ false signatures from the service certificate.
|
|||||||
%{_mandir}/man8/%{name}.8*
|
%{_mandir}/man8/%{name}.8*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Dec 13 2019 Stephen Gallagher <sgallagh@redhat.com> - 2.6.0-2
|
||||||
|
- Fix incorrect help description for --client-key-file
|
||||||
|
|
||||||
* Fri Dec 13 2019 Stephen Gallagher <sgallagh@redhat.com> - 2.6.0-1
|
* Fri Dec 13 2019 Stephen Gallagher <sgallagh@redhat.com> - 2.6.0-1
|
||||||
- Update to 2.6.0
|
- Update to 2.6.0
|
||||||
- Can now generate an empty CRL file.
|
- Can now generate an empty CRL file.
|
||||||
|
Loading…
Reference in New Issue
Block a user