Release 3.0.0
Support for OpenSSL 3.0 Support for outputting named Diffie-Hellman parameter groups Support for CentOS Stream 9 Resolves: rhbz#1984468 Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
2bd8fafbbc
commit
0d91054d47
1
.gitignore
vendored
1
.gitignore
vendored
@ -22,3 +22,4 @@
|
||||
/sscg-2.6.0.tar.xz
|
||||
/sscg-2.6.1.tar.xz
|
||||
/sscg-2.6.2.tar.xz
|
||||
/sscg-3.0.0.tar.xz
|
||||
|
@ -1,52 +0,0 @@
|
||||
From 696979f3ab82a8540a8a08fa84a2e11e057fe0b1 Mon Sep 17 00:00:00 2001
|
||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||
Date: Wed, 26 May 2021 08:36:19 -0400
|
||||
Subject: [PATCH] Fix exponent list in test
|
||||
|
||||
One of the exponents was a typo (7 instead of 17). 17 is no longer
|
||||
recommended as of OpenSSL 3.0, so drop it and replace the other
|
||||
exponents with their rsa.h aliases.
|
||||
|
||||
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
||||
---
|
||||
include/sscg.h | 2 +-
|
||||
test/generate_rsa_key_test.c | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/include/sscg.h b/include/sscg.h
|
||||
index 96b78152ccc492deafbbc61eb98702562a8fe5e6..10f9a2c2b38e4ff0bb266e7f5bed36b934382c6d 100644
|
||||
--- a/include/sscg.h
|
||||
+++ b/include/sscg.h
|
||||
@@ -46,11 +46,11 @@
|
||||
#ifndef EOK
|
||||
#define EOK 0
|
||||
#endif
|
||||
|
||||
#ifndef discard_const
|
||||
-#define discard_const(ptr) ((void *)((uintptr_t) (ptr)))
|
||||
+#define discard_const(ptr) ((void *)((uintptr_t)(ptr)))
|
||||
#endif
|
||||
|
||||
#ifndef talloc_zfree
|
||||
#define talloc_zfree(ptr) \
|
||||
do \
|
||||
diff --git a/test/generate_rsa_key_test.c b/test/generate_rsa_key_test.c
|
||||
index 304b2d3707e41c178cbe4bb5948d50400f0fca84..c8435d971c27a1b8ef8f0417d19747b89a4dc66f 100644
|
||||
--- a/test/generate_rsa_key_test.c
|
||||
+++ b/test/generate_rsa_key_test.c
|
||||
@@ -30,11 +30,11 @@ main (int argc, char **argv)
|
||||
{
|
||||
int ret, sret;
|
||||
struct sscg_bignum *e;
|
||||
struct sscg_evp_pkey *pkey;
|
||||
size_t i, j;
|
||||
- unsigned long exp_list[] = { 3, 7, 65537, 0 };
|
||||
+ unsigned long exp_list[] = { RSA_3, RSA_F4, 0 };
|
||||
int bits[] = { 512, 1024, 2048, 4096, 0 };
|
||||
|
||||
TALLOC_CTX *tmp_ctx = talloc_new (NULL);
|
||||
if (!tmp_ctx)
|
||||
{
|
||||
--
|
||||
2.31.1
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (sscg-2.6.2.tar.xz) = 5e900b4bc52d867325db2bd3ad83c072b0dac14ffcb2bf5539ea7b3d1701384ab0428a342d99928ea29d1a6ddec81664eac4a1255cd2aee2ba37e3a8105f1467
|
||||
SHA512 (sscg-3.0.0.tar.xz) = d5bbd14c102bb11b387b6018dced09b23b053498c60befd916aa142ece8240f443e364d9a578b6b5aa15c68cb943725ed96ef44cce77eb01013e464a6d4dc0f1
|
||||
|
13
sscg.spec
13
sscg.spec
@ -8,8 +8,8 @@
|
||||
|
||||
|
||||
Name: sscg
|
||||
Version: 2.6.2
|
||||
Release: 8%{?dist}
|
||||
Version: 3.0.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Simple SSL certificate generator
|
||||
|
||||
License: GPLv3+ with exceptions
|
||||
@ -25,8 +25,6 @@ BuildRequires: meson
|
||||
BuildRequires: ninja-build
|
||||
BuildRequires: help2man
|
||||
|
||||
Patch0001: 0001-Fix-exponent-list-in-test.patch
|
||||
|
||||
|
||||
%description
|
||||
A utility to aid in the creation of more secure "self-signed"
|
||||
@ -57,6 +55,13 @@ false signatures from the service certificate.
|
||||
%{_mandir}/man8/%{name}.8*
|
||||
|
||||
%changelog
|
||||
* Wed Jul 21 2021 Stephen Gallagher <sgallagh@redhat.com> - 3.0.0-1
|
||||
- Release 3.0.0
|
||||
- Support for OpenSSL 3.0
|
||||
- Support for outputting named Diffie-Hellman parameter groups
|
||||
- Support for CentOS Stream 9
|
||||
- Resolves: rhbz#1984468
|
||||
|
||||
* Wed Jun 16 2021 Mohan Boddu <mboddu@redhat.com> - 2.6.2-8
|
||||
- Rebuilt for RHEL 9 BETA for openssl 3.0
|
||||
Related: rhbz#1971065
|
||||
|
Loading…
Reference in New Issue
Block a user