squid/squid-3.1.0.15-smb-path.patch
2010-09-05 18:47:17 +02:00

38 lines
1.8 KiB
Diff

diff -up squid-3.1.8/helpers/basic_auth/SMB/Makefile.am.smb-path squid-3.1.8/helpers/basic_auth/SMB/Makefile.am
--- squid-3.1.8/helpers/basic_auth/SMB/Makefile.am.smb-path 2010-09-04 05:25:57.000000000 +0200
+++ squid-3.1.8/helpers/basic_auth/SMB/Makefile.am 2010-09-05 18:38:05.000000000 +0200
@@ -9,14 +9,14 @@
include $(top_srcdir)/src/Common.am
# SAMBAPREFIX must point to the directory where Samba has been installed.
-# By default, Samba is installed in /usr/local/samba. If you changed this
+# By default, Samba is installed in /usr. If you changed this
# by using the --prefix option when configuring Samba, you need to change
# SAMBAPREFIX accordingly.
## FIXME: autoconf should test for the samba path.
SMB_AUTH_HELPER = smb_auth.sh
-SAMBAPREFIX=/usr/local/samba
+SAMBAPREFIX=/usr
SMB_AUTH_HELPER_PATH = $(libexecdir)/$(SMB_AUTH_HELPER)
libexec_SCRIPTS = $(SMB_AUTH_HELPER)
diff -up squid-3.1.8/helpers/basic_auth/SMB/Makefile.in.smb-path squid-3.1.8/helpers/basic_auth/SMB/Makefile.in
--- squid-3.1.8/helpers/basic_auth/SMB/Makefile.in.smb-path 2010-09-04 05:26:21.000000000 +0200
+++ squid-3.1.8/helpers/basic_auth/SMB/Makefile.in 2010-09-05 18:39:47.000000000 +0200
@@ -291,11 +291,11 @@ INCLUDES = -I$(top_srcdir) -I$(top_srcdi
-I$(srcdir)
# SAMBAPREFIX must point to the directory where Samba has been installed.
-# By default, Samba is installed in /usr/local/samba. If you changed this
+# By default, Samba is installed in /usr. If you changed this
# by using the --prefix option when configuring Samba, you need to change
# SAMBAPREFIX accordingly.
SMB_AUTH_HELPER = smb_auth.sh
-SAMBAPREFIX = /usr/local/samba
+SAMBAPREFIX = /usr
SMB_AUTH_HELPER_PATH = $(libexecdir)/$(SMB_AUTH_HELPER)
libexec_SCRIPTS = $(SMB_AUTH_HELPER)
smb_auth_CFLAGS = -DSAMBAPREFIX=\"$(SAMBAPREFIX)\" -DHELPERSCRIPT=\"$(SMB_AUTH_HELPER_PATH)\"