clean up defunct patches

This commit is contained in:
Pavel Šimerda 2015-03-31 14:43:33 +02:00
parent 9e83d6c005
commit e8dc7575dd
3 changed files with 4 additions and 129 deletions

View File

@ -1,61 +0,0 @@
--- ./src/ftp.cc 2013-12-09 02:20:54.000000000 +0100
+++ ./src/ftp.cc 2013-12-30 13:08:20.216408559 +0100
@@ -2786,6 +2786,7 @@
}
ftpState->listenForDataChannel(temp, ftpState->entry->url());
+ ftpState->data.listenConn = temp;
}
/// \ingroup ServerProtocolFTPInternal
@@ -2822,13 +2823,18 @@
// pull out the internal IP address bytes to send in PORT command...
// source them from the listen_conn->local
+ struct sockaddr_in addr;
+ socklen_t addrlen = sizeof(addr);
+ getsockname(ftpState->data.listenConn->fd, (struct sockaddr *) &addr, &addrlen);
+ unsigned char port_high = ntohs(addr.sin_port) >> 8;
+ unsigned char port_low = ntohs(addr.sin_port) & 0xff;
+
struct addrinfo *AI = NULL;
ftpState->data.listenConn->local.getAddrInfo(AI, AF_INET);
unsigned char *addrptr = (unsigned char *) &((struct sockaddr_in*)AI->ai_addr)->sin_addr;
- unsigned char *portptr = (unsigned char *) &((struct sockaddr_in*)AI->ai_addr)->sin_port;
snprintf(cbuf, CTRL_BUFLEN, "PORT %d,%d,%d,%d,%d,%d\r\n",
addrptr[0], addrptr[1], addrptr[2], addrptr[3],
- portptr[0], portptr[1]);
+ port_high, port_low);
ftpState->writeCommand(cbuf);
ftpState->state = SENT_PORT;
@@ -2877,15 +2883,27 @@
ftpFail(ftpState);
return;
}
+
+ unsigned int port;
+ struct sockaddr_storage addr;
+ socklen_t addrlen = sizeof(addr);
+ getsockname(ftpState->data.listenConn->fd, (struct sockaddr *) &addr, &addrlen);
+ if (addr.ss_family == AF_INET) {
+ struct sockaddr_in *addr4 = (struct sockaddr_in*) &addr;
+ port = ntohs( addr4->sin_port );
+ } else {
+ struct sockaddr_in6 *addr6 = (struct sockaddr_in6 *) &addr;
+ port = ntohs( addr6->sin6_port );
+ }
char buf[MAX_IPSTRLEN];
/* RFC 2428 defines EPRT as IPv6 equivalent to IPv4 PORT command. */
/* Which can be used by EITHER protocol. */
- snprintf(cbuf, CTRL_BUFLEN, "EPRT |%d|%s|%d|\r\n",
+ snprintf(cbuf, CTRL_BUFLEN, "EPRT |%d|%s|%u|\r\n",
( ftpState->data.listenConn->local.isIPv6() ? 2 : 1 ),
ftpState->data.listenConn->local.toStr(buf,MAX_IPSTRLEN),
- ftpState->data.listenConn->local.port() );
+ port );
ftpState->writeCommand(cbuf);
ftpState->state = SENT_EPRT;

View File

@ -1,61 +0,0 @@
diff -up squid-3.1.9/aclocal.m4.ltdl squid-3.1.9/aclocal.m4
--- squid-3.1.9/aclocal.m4.ltdl 2010-10-25 13:34:41.000000000 +0200
+++ squid-3.1.9/aclocal.m4 2010-11-01 14:14:55.297324980 +0100
@@ -1360,7 +1360,7 @@ _LT_SET_OPTIONS([$0], [$1])
LIBTOOL_DEPS="$ltmain"
# Always use our own libtool.
-LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+LIBTOOL='$(SHELL) libtool'
AC_SUBST(LIBTOOL)dnl
_LT_SETUP
diff -up squid-3.1.9/configure.ltdl squid-3.1.9/configure
--- squid-3.1.9/configure.ltdl 2010-10-25 13:35:32.000000000 +0200
+++ squid-3.1.9/configure 2010-11-01 14:14:55.320299060 +0100
@@ -11000,7 +11000,7 @@ fi
LIBTOOL_DEPS="$ltmain"
# Always use our own libtool.
-LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+LIBTOOL='$(SHELL) libtool'
diff -up squid-3.1.9/Makefile.am.ltdl squid-3.1.9/Makefile.am
--- squid-3.1.9/Makefile.am.ltdl 2010-11-02 08:16:07.165707548 +0100
+++ squid-3.1.9/Makefile.am 2010-11-02 08:16:52.977565320 +0100
@@ -2,11 +2,8 @@
#
AUTOMAKE_OPTIONS = dist-bzip2 subdir-objects 1.5 foreign
-DIST_SUBDIRS = compat lib libltdl snmplib scripts icons errors contrib doc helpers src test-suite tools
+DIST_SUBDIRS = compat lib snmplib scripts icons errors contrib doc helpers src test-suite tools
SUBDIRS = compat lib $(makesnmplib)
-if USE_LOADABLE_MODULES
-SUBDIRS += libltdl
-endif
SUBDIRS += scripts icons errors doc helpers src tools test-suite
DISTCLEANFILES = include/stamp-h include/stamp-h[0-9]*
diff -up squid-3.1.9/Makefile.in.ltdl squid-3.1.9/Makefile.in
--- squid-3.1.9/Makefile.in.ltdl 2010-11-02 08:16:13.630458557 +0100
+++ squid-3.1.9/Makefile.in 2010-11-02 08:17:26.543714199 +0100
@@ -79,7 +79,7 @@ PRE_UNINSTALL = :
POST_UNINSTALL = :
build_triplet = @build@
host_triplet = @host@
-@USE_LOADABLE_MODULES_TRUE@am__append_1 = libltdl
+# @USE_LOADABLE_MODULES_TRUE@am__append_1 = libltdl
subdir = .
DIST_COMMON = $(srcdir)/Makefile.in $(srcdir)/Makefile.am \
$(top_srcdir)/configure $(am__configure_deps) \
@@ -472,7 +472,7 @@ top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
AUTOMAKE_OPTIONS = dist-bzip2 subdir-objects 1.5 foreign
-DIST_SUBDIRS = compat lib libltdl snmplib scripts icons errors contrib doc helpers src test-suite tools
+DIST_SUBDIRS = compat lib snmplib scripts icons errors contrib doc helpers src test-suite tools
SUBDIRS = compat lib $(makesnmplib) $(am__append_1) scripts icons \
errors doc helpers src tools test-suite
DISTCLEANFILES = include/stamp-h include/stamp-h[0-9]*

View File

@ -2,7 +2,7 @@
Name: squid
Version: 3.5.3
Release: 1%{?dist}
Release: 2%{?dist}
Summary: The Squid proxy caching server
Epoch: 7
# See CREDITS for breakdown of non GPLv2+ code
@ -30,8 +30,6 @@ Source98: perl-requires-squid.sh
Patch201: squid-3.1.0.9-config.patch
Patch202: squid-3.1.0.9-location.patch
Patch203: squid-3.0.STABLE1-perlpath.patch
Patch205: squid-3.1.9-ltdl.patch
Patch206: active-ftp.patch
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires: bash >= 2.0
@ -89,10 +87,6 @@ lookup program (dnsserver), a program for retrieving FTP data
%patch201 -p1 -b .config
%patch202 -p1 -b .location
%patch203 -p1 -b .perlpath
# Fails on 3.5.1.
#%patch205 -p1 -b .ltdl
# Fails on 3.5.1
#%patch206 -p1 -b .active-ftp
%build
@ -285,6 +279,9 @@ fi
%changelog
* Tue Mar 31 2015 Pavel Šimerda <psimerda@redhat.com> - 7:3.5.3-2
- clean up defunct patches
* Tue Mar 31 2015 Pavel Šimerda <psimerda@redhat.com> - 7:3.5.3-1
- new version 3.5.3