Rediffed build patch
This commit is contained in:
parent
0d23247719
commit
d410b29914
@ -1,6 +1,30 @@
|
|||||||
diff -up squid-3.0.STABLE9/icons/Makefile.am.build squid-3.0.STABLE9/icons/Makefile.am
|
diff -up squid-3.0.STABLE15/errors/Makefile.am.build squid-3.0.STABLE15/errors/Makefile.am
|
||||||
--- squid-3.0.STABLE9/icons/Makefile.am.build 2008-09-09 18:06:41.000000000 +0200
|
--- squid-3.0.STABLE15/errors/Makefile.am.build 2009-05-06 13:11:29.000000000 +0200
|
||||||
+++ squid-3.0.STABLE9/icons/Makefile.am 2008-10-19 23:36:13.000000000 +0200
|
+++ squid-3.0.STABLE15/errors/Makefile.am 2009-05-10 10:38:44.000000000 +0200
|
||||||
|
@@ -3,7 +3,7 @@
|
||||||
|
# $Id: Makefile.am,v 1.14.2.1 2008/02/27 10:55:13 amosjeffries Exp $
|
||||||
|
#
|
||||||
|
|
||||||
|
-errordir = $(datadir)/errors
|
||||||
|
+errordir = $(pkgdatadir)/errors
|
||||||
|
|
||||||
|
|
||||||
|
##dist-hook eveything
|
||||||
|
diff -up squid-3.0.STABLE15/errors/Makefile.in.build squid-3.0.STABLE15/errors/Makefile.in
|
||||||
|
--- squid-3.0.STABLE15/errors/Makefile.in.build 2009-05-06 13:11:29.000000000 +0200
|
||||||
|
+++ squid-3.0.STABLE15/errors/Makefile.in 2009-05-10 10:45:09.000000000 +0200
|
||||||
|
@@ -218,7 +218,7 @@ target_alias = @target_alias@
|
||||||
|
top_build_prefix = @top_build_prefix@
|
||||||
|
top_builddir = @top_builddir@
|
||||||
|
top_srcdir = @top_srcdir@
|
||||||
|
-errordir = $(datadir)/errors
|
||||||
|
+errordir = $(pkgdatadir)/errors
|
||||||
|
DEFAULT_ERROR_DIR = $(errordir)
|
||||||
|
INSTALL_LANGUAGES = templates @ERR_LANGUAGES@
|
||||||
|
LANGUAGES = \
|
||||||
|
diff -up squid-3.0.STABLE15/icons/Makefile.am.build squid-3.0.STABLE15/icons/Makefile.am
|
||||||
|
--- squid-3.0.STABLE15/icons/Makefile.am.build 2009-05-06 13:11:36.000000000 +0200
|
||||||
|
+++ squid-3.0.STABLE15/icons/Makefile.am 2009-05-10 10:38:44.000000000 +0200
|
||||||
@@ -29,7 +29,7 @@ ICONS = anthony-binhex.gif \
|
@@ -29,7 +29,7 @@ ICONS = anthony-binhex.gif \
|
||||||
anthony-xbm.gif \
|
anthony-xbm.gif \
|
||||||
anthony-xpm.gif
|
anthony-xpm.gif
|
||||||
@ -10,10 +34,10 @@ diff -up squid-3.0.STABLE9/icons/Makefile.am.build squid-3.0.STABLE9/icons/Makef
|
|||||||
icon_DATA = $(ICONS)
|
icon_DATA = $(ICONS)
|
||||||
EXTRA_DIST = $(ICONS)
|
EXTRA_DIST = $(ICONS)
|
||||||
DISTCLEANFILES =
|
DISTCLEANFILES =
|
||||||
diff -up squid-3.0.STABLE9/icons/Makefile.in.build squid-3.0.STABLE9/icons/Makefile.in
|
diff -up squid-3.0.STABLE15/icons/Makefile.in.build squid-3.0.STABLE15/icons/Makefile.in
|
||||||
--- squid-3.0.STABLE9/icons/Makefile.in.build 2008-09-09 18:06:41.000000000 +0200
|
--- squid-3.0.STABLE15/icons/Makefile.in.build 2009-05-06 13:11:36.000000000 +0200
|
||||||
+++ squid-3.0.STABLE9/icons/Makefile.in 2008-10-19 23:36:13.000000000 +0200
|
+++ squid-3.0.STABLE15/icons/Makefile.in 2009-05-10 10:45:13.000000000 +0200
|
||||||
@@ -308,7 +308,7 @@ ICONS = anthony-binhex.gif \
|
@@ -255,7 +255,7 @@ ICONS = anthony-binhex.gif \
|
||||||
anthony-xbm.gif \
|
anthony-xbm.gif \
|
||||||
anthony-xpm.gif
|
anthony-xpm.gif
|
||||||
|
|
||||||
@ -22,22 +46,10 @@ diff -up squid-3.0.STABLE9/icons/Makefile.in.build squid-3.0.STABLE9/icons/Makef
|
|||||||
icon_DATA = $(ICONS)
|
icon_DATA = $(ICONS)
|
||||||
EXTRA_DIST = $(ICONS)
|
EXTRA_DIST = $(ICONS)
|
||||||
DISTCLEANFILES =
|
DISTCLEANFILES =
|
||||||
@@ -324,9 +324,9 @@ $(srcdir)/Makefile.in: @MAINTAINER_MODE_
|
diff -up squid-3.0.STABLE15/src/Makefile.am.build squid-3.0.STABLE15/src/Makefile.am
|
||||||
exit 1;; \
|
--- squid-3.0.STABLE15/src/Makefile.am.build 2009-05-06 13:11:40.000000000 +0200
|
||||||
esac; \
|
+++ squid-3.0.STABLE15/src/Makefile.am 2009-05-10 10:38:44.000000000 +0200
|
||||||
done; \
|
@@ -928,9 +928,7 @@ BUILT_SOURCES = \
|
||||||
- echo ' cd $(top_srcdir) && $(AUTOMAKE) --foreign icons/Makefile'; \
|
|
||||||
+ echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu icons/Makefile'; \
|
|
||||||
cd $(top_srcdir) && \
|
|
||||||
- $(AUTOMAKE) --foreign icons/Makefile
|
|
||||||
+ $(AUTOMAKE) --gnu icons/Makefile
|
|
||||||
.PRECIOUS: Makefile
|
|
||||||
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
|
|
||||||
@case '$?' in \
|
|
||||||
diff -up squid-3.0.STABLE9/src/Makefile.am.build squid-3.0.STABLE9/src/Makefile.am
|
|
||||||
--- squid-3.0.STABLE9/src/Makefile.am.build 2008-09-09 18:06:43.000000000 +0200
|
|
||||||
+++ squid-3.0.STABLE9/src/Makefile.am 2008-10-19 23:36:13.000000000 +0200
|
|
||||||
@@ -929,9 +929,7 @@ BUILT_SOURCES = \
|
|
||||||
|
|
||||||
sysconf_DATA = \
|
sysconf_DATA = \
|
||||||
squid.conf.default \
|
squid.conf.default \
|
||||||
@ -48,7 +60,7 @@ diff -up squid-3.0.STABLE9/src/Makefile.am.build squid-3.0.STABLE9/src/Makefile.
|
|||||||
mib.txt
|
mib.txt
|
||||||
|
|
||||||
LDADD = libsquid.la libauth.la -L../lib -lmiscutil @XTRA_LIBS@ @EPOLL_LIBS@ @MINGW_LIBS@
|
LDADD = libsquid.la libauth.la -L../lib -lmiscutil @XTRA_LIBS@ @EPOLL_LIBS@ @MINGW_LIBS@
|
||||||
@@ -992,18 +990,18 @@ DEFAULT_PREFIX = $(prefix)
|
@@ -991,18 +989,18 @@ DEFAULT_PREFIX = $(prefix)
|
||||||
DEFAULT_CONFIG_FILE = $(sysconfdir)/squid.conf
|
DEFAULT_CONFIG_FILE = $(sysconfdir)/squid.conf
|
||||||
DEFAULT_MIME_TABLE = $(sysconfdir)/mime.conf
|
DEFAULT_MIME_TABLE = $(sysconfdir)/mime.conf
|
||||||
DEFAULT_DNSSERVER = $(libexecdir)/`echo dnsserver | sed '$(transform);s/$$/$(EXEEXT)/'`
|
DEFAULT_DNSSERVER = $(libexecdir)/`echo dnsserver | sed '$(transform);s/$$/$(EXEEXT)/'`
|
||||||
@ -73,7 +85,7 @@ diff -up squid-3.0.STABLE9/src/Makefile.am.build squid-3.0.STABLE9/src/Makefile.
|
|||||||
DEFAULT_HOSTS = @OPT_DEFAULT_HOSTS@
|
DEFAULT_HOSTS = @OPT_DEFAULT_HOSTS@
|
||||||
|
|
||||||
DEFS = @DEFS@ -DDEFAULT_CONFIG_FILE=\"$(DEFAULT_CONFIG_FILE)\"
|
DEFS = @DEFS@ -DDEFAULT_CONFIG_FILE=\"$(DEFAULT_CONFIG_FILE)\"
|
||||||
@@ -1066,7 +1064,7 @@ cf.data: cf.data.pre Makefile
|
@@ -1065,7 +1063,7 @@ cf.data: cf.data.pre Makefile
|
||||||
repl_modules.cc: repl_modules.sh Makefile
|
repl_modules.cc: repl_modules.sh Makefile
|
||||||
$(SHELL) $(srcdir)/repl_modules.sh $(REPL_POLICIES) > repl_modules.cc
|
$(SHELL) $(srcdir)/repl_modules.sh $(REPL_POLICIES) > repl_modules.cc
|
||||||
|
|
||||||
@ -82,7 +94,7 @@ diff -up squid-3.0.STABLE9/src/Makefile.am.build squid-3.0.STABLE9/src/Makefile.
|
|||||||
@if test -f $(DESTDIR)$(DEFAULT_MIME_TABLE) ; then \
|
@if test -f $(DESTDIR)$(DEFAULT_MIME_TABLE) ; then \
|
||||||
echo "$@ will not overwrite existing $(DESTDIR)$(DEFAULT_MIME_TABLE)" ; \
|
echo "$@ will not overwrite existing $(DESTDIR)$(DEFAULT_MIME_TABLE)" ; \
|
||||||
else \
|
else \
|
||||||
@@ -1079,6 +1077,12 @@ install-data-local: install-sysconfDATA
|
@@ -1078,6 +1076,12 @@ install-data-local: install-sysconfDATA
|
||||||
echo "$(INSTALL_DATA) squid.conf.default $(DESTDIR)$(DEFAULT_CONFIG_FILE)"; \
|
echo "$(INSTALL_DATA) squid.conf.default $(DESTDIR)$(DEFAULT_CONFIG_FILE)"; \
|
||||||
$(INSTALL_DATA) squid.conf.default $(DESTDIR)$(DEFAULT_CONFIG_FILE); \
|
$(INSTALL_DATA) squid.conf.default $(DESTDIR)$(DEFAULT_CONFIG_FILE); \
|
||||||
fi
|
fi
|
||||||
@ -95,7 +107,7 @@ diff -up squid-3.0.STABLE9/src/Makefile.am.build squid-3.0.STABLE9/src/Makefile.
|
|||||||
$(mkinstalldirs) $(DESTDIR)$(DEFAULT_LOG_PREFIX)
|
$(mkinstalldirs) $(DESTDIR)$(DEFAULT_LOG_PREFIX)
|
||||||
|
|
||||||
uninstall-local:
|
uninstall-local:
|
||||||
@@ -1086,6 +1090,10 @@ uninstall-local:
|
@@ -1085,6 +1089,10 @@ uninstall-local:
|
||||||
echo "rm -f $(DESTDIR)$(DEFAULT_MIME_TABLE)"; \
|
echo "rm -f $(DESTDIR)$(DEFAULT_MIME_TABLE)"; \
|
||||||
$(RM) -f $(DESTDIR)$(DEFAULT_MIME_TABLE); \
|
$(RM) -f $(DESTDIR)$(DEFAULT_MIME_TABLE); \
|
||||||
fi
|
fi
|
||||||
@ -106,10 +118,10 @@ diff -up squid-3.0.STABLE9/src/Makefile.am.build squid-3.0.STABLE9/src/Makefile.
|
|||||||
|
|
||||||
# Don't automatically uninstall config files
|
# Don't automatically uninstall config files
|
||||||
# @if test -f $(DESTDIR)$(DEFAULT_CONFIG_FILE) ; then \
|
# @if test -f $(DESTDIR)$(DEFAULT_CONFIG_FILE) ; then \
|
||||||
diff -up squid-3.0.STABLE9/src/Makefile.in.build squid-3.0.STABLE9/src/Makefile.in
|
diff -up squid-3.0.STABLE15/src/Makefile.in.build squid-3.0.STABLE15/src/Makefile.in
|
||||||
--- squid-3.0.STABLE9/src/Makefile.in.build 2008-09-09 18:06:43.000000000 +0200
|
--- squid-3.0.STABLE15/src/Makefile.in.build 2009-05-06 13:11:40.000000000 +0200
|
||||||
+++ squid-3.0.STABLE9/src/Makefile.in 2008-10-19 23:36:13.000000000 +0200
|
+++ squid-3.0.STABLE15/src/Makefile.in 2009-05-10 10:45:15.000000000 +0200
|
||||||
@@ -140,8 +140,7 @@ libsquid_la_LIBADD =
|
@@ -136,8 +136,7 @@ libsquid_la_LIBADD =
|
||||||
am_libsquid_la_OBJECTS = comm.lo IPInterception.lo
|
am_libsquid_la_OBJECTS = comm.lo IPInterception.lo
|
||||||
libsquid_la_OBJECTS = $(am_libsquid_la_OBJECTS)
|
libsquid_la_OBJECTS = $(am_libsquid_la_OBJECTS)
|
||||||
am__installdirs = "$(DESTDIR)$(bindir)" "$(DESTDIR)$(libexecdir)" \
|
am__installdirs = "$(DESTDIR)$(bindir)" "$(DESTDIR)$(libexecdir)" \
|
||||||
@ -119,7 +131,7 @@ diff -up squid-3.0.STABLE9/src/Makefile.in.build squid-3.0.STABLE9/src/Makefile.
|
|||||||
binPROGRAMS_INSTALL = $(INSTALL_PROGRAM)
|
binPROGRAMS_INSTALL = $(INSTALL_PROGRAM)
|
||||||
@ENABLE_PINGER_TRUE@am__EXEEXT_1 = pinger$(EXEEXT)
|
@ENABLE_PINGER_TRUE@am__EXEEXT_1 = pinger$(EXEEXT)
|
||||||
@USE_DNSSERVER_TRUE@am__EXEEXT_2 = dnsserver$(EXEEXT)
|
@USE_DNSSERVER_TRUE@am__EXEEXT_2 = dnsserver$(EXEEXT)
|
||||||
@@ -1529,9 +1528,8 @@ am__vpath_adj = case $$p in \
|
@@ -1576,9 +1575,8 @@ am__vpath_adj = case $$p in \
|
||||||
*) f=$$p;; \
|
*) f=$$p;; \
|
||||||
esac;
|
esac;
|
||||||
am__strip_dir = `echo $$p | sed -e 's|^.*/||'`;
|
am__strip_dir = `echo $$p | sed -e 's|^.*/||'`;
|
||||||
@ -128,9 +140,9 @@ diff -up squid-3.0.STABLE9/src/Makefile.in.build squid-3.0.STABLE9/src/Makefile.
|
|||||||
-DATA = $(data_DATA) $(sysconf_DATA)
|
-DATA = $(data_DATA) $(sysconf_DATA)
|
||||||
+DATA = $(sysconf_DATA)
|
+DATA = $(sysconf_DATA)
|
||||||
HEADERS = $(noinst_HEADERS)
|
HEADERS = $(noinst_HEADERS)
|
||||||
ETAGS = etags
|
RECURSIVE_CLEAN_TARGETS = mostlyclean-recursive clean-recursive \
|
||||||
CTAGS = ctags
|
distclean-recursive maintainer-clean-recursive
|
||||||
@@ -2573,9 +2571,7 @@ BUILT_SOURCES = \
|
@@ -2572,9 +2570,7 @@ BUILT_SOURCES = \
|
||||||
|
|
||||||
sysconf_DATA = \
|
sysconf_DATA = \
|
||||||
squid.conf.default \
|
squid.conf.default \
|
||||||
@ -141,7 +153,7 @@ diff -up squid-3.0.STABLE9/src/Makefile.in.build squid-3.0.STABLE9/src/Makefile.
|
|||||||
mib.txt
|
mib.txt
|
||||||
|
|
||||||
LDADD = libsquid.la libauth.la -L../lib -lmiscutil @XTRA_LIBS@ @EPOLL_LIBS@ @MINGW_LIBS@
|
LDADD = libsquid.la libauth.la -L../lib -lmiscutil @XTRA_LIBS@ @EPOLL_LIBS@ @MINGW_LIBS@
|
||||||
@@ -2633,18 +2629,18 @@ DEFAULT_PREFIX = $(prefix)
|
@@ -2632,18 +2628,18 @@ DEFAULT_PREFIX = $(prefix)
|
||||||
DEFAULT_CONFIG_FILE = $(sysconfdir)/squid.conf
|
DEFAULT_CONFIG_FILE = $(sysconfdir)/squid.conf
|
||||||
DEFAULT_MIME_TABLE = $(sysconfdir)/mime.conf
|
DEFAULT_MIME_TABLE = $(sysconfdir)/mime.conf
|
||||||
DEFAULT_DNSSERVER = $(libexecdir)/`echo dnsserver | sed '$(transform);s/$$/$(EXEEXT)/'`
|
DEFAULT_DNSSERVER = $(libexecdir)/`echo dnsserver | sed '$(transform);s/$$/$(EXEEXT)/'`
|
||||||
@ -166,25 +178,13 @@ diff -up squid-3.0.STABLE9/src/Makefile.in.build squid-3.0.STABLE9/src/Makefile.
|
|||||||
DEFAULT_HOSTS = @OPT_DEFAULT_HOSTS@
|
DEFAULT_HOSTS = @OPT_DEFAULT_HOSTS@
|
||||||
|
|
||||||
# Don't automatically uninstall config files
|
# Don't automatically uninstall config files
|
||||||
@@ -3965,9 +3961,9 @@ $(srcdir)/Makefile.in: @MAINTAINER_MODE_
|
@@ -5020,23 +5016,6 @@ clean-libtool:
|
||||||
exit 1;; \
|
-rm -rf .libs _libs
|
||||||
esac; \
|
-rm -rf DiskIO/DiskDaemon/.libs DiskIO/DiskDaemon/_libs
|
||||||
done; \
|
-rm -rf tests/.libs tests/_libs
|
||||||
- echo ' cd $(top_srcdir) && $(AUTOMAKE) --foreign src/Makefile'; \
|
|
||||||
+ echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu src/Makefile'; \
|
|
||||||
cd $(top_srcdir) && \
|
|
||||||
- $(AUTOMAKE) --foreign src/Makefile
|
|
||||||
+ $(AUTOMAKE) --gnu src/Makefile
|
|
||||||
.PRECIOUS: Makefile
|
|
||||||
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
|
|
||||||
@case '$?' in \
|
|
||||||
@@ -5023,23 +5019,6 @@ clean-libtool:
|
|
||||||
distclean-libtool:
|
|
||||||
-rm -f libtool
|
|
||||||
uninstall-info-am:
|
|
||||||
-install-dataDATA: $(data_DATA)
|
-install-dataDATA: $(data_DATA)
|
||||||
- @$(NORMAL_INSTALL)
|
- @$(NORMAL_INSTALL)
|
||||||
- test -z "$(datadir)" || $(mkdir_p) "$(DESTDIR)$(datadir)"
|
- test -z "$(datadir)" || $(MKDIR_P) "$(DESTDIR)$(datadir)"
|
||||||
- @list='$(data_DATA)'; for p in $$list; do \
|
- @list='$(data_DATA)'; for p in $$list; do \
|
||||||
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
||||||
- f=$(am__strip_dir) \
|
- f=$(am__strip_dir) \
|
||||||
@ -201,63 +201,66 @@ diff -up squid-3.0.STABLE9/src/Makefile.in.build squid-3.0.STABLE9/src/Makefile.
|
|||||||
- done
|
- done
|
||||||
install-sysconfDATA: $(sysconf_DATA)
|
install-sysconfDATA: $(sysconf_DATA)
|
||||||
@$(NORMAL_INSTALL)
|
@$(NORMAL_INSTALL)
|
||||||
test -z "$(sysconfdir)" || $(mkdir_p) "$(DESTDIR)$(sysconfdir)"
|
test -z "$(sysconfdir)" || $(MKDIR_P) "$(DESTDIR)$(sysconfdir)"
|
||||||
@@ -5314,7 +5293,7 @@ all-am: Makefile $(LIBRARIES) $(LTLIBRAR
|
@@ -5310,7 +5289,7 @@ all-am: Makefile $(LIBRARIES) $(LTLIBRAR
|
||||||
$(HEADERS)
|
$(HEADERS)
|
||||||
installdirs: installdirs-recursive
|
installdirs: installdirs-recursive
|
||||||
installdirs-am:
|
installdirs-am:
|
||||||
- for dir in "$(DESTDIR)$(bindir)" "$(DESTDIR)$(libexecdir)" "$(DESTDIR)$(sbindir)" "$(DESTDIR)$(datadir)" "$(DESTDIR)$(sysconfdir)"; do \
|
- for dir in "$(DESTDIR)$(bindir)" "$(DESTDIR)$(libexecdir)" "$(DESTDIR)$(sbindir)" "$(DESTDIR)$(datadir)" "$(DESTDIR)$(sysconfdir)"; do \
|
||||||
+ for dir in "$(DESTDIR)$(bindir)" "$(DESTDIR)$(libexecdir)" "$(DESTDIR)$(sbindir)" "$(DESTDIR)$(sysconfdir)"; do \
|
+ for dir in "$(DESTDIR)$(bindir)" "$(DESTDIR)$(libexecdir)" "$(DESTDIR)$(sbindir)" "$(DESTDIR)$(sysconfdir)"; do \
|
||||||
test -z "$$dir" || $(mkdir_p) "$$dir"; \
|
test -z "$$dir" || $(MKDIR_P) "$$dir"; \
|
||||||
done
|
done
|
||||||
install: $(BUILT_SOURCES)
|
install: $(BUILT_SOURCES)
|
||||||
@@ -5401,7 +5380,7 @@ info: info-recursive
|
@@ -5397,7 +5376,7 @@ info: info-recursive
|
||||||
|
|
||||||
info-am:
|
info-am:
|
||||||
|
|
||||||
-install-data-am: install-data-local install-dataDATA
|
-install-data-am: install-data-local install-dataDATA
|
||||||
+install-data-am: install-data-local
|
+install-data-am: install-data-local
|
||||||
|
|
||||||
install-exec-am: install-binPROGRAMS install-libexecPROGRAMS \
|
install-dvi: install-dvi-recursive
|
||||||
install-sbinPROGRAMS install-sysconfDATA
|
|
||||||
@@ -5430,8 +5409,8 @@ ps: ps-recursive
|
@@ -5434,9 +5413,8 @@ ps: ps-recursive
|
||||||
|
|
||||||
ps-am:
|
ps-am:
|
||||||
|
|
||||||
-uninstall-am: uninstall-binPROGRAMS uninstall-dataDATA \
|
-uninstall-am: uninstall-binPROGRAMS uninstall-dataDATA \
|
||||||
- uninstall-info-am uninstall-libexecPROGRAMS uninstall-local \
|
- uninstall-libexecPROGRAMS uninstall-local \
|
||||||
+uninstall-am: uninstall-binPROGRAMS uninstall-info-am \
|
- uninstall-sbinPROGRAMS uninstall-sysconfDATA
|
||||||
+ uninstall-libexecPROGRAMS uninstall-local \
|
+uninstall-am: uninstall-binPROGRAMS uninstall-libexecPROGRAMS \
|
||||||
uninstall-sbinPROGRAMS uninstall-sysconfDATA
|
+ uninstall-local uninstall-sbinPROGRAMS uninstall-sysconfDATA
|
||||||
|
|
||||||
uninstall-info: uninstall-info-recursive
|
.MAKE: $(RECURSIVE_CLEAN_TARGETS) $(RECURSIVE_TARGETS) install-am \
|
||||||
@@ -5445,16 +5424,15 @@ uninstall-info: uninstall-info-recursive
|
install-strip
|
||||||
distclean-libtool distclean-recursive distclean-tags distdir \
|
@@ -5449,17 +5427,16 @@ uninstall-am: uninstall-binPROGRAMS unin
|
||||||
dvi dvi-am html html-am info info-am install install-am \
|
distclean distclean-compile distclean-generic \
|
||||||
install-binPROGRAMS install-data install-data-am \
|
distclean-libtool distclean-tags distdir dvi dvi-am html \
|
||||||
- install-data-local install-dataDATA install-exec \
|
html-am info info-am install install-am install-binPROGRAMS \
|
||||||
- install-exec-am install-info install-info-am \
|
- install-data install-data-am install-data-local \
|
||||||
- install-libexecPROGRAMS install-man install-sbinPROGRAMS \
|
- install-dataDATA install-dvi install-dvi-am install-exec \
|
||||||
- install-strip install-sysconfDATA installcheck installcheck-am \
|
- install-exec-am install-html install-html-am install-info \
|
||||||
- installdirs installdirs-am maintainer-clean \
|
- install-info-am install-libexecPROGRAMS install-man \
|
||||||
- maintainer-clean-generic maintainer-clean-recursive \
|
- install-pdf install-pdf-am install-ps install-ps-am \
|
||||||
- mostlyclean mostlyclean-compile mostlyclean-generic \
|
- install-sbinPROGRAMS install-strip install-sysconfDATA \
|
||||||
- mostlyclean-libtool mostlyclean-recursive pdf pdf-am ps ps-am \
|
- installcheck installcheck-am installdirs installdirs-am \
|
||||||
- tags tags-recursive uninstall uninstall-am \
|
- maintainer-clean maintainer-clean-generic mostlyclean \
|
||||||
- uninstall-binPROGRAMS uninstall-dataDATA uninstall-info-am \
|
- mostlyclean-compile mostlyclean-generic mostlyclean-libtool \
|
||||||
+ install-data-local install-exec install-exec-am install-info \
|
- pdf pdf-am ps ps-am tags tags-recursive uninstall uninstall-am \
|
||||||
+ install-info-am install-libexecPROGRAMS install-man \
|
- uninstall-binPROGRAMS uninstall-dataDATA \
|
||||||
+ install-sbinPROGRAMS install-strip install-sysconfDATA \
|
+ install-data install-data-am install-data-local install-dvi \
|
||||||
+ installcheck installcheck-am installdirs installdirs-am \
|
+ install-dvi-am install-exec install-exec-am install-html \
|
||||||
+ maintainer-clean maintainer-clean-generic \
|
+ install-html-am install-info install-info-am \
|
||||||
+ maintainer-clean-recursive mostlyclean mostlyclean-compile \
|
+ install-libexecPROGRAMS install-man install-pdf install-pdf-am \
|
||||||
+ mostlyclean-generic mostlyclean-libtool mostlyclean-recursive \
|
+ install-ps install-ps-am install-sbinPROGRAMS install-strip \
|
||||||
+ pdf pdf-am ps ps-am tags tags-recursive uninstall uninstall-am \
|
+ install-sysconfDATA installcheck installcheck-am installdirs \
|
||||||
+ uninstall-binPROGRAMS uninstall-info-am \
|
+ installdirs-am maintainer-clean maintainer-clean-generic \
|
||||||
|
+ mostlyclean mostlyclean-compile mostlyclean-generic \
|
||||||
|
+ mostlyclean-libtool pdf pdf-am ps ps-am tags tags-recursive \
|
||||||
|
+ uninstall uninstall-am uninstall-binPROGRAMS \
|
||||||
uninstall-libexecPROGRAMS uninstall-local \
|
uninstall-libexecPROGRAMS uninstall-local \
|
||||||
uninstall-sbinPROGRAMS uninstall-sysconfDATA
|
uninstall-sbinPROGRAMS uninstall-sysconfDATA
|
||||||
|
|
||||||
@@ -5514,7 +5492,7 @@ cf.data: cf.data.pre Makefile
|
@@ -5519,7 +5496,7 @@ cf.data: cf.data.pre Makefile
|
||||||
repl_modules.cc: repl_modules.sh Makefile
|
repl_modules.cc: repl_modules.sh Makefile
|
||||||
$(SHELL) $(srcdir)/repl_modules.sh $(REPL_POLICIES) > repl_modules.cc
|
$(SHELL) $(srcdir)/repl_modules.sh $(REPL_POLICIES) > repl_modules.cc
|
||||||
|
|
||||||
@ -266,7 +269,7 @@ diff -up squid-3.0.STABLE9/src/Makefile.in.build squid-3.0.STABLE9/src/Makefile.
|
|||||||
@if test -f $(DESTDIR)$(DEFAULT_MIME_TABLE) ; then \
|
@if test -f $(DESTDIR)$(DEFAULT_MIME_TABLE) ; then \
|
||||||
echo "$@ will not overwrite existing $(DESTDIR)$(DEFAULT_MIME_TABLE)" ; \
|
echo "$@ will not overwrite existing $(DESTDIR)$(DEFAULT_MIME_TABLE)" ; \
|
||||||
else \
|
else \
|
||||||
@@ -5527,6 +5505,12 @@ install-data-local: install-sysconfDATA
|
@@ -5532,6 +5509,12 @@ install-data-local: install-sysconfDATA
|
||||||
echo "$(INSTALL_DATA) squid.conf.default $(DESTDIR)$(DEFAULT_CONFIG_FILE)"; \
|
echo "$(INSTALL_DATA) squid.conf.default $(DESTDIR)$(DEFAULT_CONFIG_FILE)"; \
|
||||||
$(INSTALL_DATA) squid.conf.default $(DESTDIR)$(DEFAULT_CONFIG_FILE); \
|
$(INSTALL_DATA) squid.conf.default $(DESTDIR)$(DEFAULT_CONFIG_FILE); \
|
||||||
fi
|
fi
|
||||||
@ -279,7 +282,7 @@ diff -up squid-3.0.STABLE9/src/Makefile.in.build squid-3.0.STABLE9/src/Makefile.
|
|||||||
$(mkinstalldirs) $(DESTDIR)$(DEFAULT_LOG_PREFIX)
|
$(mkinstalldirs) $(DESTDIR)$(DEFAULT_LOG_PREFIX)
|
||||||
|
|
||||||
uninstall-local:
|
uninstall-local:
|
||||||
@@ -5534,6 +5518,10 @@ uninstall-local:
|
@@ -5539,6 +5522,10 @@ uninstall-local:
|
||||||
echo "rm -f $(DESTDIR)$(DEFAULT_MIME_TABLE)"; \
|
echo "rm -f $(DESTDIR)$(DEFAULT_MIME_TABLE)"; \
|
||||||
$(RM) -f $(DESTDIR)$(DEFAULT_MIME_TABLE); \
|
$(RM) -f $(DESTDIR)$(DEFAULT_MIME_TABLE); \
|
||||||
fi
|
fi
|
||||||
@ -290,39 +293,3 @@ diff -up squid-3.0.STABLE9/src/Makefile.in.build squid-3.0.STABLE9/src/Makefile.
|
|||||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
# Otherwise a system limit (for SysV at least) may be exceeded.
|
||||||
.NOEXPORT:
|
.NOEXPORT:
|
||||||
diff -up squid-3.0.STABLE9/errors/Makefile.am.build squid-3.0.STABLE9/errors/Makefile.am
|
|
||||||
--- squid-3.0.STABLE9/errors/Makefile.am.build 2008-09-09 18:06:39.000000000 +0200
|
|
||||||
+++ squid-3.0.STABLE9/errors/Makefile.am 2008-10-19 23:36:13.000000000 +0200
|
|
||||||
@@ -3,7 +3,7 @@
|
|
||||||
# $Id: Makefile.am,v 1.14.2.1 2008/02/27 10:55:13 amosjeffries Exp $
|
|
||||||
#
|
|
||||||
|
|
||||||
-errordir = $(datadir)/errors
|
|
||||||
+errordir = $(pkgdatadir)/errors
|
|
||||||
|
|
||||||
|
|
||||||
##dist-hook eveything
|
|
||||||
diff -up squid-3.0.STABLE9/errors/Makefile.in.build squid-3.0.STABLE9/errors/Makefile.in
|
|
||||||
--- squid-3.0.STABLE9/errors/Makefile.in.build 2008-09-09 18:06:39.000000000 +0200
|
|
||||||
+++ squid-3.0.STABLE9/errors/Makefile.in 2008-10-19 23:36:13.000000000 +0200
|
|
||||||
@@ -271,7 +271,7 @@ sharedstatedir = @sharedstatedir@
|
|
||||||
subdirs = @subdirs@
|
|
||||||
sysconfdir = @sysconfdir@
|
|
||||||
target_alias = @target_alias@
|
|
||||||
-errordir = $(datadir)/errors
|
|
||||||
+errordir = $(pkgdatadir)/errors
|
|
||||||
DEFAULT_ERROR_DIR = $(errordir)
|
|
||||||
INSTALL_LANGUAGES = templates @ERR_LANGUAGES@
|
|
||||||
LANGUAGES = \
|
|
||||||
@@ -322,9 +322,9 @@ $(srcdir)/Makefile.in: @MAINTAINER_MODE_
|
|
||||||
exit 1;; \
|
|
||||||
esac; \
|
|
||||||
done; \
|
|
||||||
- echo ' cd $(top_srcdir) && $(AUTOMAKE) --foreign errors/Makefile'; \
|
|
||||||
+ echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu errors/Makefile'; \
|
|
||||||
cd $(top_srcdir) && \
|
|
||||||
- $(AUTOMAKE) --foreign errors/Makefile
|
|
||||||
+ $(AUTOMAKE) --gnu errors/Makefile
|
|
||||||
.PRECIOUS: Makefile
|
|
||||||
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
|
|
||||||
@case '$?' in \
|
|
||||||
|
Loading…
Reference in New Issue
Block a user