update to latest upstream 3.2.0.14
This commit is contained in:
parent
356af77684
commit
c6c593837b
2
.gitignore
vendored
2
.gitignore
vendored
@ -28,3 +28,5 @@ squid-3.1-10021.patch
|
||||
/squid-3.2.0.12.tar.bz2.asc
|
||||
/squid-3.2.0.13.tar.bz2
|
||||
/squid-3.2.0.13.tar.bz2.asc
|
||||
/squid-3.2.0.14.tar.bz2
|
||||
/squid-3.2.0.14.tar.bz2.asc
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
cef6d63729b34404a3e463f0bd81b1e3 squid-3.2.0.13.tar.bz2
|
||||
6a65c111b85313e4554e6c44d8f4fab2 squid-3.2.0.13.tar.bz2.asc
|
||||
b71beaa91e8d0a9f89956ac3685478a8 squid-3.2.0.14.tar.bz2
|
||||
d05ae51cde36421424214d4be7938847 squid-3.2.0.14.tar.bz2.asc
|
||||
|
@ -1,36 +0,0 @@
|
||||
------------------------------------------------------------
|
||||
revno: 11383
|
||||
revision-id: squid3@treenet.co.nz-20111024022732-fr9admzotjfxamq1
|
||||
parent: squid3@treenet.co.nz-20111024022558-ont2jqqprbf2ag89
|
||||
author: Francesco Chemolli <kinkie@squid-cache.org>
|
||||
committer: Amos Jeffries <squid3@treenet.co.nz>
|
||||
branch nick: SQUID_3_2
|
||||
timestamp: Sun 2011-10-23 20:27:32 -0600
|
||||
message:
|
||||
Added null pointer guard in HttpStateData::cacheableReply()
|
||||
------------------------------------------------------------
|
||||
# Bazaar merge directive format 2 (Bazaar 0.90)
|
||||
# revision_id: squid3@treenet.co.nz-20111024022732-fr9admzotjfxamq1
|
||||
# target_branch: http://bzr.squid-cache.org/bzr/squid3/branches\
|
||||
# /SQUID_3_2/
|
||||
# testament_sha1: 5f870712f3239d650a0f5a16197f366f2403c992
|
||||
# timestamp: 2011-10-24 02:38:50 +0000
|
||||
# source_branch: http://bzr.squid-cache.org/bzr/squid3/branches\
|
||||
# /SQUID_3_2
|
||||
# base_revision_id: squid3@treenet.co.nz-20111024022558-\
|
||||
# ont2jqqprbf2ag89
|
||||
#
|
||||
# Begin patch
|
||||
=== modified file 'src/http.cc'
|
||||
--- src/http.cc 2011-10-08 07:44:05 +0000
|
||||
+++ src/http.cc 2011-10-24 02:27:32 +0000
|
||||
@@ -382,7 +382,7 @@
|
||||
* RFC 2068, sec 14.9.4
|
||||
*/
|
||||
|
||||
- if (!request->cache_control->Public()) {
|
||||
+ if (!request->cache_control || !request->cache_control->Public()) {
|
||||
if (!REFRESH_OVERRIDE(ignore_auth))
|
||||
return 0;
|
||||
}
|
||||
|
@ -1,36 +0,0 @@
|
||||
------------------------------------------------------------
|
||||
revno: 11406
|
||||
revision-id: squid3@treenet.co.nz-20111104233104-1e72yz04iljr8ghp
|
||||
parent: squidadm@squid-cache.org-20111029224517-65llf81mr6p4ua6s
|
||||
fixes bug(s): http://bugs.squid-cache.org/show_bug.cgi?id=3367
|
||||
committer: Amos Jeffries <squid3@treenet.co.nz>
|
||||
branch nick: SQUID_3_2
|
||||
timestamp: Fri 2011-11-04 17:31:04 -0600
|
||||
message:
|
||||
Bug 3367: fix inverted check on host_strict_verify
|
||||
------------------------------------------------------------
|
||||
# Bazaar merge directive format 2 (Bazaar 0.90)
|
||||
# revision_id: squid3@treenet.co.nz-20111104233104-1e72yz04iljr8ghp
|
||||
# target_branch: http://bzr.squid-cache.org/bzr/squid3/branches\
|
||||
# /SQUID_3_2/
|
||||
# testament_sha1: 7add7a338726fe9ab5cd3428541ef43c0e2d41dc
|
||||
# timestamp: 2011-11-04 23:55:06 +0000
|
||||
# source_branch: http://bzr.squid-cache.org/bzr/squid3/branches\
|
||||
# /SQUID_3_2
|
||||
# base_revision_id: squidadm@squid-cache.org-20111029224517-\
|
||||
# 65llf81mr6p4ua6s
|
||||
#
|
||||
# Begin patch
|
||||
=== modified file 'src/client_side_request.cc'
|
||||
--- src/client_side_request.cc 2011-10-24 02:31:59 +0000
|
||||
+++ src/client_side_request.cc 2011-11-04 23:31:04 +0000
|
||||
@@ -634,7 +634,7 @@
|
||||
// verify the destination DNS is one of the Host: headers IPs
|
||||
ipcache_nbgethostbyname(host, hostHeaderIpVerifyWrapper, this);
|
||||
}
|
||||
- } else if (Config.onoff.hostStrictVerify) {
|
||||
+ } else if (!Config.onoff.hostStrictVerify) {
|
||||
debugs(85, 3, HERE << "validate skipped.");
|
||||
http->doCallouts();
|
||||
} else if (strlen(host) != strlen(http->request->GetHost())) {
|
||||
|
11
squid.spec
11
squid.spec
@ -3,8 +3,8 @@
|
||||
## % define __find_requires %{SOURCE99}
|
||||
|
||||
Name: squid
|
||||
Version: 3.2.0.13
|
||||
Release: 5%{?dist}
|
||||
Version: 3.2.0.14
|
||||
Release: 1%{?dist}
|
||||
Summary: The Squid proxy caching server
|
||||
Epoch: 7
|
||||
# See CREDITS for breakdown of non GPLv2+ code
|
||||
@ -25,8 +25,6 @@ Source98: perl-requires-squid.sh
|
||||
|
||||
# Upstream patches
|
||||
#Patch001: http://www.squid-cache.org/Versions/v3/3.2/changesets/squid-3.2-XXXXX.patch
|
||||
Patch001: http://www.squid-cache.org/Versions/v3/3.2/changesets/squid-3.2-11383.patch
|
||||
Patch002: http://www.squid-cache.org/Versions/v3/3.2/changesets/squid-3.2-11406.patch
|
||||
|
||||
# Local patches
|
||||
# Applying upstream patches first makes it less likely that local patches
|
||||
@ -91,8 +89,6 @@ The squid-sysvinit contains SysV initscritps support.
|
||||
%setup -q
|
||||
|
||||
#patch001 -p0
|
||||
%patch001 -p0
|
||||
%patch002 -p0
|
||||
|
||||
%patch201 -p1 -b .config
|
||||
%patch202 -p1 -b .location
|
||||
@ -306,6 +302,9 @@ fi
|
||||
/sbin/chkconfig --add squid >/dev/null 2>&1 || :
|
||||
|
||||
%changelog
|
||||
* Wed Dec 14 2011 Jiri Skala <jskala@redhat.com> - 7:3.2.0.14-1
|
||||
- update to latest upstream 3.2.0.14
|
||||
|
||||
* Mon Nov 07 2011 Jiri Skala <jskala@redhat.com> - 7:3.2.0.13-5
|
||||
- fixes #751679 - host_strict_verify setting inverted in squid.conf
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user