new version 4.0.19

This commit is contained in:
Luboš Uhliarik 2017-04-06 12:59:45 +02:00
parent 21d2c72f2e
commit c5e3d36054
4 changed files with 39 additions and 5 deletions

View File

@ -1,2 +1,2 @@
SHA512 (squid-4.0.17.tar.xz) = 473feb673c08d6a78b807fb6b59ea462ad64708f8cdc452808c357721f22dd0eda38b15a8fc6e21b8c7bd6de6196a0a99c92f63bacf53ff702cf91ca31c0e637
SHA512 (squid-4.0.17.tar.xz.asc) = 826befcbad92ff7d9d071ca2b661a3c6a65fa8bfdba35b4f9ec5973f4b325675b9fda147a9871fd2547ecd8d19c077ee2686d1a3c1c64e8adfcfa768907ed0fe
SHA512 (squid-4.0.19.tar.xz) = f7a8b47a842e2d2e59bd8762b6c2c9f49547c168e2a79080f84b884598234ad0e40ee5dc4e5cc6e3fc6a07f2dcacd45f1bcd4324e2cb82f17d72ce30a74af951
SHA512 (squid-4.0.19.tar.xz.asc) = 41c413b1fccc678c2107d142f4488930ef14aa63f3381e4b7a01d5d28a028c2e400576c0226e809c0ecfe3b3ab1da3f51100d038f7ae9a8386844d9a7c03da98

View File

@ -5,5 +5,5 @@ diff -up squid-3.0.STABLE1/contrib/url-normalizer.pl.perlpath squid-3.0.STABLE1/
-#!/usr/local/bin/perl -Tw
+#!/usr/bin/perl -Tw
#
# * Copyright (C) 1996-2016 The Squid Software Foundation and contributors
# * Copyright (C) 1996-2017 The Squid Software Foundation and contributors
# *

View File

@ -0,0 +1,26 @@
diff --git a/tools/purge/purge.cc b/tools/purge/purge.cc
index 3ef9147..07f8b32 100644
--- tools/purge/purge.cc
+++ tools/purge/purge.cc
@@ -272,7 +272,7 @@ log_extended( const char* fn, int code, long size, const SquidMetaList* meta )
snprintf( md5, sizeof(md5), "%-32s", "(no_md5_data_available)" );
}
- char timeb[64];
+ char timeb[256];
if ( meta && (findings = meta->search( STORE_META_STD )) ) {
StoreMetaStd temp;
// make data aligned, avoid SIGBUS on RISC machines (ARGH!)
diff --git a/tools/purge/purge.cc b/tools/purge/purge.cc
index 07f8b32..4bd3ddb 100644
--- tools/purge/purge.cc
+++ tools/purge/purge.cc
@@ -283,7 +283,7 @@ log_extended( const char* fn, int code, long size, const SquidMetaList* meta )
} else if ( meta && (findings = meta->search( STORE_META_STD_LFS )) ) {
StoreMetaStdLFS temp;
// make data aligned, avoid SIGBUS on RISC machines (ARGH!)
- memcpy( &temp, findings->data, sizeof(StoreMetaStd) );
+ memcpy( &temp, findings->data, sizeof(StoreMetaStdLFS) );
snprintf( timeb, sizeof(timeb), "%08lx %08lx %08lx %08lx %04x %5hu ",
(unsigned long)temp.timestamp, (unsigned long)temp.lastref,
(unsigned long)temp.expires, (unsigned long)temp.lastmod, temp.flags, temp.refcount );

View File

@ -1,8 +1,8 @@
%define __perl_requires %{SOURCE98}
Name: squid
Version: 4.0.17
Release: 2%{?dist}
Version: 4.0.19
Release: 1%{?dist}
Summary: The Squid proxy caching server
Epoch: 7
# See CREDITS for breakdown of non GPLv2+ code
@ -31,6 +31,7 @@ Patch201: squid-4.0.11-config.patch
Patch202: squid-3.1.0.9-location.patch
Patch203: squid-3.0.STABLE1-perlpath.patch
Patch204: squid-3.5.9-include-guards.patch
Patch205: squid-4.0.18-gcc7-errors.patch
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires: bash >= 2.0
@ -91,6 +92,7 @@ lookup program (dnsserver), a program for retrieving FTP data
%patch202 -p1 -b .location
%patch203 -p1 -b .perlpath
%patch204 -p0 -b .include-guards
%patch205 -p0 -b .gcc7-errors
%build
# cppunit-config patch changes configure.ac
@ -285,6 +287,12 @@ fi
%changelog
* Mon Apr 03 2017 Luboš Uhliarik <luhliari@redhat.com> - 7:4.0.19-1
- new version 4.0.19
* Thu Mar 30 2017 Luboš Uhliarik <luhliari@redhat.com> - 7:4.0.18-1
- new version 4.0.18
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 7:4.0.17-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild