Update to latest upstream STABLE13.
This commit is contained in:
parent
452df107d4
commit
bb69e646db
@ -1 +1 @@
|
|||||||
squid-3.0.STABLE12.tar.bz2
|
squid-3.0.STABLE13.tar.bz2
|
||||||
|
36
b8920.patch
36
b8920.patch
@ -1,36 +0,0 @@
|
|||||||
------------------------------------------------------------
|
|
||||||
revno: 8920
|
|
||||||
revision-id: squid3@treenet.co.nz-20081019111450-8u5w57an2g1vh9z7
|
|
||||||
parent: squid3@treenet.co.nz-20081015084824-z2n6sc78b0p88pv6
|
|
||||||
committer: Amos Jeffries <squid3@treenet.co.nz>
|
|
||||||
branch nick: SQUID_3_0
|
|
||||||
timestamp: Mon 2008-10-20 00:14:50 +1300
|
|
||||||
message:
|
|
||||||
Author: Mikio Kishi <mkishi@104.net>
|
|
||||||
Fix regression: access.log request size tag (%>st)
|
|
||||||
------------------------------------------------------------
|
|
||||||
# Bazaar merge directive format 2 (Bazaar 0.90)
|
|
||||||
# revision_id: squid3@treenet.co.nz-20081019111450-8u5w57an2g1vh9z7
|
|
||||||
# target_branch: http://www.squid-cache.org/bzr/squid3/branches\
|
|
||||||
# /SQUID_3_0/
|
|
||||||
# testament_sha1: 1f837decf60a52e0de94e91c3467edfcc6c13714
|
|
||||||
# timestamp: 2008-10-19 11:16:02 +0000
|
|
||||||
# source_branch: http://www.squid-cache.org/bzr/squid3/branches\
|
|
||||||
# /SQUID_3_0
|
|
||||||
# base_revision_id: squid3@treenet.co.nz-20081015084824-\
|
|
||||||
# z2n6sc78b0p88pv6
|
|
||||||
#
|
|
||||||
# Begin patch
|
|
||||||
=== modified file 'src/access_log.cc'
|
|
||||||
--- src/access_log.cc 2008-06-27 13:40:12 +0000
|
|
||||||
+++ src/access_log.cc 2008-10-19 11:14:50 +0000
|
|
||||||
@@ -783,7 +783,7 @@
|
|
||||||
break;
|
|
||||||
|
|
||||||
case LFT_REQUEST_SIZE_TOTAL:
|
|
||||||
- outint = al->cache.requestSize;
|
|
||||||
+ outoff = al->cache.requestSize;
|
|
||||||
dooff = 1;
|
|
||||||
break;
|
|
||||||
|
|
||||||
|
|
74
b8930.patch
74
b8930.patch
@ -1,74 +0,0 @@
|
|||||||
------------------------------------------------------------
|
|
||||||
revno: 8930
|
|
||||||
revision-id: squid3@treenet.co.nz-20081201053029-k18urfbqvmmo1whl
|
|
||||||
parent: squid3@treenet.co.nz-20081128120843-juy12m80zdtusl5v
|
|
||||||
committer: Amos Jeffries <squid3@treenet.co.nz>
|
|
||||||
branch nick: SQUID_3_0
|
|
||||||
timestamp: Mon 2008-12-01 18:30:29 +1300
|
|
||||||
message:
|
|
||||||
Rollback rev 8909
|
|
||||||
|
|
||||||
This change to StoreIO overlooked the signedness of the StoreIO* length
|
|
||||||
parameter. It may have resulted in objects that should not have been
|
|
||||||
store making their way into the cache.
|
|
||||||
|
|
||||||
Caches created by 3.0.STABLE10 release are known to contain many invalid
|
|
||||||
entries when rolled back to STABLE9 release. Whether or not these entries
|
|
||||||
are fatal to Squid is still unknown. It is currently expected that they
|
|
||||||
will be erased properly, but cause a lot of cache.log warnings while that
|
|
||||||
is happening. It is left to admin to decide if its worth purging their
|
|
||||||
cache on upgrade.
|
|
||||||
------------------------------------------------------------
|
|
||||||
# Bazaar merge directive format 2 (Bazaar 0.90)
|
|
||||||
# revision_id: squid3@treenet.co.nz-20081201053029-k18urfbqvmmo1whl
|
|
||||||
# target_branch: http://www.squid-cache.org/bzr/squid3/branches\
|
|
||||||
# /SQUID_3_0/
|
|
||||||
# testament_sha1: 491d242447b01a6ec90eb9983cc9384b050fae73
|
|
||||||
# timestamp: 2008-12-01 05:47:46 +0000
|
|
||||||
# source_branch: http://www.squid-cache.org/bzr/squid3/branches\
|
|
||||||
# /SQUID_3_0
|
|
||||||
# base_revision_id: squid3@treenet.co.nz-20081128120843-\
|
|
||||||
# juy12m80zdtusl5v
|
|
||||||
#
|
|
||||||
# Begin patch
|
|
||||||
=== modified file 'src/StoreIOBuffer.h'
|
|
||||||
--- src/StoreIOBuffer.h 2008-10-06 11:35:50 +0000
|
|
||||||
+++ src/StoreIOBuffer.h 2008-12-01 05:30:29 +0000
|
|
||||||
@@ -46,17 +46,9 @@
|
|
||||||
StoreIOBuffer():length(0), offset (0), data (NULL) {flags.error = 0;}
|
|
||||||
|
|
||||||
StoreIOBuffer(size_t aLength, int64_t anOffset, char *someData) :
|
|
||||||
- offset (anOffset), data (someData)
|
|
||||||
+ length (aLength), offset (anOffset), data (someData)
|
|
||||||
{
|
|
||||||
- /* maintain own state: detect size errors now */
|
|
||||||
- if (aLength <0) {
|
|
||||||
- flags.error = 1;
|
|
||||||
- length = 0;
|
|
||||||
- }
|
|
||||||
- else {
|
|
||||||
- flags.error = 0;
|
|
||||||
- length = aLength;
|
|
||||||
- }
|
|
||||||
+ flags.error = 0;
|
|
||||||
}
|
|
||||||
|
|
||||||
/* Create a StoreIOBuffer from a MemBuf and offset */
|
|
||||||
|
|
||||||
=== modified file 'src/store_client.cc'
|
|
||||||
--- src/store_client.cc 2008-10-06 11:35:50 +0000
|
|
||||||
+++ src/store_client.cc 2008-12-01 05:30:29 +0000
|
|
||||||
@@ -145,8 +145,11 @@
|
|
||||||
{
|
|
||||||
StoreIOBuffer result(sz, 0 ,copyInto.data);
|
|
||||||
|
|
||||||
- if (error) {
|
|
||||||
+ if (sz < 0) {
|
|
||||||
result.flags.error = 1;
|
|
||||||
+ result.length = 0;
|
|
||||||
+ } else {
|
|
||||||
+ result.flags.error = error ? 1 : 0;
|
|
||||||
}
|
|
||||||
|
|
||||||
result.offset = cmp_offset;
|
|
||||||
|
|
1
import.log
Normal file
1
import.log
Normal file
@ -0,0 +1 @@
|
|||||||
|
squid-3_0_STABLE13-1_fc9:HEAD:squid-3.0.STABLE13-1.fc9.src.rpm:1233879357
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
50f10f79b78c322c9dc21b0ecdbcbefc squid-3.0.STABLE12.tar.bz2
|
37c89c97743a81e5178fbd5d5888b7e2 squid-3.0.STABLE13.tar.bz2
|
||||||
|
@ -1,50 +0,0 @@
|
|||||||
diff -up squid-3.0.STABLE9/configure.configure_netfilter squid-3.0.STABLE9/configure
|
|
||||||
--- squid-3.0.STABLE9/configure.configure_netfilter 2008-09-09 18:06:45.000000000 +0200
|
|
||||||
+++ squid-3.0.STABLE9/configure 2008-10-19 23:29:03.000000000 +0200
|
|
||||||
@@ -24934,6 +24934,7 @@ cat >>conftest.$ac_ext <<_ACEOF
|
|
||||||
#if HAVE_NETINET_IN_H
|
|
||||||
#include <netinet/in.h>
|
|
||||||
#endif
|
|
||||||
+#include <linux/types.h>
|
|
||||||
|
|
||||||
|
|
||||||
#include <$ac_header>
|
|
||||||
diff -up squid-3.0.STABLE9/src/IPInterception.cc.configure_netfilter squid-3.0.STABLE9/src/IPInterception.cc
|
|
||||||
--- squid-3.0.STABLE9/src/IPInterception.cc.configure_netfilter 2008-09-09 18:06:43.000000000 +0200
|
|
||||||
+++ squid-3.0.STABLE9/src/IPInterception.cc 2008-10-19 23:30:43.000000000 +0200
|
|
||||||
@@ -85,7 +85,9 @@
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#if LINUX_NETFILTER
|
|
||||||
-#include <linux/types.h>
|
|
||||||
+#if HAVE_NETINET_IN_H
|
|
||||||
+# include <netinet/in.h>
|
|
||||||
+#endif
|
|
||||||
#include <linux/netfilter_ipv4.h>
|
|
||||||
#endif
|
|
||||||
|
|
||||||
diff -up squid-3.0.STABLE9/src/forward.cc.configure_netfilter squid-3.0.STABLE9/src/forward.cc
|
|
||||||
--- squid-3.0.STABLE9/src/forward.cc.configure_netfilter 2008-09-09 18:06:44.000000000 +0200
|
|
||||||
+++ squid-3.0.STABLE9/src/forward.cc 2008-10-19 23:29:03.000000000 +0200
|
|
||||||
@@ -50,6 +50,10 @@
|
|
||||||
#include "Store.h"
|
|
||||||
|
|
||||||
#if LINUX_TPROXY
|
|
||||||
+#if HAVE_NETINET_IN_H
|
|
||||||
+# include <netinet/in.h>
|
|
||||||
+#endif
|
|
||||||
+#include <linux/types.h>
|
|
||||||
#include <linux/netfilter_ipv4/ip_tproxy.h>
|
|
||||||
#endif
|
|
||||||
|
|
||||||
diff -up squid-3.0.STABLE9/configure.in.configure_netfilter squid-3.0.STABLE9/configure.in
|
|
||||||
--- squid-3.0.STABLE9/configure.in.configure_netfilter 2008-09-09 18:06:45.000000000 +0200
|
|
||||||
+++ squid-3.0.STABLE9/configure.in 2008-10-19 23:29:03.000000000 +0200
|
|
||||||
@@ -1955,6 +1955,7 @@ SQUID_DEFAULT_INCLUDES
|
|
||||||
#if HAVE_NETINET_IN_H
|
|
||||||
#include <netinet/in.h>
|
|
||||||
#endif
|
|
||||||
+#include <linux/types.h>
|
|
||||||
)
|
|
||||||
|
|
||||||
dnl *BSD dont include the depenencies for all their net/ and netinet/ files
|
|
@ -3,7 +3,7 @@
|
|||||||
## % define __find_requires %{SOURCE99}
|
## % define __find_requires %{SOURCE99}
|
||||||
|
|
||||||
Name: squid
|
Name: squid
|
||||||
Version: 3.0.STABLE12
|
Version: 3.0.STABLE13
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: The Squid proxy caching server
|
Summary: The Squid proxy caching server
|
||||||
Epoch: 7
|
Epoch: 7
|
||||||
@ -338,6 +338,9 @@ fi
|
|||||||
chgrp squid /var/cache/samba/winbindd_privileged >/dev/null 2>&1 || :
|
chgrp squid /var/cache/samba/winbindd_privileged >/dev/null 2>&1 || :
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Feb 5 2009 Jonathan Steffan <jsteffan@fedoraproject.org> - 7:3.0.STABLE13-1
|
||||||
|
- upgrade to latest upstream
|
||||||
|
|
||||||
* Tue Jan 27 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 7:3.0.STABLE12-1
|
* Tue Jan 27 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 7:3.0.STABLE12-1
|
||||||
- upgrade to latest upstream
|
- upgrade to latest upstream
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user