new version 3.5.3
This commit is contained in:
parent
fcf9efd56c
commit
9e83d6c005
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
0330ec9f69e333c2a81fa4502ba96a22 squid-3.5.2.tar.xz
|
6cd553300a2253c0913f498beb79ee51 squid-3.5.3.tar.xz
|
||||||
77e21831ec7f982fc87459e7a746ef67 squid-3.5.2.tar.xz.asc
|
af4c5d253c3c1ab034c11f2f17a41ee5 squid-3.5.3.tar.xz.asc
|
||||||
|
@ -14,15 +14,6 @@ diff -up squid-3.1.0.9/QUICKSTART.location squid-3.1.0.9/QUICKSTART
|
|||||||
|
|
||||||
==============================================================================
|
==============================================================================
|
||||||
|
|
||||||
@@ -54,7 +53,7 @@ cache_effective_user
|
|
||||||
Some configuration lines which are optional but may be needed.
|
|
||||||
|
|
||||||
|
|
||||||
-cache_dir ufs /usr/local/squid/var/cache 100 16 256
|
|
||||||
+cache_dir ufs /var/spool/squid 100 16 256
|
|
||||||
|
|
||||||
Add here (first number, here 100) the amount of hard disk space
|
|
||||||
(in megabytes) to devote to caching.
|
|
||||||
@@ -82,12 +81,12 @@ After editing squid.conf to your liking,
|
@@ -82,12 +81,12 @@ After editing squid.conf to your liking,
|
||||||
line TWICE:
|
line TWICE:
|
||||||
|
|
||||||
|
@ -1,47 +0,0 @@
|
|||||||
diff -up squid-3.5.2/src/SBufStatsAction.cc.sbufstats squid-3.5.2/src/SBufStatsAction.cc
|
|
||||||
--- squid-3.5.2/src/SBufStatsAction.cc.sbufstats 2015-03-15 13:48:36.479197186 +0100
|
|
||||||
+++ squid-3.5.2/src/SBufStatsAction.cc 2015-03-15 13:49:19.559676380 +0100
|
|
||||||
@@ -82,7 +82,8 @@ SBufStatsAction::unpack(const Ipc::Typed
|
|
||||||
msg.getPod(mbdata);
|
|
||||||
}
|
|
||||||
|
|
||||||
-static const bool Registered = (Mgr::RegisterAction("sbuf",
|
|
||||||
- "String-Buffer statistics", &SBufStatsAction::Create, 0 , 1),
|
|
||||||
- true);
|
|
||||||
-
|
|
||||||
+void
|
|
||||||
+SBufStatsAction::RegisterWithCacheManager()
|
|
||||||
+{
|
|
||||||
+ Mgr::RegisterAction("sbuf", "String-Buffer statistics", &SBufStatsAction::Create, 0 , 1);
|
|
||||||
+}
|
|
||||||
diff -up squid-3.5.2/src/SBufStatsAction.h.sbufstats squid-3.5.2/src/SBufStatsAction.h
|
|
||||||
--- squid-3.5.2/src/SBufStatsAction.h.sbufstats 2015-02-18 13:17:02.000000000 +0100
|
|
||||||
+++ squid-3.5.2/src/SBufStatsAction.h 2015-03-15 13:48:36.479197186 +0100
|
|
||||||
@@ -21,6 +21,7 @@ class SBufStatsAction: public Mgr::Actio
|
|
||||||
public:
|
|
||||||
/// Mgr::ClassActionCreationHandler for Mgr::RegisterAction()
|
|
||||||
static Pointer Create(const Mgr::CommandPointer &cmd);
|
|
||||||
+ static void RegisterWithCacheManager(void);
|
|
||||||
|
|
||||||
protected:
|
|
||||||
explicit SBufStatsAction(const Mgr::CommandPointer &cmd);
|
|
||||||
diff -up squid-3.5.2/src/main.cc.sbufstats squid-3.5.2/src/main.cc
|
|
||||||
--- squid-3.5.2/src/main.cc.sbufstats 2015-02-18 13:17:02.000000000 +0100
|
|
||||||
+++ squid-3.5.2/src/main.cc 2015-03-15 13:48:36.479197186 +0100
|
|
||||||
@@ -59,6 +59,7 @@
|
|
||||||
#include "profiler/Profiler.h"
|
|
||||||
#include "redirect.h"
|
|
||||||
#include "refresh.h"
|
|
||||||
+#include "SBufStatsAction.h"
|
|
||||||
#include "send-announce.h"
|
|
||||||
#include "SquidConfig.h"
|
|
||||||
#include "SquidDns.h"
|
|
||||||
@@ -1089,6 +1090,8 @@ mainInitialize(void)
|
|
||||||
/* register the modules in the cache manager menus */
|
|
||||||
|
|
||||||
cbdataRegisterWithCacheManager();
|
|
||||||
+ SBufStatsAction::RegisterWithCacheManager();
|
|
||||||
+
|
|
||||||
/* These use separate calls so that the comm loops can eventually
|
|
||||||
* coexist.
|
|
||||||
*/
|
|
10
squid.spec
10
squid.spec
@ -1,8 +1,8 @@
|
|||||||
%define __perl_requires %{SOURCE98}
|
%define __perl_requires %{SOURCE98}
|
||||||
|
|
||||||
Name: squid
|
Name: squid
|
||||||
Version: 3.5.2
|
Version: 3.5.3
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: The Squid proxy caching server
|
Summary: The Squid proxy caching server
|
||||||
Epoch: 7
|
Epoch: 7
|
||||||
# See CREDITS for breakdown of non GPLv2+ code
|
# See CREDITS for breakdown of non GPLv2+ code
|
||||||
@ -32,8 +32,6 @@ Patch202: squid-3.1.0.9-location.patch
|
|||||||
Patch203: squid-3.0.STABLE1-perlpath.patch
|
Patch203: squid-3.0.STABLE1-perlpath.patch
|
||||||
Patch205: squid-3.1.9-ltdl.patch
|
Patch205: squid-3.1.9-ltdl.patch
|
||||||
Patch206: active-ftp.patch
|
Patch206: active-ftp.patch
|
||||||
# pushed upstream in trunk revision 13985.
|
|
||||||
Patch207: squid-3.5.2-sbufstats.patch
|
|
||||||
|
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Requires: bash >= 2.0
|
Requires: bash >= 2.0
|
||||||
@ -95,7 +93,6 @@ lookup program (dnsserver), a program for retrieving FTP data
|
|||||||
#%patch205 -p1 -b .ltdl
|
#%patch205 -p1 -b .ltdl
|
||||||
# Fails on 3.5.1
|
# Fails on 3.5.1
|
||||||
#%patch206 -p1 -b .active-ftp
|
#%patch206 -p1 -b .active-ftp
|
||||||
%patch207 -p1 -b .sbufstats
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
@ -288,6 +285,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 31 2015 Pavel Šimerda <psimerda@redhat.com> - 7:3.5.3-1
|
||||||
|
- new version 3.5.3
|
||||||
|
|
||||||
* Mon Mar 23 2015 Pavel Šimerda <psimerda@redhat.com> - 7:3.5.2-4
|
* Mon Mar 23 2015 Pavel Šimerda <psimerda@redhat.com> - 7:3.5.2-4
|
||||||
- Resolves: #1145235, #1173488, #1176318 – revert a couple of recent changes
|
- Resolves: #1145235, #1173488, #1176318 – revert a couple of recent changes
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user