the latest stable upstream, reworked fd config patch
This commit is contained in:
parent
acf9466998
commit
9ca10df721
2
sources
2
sources
@ -1 +1 @@
|
|||||||
d6bb23a67b0475cca11d4af8d574d054 squid-2.6.STABLE1.tar.bz2
|
838492f95de0964e31e633bfa07a0682 squid-2.6.STABLE2.tar.bz2
|
||||||
|
117
squid-2.6.STABLE2-build.patch
Normal file
117
squid-2.6.STABLE2-build.patch
Normal file
@ -0,0 +1,117 @@
|
|||||||
|
--- squid-2.6.STABLE2/errors/Makefile.in.build 2006-06-12 08:09:43.000000000 +0200
|
||||||
|
+++ squid-2.6.STABLE2/errors/Makefile.in 2006-07-31 09:38:42.000000000 +0200
|
||||||
|
@@ -221,8 +221,8 @@
|
||||||
|
sharedstatedir = @sharedstatedir@
|
||||||
|
sysconfdir = @sysconfdir@
|
||||||
|
target_alias = @target_alias@
|
||||||
|
-errordir = $(datadir)/errors
|
||||||
|
-DEFAULT_ERROR_DIR = $(errordir)
|
||||||
|
+errordir = $(pkgdatadir)/errors
|
||||||
|
+DEFAULT_ERROR_DIR = $(sysconfdir)/errors
|
||||||
|
INSTALL_LANGUAGES = @ERR_LANGUAGES@
|
||||||
|
LANGUAGES = \
|
||||||
|
Azerbaijani \
|
||||||
|
@@ -413,17 +413,17 @@
|
||||||
|
|
||||||
|
install-data-local:
|
||||||
|
@for l in $(INSTALL_LANGUAGES); do \
|
||||||
|
- $(mkinstalldirs) $(DESTDIR)$(DEFAULT_ERROR_DIR)/$$l && \
|
||||||
|
+ $(mkinstalldirs) $(DESTDIR)$(errordir)/$$l && \
|
||||||
|
for f in $(srcdir)/$$l/ERR_*; do \
|
||||||
|
- echo "$(INSTALL_DATA) $$f $(DESTDIR)$(DEFAULT_ERROR_DIR)/$$l"; \
|
||||||
|
- $(INSTALL_DATA) $$f $(DESTDIR)$(DEFAULT_ERROR_DIR)/$$l; \
|
||||||
|
+ echo "$(INSTALL_DATA) $$f $(DESTDIR)$(errordir)/$$l"; \
|
||||||
|
+ $(INSTALL_DATA) $$f $(DESTDIR)$(errordir)/$$l; \
|
||||||
|
done \
|
||||||
|
done
|
||||||
|
|
||||||
|
uninstall-local:
|
||||||
|
@for l in $(INSTALL_LANGUAGES); do \
|
||||||
|
for f in $(srcdir)/$$l/ERR_*; do \
|
||||||
|
- rm -f $(DESTDIR)$(DEFAULT_ERROR_DIR)/$$l/`basename $$f`; \
|
||||||
|
+ rm -f $(DESTDIR)$(errordir)/$$l/`basename $$f`; \
|
||||||
|
done \
|
||||||
|
done
|
||||||
|
|
||||||
|
@@ -436,13 +436,13 @@
|
||||||
|
#
|
||||||
|
addlang: all
|
||||||
|
-@if test -d $(srcdir)/$(ADDLANG); then \
|
||||||
|
- if test -d $(DEFAULT_ERROR_DIR)/$(DESTLANG); then \
|
||||||
|
+ if test -d $(errordir)/$(DESTLANG); then \
|
||||||
|
cd $(srcdir)/$(ADDLANG)/ ; \
|
||||||
|
for f in ERR_*; do \
|
||||||
|
- if test -f $(DEFAULT_ERROR_DIR)/$(DESTLANG)/$$f ; then \
|
||||||
|
+ if test -f $(errordir)/$(DESTLANG)/$$f ; then \
|
||||||
|
echo "appending $(ADDLANG)/$$f"; \
|
||||||
|
- echo "<HR>" >> $(DEFAULT_ERROR_DIR)/$(DESTLANG)/$$f ; \
|
||||||
|
- cat $$f >> $(DEFAULT_ERROR_DIR)/$(DESTLANG)/$$f; \
|
||||||
|
+ echo "<HR>" >> $(errordir)/$(DESTLANG)/$$f ; \
|
||||||
|
+ cat $$f >> $(errordir)/$(DESTLANG)/$$f; \
|
||||||
|
fi; \
|
||||||
|
done; \
|
||||||
|
fi \
|
||||||
|
--- squid-2.6.STABLE2/icons/Makefile.in.build 2006-06-12 08:10:08.000000000 +0200
|
||||||
|
+++ squid-2.6.STABLE2/icons/Makefile.in 2006-07-31 09:38:42.000000000 +0200
|
||||||
|
@@ -258,7 +258,7 @@
|
||||||
|
anthony-xbm.gif \
|
||||||
|
anthony-xpm.gif
|
||||||
|
|
||||||
|
-icondir = $(datadir)/icons
|
||||||
|
+icondir = $(pkgdatadir)/icons
|
||||||
|
icon_DATA = $(ICON1) $(ICON2)
|
||||||
|
EXTRA_DIST = $(ICON1) $(ICON2) icons.shar
|
||||||
|
DISTCLEANFILES =
|
||||||
|
--- squid-2.6.STABLE2/src/Makefile.in.build 2006-07-30 10:56:18.000000000 +0200
|
||||||
|
+++ squid-2.6.STABLE2/src/Makefile.in 2006-07-31 09:47:33.000000000 +0200
|
||||||
|
@@ -586,18 +586,18 @@
|
||||||
|
DEFAULT_CONFIG_FILE = $(sysconfdir)/squid.conf
|
||||||
|
DEFAULT_MIME_TABLE = $(sysconfdir)/mime.conf
|
||||||
|
DEFAULT_DNSSERVER = $(libexecdir)/`echo dnsserver | sed '$(transform);s/$$/$(EXEEXT)/'`
|
||||||
|
-DEFAULT_LOG_PREFIX = $(localstatedir)/logs
|
||||||
|
+DEFAULT_LOG_PREFIX = $(localstatedir)/log/squid
|
||||||
|
DEFAULT_CACHE_LOG = $(DEFAULT_LOG_PREFIX)/cache.log
|
||||||
|
DEFAULT_ACCESS_LOG = $(DEFAULT_LOG_PREFIX)/access.log
|
||||||
|
DEFAULT_STORE_LOG = $(DEFAULT_LOG_PREFIX)/store.log
|
||||||
|
-DEFAULT_PID_FILE = $(DEFAULT_LOG_PREFIX)/squid.pid
|
||||||
|
-DEFAULT_SWAP_DIR = $(localstatedir)/cache
|
||||||
|
+DEFAULT_PID_FILE = $(localstatedir)/run/squid.pid
|
||||||
|
+DEFAULT_SWAP_DIR = $(localstatedir)/spool/squid
|
||||||
|
DEFAULT_PINGER = $(libexecdir)/`echo pinger | sed '$(transform);s/$$/$(EXEEXT)/'`
|
||||||
|
DEFAULT_UNLINKD = $(libexecdir)/`echo unlinkd | sed '$(transform);s/$$/$(EXEEXT)/'`
|
||||||
|
DEFAULT_DISKD = $(libexecdir)/`echo diskd-daemon | sed '$(transform);s/$$/$(EXEEXT)/'`
|
||||||
|
-DEFAULT_ICON_DIR = $(datadir)/icons
|
||||||
|
-DEFAULT_ERROR_DIR = $(datadir)/errors/@ERR_DEFAULT_LANGUAGE@
|
||||||
|
-DEFAULT_MIB_PATH = $(datadir)/mib.txt
|
||||||
|
+DEFAULT_ICON_DIR = $(pkgdatadir)/icons
|
||||||
|
+DEFAULT_ERROR_DIR = $(pkgdatadir)/errors/@ERR_DEFAULT_LANGUAGE@
|
||||||
|
+DEFAULT_MIB_PATH = $(sysconfdir)/mib.txt
|
||||||
|
DEFAULT_HOSTS = @OPT_DEFAULT_HOSTS@
|
||||||
|
|
||||||
|
# Don't automatically uninstall config files
|
||||||
|
@@ -842,20 +842,20 @@
|
||||||
|
uninstall-info-am:
|
||||||
|
install-dataDATA: $(data_DATA)
|
||||||
|
@$(NORMAL_INSTALL)
|
||||||
|
- test -z "$(datadir)" || $(mkdir_p) "$(DESTDIR)$(datadir)"
|
||||||
|
+ test -z "$(sysconfdir)/squid" || $(mkdir_p) "$(DESTDIR)$(sysconfdir)/squid"
|
||||||
|
@list='$(data_DATA)'; for p in $$list; do \
|
||||||
|
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
||||||
|
f=$(am__strip_dir) \
|
||||||
|
- echo " $(dataDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(datadir)/$$f'"; \
|
||||||
|
- $(dataDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(datadir)/$$f"; \
|
||||||
|
+ echo " $(dataDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(sysconfdir)/$$f'"; \
|
||||||
|
+ $(dataDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(sysconfdir)/$$f"; \
|
||||||
|
done
|
||||||
|
|
||||||
|
uninstall-dataDATA:
|
||||||
|
@$(NORMAL_UNINSTALL)
|
||||||
|
@list='$(data_DATA)'; for p in $$list; do \
|
||||||
|
f=$(am__strip_dir) \
|
||||||
|
- echo " rm -f '$(DESTDIR)$(datadir)/$$f'"; \
|
||||||
|
- rm -f "$(DESTDIR)$(datadir)/$$f"; \
|
||||||
|
+ echo " rm -f '$(DESTDIR)$(sysconfdir)/$$f'"; \
|
||||||
|
+ rm -f "$(DESTDIR)$(sysconfdir)/$$f"; \
|
||||||
|
done
|
||||||
|
install-sysconfDATA: $(sysconf_DATA)
|
||||||
|
@$(NORMAL_INSTALL)
|
16
squid.spec
16
squid.spec
@ -4,8 +4,8 @@
|
|||||||
|
|
||||||
Summary: The Squid proxy caching server.
|
Summary: The Squid proxy caching server.
|
||||||
Name: squid
|
Name: squid
|
||||||
Version: 2.6.STABLE1
|
Version: 2.6.STABLE2
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 7
|
Epoch: 7
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -20,7 +20,6 @@ Source98: perl-requires-squid.sh
|
|||||||
|
|
||||||
# Upstream patches
|
# Upstream patches
|
||||||
# the latest upstream CVS snapshot
|
# the latest upstream CVS snapshot
|
||||||
Patch100: squid-2.6.STABLE1-20060725.patch
|
|
||||||
|
|
||||||
# External patches
|
# External patches
|
||||||
|
|
||||||
@ -29,10 +28,10 @@ Patch100: squid-2.6.STABLE1-20060725.patch
|
|||||||
# will break upstream ones.
|
# will break upstream ones.
|
||||||
Patch201: squid-2.5.STABLE11-config.patch
|
Patch201: squid-2.5.STABLE11-config.patch
|
||||||
Patch202: squid-2.5.STABLE4-location.patch
|
Patch202: squid-2.5.STABLE4-location.patch
|
||||||
Patch203: squid-2.6.STABLE1-build.patch
|
Patch203: squid-2.6.STABLE2-build.patch
|
||||||
Patch204: squid-2.5.STABLE4-perlpath.patch
|
Patch204: squid-2.5.STABLE4-perlpath.patch
|
||||||
Patch205: squid-2.5.STABLE12-smb-path.patch
|
Patch205: squid-2.5.STABLE12-smb-path.patch
|
||||||
Patch206: squid-2.6.STABLE1-fd-config.patch
|
Patch206: squid-2.6.STABLE1-fd-config-updated.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
Prereq: /sbin/chkconfig logrotate shadow-utils
|
Prereq: /sbin/chkconfig logrotate shadow-utils
|
||||||
@ -55,8 +54,6 @@ lookup program (dnsserver), a program for retrieving FTP data
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch100 -p1
|
|
||||||
|
|
||||||
%patch201 -p1 -b .config
|
%patch201 -p1 -b .config
|
||||||
%patch202 -p1 -b .location
|
%patch202 -p1 -b .location
|
||||||
%patch203 -p1 -b .build
|
%patch203 -p1 -b .build
|
||||||
@ -101,6 +98,7 @@ lookup program (dnsserver), a program for retrieving FTP data
|
|||||||
--enable-follow-x-forwarded-for \
|
--enable-follow-x-forwarded-for \
|
||||||
--enable-wccpv2 \
|
--enable-wccpv2 \
|
||||||
--enable-fd-config \
|
--enable-fd-config \
|
||||||
|
--with-maxfd=16384 \
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
@ -324,6 +322,10 @@ fi
|
|||||||
chgrp squid /var/cache/samba/winbindd_privileged > /dev/null 2>& 1 || true
|
chgrp squid /var/cache/samba/winbindd_privileged > /dev/null 2>& 1 || true
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 31 2006 Martin Stransky <stransky@redhat.com> - 7:2.6.STABLE2-1
|
||||||
|
- the latest stable upstream
|
||||||
|
- reworked fd config patch
|
||||||
|
|
||||||
* Wed Jul 25 2006 Martin Stransky <stransky@redhat.com> - 7:2.6.STABLE1-3
|
* Wed Jul 25 2006 Martin Stransky <stransky@redhat.com> - 7:2.6.STABLE1-3
|
||||||
- the latest CVS upstream snapshot
|
- the latest CVS upstream snapshot
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user