- upgrade to latest upstream
- fix bad allocation
This commit is contained in:
parent
e844aa549d
commit
77a7563b3e
@ -1 +1 @@
|
|||||||
squid-3.0.STABLE5.tar.bz2
|
squid-3.0.STABLE6.tar.bz2
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
60255e66bca8203afb9a635f318b9c65 squid-3.0.STABLE5.tar.bz2
|
231323a73346041cec825e785960e348 squid-3.0.STABLE6.tar.bz2
|
||||||
|
14
squid-3.0.STABLE5-bad_allocation
Normal file
14
squid-3.0.STABLE5-bad_allocation
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
diff -up squid-3.0.STABLE5/src/tools.cc.bad_allocation squid-3.0.STABLE5/src/tools.cc
|
||||||
|
--- squid-3.0.STABLE5/src/tools.cc.bad_allocation 2008-05-21 10:49:55.000000000 +0200
|
||||||
|
+++ squid-3.0.STABLE5/src/tools.cc 2008-05-21 10:50:02.000000000 +0200
|
||||||
|
@@ -1343,8 +1343,8 @@ static void
|
||||||
|
restoreCapabilities(int keep)
|
||||||
|
{
|
||||||
|
#if defined(_SQUID_LINUX_) && HAVE_SYS_CAPABILITY_H
|
||||||
|
- cap_user_header_t head = (cap_user_header_t) xcalloc(1, sizeof(cap_user_header_t));
|
||||||
|
- cap_user_data_t cap = (cap_user_data_t) xcalloc(1, sizeof(cap_user_data_t));
|
||||||
|
+ cap_user_header_t head = (cap_user_header_t) xcalloc(1, sizeof(*head));
|
||||||
|
+ cap_user_data_t cap = (cap_user_data_t) xcalloc(1, sizeof(*cap));
|
||||||
|
|
||||||
|
head->version = _LINUX_CAPABILITY_VERSION;
|
||||||
|
|
12
squid.spec
12
squid.spec
@ -3,8 +3,8 @@
|
|||||||
## % define __find_requires %{SOURCE99}
|
## % define __find_requires %{SOURCE99}
|
||||||
|
|
||||||
Name: squid
|
Name: squid
|
||||||
Version: 3.0.STABLE5
|
Version: 3.0.STABLE6
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: The Squid proxy caching server
|
Summary: The Squid proxy caching server
|
||||||
Epoch: 7
|
Epoch: 7
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
@ -20,6 +20,7 @@ Source98: perl-requires-squid.sh
|
|||||||
## Source99: filter-requires-squid.sh
|
## Source99: filter-requires-squid.sh
|
||||||
|
|
||||||
# Upstream patches
|
# Upstream patches
|
||||||
|
Patch0: squid-3.0.STABLE5-bad_allocation
|
||||||
|
|
||||||
# External patches
|
# External patches
|
||||||
|
|
||||||
@ -58,6 +59,8 @@ lookup program (dnsserver), a program for retrieving FTP data
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
|
%patch0 -p1 -b .bad_allocation
|
||||||
|
|
||||||
%patch201 -p1 -b .config
|
%patch201 -p1 -b .config
|
||||||
%patch202 -p1 -b .location
|
%patch202 -p1 -b .location
|
||||||
%patch203 -p1 -b .build
|
%patch203 -p1 -b .build
|
||||||
@ -194,6 +197,7 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%config /etc/squid/msntauth.conf.default
|
%config /etc/squid/msntauth.conf.default
|
||||||
%config /etc/squid/squid.conf.default
|
%config /etc/squid/squid.conf.default
|
||||||
%config /etc/squid/mime.conf.default
|
%config /etc/squid/mime.conf.default
|
||||||
|
%config /etc/squid/cachemgr.conf.default
|
||||||
%config(noreplace) /etc/pam.d/squid
|
%config(noreplace) /etc/pam.d/squid
|
||||||
%config(noreplace) /etc/logrotate.d/squid
|
%config(noreplace) /etc/logrotate.d/squid
|
||||||
|
|
||||||
@ -336,6 +340,10 @@ fi
|
|||||||
chgrp squid /var/cache/samba/winbindd_privileged >/dev/null 2>&1 || :
|
chgrp squid /var/cache/samba/winbindd_privileged >/dev/null 2>&1 || :
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed May 21 2008 Martin Nagy <mnagy@redhat.com> - 7:3.0.STABLE6-1
|
||||||
|
- upgrade to latest upstream
|
||||||
|
- fix bad allocation
|
||||||
|
|
||||||
* Fri May 09 2008 Martin Nagy <mnagy@redhat.com> - 7:3.0.STABLE5-2
|
* Fri May 09 2008 Martin Nagy <mnagy@redhat.com> - 7:3.0.STABLE5-2
|
||||||
- fix configure detection of netfilter kernel headers (#435499),
|
- fix configure detection of netfilter kernel headers (#435499),
|
||||||
patch by aoliva@redhat.com
|
patch by aoliva@redhat.com
|
||||||
|
Loading…
Reference in New Issue
Block a user