Enable squid_kerb_auth after a bit of cleanup

This commit is contained in:
Henrik Nordström 2009-09-08 15:57:10 +00:00
parent 28084ae300
commit 77400c9da9
2 changed files with 128 additions and 5 deletions

View File

@ -4,7 +4,7 @@
Name: squid
Version: 3.1.0.13
Release: 2%{?dist}
Release: 3%{?dist}
Summary: The Squid proxy caching server
Epoch: 7
License: GPLv2+
@ -23,13 +23,16 @@ Source98: perl-requires-squid.sh
# Upstream patches
#Patch001: http://www.squid-cache.org/Versions/v3/3.1/changesets/bXXXX.patch
Patch001: http://www.squid-cache.org/Versions/v3/3.1/changesets/b9694.patch
# Upstream fix, but have not reached 3.1 yet
Patch002: http://www.squid-cache.org/Versions/v3/3.1/changesets/b9696.patch
Patch003: http://www.squid-cache.org/Versions/v3/3.1/changesets/b9704.patch
Patch004: http://www.squid-cache.org/Versions/v3/3.1/changesets/b9707.patch
# Upstream fix, but have not reached 3.1 yet
Patch005: squid-3.1.0.13-alias-link.patch
# External patches
# Submitted upstream on squid-dev by Markus Moeller <huaraz@moeller.plus.com>
Patch101: squid_kerb_auth-configure.in.patch
# Local patches
# Applying upstream patches first makes it less likely that local patches
@ -69,6 +72,7 @@ lookup program (dnsserver), a program for retrieving FTP data
%patch003 -p0 -b .b9704
%patch004 -p0 -b .b9707
%patch005 -p0 -b .alias-link
%patch101 -p1 -b .kerb_auth_configure
%patch201 -p1 -b .config
%patch202 -p1 -b .location
%patch204 -p1 -b .perlpath
@ -92,6 +96,7 @@ export CXXFLAGS="-fPIE %{optflags}" ; export CFLAGS="-fPIE -Os -g -pipe -fsigned
--enable-basic-auth-helpers="LDAP,MSNT,NCSA,PAM,SMB,YP,getpwnam,multi-domain-NTLM,SASL,DB,POP3,squid_radius_auth" \
--enable-ntlm-auth-helpers="smb_lm,no_check,fakeauth" \
--enable-digest-auth-helpers="password,ldap,eDirectory" \
--enable-negotiate-auth-helpers="squid_kerb_auth" \
--enable-external-acl-helpers="ip_user,ldap_group,session,unix_group,wbinfo_group" \
--enable-cache-digests \
--enable-cachemgr-hostname=localhost \
@ -117,9 +122,6 @@ export CXXFLAGS="-fPIE %{optflags}" ; export CFLAGS="-fPIE -Os -g -pipe -fsigned
--with-openssl \
--with-pthreads
# following options should be enabled but fails Fedora QA chechs
# --enable-negotiate-auth-helpers="squid_kerb_auth"
export CXXFLAGS="-fPIE" ; export CFLAGS="-fPIE -Os -g -pipe -fsigned-char" ; export LDFLAGS="-pie" ;
make \
DEFAULT_SWAP_DIR='$(localstatedir)/spool/squid' \
@ -251,6 +253,9 @@ fi
chgrp squid /var/cache/samba/winbindd_privileged >/dev/null 2>&1 || :
%changelog
* Tue Sep 08 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 7:3.1.0.13-3
- Enable squid_kerb_auth
* Mon Sep 07 2009 Henrik Nordstrom <henrik@henriknordtrom.net> - 7:3.1.0.13-2
- Cleaned up packaging to ease future maintenance

View File

@ -0,0 +1,118 @@
diff -up squid-3.1.0.13/helpers/negotiate_auth/squid_kerb_auth/configure.in.kerb_auth_configure squid-3.1.0.13/helpers/negotiate_auth/squid_kerb_auth/configure.in
--- squid-3.1.0.13/helpers/negotiate_auth/squid_kerb_auth/configure.in.kerb_auth_configure 2009-08-04 15:32:10.000000000 +0200
+++ squid-3.1.0.13/helpers/negotiate_auth/squid_kerb_auth/configure.in 2009-09-08 17:46:17.000000000 +0200
@@ -69,7 +69,7 @@ check_mit() {
ac_includedir=""
ac_libdir=""
case $sys in
- Linux) if test "x$enableval" != "xyes" -a "x$enableval" != "x" ; then
+ Linux) if test "x$enableval" != "xyes" -a "x$enableval" != "x" -a "x$enableval" != "xno" ; then
ac_libdir=$enableval/lib
ac_includedir=$enableval/include
else
@@ -101,7 +101,7 @@ check_mit() {
fi
fi
;;
- *) if test "x$enableval" != "xyes" -a "x$enableval" != "x" ; then
+ *) if test "x$enableval" != "xyes" -a "x$enableval" != "x" -a "x$enableval" != "xno" ; then
ac_libdir=$enableval/lib
ac_includedir=$enableval/include
CPPFLAGS="$CPPFLAGS -I$ac_includedir"
@@ -142,7 +142,7 @@ check_heimdal(){
ac_includedir=""
ac_libdir=""
case $sys in
- Linux) if test "x$enableval" != "xyes" -a "x$enableval" != "x" ; then
+ Linux) if test "x$enableval" != "xyes" -a "x$enableval" != "x" -a "x$enableval" != "xno" ; then
ac_libdir=$enableval/lib
ac_includedir=$enableval/include
else
@@ -179,7 +179,7 @@ check_heimdal(){
fi
fi
;;
- *) if test "x$enableval" != "xyes" -a "x$enableval" != "x" ; then
+ *) if test "x$enableval" != "xyes" -a "x$enableval" != "x" -a "x$enableval" != "xno" ; then
ac_libdir=$enableval/lib
ac_includedir=$enableval/include
CPPFLAGS="$CPPFLAGS -I$ac_includedir"
@@ -424,8 +424,7 @@ AC_ARG_WITH([squid],
[ squid_dir=$withval ]
)
-eval ac_p_include=$includedir
-CPPFLAGS="$CPPFLAGS -I$ac_p_include -I../../../ -I../../../include/ -I$squid_dir/include -I$squid_dir/src -I$squid_dir"
+CPPFLAGS="$CPPFLAGS -I../../../ -I../../../include/ -I$squid_dir/include -I$squid_dir/src -I$squid_dir"
AC_CACHE_CHECK([for SQUID at '$squid_dir' ],ac_cv_have_squid,[
AC_TRY_RUN([
#include <config.h>
@@ -439,8 +438,7 @@ return 1;
ac_cv_have_squid=yes,
ac_cv_have_squid=no)
])
-eval ac_p_lib=$libdir
-LDFLAGS="$LDFLAGS -L../../../lib -L$ac_p_lib $w_flag$ac_p_lib$w_flag_2"
+LDFLAGS="$LDFLAGS -L../../../lib"
if test "x$ac_cv_have_squid" = "xyes"; then
AC_DEFINE(HAVE_SQUID,1, [Define to 1 if you have SQUID])
AC_CHECK_HEADERS(getaddrinfo.h getnameinfo.h util.h)
diff -up squid-3.1.0.13/helpers/negotiate_auth/squid_kerb_auth/configure.kerb_auth_configure squid-3.1.0.13/helpers/negotiate_auth/squid_kerb_auth/configure
--- squid-3.1.0.13/helpers/negotiate_auth/squid_kerb_auth/configure.kerb_auth_configure 2009-08-04 15:32:53.000000000 +0200
+++ squid-3.1.0.13/helpers/negotiate_auth/squid_kerb_auth/configure 2009-09-08 17:48:25.000000000 +0200
@@ -3766,7 +3766,7 @@ _ACEOF
ac_includedir=""
ac_libdir=""
case $sys in
- Linux) if test "x$enableval" != "xyes" -a "x$enableval" != "x" ; then
+ Linux) if test "x$enableval" != "xyes" -a "x$enableval" != "x" -a "x$enableval" != "xno" ; then
ac_libdir=$enableval/lib
ac_includedir=$enableval/include
else
@@ -4479,7 +4479,7 @@ fi
fi
fi
;;
- *) if test "x$enableval" != "xyes" -a "x$enableval" != "x" ; then
+ *) if test "x$enableval" != "xyes" -a "x$enableval" != "x" -a "x$enableval" != "xno" ; then
ac_libdir=$enableval/lib
ac_includedir=$enableval/include
CPPFLAGS="$CPPFLAGS -I$ac_includedir"
@@ -4972,7 +4972,7 @@ _ACEOF
ac_includedir=""
ac_libdir=""
case $sys in
- Linux) if test "x$enableval" != "xyes" -a "x$enableval" != "x" ; then
+ Linux) if test "x$enableval" != "xyes" -a "x$enableval" != "x" -a "x$enableval" != "xno" ; then
ac_libdir=$enableval/lib
ac_includedir=$enableval/include
else
@@ -5303,7 +5303,7 @@ fi
fi
fi
;;
- *) if test "x$enableval" != "xyes" -a "x$enableval" != "x" ; then
+ *) if test "x$enableval" != "xyes" -a "x$enableval" != "x" -a "x$enableval" != "xno" ; then
ac_libdir=$enableval/lib
ac_includedir=$enableval/include
CPPFLAGS="$CPPFLAGS -I$ac_includedir"
@@ -7033,8 +7033,7 @@ if test "${with_squid+set}" = set; then
fi
-eval ac_p_include=$includedir
-CPPFLAGS="$CPPFLAGS -I$ac_p_include -I../../../ -I../../../include/ -I$squid_dir/include -I$squid_dir/src -I$squid_dir"
+CPPFLAGS="$CPPFLAGS -I../../../ -I../../../include/ -I$squid_dir/include -I$squid_dir/src -I$squid_dir"
{ $as_echo "$as_me:$LINENO: checking for SQUID at '$squid_dir' " >&5
$as_echo_n "checking for SQUID at '$squid_dir' ... " >&6; }
if test "${ac_cv_have_squid+set}" = set; then
@@ -7104,8 +7103,7 @@ fi
fi
{ $as_echo "$as_me:$LINENO: result: $ac_cv_have_squid" >&5
$as_echo "$ac_cv_have_squid" >&6; }
-eval ac_p_lib=$libdir
-LDFLAGS="$LDFLAGS -L../../../lib -L$ac_p_lib $w_flag$ac_p_lib$w_flag_2"
+LDFLAGS="$LDFLAGS -L../../../lib"
if test "x$ac_cv_have_squid" = "xyes"; then
cat >>confdefs.h <<\_ACEOF