- used ncsa_auth.8 from man-pages. there will be this file removed due to
conflict - fix #458593 noisy initscript - fix #463129 init script tests wrong conf file - fix #450352 - build.patch patches only generated files
This commit is contained in:
parent
0975fc2140
commit
6f485e0e14
@ -1,7 +1,183 @@
|
||||
diff -up squid-3.0.STABLE1/src/Makefile.in.build squid-3.0.STABLE1/src/Makefile.in
|
||||
--- squid-3.0.STABLE1/src/Makefile.in.build 2007-12-05 02:11:21.000000000 +0100
|
||||
+++ squid-3.0.STABLE1/src/Makefile.in 2008-01-23 12:07:50.000000000 +0100
|
||||
@@ -2610,18 +2610,18 @@ DEFAULT_PREFIX = $(prefix)
|
||||
diff -up squid-3.0.STABLE7/errors/Makefile.am.build squid-3.0.STABLE7/errors/Makefile.am
|
||||
--- squid-3.0.STABLE7/errors/Makefile.am.build 2008-06-22 05:35:47.000000000 +0200
|
||||
+++ squid-3.0.STABLE7/errors/Makefile.am 2008-10-06 11:31:55.000000000 +0200
|
||||
@@ -3,7 +3,7 @@
|
||||
# $Id: Makefile.am,v 1.14.2.1 2008/02/27 10:55:13 amosjeffries Exp $
|
||||
#
|
||||
|
||||
-errordir = $(datadir)/errors
|
||||
+errordir = $(pkgdatadir)/errors
|
||||
|
||||
|
||||
##dist-hook eveything
|
||||
diff -up squid-3.0.STABLE7/errors/Makefile.in.build squid-3.0.STABLE7/errors/Makefile.in
|
||||
--- squid-3.0.STABLE7/errors/Makefile.in.build 2008-06-22 05:35:47.000000000 +0200
|
||||
+++ squid-3.0.STABLE7/errors/Makefile.in 2008-10-06 13:01:47.000000000 +0200
|
||||
@@ -269,7 +269,7 @@ sharedstatedir = @sharedstatedir@
|
||||
subdirs = @subdirs@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
-errordir = $(datadir)/errors
|
||||
+errordir = $(pkgdatadir)/errors
|
||||
DEFAULT_ERROR_DIR = $(errordir)
|
||||
INSTALL_LANGUAGES = @ERR_LANGUAGES@
|
||||
LANGUAGES = \
|
||||
@@ -320,9 +320,9 @@ $(srcdir)/Makefile.in: @MAINTAINER_MODE_
|
||||
exit 1;; \
|
||||
esac; \
|
||||
done; \
|
||||
- echo ' cd $(top_srcdir) && $(AUTOMAKE) --foreign errors/Makefile'; \
|
||||
+ echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu errors/Makefile'; \
|
||||
cd $(top_srcdir) && \
|
||||
- $(AUTOMAKE) --foreign errors/Makefile
|
||||
+ $(AUTOMAKE) --gnu errors/Makefile
|
||||
.PRECIOUS: Makefile
|
||||
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
|
||||
@case '$?' in \
|
||||
diff -up squid-3.0.STABLE7/icons/Makefile.am.build squid-3.0.STABLE7/icons/Makefile.am
|
||||
--- squid-3.0.STABLE7/icons/Makefile.am.build 2008-06-22 05:35:49.000000000 +0200
|
||||
+++ squid-3.0.STABLE7/icons/Makefile.am 2008-10-06 11:31:55.000000000 +0200
|
||||
@@ -29,7 +29,7 @@ ICON2 = anthony-bomb.gif \
|
||||
anthony-xbm.gif \
|
||||
anthony-xpm.gif
|
||||
|
||||
-icondir = $(datadir)/icons
|
||||
+icondir = $(pkgdatadir)/icons
|
||||
icon_DATA = $(ICON1) $(ICON2)
|
||||
EXTRA_DIST = $(ICON1) $(ICON2) icons.shar
|
||||
DISTCLEANFILES =
|
||||
diff -up squid-3.0.STABLE7/icons/Makefile.in.build squid-3.0.STABLE7/icons/Makefile.in
|
||||
--- squid-3.0.STABLE7/icons/Makefile.in.build 2008-06-22 05:35:50.000000000 +0200
|
||||
+++ squid-3.0.STABLE7/icons/Makefile.in 2008-10-06 13:01:58.000000000 +0200
|
||||
@@ -306,7 +306,7 @@ ICON2 = anthony-bomb.gif \
|
||||
anthony-xbm.gif \
|
||||
anthony-xpm.gif
|
||||
|
||||
-icondir = $(datadir)/icons
|
||||
+icondir = $(pkgdatadir)/icons
|
||||
icon_DATA = $(ICON1) $(ICON2)
|
||||
EXTRA_DIST = $(ICON1) $(ICON2) icons.shar
|
||||
DISTCLEANFILES =
|
||||
@@ -322,9 +322,9 @@ $(srcdir)/Makefile.in: @MAINTAINER_MODE_
|
||||
exit 1;; \
|
||||
esac; \
|
||||
done; \
|
||||
- echo ' cd $(top_srcdir) && $(AUTOMAKE) --foreign icons/Makefile'; \
|
||||
+ echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu icons/Makefile'; \
|
||||
cd $(top_srcdir) && \
|
||||
- $(AUTOMAKE) --foreign icons/Makefile
|
||||
+ $(AUTOMAKE) --gnu icons/Makefile
|
||||
.PRECIOUS: Makefile
|
||||
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
|
||||
@case '$?' in \
|
||||
diff -up squid-3.0.STABLE7/src/Makefile.am.build squid-3.0.STABLE7/src/Makefile.am
|
||||
--- squid-3.0.STABLE7/src/Makefile.am.build 2008-06-22 05:35:52.000000000 +0200
|
||||
+++ squid-3.0.STABLE7/src/Makefile.am 2008-10-06 13:01:31.000000000 +0200
|
||||
@@ -925,9 +925,7 @@ BUILT_SOURCES = \
|
||||
|
||||
sysconf_DATA = \
|
||||
squid.conf.default \
|
||||
- mime.conf.default
|
||||
-
|
||||
-data_DATA = \
|
||||
+ mime.conf.default \
|
||||
mib.txt
|
||||
|
||||
LDADD = libsquid.la libauth.la -L../lib -lmiscutil @XTRA_LIBS@ @EPOLL_LIBS@ @MINGW_LIBS@
|
||||
@@ -988,18 +986,18 @@ DEFAULT_PREFIX = $(prefix)
|
||||
DEFAULT_CONFIG_FILE = $(sysconfdir)/squid.conf
|
||||
DEFAULT_MIME_TABLE = $(sysconfdir)/mime.conf
|
||||
DEFAULT_DNSSERVER = $(libexecdir)/`echo dnsserver | sed '$(transform);s/$$/$(EXEEXT)/'`
|
||||
-DEFAULT_LOG_PREFIX = $(localstatedir)/logs
|
||||
+DEFAULT_LOG_PREFIX = $(localstatedir)/log/squid
|
||||
DEFAULT_CACHE_LOG = $(DEFAULT_LOG_PREFIX)/cache.log
|
||||
DEFAULT_ACCESS_LOG = $(DEFAULT_LOG_PREFIX)/access.log
|
||||
DEFAULT_STORE_LOG = $(DEFAULT_LOG_PREFIX)/store.log
|
||||
-DEFAULT_PID_FILE = $(DEFAULT_LOG_PREFIX)/squid.pid
|
||||
-DEFAULT_SWAP_DIR = $(localstatedir)/cache
|
||||
+DEFAULT_PID_FILE = $(localstatedir)/run/squid.pid
|
||||
+DEFAULT_SWAP_DIR = $(localstatedir)/spool/squid
|
||||
DEFAULT_PINGER = $(libexecdir)/`echo pinger | sed '$(transform);s/$$/$(EXEEXT)/'`
|
||||
DEFAULT_UNLINKD = $(libexecdir)/`echo unlinkd | sed '$(transform);s/$$/$(EXEEXT)/'`
|
||||
DEFAULT_DISKD = $(libexecdir)/`echo diskd | sed '$(transform);s/$$/$(EXEEXT)/'`
|
||||
-DEFAULT_ICON_DIR = $(datadir)/icons
|
||||
-DEFAULT_ERROR_DIR = $(datadir)/errors/@ERR_DEFAULT_LANGUAGE@
|
||||
-DEFAULT_MIB_PATH = $(datadir)/mib.txt
|
||||
+DEFAULT_ICON_DIR = $(pkgdatadir)/icons
|
||||
+DEFAULT_ERROR_DIR = $(pkgdatadir)/errors/@ERR_DEFAULT_LANGUAGE@
|
||||
+DEFAULT_MIB_PATH = $(sysconfdir)/mib.txt
|
||||
DEFAULT_HOSTS = @OPT_DEFAULT_HOSTS@
|
||||
|
||||
DEFS = @DEFS@ -DDEFAULT_CONFIG_FILE=\"$(DEFAULT_CONFIG_FILE)\"
|
||||
@@ -1062,7 +1060,7 @@ cf.data: cf.data.pre Makefile
|
||||
repl_modules.cc: repl_modules.sh Makefile
|
||||
$(SHELL) $(srcdir)/repl_modules.sh $(REPL_POLICIES) > repl_modules.cc
|
||||
|
||||
-install-data-local: install-sysconfDATA install-dataDATA
|
||||
+install-data-local: install-sysconfDATA
|
||||
@if test -f $(DESTDIR)$(DEFAULT_MIME_TABLE) ; then \
|
||||
echo "$@ will not overwrite existing $(DESTDIR)$(DEFAULT_MIME_TABLE)" ; \
|
||||
else \
|
||||
@@ -1075,6 +1073,12 @@ install-data-local: install-sysconfDATA
|
||||
echo "$(INSTALL_DATA) squid.conf.default $(DESTDIR)$(DEFAULT_CONFIG_FILE)"; \
|
||||
$(INSTALL_DATA) squid.conf.default $(DESTDIR)$(DEFAULT_CONFIG_FILE); \
|
||||
fi
|
||||
+ @if test -f $(DESTDIR)$(DEFAULT_MIB_PATH) ; then \
|
||||
+ echo "$@ will not overwrite existing $(DESTDIR)$(DEFAULT_MIB_PATH)" ; \
|
||||
+ else \
|
||||
+ echo "$(INSTALL_DATA) squid.conf.default $(DESTDIR)$(DEFAULT_MIB_PATH)"; \
|
||||
+ $(INSTALL_DATA) squid.conf.default $(DESTDIR)$(DEFAULT_MIB_PATH); \
|
||||
+ fi
|
||||
$(mkinstalldirs) $(DESTDIR)$(DEFAULT_LOG_PREFIX)
|
||||
|
||||
uninstall-local:
|
||||
@@ -1082,6 +1086,10 @@ uninstall-local:
|
||||
echo "rm -f $(DESTDIR)$(DEFAULT_MIME_TABLE)"; \
|
||||
$(RM) -f $(DESTDIR)$(DEFAULT_MIME_TABLE); \
|
||||
fi
|
||||
+ @if test -f $(DESTDIR)$(DEFAULT_MIB_PATH) ; then \
|
||||
+ echo "rm -f $(DESTDIR)$(DEFAULT_MIB_PATH)"; \
|
||||
+ $(RM) -f $(DESTDIR)$(DEFAULT_MIB_PATH); \
|
||||
+ fi
|
||||
|
||||
# Don't automatically uninstall config files
|
||||
# @if test -f $(DESTDIR)$(DEFAULT_CONFIG_FILE) ; then \
|
||||
diff -up squid-3.0.STABLE7/src/Makefile.in.build squid-3.0.STABLE7/src/Makefile.in
|
||||
--- squid-3.0.STABLE7/src/Makefile.in.build 2008-06-22 05:35:52.000000000 +0200
|
||||
+++ squid-3.0.STABLE7/src/Makefile.in 2008-10-06 13:02:02.000000000 +0200
|
||||
@@ -140,8 +140,7 @@ libsquid_la_LIBADD =
|
||||
am_libsquid_la_OBJECTS = comm.lo IPInterception.lo
|
||||
libsquid_la_OBJECTS = $(am_libsquid_la_OBJECTS)
|
||||
am__installdirs = "$(DESTDIR)$(bindir)" "$(DESTDIR)$(libexecdir)" \
|
||||
- "$(DESTDIR)$(sbindir)" "$(DESTDIR)$(datadir)" \
|
||||
- "$(DESTDIR)$(sysconfdir)"
|
||||
+ "$(DESTDIR)$(sbindir)" "$(DESTDIR)$(sysconfdir)"
|
||||
binPROGRAMS_INSTALL = $(INSTALL_PROGRAM)
|
||||
@ENABLE_PINGER_TRUE@am__EXEEXT_1 = pinger$(EXEEXT)
|
||||
@USE_DNSSERVER_TRUE@am__EXEEXT_2 = dnsserver$(EXEEXT)
|
||||
@@ -1514,9 +1513,8 @@ am__vpath_adj = case $$p in \
|
||||
*) f=$$p;; \
|
||||
esac;
|
||||
am__strip_dir = `echo $$p | sed -e 's|^.*/||'`;
|
||||
-dataDATA_INSTALL = $(INSTALL_DATA)
|
||||
sysconfDATA_INSTALL = $(INSTALL_DATA)
|
||||
-DATA = $(data_DATA) $(sysconf_DATA)
|
||||
+DATA = $(sysconf_DATA)
|
||||
HEADERS = $(noinst_HEADERS)
|
||||
ETAGS = etags
|
||||
CTAGS = ctags
|
||||
@@ -2552,9 +2550,7 @@ BUILT_SOURCES = \
|
||||
|
||||
sysconf_DATA = \
|
||||
squid.conf.default \
|
||||
- mime.conf.default
|
||||
-
|
||||
-data_DATA = \
|
||||
+ mime.conf.default \
|
||||
mib.txt
|
||||
|
||||
LDADD = libsquid.la libauth.la -L../lib -lmiscutil @XTRA_LIBS@ @EPOLL_LIBS@ @MINGW_LIBS@
|
||||
@@ -2612,18 +2608,18 @@ DEFAULT_PREFIX = $(prefix)
|
||||
DEFAULT_CONFIG_FILE = $(sysconfdir)/squid.conf
|
||||
DEFAULT_MIME_TABLE = $(sysconfdir)/mime.conf
|
||||
DEFAULT_DNSSERVER = $(libexecdir)/`echo dnsserver | sed '$(transform);s/$$/$(EXEEXT)/'`
|
||||
@ -22,99 +198,131 @@ diff -up squid-3.0.STABLE1/src/Makefile.in.build squid-3.0.STABLE1/src/Makefile.
|
||||
-DEFAULT_MIB_PATH = $(datadir)/mib.txt
|
||||
+DEFAULT_ICON_DIR = $(pkgdatadir)/icons
|
||||
+DEFAULT_ERROR_DIR = $(pkgdatadir)/errors/@ERR_DEFAULT_LANGUAGE@
|
||||
+DEFAULT_MIB_PATH = $(sysconfigdir)/mib.txt
|
||||
+DEFAULT_MIB_PATH = $(sysconfdir)/mib.txt
|
||||
DEFAULT_HOSTS = @OPT_DEFAULT_HOSTS@
|
||||
|
||||
# Don't automatically uninstall config files
|
||||
@@ -4986,20 +4986,20 @@ distclean-libtool:
|
||||
@@ -3932,9 +3928,9 @@ $(srcdir)/Makefile.in: @MAINTAINER_MODE_
|
||||
exit 1;; \
|
||||
esac; \
|
||||
done; \
|
||||
- echo ' cd $(top_srcdir) && $(AUTOMAKE) --foreign src/Makefile'; \
|
||||
+ echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu src/Makefile'; \
|
||||
cd $(top_srcdir) && \
|
||||
- $(AUTOMAKE) --foreign src/Makefile
|
||||
+ $(AUTOMAKE) --gnu src/Makefile
|
||||
.PRECIOUS: Makefile
|
||||
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
|
||||
@case '$?' in \
|
||||
@@ -4988,23 +4984,6 @@ clean-libtool:
|
||||
distclean-libtool:
|
||||
-rm -f libtool
|
||||
uninstall-info-am:
|
||||
install-dataDATA: $(data_DATA)
|
||||
@$(NORMAL_INSTALL)
|
||||
-install-dataDATA: $(data_DATA)
|
||||
- @$(NORMAL_INSTALL)
|
||||
- test -z "$(datadir)" || $(mkdir_p) "$(DESTDIR)$(datadir)"
|
||||
+ test -z "$(sysconfdir)/squid" || $(mkdir_p) "$(DESTDIR)$(sysconfdir)/squid"
|
||||
@list='$(data_DATA)'; for p in $$list; do \
|
||||
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
||||
f=$(am__strip_dir) \
|
||||
- @list='$(data_DATA)'; for p in $$list; do \
|
||||
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
||||
- f=$(am__strip_dir) \
|
||||
- echo " $(dataDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(datadir)/$$f'"; \
|
||||
- $(dataDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(datadir)/$$f"; \
|
||||
+ echo " $(dataDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(sysconfdir)/$$f'"; \
|
||||
+ $(dataDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(sysconfdir)/$$f"; \
|
||||
done
|
||||
|
||||
uninstall-dataDATA:
|
||||
@$(NORMAL_UNINSTALL)
|
||||
@list='$(data_DATA)'; for p in $$list; do \
|
||||
f=$(am__strip_dir) \
|
||||
- done
|
||||
-
|
||||
-uninstall-dataDATA:
|
||||
- @$(NORMAL_UNINSTALL)
|
||||
- @list='$(data_DATA)'; for p in $$list; do \
|
||||
- f=$(am__strip_dir) \
|
||||
- echo " rm -f '$(DESTDIR)$(datadir)/$$f'"; \
|
||||
- rm -f "$(DESTDIR)$(datadir)/$$f"; \
|
||||
+ echo " rm -f '$(DESTDIR)$(sysconfdir)/$$f'"; \
|
||||
+ rm -f "$(DESTDIR)$(sysconfdir)/$$f"; \
|
||||
done
|
||||
- done
|
||||
install-sysconfDATA: $(sysconf_DATA)
|
||||
@$(NORMAL_INSTALL)
|
||||
diff -up squid-3.0.STABLE1/errors/Makefile.in.build squid-3.0.STABLE1/errors/Makefile.in
|
||||
--- squid-3.0.STABLE1/errors/Makefile.in.build 2007-12-05 02:10:48.000000000 +0100
|
||||
+++ squid-3.0.STABLE1/errors/Makefile.in 2008-01-23 12:07:50.000000000 +0100
|
||||
@@ -269,8 +269,8 @@ sharedstatedir = @sharedstatedir@
|
||||
subdirs = @subdirs@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
-errordir = $(datadir)/errors
|
||||
-DEFAULT_ERROR_DIR = $(errordir)
|
||||
+errordir = $(pkgdatadir)/errors
|
||||
+DEFAULT_ERROR_DIR = $(sysconfdir)/errors
|
||||
INSTALL_LANGUAGES = @ERR_LANGUAGES@
|
||||
LANGUAGES = \
|
||||
Armenian \
|
||||
@@ -472,17 +472,17 @@ uninstall-am: uninstall-info-am uninstal
|
||||
|
||||
install-data-local:
|
||||
@for l in $(INSTALL_LANGUAGES); do \
|
||||
- $(mkinstalldirs) $(DESTDIR)$(DEFAULT_ERROR_DIR)/$$l && \
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(errordir)/$$l && \
|
||||
for f in $(srcdir)/$$l/ERR_*; do \
|
||||
- echo "$(INSTALL_DATA) $$f $(DESTDIR)$(DEFAULT_ERROR_DIR)/$$l"; \
|
||||
- $(INSTALL_DATA) $$f $(DESTDIR)$(DEFAULT_ERROR_DIR)/$$l; \
|
||||
+ echo "$(INSTALL_DATA) $$f $(DESTDIR)$(errordir)/$$l"; \
|
||||
+ $(INSTALL_DATA) $$f $(DESTDIR)$(errordir)/$$l; \
|
||||
done \
|
||||
test -z "$(sysconfdir)" || $(mkdir_p) "$(DESTDIR)$(sysconfdir)"
|
||||
@@ -5279,7 +5258,7 @@ all-am: Makefile $(LIBRARIES) $(LTLIBRAR
|
||||
$(HEADERS)
|
||||
installdirs: installdirs-recursive
|
||||
installdirs-am:
|
||||
- for dir in "$(DESTDIR)$(bindir)" "$(DESTDIR)$(libexecdir)" "$(DESTDIR)$(sbindir)" "$(DESTDIR)$(datadir)" "$(DESTDIR)$(sysconfdir)"; do \
|
||||
+ for dir in "$(DESTDIR)$(bindir)" "$(DESTDIR)$(libexecdir)" "$(DESTDIR)$(sbindir)" "$(DESTDIR)$(sysconfdir)"; do \
|
||||
test -z "$$dir" || $(mkdir_p) "$$dir"; \
|
||||
done
|
||||
install: $(BUILT_SOURCES)
|
||||
@@ -5366,7 +5345,7 @@ info: info-recursive
|
||||
|
||||
info-am:
|
||||
|
||||
-install-data-am: install-data-local install-dataDATA
|
||||
+install-data-am: install-data-local
|
||||
|
||||
install-exec-am: install-binPROGRAMS install-libexecPROGRAMS \
|
||||
install-sbinPROGRAMS install-sysconfDATA
|
||||
@@ -5395,8 +5374,8 @@ ps: ps-recursive
|
||||
|
||||
ps-am:
|
||||
|
||||
-uninstall-am: uninstall-binPROGRAMS uninstall-dataDATA \
|
||||
- uninstall-info-am uninstall-libexecPROGRAMS uninstall-local \
|
||||
+uninstall-am: uninstall-binPROGRAMS uninstall-info-am \
|
||||
+ uninstall-libexecPROGRAMS uninstall-local \
|
||||
uninstall-sbinPROGRAMS uninstall-sysconfDATA
|
||||
|
||||
uninstall-info: uninstall-info-recursive
|
||||
@@ -5410,16 +5389,15 @@ uninstall-info: uninstall-info-recursive
|
||||
distclean-libtool distclean-recursive distclean-tags distdir \
|
||||
dvi dvi-am html html-am info info-am install install-am \
|
||||
install-binPROGRAMS install-data install-data-am \
|
||||
- install-data-local install-dataDATA install-exec \
|
||||
- install-exec-am install-info install-info-am \
|
||||
- install-libexecPROGRAMS install-man install-sbinPROGRAMS \
|
||||
- install-strip install-sysconfDATA installcheck installcheck-am \
|
||||
- installdirs installdirs-am maintainer-clean \
|
||||
- maintainer-clean-generic maintainer-clean-recursive \
|
||||
- mostlyclean mostlyclean-compile mostlyclean-generic \
|
||||
- mostlyclean-libtool mostlyclean-recursive pdf pdf-am ps ps-am \
|
||||
- tags tags-recursive uninstall uninstall-am \
|
||||
- uninstall-binPROGRAMS uninstall-dataDATA uninstall-info-am \
|
||||
+ install-data-local install-exec install-exec-am install-info \
|
||||
+ install-info-am install-libexecPROGRAMS install-man \
|
||||
+ install-sbinPROGRAMS install-strip install-sysconfDATA \
|
||||
+ installcheck installcheck-am installdirs installdirs-am \
|
||||
+ maintainer-clean maintainer-clean-generic \
|
||||
+ maintainer-clean-recursive mostlyclean mostlyclean-compile \
|
||||
+ mostlyclean-generic mostlyclean-libtool mostlyclean-recursive \
|
||||
+ pdf pdf-am ps ps-am tags tags-recursive uninstall uninstall-am \
|
||||
+ uninstall-binPROGRAMS uninstall-info-am \
|
||||
uninstall-libexecPROGRAMS uninstall-local \
|
||||
uninstall-sbinPROGRAMS uninstall-sysconfDATA
|
||||
|
||||
@@ -5479,7 +5457,7 @@ cf.data: cf.data.pre Makefile
|
||||
repl_modules.cc: repl_modules.sh Makefile
|
||||
$(SHELL) $(srcdir)/repl_modules.sh $(REPL_POLICIES) > repl_modules.cc
|
||||
|
||||
-install-data-local: install-sysconfDATA install-dataDATA
|
||||
+install-data-local: install-sysconfDATA
|
||||
@if test -f $(DESTDIR)$(DEFAULT_MIME_TABLE) ; then \
|
||||
echo "$@ will not overwrite existing $(DESTDIR)$(DEFAULT_MIME_TABLE)" ; \
|
||||
else \
|
||||
@@ -5492,6 +5470,12 @@ install-data-local: install-sysconfDATA
|
||||
echo "$(INSTALL_DATA) squid.conf.default $(DESTDIR)$(DEFAULT_CONFIG_FILE)"; \
|
||||
$(INSTALL_DATA) squid.conf.default $(DESTDIR)$(DEFAULT_CONFIG_FILE); \
|
||||
fi
|
||||
+ @if test -f $(DESTDIR)$(DEFAULT_MIB_PATH) ; then \
|
||||
+ echo "$@ will not overwrite existing $(DESTDIR)$(DEFAULT_MIB_PATH)" ; \
|
||||
+ else \
|
||||
+ echo "$(INSTALL_DATA) squid.conf.default $(DESTDIR)$(DEFAULT_MIB_PATH)"; \
|
||||
+ $(INSTALL_DATA) squid.conf.default $(DESTDIR)$(DEFAULT_MIB_PATH); \
|
||||
+ fi
|
||||
$(mkinstalldirs) $(DESTDIR)$(DEFAULT_LOG_PREFIX)
|
||||
|
||||
uninstall-local:
|
||||
@for l in $(INSTALL_LANGUAGES); do \
|
||||
for f in $(srcdir)/$$l/ERR_*; do \
|
||||
- rm -f $(DESTDIR)$(DEFAULT_ERROR_DIR)/$$l/`basename $$f`; \
|
||||
+ rm -f $(DESTDIR)$(errordir)/$$l/`basename $$f`; \
|
||||
done \
|
||||
done
|
||||
|
||||
@@ -495,13 +495,13 @@ uninstall-local:
|
||||
#
|
||||
addlang: all
|
||||
-@if test -d $(srcdir)/$(ADDLANG); then \
|
||||
- if test -d $(DEFAULT_ERROR_DIR)/$(DESTLANG); then \
|
||||
+ if test -d $(errordir)/$(DESTLANG); then \
|
||||
cd $(srcdir)/$(ADDLANG)/ ; \
|
||||
for f in ERR_*; do \
|
||||
- if test -f $(DEFAULT_ERROR_DIR)/$(DESTLANG)/$$f ; then \
|
||||
+ if test -f $(errordir)/$(DESTLANG)/$$f ; then \
|
||||
echo "appending $(ADDLANG)/$$f"; \
|
||||
- echo "<HR>" >> $(DEFAULT_ERROR_DIR)/$(DESTLANG)/$$f ; \
|
||||
- cat $$f >> $(DEFAULT_ERROR_DIR)/$(DESTLANG)/$$f; \
|
||||
+ echo "<HR>" >> $(errordir)/$(DESTLANG)/$$f ; \
|
||||
+ cat $$f >> $(errordir)/$(DESTLANG)/$$f; \
|
||||
fi; \
|
||||
done; \
|
||||
fi \
|
||||
diff -up squid-3.0.STABLE1/icons/Makefile.in.build squid-3.0.STABLE1/icons/Makefile.in
|
||||
--- squid-3.0.STABLE1/icons/Makefile.in.build 2007-12-05 02:11:15.000000000 +0100
|
||||
+++ squid-3.0.STABLE1/icons/Makefile.in 2008-01-23 12:07:50.000000000 +0100
|
||||
@@ -306,7 +306,7 @@ ICON2 = anthony-bomb.gif \
|
||||
anthony-xbm.gif \
|
||||
anthony-xpm.gif
|
||||
|
||||
-icondir = $(datadir)/icons
|
||||
+icondir = $(pkgdatadir)/icons
|
||||
icon_DATA = $(ICON1) $(ICON2)
|
||||
EXTRA_DIST = $(ICON1) $(ICON2) icons.shar
|
||||
DISTCLEANFILES =
|
||||
@@ -5499,6 +5483,10 @@ uninstall-local:
|
||||
echo "rm -f $(DESTDIR)$(DEFAULT_MIME_TABLE)"; \
|
||||
$(RM) -f $(DESTDIR)$(DEFAULT_MIME_TABLE); \
|
||||
fi
|
||||
+ @if test -f $(DESTDIR)$(DEFAULT_MIB_PATH) ; then \
|
||||
+ echo "rm -f $(DESTDIR)$(DEFAULT_MIB_PATH)"; \
|
||||
+ $(RM) -f $(DESTDIR)$(DEFAULT_MIB_PATH); \
|
||||
+ fi
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
||||
.NOEXPORT:
|
||||
|
80
squid-3.0.STABLE7-from_manpg.patch
Normal file
80
squid-3.0.STABLE7-from_manpg.patch
Normal file
@ -0,0 +1,80 @@
|
||||
diff -up squid-3.0.STABLE7/helpers/basic_auth/NCSA/ncsa_auth.8.from_manpg squid-3.0.STABLE7/helpers/basic_auth/NCSA/ncsa_auth.8
|
||||
--- squid-3.0.STABLE7/helpers/basic_auth/NCSA/ncsa_auth.8.from_manpg 2008-06-22 05:35:49.000000000 +0200
|
||||
+++ squid-3.0.STABLE7/helpers/basic_auth/NCSA/ncsa_auth.8 2007-06-06 18:25:30.000000000 +0200
|
||||
@@ -1,38 +1,38 @@
|
||||
-.\" This file is distributed in the hope that it will be useful,
|
||||
-.\" but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
-.\" MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See
|
||||
-.\" the GNU General Public License for more details.
|
||||
-.\"
|
||||
-.\" You should have received a copy of the GNU General Public License
|
||||
-.\" along with this file; if not, write to the Free Software
|
||||
-.\" Foundation, Inc., 59 Temple Place, Suite 330, Boston,
|
||||
-.\" MA 02111-1307 USA
|
||||
-.\"
|
||||
-.\" HISTORY:
|
||||
-.\" 2006-05-16, created by Rodrigo Rubira Branco <rrbranco@br.ibm.com>
|
||||
-.TH ncsa_auth 8 "May 16, 2006" "Squid NCSA Auth helper"
|
||||
-.SH NAME
|
||||
-ncsa_auth \- NCSA httpd-style password file authentication helper for Squid
|
||||
-\fB
|
||||
-.SH SYNOPSIS
|
||||
-.nf
|
||||
-.fam C
|
||||
-\fBncsa_auth\fP \fIpasswdfile\fP
|
||||
-.fam T
|
||||
-.fi
|
||||
-.SH DESCRIPTION
|
||||
-\fBncsa_auth\fP allows Squid to read and authenticate user and password information from an NCSA/Apache httpd-style password file when using basic HTTP authentication.
|
||||
-.PP
|
||||
-The only parameter is the password file. It must have permissions to be read by the user that Squid is running as (cache_effective_user in squid.conf).
|
||||
-.PP
|
||||
-This password file can be manipulated using htpasswd.
|
||||
-.SH OPTIONS
|
||||
-Only specify the password file name.
|
||||
-.SH EXAMPLE
|
||||
-\fBncsa_auth\fP /etc/squid/squid.pass
|
||||
-.SH SECURITY
|
||||
-\fBncsa_auth\fP must have access to the password file to be executed.
|
||||
-.SH SEE ALSO
|
||||
-\fBhtpasswd\fP(1), \fBsquid\fP(8)
|
||||
-.SH AUTHOR
|
||||
-Manpage written by Rodrigo Rubira Branco <rrbranco@br.ibm.com>
|
||||
+.\" This file is distributed in the hope that it will be useful,
|
||||
+.\" but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+.\" MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See
|
||||
+.\" the GNU General Public License for more details.
|
||||
+.\"
|
||||
+.\" You should have received a copy of the GNU General Public License
|
||||
+.\" along with this file; if not, write to the Free Software
|
||||
+.\" Foundation, Inc., 59 Temple Place, Suite 330, Boston,
|
||||
+.\" MA 02111-1307 USA
|
||||
+.\"
|
||||
+.\" HISTORY:
|
||||
+.\" 2006-05-16, created by Rodrigo Rubira Branco <rrbranco@br.ibm.com>
|
||||
+.TH ncsa_auth 8 "May 16, 2006" "User Manuals" "User Manuals"
|
||||
+.SH NAME
|
||||
+ncsa_auth \- NCSA httpd-style password file authentication helper for Squid
|
||||
+\fB
|
||||
+.SH SYNOPSIS
|
||||
+.nf
|
||||
+.fam C
|
||||
+\fBncsa_auth\fP \fIpasswdfile\fP
|
||||
+.fam T
|
||||
+.fi
|
||||
+.SH DESCRIPTION
|
||||
+\fBncsa_auth\fP allows Squid to read and authenticate user and password information from an NCSA httpd-style password file when using basic HTTP authentication.
|
||||
+.PP
|
||||
+The only parameter is the password file. It must have permissions to be read by the user that Squid is running as. By default this user is proxy. This can be changed using the cache_effective_user directive in the squid.conf file.
|
||||
+.PP
|
||||
+This password file can be manipulated using htpasswd.
|
||||
+.SH OPTIONS
|
||||
+Only specify the password file name.
|
||||
+.SH EXAMPLE
|
||||
+\fBncsa_auth\fP /etc/squid/squid.pass
|
||||
+.SH SECURITY
|
||||
+\fBncsa_auth\fP must have access to the password file to be executed.
|
||||
+.SH SEE ALSO
|
||||
+\fBhtpasswd\fP(1), \fBsquid\fP(8)
|
||||
+.SH AUTHOR
|
||||
+Manpage written by Rodrigo Rubira Branco <rrbranco@br.ibm.com>
|
26
squid.init
26
squid.init
@ -32,20 +32,15 @@ fi
|
||||
SQUID_OPTS=${SQUID_OPTS:-"-D"}
|
||||
SQUID_PIDFILE_TIMEOUT=${SQUID_PIDFILE_TIMEOUT:-20}
|
||||
SQUID_SHUTDOWN_TIMEOUT=${SQUID_SHUTDOWN_TIMEOUT:-100}
|
||||
SQUID_CONF=${SQUID_CONF:-"/etc/squid/squid.conf"}
|
||||
|
||||
# determine the name of the squid binary
|
||||
[ -f /usr/sbin/squid ] && SQUID=squid
|
||||
|
||||
if [ "$1" == "status" ]; then
|
||||
[ -z "$SQUID" ] && exit 4
|
||||
else
|
||||
[ -z "$SQUID" ] && exit 1
|
||||
fi
|
||||
|
||||
prog="$SQUID"
|
||||
|
||||
# determine which one is the cache_swap directory
|
||||
CACHE_SWAP=`sed -e 's/#.*//g' /etc/squid/squid.conf | \
|
||||
CACHE_SWAP=`sed -e 's/#.*//g' $SQUID_CONF | \
|
||||
grep cache_dir | awk '{ print $3 }'`
|
||||
[ -z "$CACHE_SWAP" ] && CACHE_SWAP=/var/spool/squid
|
||||
|
||||
@ -55,19 +50,22 @@ probe() {
|
||||
# Check that networking is up.
|
||||
[ ${NETWORKING} = "no" ] && exit 1
|
||||
|
||||
[ -z "$SQUID" ] && exit 4
|
||||
|
||||
# check if the squid conf file is present
|
||||
[ -f /etc/squid/squid.conf ] || exit 6
|
||||
[ -f $SQUID_CONF ] || exit 6
|
||||
}
|
||||
|
||||
start() {
|
||||
probe
|
||||
|
||||
$SQUID -k parse
|
||||
parse=`$SQUID -k parse -f $SQUID_CONF 2>&1`
|
||||
RETVAL=$?
|
||||
if [ $RETVAL -ne 0 ]; then
|
||||
echo -n $"Starting $prog: "
|
||||
echo_failure
|
||||
echo
|
||||
echo "$parse"
|
||||
return 1
|
||||
fi
|
||||
for adir in $CACHE_SWAP; do
|
||||
@ -77,7 +75,7 @@ start() {
|
||||
fi
|
||||
done
|
||||
echo -n $"Starting $prog: "
|
||||
$SQUID $SQUID_OPTS >> /var/log/squid/squid.out 2>&1
|
||||
$SQUID $SQUID_OPTS -f $SQUID_CONF >> /var/log/squid/squid.out 2>&1
|
||||
RETVAL=$?
|
||||
if [ $RETVAL -eq 0 ]; then
|
||||
timeout=0;
|
||||
@ -100,10 +98,10 @@ start() {
|
||||
|
||||
stop() {
|
||||
echo -n $"Stopping $prog: "
|
||||
$SQUID -k check >> /var/log/squid/squid.out 2>&1
|
||||
$SQUID -k check -f $SQUID_CONF >> /var/log/squid/squid.out 2>&1
|
||||
RETVAL=$?
|
||||
if [ $RETVAL -eq 0 ] ; then
|
||||
$SQUID -k shutdown &
|
||||
$SQUID -k shutdown -f $SQUID_CONF &
|
||||
rm -f /var/lock/subsys/$SQUID
|
||||
timeout=0
|
||||
while : ; do
|
||||
@ -125,7 +123,7 @@ stop() {
|
||||
}
|
||||
|
||||
reload() {
|
||||
$SQUID $SQUID_OPTS -k reconfigure
|
||||
$SQUID $SQUID_OPTS -k reconfigure -f $SQUID_CONF
|
||||
}
|
||||
|
||||
restart() {
|
||||
@ -138,7 +136,7 @@ condrestart() {
|
||||
}
|
||||
|
||||
rhstatus() {
|
||||
status $SQUID && $SQUID -k check
|
||||
status $SQUID && $SQUID -k check -f $SQUID_CONF
|
||||
}
|
||||
|
||||
|
||||
|
10
squid.spec
10
squid.spec
@ -4,7 +4,7 @@
|
||||
|
||||
Name: squid
|
||||
Version: 3.0.STABLE7
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: The Squid proxy caching server
|
||||
Epoch: 7
|
||||
License: GPLv2+
|
||||
@ -33,6 +33,7 @@ Patch204: squid-3.0.STABLE1-perlpath.patch
|
||||
Patch205: squid-3.0.STABLE1-smb-path.patch
|
||||
Patch206: squid-3.0.STABLE2-fix_warnings.patch
|
||||
Patch207: squid-3.0.STABLE5-configure_netfilter.patch
|
||||
Patch208: squid-3.0.STABLE7-from_manpg.patch
|
||||
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Requires: bash >= 2.0
|
||||
@ -65,6 +66,7 @@ lookup program (dnsserver), a program for retrieving FTP data
|
||||
%patch205 -p1 -b .smb-path
|
||||
%patch206 -p1 -b .fix_warnings
|
||||
%patch207 -p1 -b .configure_netfilter
|
||||
%patch208 -p1 -b .from_manpg
|
||||
|
||||
%build
|
||||
export CXXFLAGS="-fPIE %{optflags}" ; export CFLAGS="-fPIE -Os -g -pipe -fsigned-char %{optflags}" ; export LDFLAGS="-pie" ;
|
||||
@ -337,6 +339,12 @@ fi
|
||||
chgrp squid /var/cache/samba/winbindd_privileged >/dev/null 2>&1 || :
|
||||
|
||||
%changelog
|
||||
* Thu Aug 14 2008 Jiri Skala <jskala@redhat.com> - 7:3.0.STABLE7-2
|
||||
- used ncsa_auth.8 from man-pages. there will be this file removed due to conflict
|
||||
- fix #458593 noisy initscript
|
||||
- fix #463129 init script tests wrong conf file
|
||||
- fix #450352 - build.patch patches only generated files
|
||||
|
||||
* Wed Jul 02 2008 Jiri Skala <jskala@redhat.com> - 7:3.0.STABLE7-1
|
||||
- update to latest upstream
|
||||
- fix #453214
|
||||
|
@ -6,3 +6,6 @@ SQUID_OPTS="-D"
|
||||
# Time to wait for Squid to shut down when asked. Should not be necessary
|
||||
# most of the time.
|
||||
SQUID_SHUTDOWN_TIMEOUT=100
|
||||
|
||||
# default squid conf file
|
||||
SQUID_CONF="/etc/squid/squid.conf"
|
||||
|
Loading…
Reference in New Issue
Block a user