Bug #453304 - Squid requires restart after Network Manager connection setup
This commit is contained in:
parent
d410b29914
commit
323903984d
@ -1,6 +1,6 @@
|
||||
diff -up squid-3.0.STABLE1/helpers/basic_auth/SMB/Makefile.am.smb-path squid-3.0.STABLE1/helpers/basic_auth/SMB/Makefile.am
|
||||
--- squid-3.0.STABLE1/helpers/basic_auth/SMB/Makefile.am.smb-path 2003-01-23 01:35:40.000000000 +0100
|
||||
+++ squid-3.0.STABLE1/helpers/basic_auth/SMB/Makefile.am 2008-01-23 12:17:22.000000000 +0100
|
||||
diff -up squid-3.0.STABLE15/helpers/basic_auth/SMB/Makefile.am.smb-path squid-3.0.STABLE15/helpers/basic_auth/SMB/Makefile.am
|
||||
--- squid-3.0.STABLE15/helpers/basic_auth/SMB/Makefile.am.smb-path 2009-05-06 13:11:32.000000000 +0200
|
||||
+++ squid-3.0.STABLE15/helpers/basic_auth/SMB/Makefile.am 2009-05-23 13:23:34.000000000 +0200
|
||||
@@ -7,14 +7,14 @@
|
||||
#
|
||||
|
||||
@ -18,9 +18,9 @@ diff -up squid-3.0.STABLE1/helpers/basic_auth/SMB/Makefile.am.smb-path squid-3.0
|
||||
SMB_AUTH_HELPER_PATH = $(libexecdir)/$(SMB_AUTH_HELPER)
|
||||
|
||||
libexec_SCRIPTS = $(SMB_AUTH_HELPER)
|
||||
diff -up squid-3.0.STABLE1/helpers/basic_auth/SMB/Makefile.in.smb-path squid-3.0.STABLE1/helpers/basic_auth/SMB/Makefile.in
|
||||
--- squid-3.0.STABLE1/helpers/basic_auth/SMB/Makefile.in.smb-path 2007-12-05 02:10:56.000000000 +0100
|
||||
+++ squid-3.0.STABLE1/helpers/basic_auth/SMB/Makefile.in 2008-01-23 12:17:22.000000000 +0100
|
||||
diff -up squid-3.0.STABLE15/helpers/basic_auth/SMB/Makefile.in.smb-path squid-3.0.STABLE15/helpers/basic_auth/SMB/Makefile.in
|
||||
--- squid-3.0.STABLE15/helpers/basic_auth/SMB/Makefile.in.smb-path 2009-05-06 13:11:32.000000000 +0200
|
||||
+++ squid-3.0.STABLE15/helpers/basic_auth/SMB/Makefile.in 2009-05-23 13:24:39.000000000 +0200
|
||||
@@ -23,7 +23,7 @@
|
||||
#
|
||||
|
||||
@ -30,9 +30,9 @@ diff -up squid-3.0.STABLE1/helpers/basic_auth/SMB/Makefile.in.smb-path squid-3.0
|
||||
# by using the --prefix option when configuring Samba, you need to change
|
||||
# SAMBAPREFIX accordingly.
|
||||
|
||||
@@ -306,7 +306,7 @@ subdirs = @subdirs@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
@@ -259,7 +259,7 @@ top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
SMB_AUTH_HELPER = smb_auth.sh
|
||||
-SAMBAPREFIX = /usr/local/samba
|
||||
+SAMBAPREFIX = /usr
|
5
squid.nm
Executable file
5
squid.nm
Executable file
@ -0,0 +1,5 @@
|
||||
#!/bin/sh
|
||||
|
||||
if [ "$2" = "up" ]; then
|
||||
/sbin/service squid reload || :
|
||||
fi
|
11
squid.spec
11
squid.spec
@ -4,7 +4,7 @@
|
||||
|
||||
Name: squid
|
||||
Version: 3.0.STABLE15
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: The Squid proxy caching server
|
||||
Epoch: 7
|
||||
License: GPLv2+
|
||||
@ -16,6 +16,7 @@ Source2: squid.init
|
||||
Source3: squid.logrotate
|
||||
Source4: squid.sysconfig
|
||||
Source5: squid.pam
|
||||
Source6: squid.nm
|
||||
Source98: perl-requires-squid.sh
|
||||
## Source99: filter-requires-squid.sh
|
||||
|
||||
@ -31,7 +32,7 @@ Patch201: squid-3.0.STABLE1-config.patch
|
||||
Patch202: squid-3.0.STABLE1-location.patch
|
||||
Patch203: squid-3.0.STABLE1-build.patch
|
||||
Patch204: squid-3.0.STABLE1-perlpath.patch
|
||||
Patch205: squid-3.0.STABLE1-smb-path.patch
|
||||
Patch205: squid-3.0.STABLE15-smb-path.patch
|
||||
Patch208: squid-3.0.STABLE7-from_manpg.patch
|
||||
Patch209: squid-3.0.STABLE13-gcc44.patch
|
||||
|
||||
@ -154,11 +155,13 @@ mkdir -p $RPM_BUILD_ROOT/etc/logrotate.d
|
||||
mkdir -p $RPM_BUILD_ROOT/etc/sysconfig
|
||||
mkdir -p $RPM_BUILD_ROOT/etc/pam.d
|
||||
mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d/
|
||||
mkdir -p $RPM_BUILD_ROOT/etc/NetworkManager/dispatcher.d
|
||||
install -m 755 %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/squid
|
||||
install -m 644 %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/squid
|
||||
install -m 644 %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/squid
|
||||
install -m 644 %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/squid
|
||||
install -m 644 $RPM_BUILD_ROOT/squid.httpd.tmp $RPM_BUILD_ROOT/etc/httpd/conf.d/squid.conf
|
||||
install -m 644 %{SOURCE6} $RPM_BUILD_ROOT/etc/NetworkManager/dispatcher.d/20-squid
|
||||
mkdir -p $RPM_BUILD_ROOT/var/log/squid
|
||||
mkdir -p $RPM_BUILD_ROOT/var/spool/squid
|
||||
chmod 644 contrib/url-normalizer.pl contrib/rredir.* contrib/user-agents.pl
|
||||
@ -204,6 +207,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%attr(-,root,root) %{_datadir}/squid/errors
|
||||
%attr(-,root,root) /etc/squid/icons
|
||||
%attr(755,root,root) /etc/rc.d/init.d/squid
|
||||
%attr(755,root,root) /etc/NetworkManager/dispatcher.d/20-squid
|
||||
%{_datadir}/squid/icons
|
||||
%{_sbindir}/squid
|
||||
%{_sbindir}/squidclient
|
||||
@ -338,6 +342,9 @@ fi
|
||||
chgrp squid /var/cache/samba/winbindd_privileged >/dev/null 2>&1 || :
|
||||
|
||||
%changelog
|
||||
* Sat May 23 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 3.0.STABLE15-2
|
||||
- Bug #453304 - Squid requires restart after Network Manager connection setup
|
||||
|
||||
* Sat May 09 2009 Henrik Nordstrom <henrik@henriknordstrom.net> 3.0.STABLE15-1
|
||||
- Upgrade to 3.0.STABLE15
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user