new version 6.7
switch to autosetup fix FTBFS when using gcc14
This commit is contained in:
parent
2af86284bc
commit
24c56d185e
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (squid-6.6.tar.xz) = 4ab261ed85ad674288467500aca9d8a48e3918b55f777635c0ba7a2551f248d35536848a5fbf2c946490a818004727f2aed33144f0a3ebab0be36cc4cffb020c
|
||||
SHA512 (squid-6.6.tar.xz.asc) = 08550569759c403a1a9747d08ea7055751fbf251355691074f6d09baca76a0987c5dff36e1f01b64edd446d568c7244b14124f6f8a1b19ccfc30293eed83a297
|
||||
SHA512 (pgp.asc) = 09f7012030d68831dfc083d67ca63ee54ed851482ca8d0e9505b444ee3e7ddeed62369b53f2917c9b2e0e57cc0533fce46e8cafd2ebcd1c6cb186b516efd0ad2
|
||||
SHA512 (squid-6.7.tar.xz) = 6221437056c600119fe9ff1ceeeaa9955cf9f21df481ad29a3515f8439a41b779d51f37b820b75641d0d4d6de54554f6f924dbd347834bf4a6ad6b5b317084a0
|
||||
SHA512 (squid-6.7.tar.xz.asc) = 4a1f9d123ce6b5a600d9d2dd3af95a7ce98bfe28ba42d1281ab1f3d7f220f8738a4320afb85eeba1bf9d31e722ffaccd2d89cbefcd11e6b6ea31fe237ccf9a8c
|
||||
SHA512 (pgp.asc) = b1e1dd5ead34711f064a12a324b2f156ad4835330d861eae4032926b8a6cd07c0eacc76f52518d47ed5a8ead4695f5abd02f2b4190af8e7833bd3ea31453569d
|
||||
|
123
squid-6.7-gcc-14.patch
Normal file
123
squid-6.7-gcc-14.patch
Normal file
@ -0,0 +1,123 @@
|
||||
From 7080c9ea3c761f4ac67e3341bbc371383e4e739b Mon Sep 17 00:00:00 2001
|
||||
From: Amos Jeffries <amosjeffries@squid-cache.org>
|
||||
Date: Wed, 14 Feb 2024 03:07:20 +1300
|
||||
Subject: [PATCH 1/4] Fix undefined std::find
|
||||
|
||||
---
|
||||
src/helper/Reply.cc | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/src/helper/Reply.cc b/src/helper/Reply.cc
|
||||
index 93cd5c84322..2e5e92aa2be 100644
|
||||
--- a/src/helper/Reply.cc
|
||||
+++ b/src/helper/Reply.cc
|
||||
@@ -17,6 +17,8 @@
|
||||
#include "rfc1738.h"
|
||||
#include "SquidString.h"
|
||||
|
||||
+#include <algorithm>
|
||||
+
|
||||
Helper::Reply::Reply() :
|
||||
result(Helper::Unknown)
|
||||
{
|
||||
|
||||
From 906884bf2565025cbc5b322c47425defa07f1f8e Mon Sep 17 00:00:00 2001
|
||||
From: Amos Jeffries <amosjeffries@squid-cache.org>
|
||||
Date: Wed, 14 Feb 2024 03:51:17 +1300
|
||||
Subject: [PATCH 2/4] Fix error: 'InstanceId<...>::InstanceId(const
|
||||
InstanceId<...> &)' is private within this context
|
||||
|
||||
---
|
||||
src/base/InstanceId.h | 5 +----
|
||||
1 file changed, 1 insertion(+), 4 deletions(-)
|
||||
|
||||
diff --git a/src/base/InstanceId.h b/src/base/InstanceId.h
|
||||
index a48be882cc4..c4dd4090b00 100644
|
||||
--- a/src/base/InstanceId.h
|
||||
+++ b/src/base/InstanceId.h
|
||||
@@ -49,6 +49,7 @@ class InstanceId
|
||||
typedef ValueType Value; ///< id storage type
|
||||
|
||||
InstanceId() {change();}
|
||||
+ InstanceId(const InstanceId &); ///< no copying; IDs are unique
|
||||
|
||||
operator Value() const { return value; }
|
||||
bool operator ==(const InstanceId &o) const { return value == o.value; }
|
||||
@@ -67,10 +68,6 @@ class InstanceId
|
||||
|
||||
public:
|
||||
Value value = Value(); ///< instance identifier
|
||||
-
|
||||
-private:
|
||||
- InstanceId(const InstanceId &); ///< not implemented; IDs are unique
|
||||
- InstanceId& operator=(const InstanceId &); ///< not implemented
|
||||
};
|
||||
|
||||
/// An InstanceIdDefinitions() helper. Avoid direct use.
|
||||
|
||||
From 2631e20bf8adc2102ba039baf86c1c64c158431f Mon Sep 17 00:00:00 2001
|
||||
From: Amos Jeffries <amosjeffries@squid-cache.org>
|
||||
Date: Wed, 14 Feb 2024 03:58:47 +1300
|
||||
Subject: [PATCH 3/4] =?UTF-8?q?Fix=20error:=20=E2=80=98void*=20calloc(size?=
|
||||
=?UTF-8?q?=5Ft,=20size=5Ft)=E2=80=99=20sizes?=
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
... specified with ‘sizeof’ in the earlier argument
|
||||
and not in the later argument [-Werror=calloc-transposed-args]
|
||||
---
|
||||
src/auth/basic/LDAP/basic_ldap_auth.cc | 2 +-
|
||||
src/auth/digest/eDirectory/edir_ldapext.cc | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/auth/basic/LDAP/basic_ldap_auth.cc b/src/auth/basic/LDAP/basic_ldap_auth.cc
|
||||
index 4d9a78574cb..f79a5b88984 100644
|
||||
--- a/src/auth/basic/LDAP/basic_ldap_auth.cc
|
||||
+++ b/src/auth/basic/LDAP/basic_ldap_auth.cc
|
||||
@@ -795,7 +795,7 @@ readSecret(const char *filename)
|
||||
if ((e = strrchr(buf, '\r')))
|
||||
*e = 0;
|
||||
|
||||
- passwd = (char *) calloc(sizeof(char), strlen(buf) + 1);
|
||||
+ passwd = static_cast<char *>(calloc(strlen(buf) + 1, sizeof(char)));
|
||||
if (!passwd) {
|
||||
fprintf(stderr, PROGRAM_NAME " ERROR: can not allocate memory\n");
|
||||
exit(EXIT_FAILURE);
|
||||
diff --git a/src/auth/digest/eDirectory/edir_ldapext.cc b/src/auth/digest/eDirectory/edir_ldapext.cc
|
||||
index f34341c912c..13e7daca67b 100644
|
||||
--- a/src/auth/digest/eDirectory/edir_ldapext.cc
|
||||
+++ b/src/auth/digest/eDirectory/edir_ldapext.cc
|
||||
@@ -69,7 +69,7 @@
|
||||
|
||||
#define NMAS_LDAP_EXT_VERSION 1
|
||||
|
||||
-#define SMB_MALLOC_ARRAY(type, nelem) calloc(sizeof(type), nelem)
|
||||
+#define SMB_MALLOC_ARRAY(type, nelem) calloc(nelem, sizeof(type))
|
||||
#define DEBUG(level, args)
|
||||
|
||||
/**********************************************************************
|
||||
|
||||
From 535606d99e04f3479af07c471768af688ff790cb Mon Sep 17 00:00:00 2001
|
||||
From: Amos Jeffries <yadij@users.noreply.github.com>
|
||||
Date: Wed, 14 Feb 2024 05:52:05 +1300
|
||||
Subject: [PATCH 4/4] Update src/base/InstanceId.h
|
||||
|
||||
Co-authored-by: Alex Rousskov <rousskov@measurement-factory.com>
|
||||
---
|
||||
src/base/InstanceId.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/base/InstanceId.h b/src/base/InstanceId.h
|
||||
index c4dd4090b00..d3e2ebb2b2e 100644
|
||||
--- a/src/base/InstanceId.h
|
||||
+++ b/src/base/InstanceId.h
|
||||
@@ -49,7 +49,7 @@ class InstanceId
|
||||
typedef ValueType Value; ///< id storage type
|
||||
|
||||
InstanceId() {change();}
|
||||
- InstanceId(const InstanceId &); ///< no copying; IDs are unique
|
||||
+ InstanceId(InstanceId &&) = delete; // no copying/moving of any kind
|
||||
|
||||
operator Value() const { return value; }
|
||||
bool operator ==(const InstanceId &o) const { return value == o.value; }
|
24
squid.spec
24
squid.spec
@ -1,8 +1,8 @@
|
||||
%define __perl_requires %{SOURCE98}
|
||||
|
||||
Name: squid
|
||||
Version: 6.6
|
||||
Release: 2%{?dist}
|
||||
Version: 6.7
|
||||
Release: 1%{?dist}
|
||||
Summary: The Squid proxy caching server
|
||||
Epoch: 7
|
||||
# See CREDITS for breakdown of non GPLv2+ code
|
||||
@ -38,6 +38,8 @@ Patch203: squid-6.1-perlpath.patch
|
||||
Patch204: squid-6.1-symlink-lang-err.patch
|
||||
# Upstream PR: https://github.com/squid-cache/squid/pull/1442
|
||||
Patch205: squid-6.1-crash-half-closed.patch
|
||||
# https://github.com/squid-cache/squid/pull/1673
|
||||
Patch206: squid-6.7-gcc-14.patch
|
||||
|
||||
# cache_swap.sh
|
||||
Requires: bash gawk
|
||||
@ -95,19 +97,8 @@ lookup program (dnsserver), a program for retrieving FTP data
|
||||
|
||||
%prep
|
||||
%{gpgverify} --keyring='%{SOURCE2}' --signature='%{SOURCE1}' --data='%{SOURCE0}'
|
||||
%setup -q
|
||||
|
||||
# Upstream patches
|
||||
|
||||
# Backported patches
|
||||
# %patch101 -p1 -b .patch
|
||||
|
||||
# Local patches
|
||||
%patch -P 201 -p1 -b .config
|
||||
%patch -P 202 -p1 -b .location
|
||||
%patch -P 203 -p1 -b .perlpath
|
||||
%patch -P 204 -p1 -b .symlink-lang-err
|
||||
%patch -P 205 -p1 -b .crash-half-closed
|
||||
%autosetup -p1
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1679526
|
||||
# Patch in the vendor documentation and used different location for documentation
|
||||
@ -335,6 +326,11 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Feb 12 2024 Luboš Uhliarik <luhliari@redhat.com> - 7:6.7-1
|
||||
- new version 6.7
|
||||
- switch to autosetup
|
||||
- fix FTBFS when using gcc14
|
||||
|
||||
* Sat Jan 27 2024 Fedora Release Engineering <releng@fedoraproject.org> - 7:6.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user