Update to latest upstream version 3.3.9

Fixed #976815: file descriptors are hard coded to 16384
Fixed: active ftp crashing
Fixed: offset of patches
This commit is contained in:
Michal Luscon 2013-09-13 12:05:26 +02:00
parent 445a4636f7
commit 1efb17f7ed
8 changed files with 34 additions and 36 deletions

11
active-ftp.patch Normal file
View File

@ -0,0 +1,11 @@
--- ./src/ftp.cc 2013-04-30 06:47:06.000000000 +0200
+++ ./src/ftp.cc 2013-07-04 14:42:06.000000000 +0200
@@ -2555,7 +2555,7 @@
/** \par
* Checks for previous EPSV/PASV failures on this server/session.
* Diverts to EPRT immediately if they are not working. */
- if (!ftpState->flags.pasv_supported) {
+ if (!ftpState->flags.pasv_supported && Config.Ftp.passive) {
ftpSendEPRT(ftpState);
return;
}

View File

@ -1,2 +1,2 @@
6a8fa0075f2fbdd899ac4c9d95fe67cb squid-3.3.8.tar.xz 6c4ba0d63c3a6d94de2da689f361cdab squid-3.3.9.tar.xz
db73bb5a2197759be4c96595b4bf7d19 squid-3.3.8.tar.xz.asc 0e36dd553c5f51cd3a2fa663cd2aa7af squid-3.3.9.tar.xz.asc

View File

@ -1,6 +1,6 @@
--- ./src/cf.data.pre 2013-04-27 05:34:48.000000000 +0200 --- ./src/cf.data.pre 2013-04-27 05:34:48.000000000 +0200
+++ ./src/cf.data.pre 2013-05-03 10:13:16.007067356 +0200 +++ ./src/cf.data.pre 2013-05-03 10:13:16.007067356 +0200
@@ -3876,7 +3876,7 @@ @@ -3889,7 +3889,7 @@
NAME: logfile_rotate NAME: logfile_rotate
TYPE: int TYPE: int
@ -9,7 +9,7 @@
LOC: Config.Log.rotateNumber LOC: Config.Log.rotateNumber
DOC_START DOC_START
Specifies the number of logfile rotations to make when you Specifies the number of logfile rotations to make when you
@@ -5300,11 +5300,11 @@ @@ -5313,11 +5313,11 @@
NAME: cache_mgr NAME: cache_mgr
TYPE: string TYPE: string

View File

@ -1,7 +1,7 @@
diff -up squid-3.1.0.9/QUICKSTART.location squid-3.1.0.9/QUICKSTART diff -up squid-3.1.0.9/QUICKSTART.location squid-3.1.0.9/QUICKSTART
--- squid-3.1.0.9/QUICKSTART.location 2009-06-26 12:35:27.000000000 +0200 --- squid-3.1.0.9/QUICKSTART.location 2009-06-26 12:35:27.000000000 +0200
+++ squid-3.1.0.9/QUICKSTART 2009-07-17 14:03:10.000000000 +0200 +++ squid-3.1.0.9/QUICKSTART 2009-07-17 14:03:10.000000000 +0200
@@ -12,10 +12,9 @@ After you retrieved, compiled and instal @@ -10,10 +10,9 @@ After you retrieved, compiled and instal
INSTALL in the same directory), you have to configure the squid.conf INSTALL in the same directory), you have to configure the squid.conf
file. This is the list of the values you *need* to change, because no file. This is the list of the values you *need* to change, because no
sensible defaults could be defined. Do not touch the other variables sensible defaults could be defined. Do not touch the other variables
@ -14,7 +14,7 @@ diff -up squid-3.1.0.9/QUICKSTART.location squid-3.1.0.9/QUICKSTART
============================================================================== ==============================================================================
@@ -56,7 +55,7 @@ cache_effective_user @@ -54,7 +53,7 @@ cache_effective_user
Some configuration lines which are optional but may be needed. Some configuration lines which are optional but may be needed.
@ -23,7 +23,7 @@ diff -up squid-3.1.0.9/QUICKSTART.location squid-3.1.0.9/QUICKSTART
Add here (first number, here 100) the amount of hard disk space Add here (first number, here 100) the amount of hard disk space
(in megabytes) to devote to caching. (in megabytes) to devote to caching.
@@ -84,12 +83,12 @@ After editing squid.conf to your liking, @@ -82,12 +81,12 @@ After editing squid.conf to your liking,
line TWICE: line TWICE:
To create any disk cache_dir configured: To create any disk cache_dir configured:

View File

@ -1,7 +1,7 @@
diff -up squid-3.1.9/aclocal.m4.ltdl squid-3.1.9/aclocal.m4 diff -up squid-3.1.9/aclocal.m4.ltdl squid-3.1.9/aclocal.m4
--- squid-3.1.9/aclocal.m4.ltdl 2010-10-25 13:34:41.000000000 +0200 --- squid-3.1.9/aclocal.m4.ltdl 2010-10-25 13:34:41.000000000 +0200
+++ squid-3.1.9/aclocal.m4 2010-11-01 14:14:55.297324980 +0100 +++ squid-3.1.9/aclocal.m4 2010-11-01 14:14:55.297324980 +0100
@@ -1117,7 +1117,7 @@ _LT_SET_OPTIONS([$0], [$1]) @@ -1217,7 +1217,7 @@ _LT_SET_OPTIONS([$0], [$1])
LIBTOOL_DEPS="$ltmain" LIBTOOL_DEPS="$ltmain"
# Always use our own libtool. # Always use our own libtool.
@ -13,7 +13,7 @@ diff -up squid-3.1.9/aclocal.m4.ltdl squid-3.1.9/aclocal.m4
diff -up squid-3.1.9/configure.ltdl squid-3.1.9/configure diff -up squid-3.1.9/configure.ltdl squid-3.1.9/configure
--- squid-3.1.9/configure.ltdl 2010-10-25 13:35:32.000000000 +0200 --- squid-3.1.9/configure.ltdl 2010-10-25 13:35:32.000000000 +0200
+++ squid-3.1.9/configure 2010-11-01 14:14:55.320299060 +0100 +++ squid-3.1.9/configure 2010-11-01 14:14:55.320299060 +0100
@@ -9066,7 +9066,7 @@ fi @@ -10286,7 +10286,7 @@ fi
LIBTOOL_DEPS="$ltmain" LIBTOOL_DEPS="$ltmain"
# Always use our own libtool. # Always use our own libtool.
@ -41,7 +41,7 @@ diff -up squid-3.1.9/Makefile.am.ltdl squid-3.1.9/Makefile.am
diff -up squid-3.1.9/Makefile.in.ltdl squid-3.1.9/Makefile.in diff -up squid-3.1.9/Makefile.in.ltdl squid-3.1.9/Makefile.in
--- squid-3.1.9/Makefile.in.ltdl 2010-11-02 08:16:13.630458557 +0100 --- squid-3.1.9/Makefile.in.ltdl 2010-11-02 08:16:13.630458557 +0100
+++ squid-3.1.9/Makefile.in 2010-11-02 08:17:26.543714199 +0100 +++ squid-3.1.9/Makefile.in 2010-11-02 08:17:26.543714199 +0100
@@ -33,7 +33,7 @@ PRE_UNINSTALL = : @@ -35,7 +35,7 @@ PRE_UNINSTALL = :
POST_UNINSTALL = : POST_UNINSTALL = :
build_triplet = @build@ build_triplet = @build@
host_triplet = @host@ host_triplet = @host@
@ -50,7 +50,7 @@ diff -up squid-3.1.9/Makefile.in.ltdl squid-3.1.9/Makefile.in
subdir = . subdir = .
DIST_COMMON = README $(am__configure_deps) $(srcdir)/Makefile.am \ DIST_COMMON = README $(am__configure_deps) $(srcdir)/Makefile.am \
$(srcdir)/Makefile.in $(top_srcdir)/configure \ $(srcdir)/Makefile.in $(top_srcdir)/configure \
@@ -272,7 +272,7 @@ top_build_prefix = @top_build_prefix@ @@ -325,7 +325,7 @@ top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@ top_builddir = @top_builddir@
top_srcdir = @top_srcdir@ top_srcdir = @top_srcdir@
AUTOMAKE_OPTIONS = dist-bzip2 subdir-objects 1.5 foreign AUTOMAKE_OPTIONS = dist-bzip2 subdir-objects 1.5 foreign

View File

@ -1,7 +1,7 @@
diff -up squid-3.2.0.9/compat/Makefile.in.fpic squid-3.2.0.9/compat/Makefile.in diff -up squid-3.2.0.9/compat/Makefile.in.fpic squid-3.2.0.9/compat/Makefile.in
--- squid-3.2.0.9/compat/Makefile.in.fpic 2011-07-01 11:38:35.332618191 +0200 --- squid-3.2.0.9/compat/Makefile.in.fpic 2011-07-01 11:38:35.332618191 +0200
+++ squid-3.2.0.9/compat/Makefile.in 2011-07-01 11:41:07.207345197 +0200 +++ squid-3.2.0.9/compat/Makefile.in 2011-07-01 11:41:07.207345197 +0200
@@ -316,7 +316,7 @@ target_alias = @target_alias@ @@ -321,7 +321,7 @@ target_alias = @target_alias@
top_build_prefix = @top_build_prefix@ top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@ top_builddir = @top_builddir@
top_srcdir = @top_srcdir@ top_srcdir = @top_srcdir@
@ -25,7 +25,7 @@ diff -up squid-3.2.0.9/snmplib/Makefile.am.fpic squid-3.2.0.9/snmplib/Makefile.a
diff -up squid-3.2.0.9/snmplib/Makefile.in.fpic squid-3.2.0.9/snmplib/Makefile.in diff -up squid-3.2.0.9/snmplib/Makefile.in.fpic squid-3.2.0.9/snmplib/Makefile.in
--- squid-3.2.0.9/snmplib/Makefile.in.fpic 2011-07-01 12:04:44.083181152 +0200 --- squid-3.2.0.9/snmplib/Makefile.in.fpic 2011-07-01 12:04:44.083181152 +0200
+++ squid-3.2.0.9/snmplib/Makefile.in 2011-07-01 12:05:06.796437407 +0200 +++ squid-3.2.0.9/snmplib/Makefile.in 2011-07-01 12:05:06.796437407 +0200
@@ -286,7 +286,7 @@ target_alias = @target_alias@ @@ -290,7 +290,7 @@ target_alias = @target_alias@
top_build_prefix = @top_build_prefix@ top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@ top_builddir = @top_builddir@
top_srcdir = @top_srcdir@ top_srcdir = @top_srcdir@

View File

@ -1,20 +0,0 @@
File: squid-3.3.4.tar.bz2
Date: Sat Apr 27 04:00:16 UTC 2013
Size: 2987756
MD5 : 0ef8e63a980389c62130fa639079fb54
SHA1: fdbdcafb7ab2a4aabf5fb0d7ccb700f7b7b9e4c0
Key : 0xFF5CF463 <squid3@treenet.co.nz>
fingerprint = EA31 CC5E 9488 E516 8D2D CC5E B268 E706 FF5C F463
keyring = http://www.squid-cache.org/pgp.asc
keyserver = subkeys.pgp.net
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)
iQEcBAABAgAGBQJRe05JAAoJELJo5wb/XPRjrWIIANBTcue7r2h4Ra/KNKXSUSEG
ZjTKLRhDYdMEreCrhy4XrMXDtZXR3UHknzJVeeu9d7toBL5D6FR2wWcEzehoVBtx
JL9DCOHFty3oaSXP8cLNKQ7yVmTGQs7WBNOvUllNb9mAyITpJ9Ruk2U3c6YYeTUo
G0Yf+OyZsQCH5Vyn8cKHZ56Nmv1yOC9/ed0PBC+pDc9f44aTKgUKB3NN+5aA//7w
rIi3Au2IFsEiVJhzpZk+HmgF4qh2kNh/qzR+Vx5FX61BonzpjP/UdJQWFwrEjSXG
e6AxHylaoKLI1/OQ7WFZrxFEHPwQpXoOGR9zIsifKdxRUrtyHxwm511IvSVSHAM=
=S0PM
-----END PGP SIGNATURE-----

View File

@ -3,8 +3,8 @@
## % define __find_requires %{SOURCE99} ## % define __find_requires %{SOURCE99}
Name: squid Name: squid
Version: 3.3.8 Version: 3.3.9
Release: 3%{?dist} Release: 1%{?dist}
Summary: The Squid proxy caching server Summary: The Squid proxy caching server
Epoch: 7 Epoch: 7
# See CREDITS for breakdown of non GPLv2+ code # See CREDITS for breakdown of non GPLv2+ code
@ -38,6 +38,7 @@ Patch203: squid-3.0.STABLE1-perlpath.patch
Patch204: squid-3.2.0.9-fpic.patch Patch204: squid-3.2.0.9-fpic.patch
Patch205: squid-3.1.9-ltdl.patch Patch205: squid-3.1.9-ltdl.patch
Patch206: squid-3.3.4-empty-pod2man.patch Patch206: squid-3.3.4-empty-pod2man.patch
Patch207: active-ftp.patch
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires: bash >= 2.0 Requires: bash >= 2.0
@ -109,6 +110,7 @@ The squid-sysvinit contains SysV initscritps support.
%patch204 -p1 -b .fpic %patch204 -p1 -b .fpic
%patch205 -p1 -b .ltdl %patch205 -p1 -b .ltdl
%patch206 -p1 -b .empty-pod2man %patch206 -p1 -b .empty-pod2man
%patch207 -p1 -b .active-ftp
%build %build
%ifarch sparcv9 sparc64 s390 s390x %ifarch sparcv9 sparc64 s390 s390x
@ -158,7 +160,6 @@ LDFLAGS="$RPM_LD_FLAGS -pie -Wl,-z,relro -Wl,-z,now"
--enable-ecap \ --enable-ecap \
--with-aio \ --with-aio \
--with-default-user="squid" \ --with-default-user="squid" \
--with-filedescriptors=16384 \
--with-dl \ --with-dl \
--with-openssl \ --with-openssl \
--with-pthreads --with-pthreads
@ -313,6 +314,12 @@ fi
/sbin/chkconfig --add squid >/dev/null 2>&1 || : /sbin/chkconfig --add squid >/dev/null 2>&1 || :
%changelog %changelog
* Fri Sep 13 2013 Michal Luscon <mluscon@redhat.com> - 7:3.3.9-1
- Update to latest upstream version 3.3.9
- Fixed #976815: file descriptors are hard coded to 16384
- Fixed: active ftp crashing
- Fixed: offset of patches
* Thu Aug 08 2013 Michal Luscon <mluscon@redhat.com> - 7:3.3.8-3 * Thu Aug 08 2013 Michal Luscon <mluscon@redhat.com> - 7:3.3.8-3
- Fixed #994814: enable time_quota helper - Fixed #994814: enable time_quota helper