related: new version 4.0.20
This commit is contained in:
parent
e3443fc1f9
commit
0add6ab8e9
@ -1,26 +0,0 @@
|
||||
diff --git a/tools/purge/purge.cc b/tools/purge/purge.cc
|
||||
index 3ef9147..07f8b32 100644
|
||||
--- tools/purge/purge.cc
|
||||
+++ tools/purge/purge.cc
|
||||
@@ -272,7 +272,7 @@ log_extended( const char* fn, int code, long size, const SquidMetaList* meta )
|
||||
snprintf( md5, sizeof(md5), "%-32s", "(no_md5_data_available)" );
|
||||
}
|
||||
|
||||
- char timeb[64];
|
||||
+ char timeb[256];
|
||||
if ( meta && (findings = meta->search( STORE_META_STD )) ) {
|
||||
StoreMetaStd temp;
|
||||
// make data aligned, avoid SIGBUS on RISC machines (ARGH!)
|
||||
diff --git a/tools/purge/purge.cc b/tools/purge/purge.cc
|
||||
index 07f8b32..4bd3ddb 100644
|
||||
--- tools/purge/purge.cc
|
||||
+++ tools/purge/purge.cc
|
||||
@@ -283,7 +283,7 @@ log_extended( const char* fn, int code, long size, const SquidMetaList* meta )
|
||||
} else if ( meta && (findings = meta->search( STORE_META_STD_LFS )) ) {
|
||||
StoreMetaStdLFS temp;
|
||||
// make data aligned, avoid SIGBUS on RISC machines (ARGH!)
|
||||
- memcpy( &temp, findings->data, sizeof(StoreMetaStd) );
|
||||
+ memcpy( &temp, findings->data, sizeof(StoreMetaStdLFS) );
|
||||
snprintf( timeb, sizeof(timeb), "%08lx %08lx %08lx %08lx %04x %5hu ",
|
||||
(unsigned long)temp.timestamp, (unsigned long)temp.lastref,
|
||||
(unsigned long)temp.expires, (unsigned long)temp.lastmod, temp.flags, temp.refcount );
|
@ -2,7 +2,7 @@
|
||||
|
||||
Name: squid
|
||||
Version: 4.0.20
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: The Squid proxy caching server
|
||||
Epoch: 7
|
||||
# See CREDITS for breakdown of non GPLv2+ code
|
||||
@ -31,7 +31,6 @@ Patch201: squid-4.0.11-config.patch
|
||||
Patch202: squid-3.1.0.9-location.patch
|
||||
Patch203: squid-3.0.STABLE1-perlpath.patch
|
||||
Patch204: squid-3.5.9-include-guards.patch
|
||||
Patch205: squid-4.0.18-gcc7-errors.patch
|
||||
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Requires: bash >= 2.0
|
||||
@ -92,7 +91,6 @@ lookup program (dnsserver), a program for retrieving FTP data
|
||||
%patch202 -p1 -b .location
|
||||
%patch203 -p1 -b .perlpath
|
||||
%patch204 -p0 -b .include-guards
|
||||
%patch205 -p0 -b .gcc7-errors
|
||||
|
||||
%build
|
||||
# cppunit-config patch changes configure.ac
|
||||
@ -301,6 +299,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jun 05 2017 Luboš Uhliarik <luhliari@redhat.com> - 7:4.0.20-2
|
||||
- related: new version 4.0.20
|
||||
|
||||
* Mon Jun 05 2017 Luboš Uhliarik <luhliari@redhat.com> - 7:4.0.20-1
|
||||
- new version 4.0.20
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user