parent
49ddcd0e19
commit
0975fc2140
2
sources
2
sources
@ -1 +1 @@
|
||||
231323a73346041cec825e785960e348 squid-3.0.STABLE6.tar.bz2
|
||||
fa0fc5a3ce226099975b34c1cd2a3f95 squid-3.0.STABLE7.tar.bz2
|
||||
|
@ -1,20 +0,0 @@
|
||||
diff -up squid-3.0.STABLE6/src/tools.cc.bad_allocation squid-3.0.STABLE6/src/tools.cc
|
||||
--- squid-3.0.STABLE6/src/tools.cc.bad_allocation 2008-05-20 17:01:16.000000000 +0200
|
||||
+++ squid-3.0.STABLE6/src/tools.cc 2008-05-23 11:14:24.000000000 +0200
|
||||
@@ -1354,10 +1354,14 @@ static void
|
||||
restoreCapabilities(int keep)
|
||||
{
|
||||
#if defined(_SQUID_LINUX_) && HAVE_SYS_CAPABILITY_H
|
||||
- cap_user_header_t head = (cap_user_header_t) xcalloc(1, sizeof(cap_user_header_t));
|
||||
- cap_user_data_t cap = (cap_user_data_t) xcalloc(1, sizeof(cap_user_data_t));
|
||||
+ cap_user_header_t head = (cap_user_header_t) xcalloc(1, sizeof(*head));
|
||||
+ cap_user_data_t cap = (cap_user_data_t) xcalloc(1, sizeof(*cap));
|
||||
|
||||
+#ifdef _LINUX_CAPABILITY_VERSION_1
|
||||
+ head->version = _LINUX_CAPABILITY_VERSION_1;
|
||||
+#else
|
||||
head->version = _LINUX_CAPABILITY_VERSION;
|
||||
+#endif
|
||||
|
||||
if (capget(head, cap) != 0) {
|
||||
debugs(50, 1, "Can't get current capabilities");
|
11
squid.spec
11
squid.spec
@ -3,8 +3,8 @@
|
||||
## % define __find_requires %{SOURCE99}
|
||||
|
||||
Name: squid
|
||||
Version: 3.0.STABLE6
|
||||
Release: 2%{?dist}
|
||||
Version: 3.0.STABLE7
|
||||
Release: 1%{?dist}
|
||||
Summary: The Squid proxy caching server
|
||||
Epoch: 7
|
||||
License: GPLv2+
|
||||
@ -20,7 +20,6 @@ Source98: perl-requires-squid.sh
|
||||
## Source99: filter-requires-squid.sh
|
||||
|
||||
# Upstream patches
|
||||
Patch0: squid-3.0.STABLE5-bad_allocation
|
||||
|
||||
# External patches
|
||||
|
||||
@ -59,8 +58,6 @@ lookup program (dnsserver), a program for retrieving FTP data
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch0 -p1 -b .bad_allocation
|
||||
|
||||
%patch201 -p1 -b .config
|
||||
%patch202 -p1 -b .location
|
||||
%patch203 -p1 -b .build
|
||||
@ -340,6 +337,10 @@ fi
|
||||
chgrp squid /var/cache/samba/winbindd_privileged >/dev/null 2>&1 || :
|
||||
|
||||
%changelog
|
||||
* Wed Jul 02 2008 Jiri Skala <jskala@redhat.com> - 7:3.0.STABLE7-1
|
||||
- update to latest upstream
|
||||
- fix #453214
|
||||
|
||||
* Mon May 26 2008 Martin Nagy <mnagy@redhat.com> - 7:3.0.STABLE6-2
|
||||
- fix bad allocation
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user