Fix 3.1 packaging errors
This commit is contained in:
parent
6438e69aa1
commit
050c14b064
@ -1,6 +1,6 @@
|
||||
diff -up squid-3.1.0.13/errors/Makefile.am.build squid-3.1.0.13/errors/Makefile.am
|
||||
--- squid-3.1.0.13/errors/Makefile.am.build 2009-08-04 15:32:08.000000000 +0200
|
||||
+++ squid-3.1.0.13/errors/Makefile.am 2009-09-01 01:21:40.000000000 +0200
|
||||
+++ squid-3.1.0.13/errors/Makefile.am 2009-09-01 01:55:37.000000000 +0200
|
||||
@@ -3,7 +3,7 @@
|
||||
# $Id$
|
||||
#
|
||||
@ -12,7 +12,7 @@ diff -up squid-3.1.0.13/errors/Makefile.am.build squid-3.1.0.13/errors/Makefile.
|
||||
|
||||
diff -up squid-3.1.0.13/errors/Makefile.in.build squid-3.1.0.13/errors/Makefile.in
|
||||
--- squid-3.1.0.13/errors/Makefile.in.build 2009-08-04 15:32:30.000000000 +0200
|
||||
+++ squid-3.1.0.13/errors/Makefile.in 2009-09-01 01:23:39.000000000 +0200
|
||||
+++ squid-3.1.0.13/errors/Makefile.in 2009-09-01 01:56:14.000000000 +0200
|
||||
@@ -221,7 +221,7 @@ target_alias = @target_alias@
|
||||
top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
@ -24,7 +24,7 @@ diff -up squid-3.1.0.13/errors/Makefile.in.build squid-3.1.0.13/errors/Makefile.
|
||||
TRANSLATIONPO = `ls -1 $(top_srcdir)/errors/*.po | grep -o -E "[a-z\-]+\.po" | sed s/.po//`
|
||||
diff -up squid-3.1.0.13/icons/Makefile.am.build squid-3.1.0.13/icons/Makefile.am
|
||||
--- squid-3.1.0.13/icons/Makefile.am.build 2009-08-04 15:32:10.000000000 +0200
|
||||
+++ squid-3.1.0.13/icons/Makefile.am 2009-09-01 01:10:05.000000000 +0200
|
||||
+++ squid-3.1.0.13/icons/Makefile.am 2009-09-01 01:55:37.000000000 +0200
|
||||
@@ -29,7 +29,7 @@ ICONS = anthony-binhex.gif \
|
||||
anthony-xbm.gif \
|
||||
anthony-xpm.gif
|
||||
@ -36,7 +36,7 @@ diff -up squid-3.1.0.13/icons/Makefile.am.build squid-3.1.0.13/icons/Makefile.am
|
||||
DISTCLEANFILES =
|
||||
diff -up squid-3.1.0.13/icons/Makefile.in.build squid-3.1.0.13/icons/Makefile.in
|
||||
--- squid-3.1.0.13/icons/Makefile.in.build 2009-08-04 15:32:35.000000000 +0200
|
||||
+++ squid-3.1.0.13/icons/Makefile.in 2009-09-01 01:23:45.000000000 +0200
|
||||
+++ squid-3.1.0.13/icons/Makefile.in 2009-09-01 01:56:19.000000000 +0200
|
||||
@@ -258,7 +258,7 @@ ICONS = anthony-binhex.gif \
|
||||
anthony-xbm.gif \
|
||||
anthony-xpm.gif
|
||||
@ -48,17 +48,19 @@ diff -up squid-3.1.0.13/icons/Makefile.in.build squid-3.1.0.13/icons/Makefile.in
|
||||
DISTCLEANFILES =
|
||||
diff -up squid-3.1.0.13/src/Makefile.am.build squid-3.1.0.13/src/Makefile.am
|
||||
--- squid-3.1.0.13/src/Makefile.am.build 2009-08-04 15:32:13.000000000 +0200
|
||||
+++ squid-3.1.0.13/src/Makefile.am 2009-09-01 01:20:45.000000000 +0200
|
||||
@@ -639,7 +639,7 @@ sysconf_DATA = \
|
||||
+++ squid-3.1.0.13/src/Makefile.am 2009-09-01 01:55:37.000000000 +0200
|
||||
@@ -639,7 +639,9 @@ sysconf_DATA = \
|
||||
squid.conf.documented \
|
||||
mime.conf.default
|
||||
|
||||
-data_DATA = \
|
||||
+pkgdata_DATA =
|
||||
+# This really should be installed where snmpget & friends will find it,
|
||||
+# not used by Squid as such.
|
||||
+pkgdata_DATA = \
|
||||
mib.txt
|
||||
|
||||
LDADD = $(COMMON_LIBS) -L../lib -lmiscutil @XTRA_LIBS@ @EPOLL_LIBS@ @MINGW_LIBS@
|
||||
@@ -712,13 +712,13 @@ DEFAULT_ACCESS_LOG = $(DEFAULT_LOG_
|
||||
@@ -712,13 +714,13 @@ DEFAULT_ACCESS_LOG = $(DEFAULT_LOG_
|
||||
DEFAULT_STORE_LOG = $(DEFAULT_LOG_PREFIX)/store.log
|
||||
DEFAULT_PID_FILE = @DEFAULT_PIDFILE@
|
||||
DEFAULT_NETDB_FILE = $(DEFAULT_LOG_PREFIX)/netdb.state
|
||||
@ -76,7 +78,7 @@ diff -up squid-3.1.0.13/src/Makefile.am.build squid-3.1.0.13/src/Makefile.am
|
||||
DEFAULT_HOSTS = @OPT_DEFAULT_HOSTS@
|
||||
|
||||
# Make location configure settings available to the code
|
||||
@@ -785,7 +785,7 @@ cf.data: cf.data.pre Makefile
|
||||
@@ -785,7 +787,7 @@ cf.data: cf.data.pre Makefile
|
||||
repl_modules.cc: repl_modules.sh Makefile
|
||||
$(SHELL) $(srcdir)/repl_modules.sh $(REPL_POLICIES) > repl_modules.cc
|
||||
|
||||
@ -87,7 +89,7 @@ diff -up squid-3.1.0.13/src/Makefile.am.build squid-3.1.0.13/src/Makefile.am
|
||||
else \
|
||||
diff -up squid-3.1.0.13/src/Makefile.in.build squid-3.1.0.13/src/Makefile.in
|
||||
--- squid-3.1.0.13/src/Makefile.in.build 2009-08-04 15:32:36.000000000 +0200
|
||||
+++ squid-3.1.0.13/src/Makefile.in 2009-09-01 01:23:47.000000000 +0200
|
||||
+++ squid-3.1.0.13/src/Makefile.in 2009-09-01 01:56:20.000000000 +0200
|
||||
@@ -130,7 +130,7 @@ am_libsquid_la_OBJECTS = comm.lo CommCal
|
||||
SquidConfig.lo TextException.lo
|
||||
libsquid_la_OBJECTS = $(am_libsquid_la_OBJECTS)
|
||||
@ -109,18 +111,19 @@ diff -up squid-3.1.0.13/src/Makefile.in.build squid-3.1.0.13/src/Makefile.in
|
||||
HEADERS = $(noinst_HEADERS)
|
||||
RECURSIVE_CLEAN_TARGETS = mostlyclean-recursive clean-recursive \
|
||||
distclean-recursive maintainer-clean-recursive
|
||||
@@ -1850,9 +1850,7 @@ sysconf_DATA = \
|
||||
@@ -1850,7 +1850,10 @@ sysconf_DATA = \
|
||||
squid.conf.documented \
|
||||
mime.conf.default
|
||||
|
||||
-data_DATA = \
|
||||
- mib.txt
|
||||
-
|
||||
+pkgdata_DATA =
|
||||
+
|
||||
+# This really should be installed where snmpget & friends will find it,
|
||||
+# not used by Squid as such.
|
||||
+pkgdata_DATA = \
|
||||
mib.txt
|
||||
|
||||
LDADD = $(COMMON_LIBS) -L../lib -lmiscutil @XTRA_LIBS@ @EPOLL_LIBS@ @MINGW_LIBS@
|
||||
EXTRA_DIST = \
|
||||
cf_gen_defines \
|
||||
@@ -1920,13 +1918,13 @@ DEFAULT_ACCESS_LOG = $(DEFAULT_LOG_PREFI
|
||||
@@ -1920,13 +1923,13 @@ DEFAULT_ACCESS_LOG = $(DEFAULT_LOG_PREFI
|
||||
DEFAULT_STORE_LOG = $(DEFAULT_LOG_PREFIX)/store.log
|
||||
DEFAULT_PID_FILE = @DEFAULT_PIDFILE@
|
||||
DEFAULT_NETDB_FILE = $(DEFAULT_LOG_PREFIX)/netdb.state
|
||||
@ -138,7 +141,7 @@ diff -up squid-3.1.0.13/src/Makefile.in.build squid-3.1.0.13/src/Makefile.in
|
||||
DEFAULT_HOSTS = @OPT_DEFAULT_HOSTS@
|
||||
|
||||
# stock tools for unit tests - library independent versions of dlink_list
|
||||
@@ -4023,22 +4021,22 @@ clean-libtool:
|
||||
@@ -4023,22 +4026,22 @@ clean-libtool:
|
||||
-rm -rf .libs _libs
|
||||
-rm -rf DiskIO/DiskDaemon/.libs DiskIO/DiskDaemon/_libs
|
||||
-rm -rf tests/.libs tests/_libs
|
||||
@ -170,7 +173,7 @@ diff -up squid-3.1.0.13/src/Makefile.in.build squid-3.1.0.13/src/Makefile.in
|
||||
done
|
||||
install-sysconfDATA: $(sysconf_DATA)
|
||||
@$(NORMAL_INSTALL)
|
||||
@@ -4313,7 +4311,7 @@ all-am: Makefile $(LIBRARIES) $(LTLIBRAR
|
||||
@@ -4313,7 +4316,7 @@ all-am: Makefile $(LIBRARIES) $(LTLIBRAR
|
||||
$(HEADERS)
|
||||
installdirs: installdirs-recursive
|
||||
installdirs-am:
|
||||
@ -179,7 +182,7 @@ diff -up squid-3.1.0.13/src/Makefile.in.build squid-3.1.0.13/src/Makefile.in
|
||||
test -z "$$dir" || $(MKDIR_P) "$$dir"; \
|
||||
done
|
||||
install: $(BUILT_SOURCES)
|
||||
@@ -4378,7 +4376,7 @@ info: info-recursive
|
||||
@@ -4378,7 +4381,7 @@ info: info-recursive
|
||||
|
||||
info-am:
|
||||
|
||||
@ -188,7 +191,7 @@ diff -up squid-3.1.0.13/src/Makefile.in.build squid-3.1.0.13/src/Makefile.in
|
||||
|
||||
install-dvi: install-dvi-recursive
|
||||
|
||||
@@ -4415,9 +4413,9 @@ ps: ps-recursive
|
||||
@@ -4415,9 +4418,9 @@ ps: ps-recursive
|
||||
|
||||
ps-am:
|
||||
|
||||
@ -201,7 +204,7 @@ diff -up squid-3.1.0.13/src/Makefile.in.build squid-3.1.0.13/src/Makefile.in
|
||||
|
||||
.MAKE: $(RECURSIVE_CLEAN_TARGETS) $(RECURSIVE_TARGETS) install-am \
|
||||
install-strip
|
||||
@@ -4430,19 +4428,19 @@ uninstall-am: uninstall-binPROGRAMS unin
|
||||
@@ -4430,19 +4433,19 @@ uninstall-am: uninstall-binPROGRAMS unin
|
||||
distclean distclean-compile distclean-generic \
|
||||
distclean-libtool distclean-tags distdir dvi dvi-am html \
|
||||
html-am info info-am install install-am install-binPROGRAMS \
|
||||
@ -229,15 +232,7 @@ diff -up squid-3.1.0.13/src/Makefile.in.build squid-3.1.0.13/src/Makefile.in
|
||||
|
||||
|
||||
$(OBJS): $(top_srcdir)/include/version.h $(top_builddir)/include/autoconf.h
|
||||
@@ -4450,6 +4448,7 @@ cf_gen.$(OBJEXT): cf_gen_defines.h
|
||||
|
||||
DiskIO/DiskIOModules_gen.cc: Makefile
|
||||
$(SHELL) $(srcdir)/DiskIO/modules.sh $(DISK_MODULES) > DiskIO/DiskIOModules_gen.cc
|
||||
+ mib.txt
|
||||
|
||||
snmp_core.o snmp_agent.o: ../snmplib/libsnmp.a $(top_srcdir)/include/cache_snmp.h
|
||||
|
||||
@@ -4508,7 +4507,7 @@ cf.data: cf.data.pre Makefile
|
||||
@@ -4508,7 +4511,7 @@ cf.data: cf.data.pre Makefile
|
||||
repl_modules.cc: repl_modules.sh Makefile
|
||||
$(SHELL) $(srcdir)/repl_modules.sh $(REPL_POLICIES) > repl_modules.cc
|
||||
|
||||
|
@ -29,6 +29,7 @@ Source98: perl-requires-squid.sh
|
||||
|
||||
# Upstream patches
|
||||
#Patch001: http://www.squid-cache.org/Versions/v3/3.1/changesets/bXXXX.patch
|
||||
Patch001: http://www.squid-cache.org/Versions/v3/3.1/changesets/b9694.patch
|
||||
|
||||
# External patches
|
||||
|
||||
@ -66,6 +67,7 @@ lookup program (dnsserver), a program for retrieving FTP data
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch001 -p0 -b .b9694
|
||||
%patch201 -p1 -b .config
|
||||
%patch202 -p1 -b .location
|
||||
%patch203 -p1 -b .build
|
||||
|
Loading…
Reference in New Issue
Block a user