Pass the compressor options through the make call instead of a patch.
This commit is contained in:
parent
a53ae83689
commit
b4793228eb
@ -1,29 +0,0 @@
|
|||||||
--- squashfs-tools/Makefile.orig 2011-03-01 22:29:17.000000000 -0600
|
|
||||||
+++ squashfs-tools/Makefile 2011-03-01 22:29:59.000000000 -0600
|
|
||||||
@@ -26,7 +26,7 @@
|
|
||||||
# To build using XZ Utils liblzma - install the library and uncomment
|
|
||||||
# the XZ_SUPPORT line below.
|
|
||||||
#
|
|
||||||
-#XZ_SUPPORT = 1
|
|
||||||
+XZ_SUPPORT = 1
|
|
||||||
|
|
||||||
|
|
||||||
############ Building LZO support ##############
|
|
||||||
@@ -37,7 +37,7 @@
|
|
||||||
# LZO_SUPPORT line below. If needed, uncomment and set LZO_DIR to the
|
|
||||||
# installation prefix.
|
|
||||||
#
|
|
||||||
-#LZO_SUPPORT = 1
|
|
||||||
+LZO_SUPPORT = 1
|
|
||||||
#LZO_DIR = /usr/local
|
|
||||||
|
|
||||||
########### Building LZMA support #############
|
|
||||||
@@ -57,7 +57,7 @@
|
|
||||||
# work) - download and unpack it, uncomment and set LZMA_DIR to unpacked source,
|
|
||||||
# and uncomment the LZMA_SUPPORT line below.
|
|
||||||
#
|
|
||||||
-#LZMA_XZ_SUPPORT = 1
|
|
||||||
+LZMA_XZ_SUPPORT = 1
|
|
||||||
#LZMA_SUPPORT = 1
|
|
||||||
#LZMA_DIR = ../../../../LZMA/lzma465
|
|
||||||
|
|
@ -6,7 +6,6 @@ License: GPLv2+
|
|||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
URL: http://squashfs.sourceforge.net/
|
URL: http://squashfs.sourceforge.net/
|
||||||
Source0: http://downloads.sourceforge.net/squashfs/squashfs%{version}.tar.gz
|
Source0: http://downloads.sourceforge.net/squashfs/squashfs%{version}.tar.gz
|
||||||
Patch1: squashfs-compressors.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
BuildRequires: zlib-devel
|
BuildRequires: zlib-devel
|
||||||
BuildRequires: xz-devel
|
BuildRequires: xz-devel
|
||||||
@ -19,11 +18,10 @@ contains the utilities for manipulating squashfs filesystems.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n squashfs4.2
|
%setup -q -n squashfs4.2
|
||||||
%patch1 -p0
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
pushd squashfs-tools
|
pushd squashfs-tools
|
||||||
CFLAGS="%{optflags}" make %{?_smp_mflags}
|
CFLAGS="%{optflags}" XZ_SUPPORT=1 LZO_SUPPORT=1 LZMA_XZ_SUPPORT=1 make %{?_smp_mflags}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
mkdir -p %{buildroot}/sbin %{buildroot}/usr/sbin
|
mkdir -p %{buildroot}/sbin %{buildroot}/usr/sbin
|
||||||
@ -48,6 +46,7 @@ rm -rf %{buildroot}
|
|||||||
- Big endian patch is now upstream.
|
- Big endian patch is now upstream.
|
||||||
- Buildroot tag isn't needed any more.
|
- Buildroot tag isn't needed any more.
|
||||||
- We can now specify CFLAGS on the make call.
|
- We can now specify CFLAGS on the make call.
|
||||||
|
- Compressor options are now passed with the make call.
|
||||||
|
|
||||||
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2-0.4.20101231
|
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2-0.4.20101231
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
Loading…
Reference in New Issue
Block a user