88 lines
2.6 KiB
Diff
88 lines
2.6 KiB
Diff
Build FTS based on http://marc.info/?l=sqlite-users&m=118004021520533&q=raw
|
|
|
|
--- sqlite-3.3.17/Makefile.in.fts 2007-06-01 12:52:44.000000000 +0100
|
|
+++ sqlite-3.3.17/Makefile.in 2007-06-01 12:54:19.000000000 +0100
|
|
@@ -116,7 +116,9 @@
|
|
|
|
# You should not have to change anything below this line
|
|
###############################################################################
|
|
-TCC += -DSQLITE_OMIT_LOAD_EXTENSION=1
|
|
+#TCC += -DSQLITE_OMIT_LOAD_EXTENSION=1
|
|
+TCC += -DSQLITE_ENABLE_FTS1=1
|
|
+TCC += -DSQLITE_ENABLE_FTS2=1
|
|
|
|
# Object files for the SQLite library.
|
|
#
|
|
@@ -130,6 +132,12 @@
|
|
vdbe.lo vdbeapi.lo vdbeaux.lo vdbefifo.lo vdbemem.lo \
|
|
where.lo utf.lo legacy.lo vtab.lo
|
|
|
|
+# FTS1 (optional)
|
|
+LIBOBJ += fts1.lo fts1_hash.lo fts1_porter.lo fts1_tokenizer1.lo
|
|
+
|
|
+# FTS2 (optional)
|
|
+LIBOBJ += fts2.lo fts2_hash.lo fts2_porter.lo fts2_tokenizer1.lo
|
|
+
|
|
# All of the source code files.
|
|
#
|
|
SRC = \
|
|
@@ -194,7 +202,14 @@
|
|
$(TOP)/ext/fts1/fts1_hash.h \
|
|
$(TOP)/ext/fts1/fts1_porter.c \
|
|
$(TOP)/ext/fts1/fts1_tokenizer.h \
|
|
- $(TOP)/ext/fts1/fts1_tokenizer1.c
|
|
+ $(TOP)/ext/fts1/fts1_tokenizer1.c \
|
|
+ $(TOP)/ext/fts2/fts2.c \
|
|
+ $(TOP)/ext/fts2/fts2.h \
|
|
+ $(TOP)/ext/fts2/fts2_hash.c \
|
|
+ $(TOP)/ext/fts2/fts2_hash.h \
|
|
+ $(TOP)/ext/fts2/fts2_porter.c \
|
|
+ $(TOP)/ext/fts2/fts2_tokenizer.h \
|
|
+ $(TOP)/ext/fts2/fts2_tokenizer1.c
|
|
|
|
|
|
# Source code to the test files.
|
|
@@ -252,7 +267,10 @@
|
|
HDR += \
|
|
$(TOP)/ext/fts1/fts1.h \
|
|
$(TOP)/ext/fts1/fts1_hash.h \
|
|
- $(TOP)/ext/fts1/fts1_tokenizer.h
|
|
+ $(TOP)/ext/fts1/fts1_tokenizer.h \
|
|
+ $(TOP)/ext/fts2/fts2.h \
|
|
+ $(TOP)/ext/fts2/fts2_hash.h \
|
|
+ $(TOP)/ext/fts2/fts2_tokenizer.h
|
|
|
|
# Header files used by the VDBE submodule
|
|
#
|
|
@@ -469,6 +487,30 @@
|
|
where.lo: $(TOP)/src/where.c $(HDR)
|
|
$(LTCOMPILE) -c $(TOP)/src/where.c
|
|
|
|
+fts1.lo: $(TOP)/ext/fts1/fts1.c $(HDR)
|
|
+ $(LTCOMPILE) -c $(TOP)/ext/fts1/fts1.c
|
|
+
|
|
+fts1_hash.lo: $(TOP)/ext/fts1/fts1_hash.c $(HDR)
|
|
+ $(LTCOMPILE) -c $(TOP)/ext/fts1/fts1_hash.c
|
|
+
|
|
+fts1_porter.lo: $(TOP)/ext/fts1/fts1_porter.c $(HDR)
|
|
+ $(LTCOMPILE) -c $(TOP)/ext/fts1/fts1_porter.c
|
|
+
|
|
+fts1_tokenizer1.lo: $(TOP)/ext/fts1/fts1_tokenizer1.c $(HDR)
|
|
+ $(LTCOMPILE) -c $(TOP)/ext/fts1/fts1_tokenizer1.c
|
|
+
|
|
+fts2.lo: $(TOP)/ext/fts2/fts2.c $(HDR)
|
|
+ $(LTCOMPILE) -c $(TOP)/ext/fts2/fts2.c
|
|
+
|
|
+fts2_hash.lo: $(TOP)/ext/fts2/fts2_hash.c $(HDR)
|
|
+ $(LTCOMPILE) -c $(TOP)/ext/fts2/fts2_hash.c
|
|
+
|
|
+fts2_porter.lo: $(TOP)/ext/fts2/fts2_porter.c $(HDR)
|
|
+ $(LTCOMPILE) -c $(TOP)/ext/fts2/fts2_porter.c
|
|
+
|
|
+fts2_tokenizer1.lo: $(TOP)/ext/fts2/fts2_tokenizer1.c $(HDR)
|
|
+ $(LTCOMPILE) -c $(TOP)/ext/fts2/fts2_tokenizer1.c
|
|
+
|
|
tclsqlite-shell.lo: $(TOP)/src/tclsqlite.c $(HDR)
|
|
$(LTCOMPILE) -DTCLSH=1 -o $@ -c $(TOP)/src/tclsqlite.c
|
|
|