54145bd8e4
- disable buggy malloc_usable_size code (#801981)
25 lines
1.2 KiB
Diff
25 lines
1.2 KiB
Diff
diff -up sqlite-src-3071100/configure.ac.malloc_usable_size sqlite-src-3071100/configure.ac
|
|
--- sqlite-src-3071100/configure.ac.malloc_usable_size 2012-04-25 09:36:02.999684178 +0300
|
|
+++ sqlite-src-3071100/configure.ac 2012-04-25 09:36:21.415584431 +0300
|
|
@@ -127,7 +127,7 @@ AC_CHECK_HEADERS([sys/types.h stdlib.h s
|
|
#########
|
|
# Figure out whether or not we have these functions
|
|
#
|
|
-AC_CHECK_FUNCS([usleep fdatasync localtime_r gmtime_r localtime_s utime malloc_usable_size])
|
|
+AC_CHECK_FUNCS([usleep fdatasync localtime_r gmtime_r localtime_s utime])
|
|
|
|
#########
|
|
# By default, we use the amalgamation (this may be changed below...)
|
|
diff -up sqlite-src-3071100/configure.malloc_usable_size sqlite-src-3071100/configure
|
|
--- sqlite-src-3071100/configure.malloc_usable_size 2012-04-25 09:36:10.255643392 +0300
|
|
+++ sqlite-src-3071100/configure 2012-04-25 09:36:37.684496632 +0300
|
|
@@ -12148,7 +12148,7 @@ done
|
|
|
|
|
|
|
|
-for ac_func in usleep fdatasync localtime_r gmtime_r localtime_s utime malloc_usable_size
|
|
+for ac_func in usleep fdatasync localtime_r gmtime_r localtime_s utime
|
|
do
|
|
as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
|
|
{ $as_echo "$as_me:$LINENO: checking for $ac_func" >&5
|