- update to 3.7.4
- deal with upstream source naming, versioning and format changing - fixup wal2-test expections wrt SQLITE_DISABLE_DIRSYNC use
This commit is contained in:
parent
abaefeeb05
commit
e5b14b43aa
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +1,4 @@
|
|||||||
/sqlite_docs_3_7_3.zip
|
/sqlite_docs_3_7_3.zip
|
||||||
/sqlite-3.7.3.tar.gz
|
/sqlite-3.7.3.tar.gz
|
||||||
|
/sqlite-doc-3070400.zip
|
||||||
|
/sqlite-src-3070400.zip
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
ed6f040910936cf57ad55045fa3bcb1d sqlite_docs_3_7_3.zip
|
c38a4aae9cf6e8921ba7ad48a9301288 sqlite-doc-3070400.zip
|
||||||
5437978aae90350cf984993091e0d695 sqlite-3.7.3.tar.gz
|
2b5c53328505893599de6e2055996d7a sqlite-src-3070400.zip
|
||||||
|
16
sqlite-3.7.4-wal2-nodirsync.patch
Normal file
16
sqlite-3.7.4-wal2-nodirsync.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
diff -up sqlite-src-3070400/test/wal2.test.nodirsync sqlite-src-3070400/test/wal2.test
|
||||||
|
--- sqlite-src-3070400/test/wal2.test.nodirsync 2010-12-09 13:49:43.000000000 +0200
|
||||||
|
+++ sqlite-src-3070400/test/wal2.test 2010-12-09 13:57:57.000000000 +0200
|
||||||
|
@@ -1160,9 +1160,9 @@ if {$::tcl_platform(platform) == "unix"}
|
||||||
|
# Test that "PRAGMA checkpoint_fullsync" appears to be working.
|
||||||
|
#
|
||||||
|
foreach {tn sql reslist} {
|
||||||
|
- 1 { } {8 0 3 0 5 0}
|
||||||
|
- 2 { PRAGMA checkpoint_fullfsync = 1 } {8 4 3 2 5 2}
|
||||||
|
- 3 { PRAGMA checkpoint_fullfsync = 0 } {8 0 3 0 5 0}
|
||||||
|
+ 1 { } {7 0 3 0 5 0}
|
||||||
|
+ 2 { PRAGMA checkpoint_fullfsync = 1 } {7 4 3 2 5 2}
|
||||||
|
+ 3 { PRAGMA checkpoint_fullfsync = 0 } {7 0 3 0 5 0}
|
||||||
|
} {
|
||||||
|
faultsim_delete_and_reopen
|
||||||
|
|
25
sqlite.spec
25
sqlite.spec
@ -3,23 +3,24 @@
|
|||||||
%bcond_with static
|
%bcond_with static
|
||||||
%bcond_without check
|
%bcond_without check
|
||||||
|
|
||||||
# upstream doesn't provide separate -docs sources for all minor releases
|
%define realver 3070400
|
||||||
%define basever 3.7.3
|
%define rpmver %(echo %{realver}|sed -e "s/00//g" -e "s/0/./g")
|
||||||
%define docver %(echo %{basever}|sed -e "s/\\./_/g")
|
|
||||||
|
|
||||||
Summary: Library that implements an embeddable SQL database engine
|
Summary: Library that implements an embeddable SQL database engine
|
||||||
Name: sqlite
|
Name: sqlite
|
||||||
Version: %{basever}
|
Version: %{rpmver}
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: Public Domain
|
License: Public Domain
|
||||||
Group: Applications/Databases
|
Group: Applications/Databases
|
||||||
URL: http://www.sqlite.org/
|
URL: http://www.sqlite.org/
|
||||||
Source0: http://www.sqlite.org/sqlite-%{version}.tar.gz
|
Source0: http://www.sqlite.org/sqlite-src-%{realver}.zip
|
||||||
Source1: http://www.sqlite.org/sqlite_docs_%{docver}.zip
|
Source1: http://www.sqlite.org/sqlite-doc-%{realver}.zip
|
||||||
# Fix build with --enable-load-extension, upstream ticket #3137
|
# Fix build with --enable-load-extension, upstream ticket #3137
|
||||||
Patch1: sqlite-3.6.12-libdl.patch
|
Patch1: sqlite-3.6.12-libdl.patch
|
||||||
# Support a system-wide lemon template
|
# Support a system-wide lemon template
|
||||||
Patch2: sqlite-3.6.23-lemon-system-template.patch
|
Patch2: sqlite-3.6.23-lemon-system-template.patch
|
||||||
|
# Fixup test-suite expectations wrt SQLITE_DISABLE_DIRSYNC
|
||||||
|
Patch3: sqlite-3.7.4-wal2-nodirsync.patch
|
||||||
BuildRequires: ncurses-devel readline-devel glibc-devel
|
BuildRequires: ncurses-devel readline-devel glibc-devel
|
||||||
# libdl patch needs
|
# libdl patch needs
|
||||||
BuildRequires: autoconf
|
BuildRequires: autoconf
|
||||||
@ -87,9 +88,10 @@ This package contains the tcl modules for %{name}.
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -a1
|
%setup -q -a1 -n %{name}-src-%{realver}
|
||||||
%patch1 -p1 -b .libdl
|
%patch1 -p1 -b .libdl
|
||||||
%patch2 -p1 -b .lemon-system-template
|
%patch2 -p1 -b .lemon-system-template
|
||||||
|
%patch3 -p1 -b .wal2-nodirsync
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoconf
|
autoconf
|
||||||
@ -159,7 +161,7 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
%files doc
|
%files doc
|
||||||
%defattr(-, root, root)
|
%defattr(-, root, root)
|
||||||
%doc %{name}-%{docver}-docs/*
|
%doc %{name}-doc-%{realver}/*
|
||||||
|
|
||||||
%files -n lemon
|
%files -n lemon
|
||||||
%defattr(-, root, root)
|
%defattr(-, root, root)
|
||||||
@ -173,6 +175,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Dec 9 2010 Panu Matilainen <pmatilai@redhat.com> - 3.7.4-1
|
||||||
|
- update to 3.7.4 (http://www.sqlite.org/releaselog/3_7_4.html)
|
||||||
|
- deal with upstream source naming, versioning and format changing
|
||||||
|
- fixup wal2-test expections wrt SQLITE_DISABLE_DIRSYNC use
|
||||||
|
|
||||||
* Fri Nov 5 2010 Dan Horák <dan[at]danny.cz> - 3.7.3-2
|
* Fri Nov 5 2010 Dan Horák <dan[at]danny.cz> - 3.7.3-2
|
||||||
- expect test failures also on s390x
|
- expect test failures also on s390x
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user