Updated to version 3.13.0
This commit is contained in:
parent
7bf18aa23a
commit
e4c2a64939
6
sources
6
sources
@ -1,3 +1,3 @@
|
|||||||
ad51fce1593191281c6eca810e0cc629 sqlite-src-3120200.zip
|
1184f80542c8e63dea5ba467c40b1220 sqlite-src-3130000.zip
|
||||||
8d4572295e17612b8f2e17ef60707ba4 sqlite-doc-3120200.zip
|
24e54c25ef018e3a26c8e101fab2515e sqlite-doc-3130000.zip
|
||||||
c552a133aca1ce1d647163d9e43bbcb1 sqlite-autoconf-3120200.tar.gz
|
4e83f39fa2ffb610ac5ecd36865da6a2 sqlite-autoconf-3130000.tar.gz
|
||||||
|
@ -13,7 +13,7 @@ diff -up sqlite-src-3120200/configure.ac.malloc_usable_size sqlite-src-3120200/c
|
|||||||
diff -up sqlite-src-3120200/configure.malloc_usable_size sqlite-src-3120200/configure
|
diff -up sqlite-src-3120200/configure.malloc_usable_size sqlite-src-3120200/configure
|
||||||
--- sqlite-src-3120200/configure.malloc_usable_size 2016-04-25 09:47:12.594679063 +0200
|
--- sqlite-src-3120200/configure.malloc_usable_size 2016-04-25 09:47:12.594679063 +0200
|
||||||
+++ sqlite-src-3120200/configure 2016-04-25 09:49:28.684615042 +0200
|
+++ sqlite-src-3120200/configure 2016-04-25 09:49:28.684615042 +0200
|
||||||
@@ -10273,7 +10273,7 @@ done
|
@@ -10275,7 +10275,7 @@ done
|
||||||
#########
|
#########
|
||||||
# Figure out whether or not we have these functions
|
# Figure out whether or not we have these functions
|
||||||
#
|
#
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
diff -up sqlite-3.6.23/tool/lemon.c.system-template sqlite-3.6.23/tool/lemon.c
|
diff -up sqlite-3.6.23/tool/lemon.c.system-template sqlite-3.6.23/tool/lemon.c
|
||||||
--- sqlite-3.6.23/tool/lemon.c.system-template 2010-03-10 16:40:35.000000000 +0200
|
--- sqlite-3.6.23/tool/lemon.c.system-template 2010-03-10 16:40:35.000000000 +0200
|
||||||
+++ sqlite-3.6.23/tool/lemon.c 2010-03-10 16:40:39.000000000 +0200
|
+++ sqlite-3.6.23/tool/lemon.c 2010-03-10 16:40:39.000000000 +0200
|
||||||
@@ -3106,6 +3106,8 @@ PRIVATE FILE *tplt_open(struct lemon *le
|
@@ -3363,6 +3363,8 @@ PRIVATE FILE *tplt_open(struct lemon *le
|
||||||
tpltname = buf;
|
tpltname = buf;
|
||||||
}else if( access(templatename,004)==0 ){
|
}else if( access(templatename,004)==0 ){
|
||||||
tpltname = templatename;
|
tpltname = templatename;
|
||||||
@ -10,7 +10,7 @@ diff -up sqlite-3.6.23/tool/lemon.c.system-template sqlite-3.6.23/tool/lemon.c
|
|||||||
}else{
|
}else{
|
||||||
tpltname = pathsearch(lemp->argv0,templatename,0);
|
tpltname = pathsearch(lemp->argv0,templatename,0);
|
||||||
}
|
}
|
||||||
@@ -3117,7 +3119,7 @@ PRIVATE FILE *tplt_open(struct lemon *le
|
@@ -3374,7 +3376,7 @@ PRIVATE FILE *tplt_open(struct lemon *le
|
||||||
}
|
}
|
||||||
in = fopen(tpltname,"rb");
|
in = fopen(tpltname,"rb");
|
||||||
if( in==0 ){
|
if( in==0 ){
|
||||||
|
@ -3,10 +3,10 @@ According to sqlite upstream[1], this should be fixed in tcl 8.6.5.
|
|||||||
|
|
||||||
[1] http://mailinglists.sqlite.org/cgi-bin/mailman/private/sqlite-users/2015-May/059518.html
|
[1] http://mailinglists.sqlite.org/cgi-bin/mailman/private/sqlite-users/2015-May/059518.html
|
||||||
|
|
||||||
diff -up sqlite-src-3081001/test/shell1.test.old sqlite-src-3081001/test/shell1.test
|
diff -up sqlite-src-3130000/test/shell1.test.orig sqlite-src-3130000/test/shell1.test
|
||||||
--- sqlite-src-3081001/test/shell1.test.old 2015-05-18 10:33:00.360463061 +0200
|
--- sqlite-src-3130000/test/shell1.test.orig 2016-05-24 17:46:53.447074482 +0200
|
||||||
+++ sqlite-src-3081001/test/shell1.test 2015-05-18 10:33:13.353532231 +0200
|
+++ sqlite-src-3130000/test/shell1.test 2016-05-24 17:48:20.951080978 +0200
|
||||||
@@ -863,59 +863,59 @@ do_test shell1-4.6 {
|
@@ -855,65 +855,65 @@ do_test shell1-4.6 {
|
||||||
|
|
||||||
# Test using arbitrary byte data with the shell via standard input/output.
|
# Test using arbitrary byte data with the shell via standard input/output.
|
||||||
#
|
#
|
||||||
@ -60,7 +60,12 @@ diff -up sqlite-src-3081001/test/shell1.test.old sqlite-src-3081001/test/shell1.
|
|||||||
- error "failed with error: $res"
|
- error "failed with error: $res"
|
||||||
- }
|
- }
|
||||||
- if {$res ne "$oldChar\n"} {
|
- if {$res ne "$oldChar\n"} {
|
||||||
- error "failed with byte $hex mismatch"
|
- if {[llength $res] > 0} {
|
||||||
|
- set got [format %02X [scan $res %c]]
|
||||||
|
- } else {
|
||||||
|
- set got <empty>
|
||||||
|
- }
|
||||||
|
- error "failed with byte $hex mismatch, got $got"
|
||||||
- }
|
- }
|
||||||
- }
|
- }
|
||||||
-} {}
|
-} {}
|
||||||
@ -114,9 +119,15 @@ diff -up sqlite-src-3081001/test/shell1.test.old sqlite-src-3081001/test/shell1.
|
|||||||
+# error "failed with error: $res"
|
+# error "failed with error: $res"
|
||||||
+# }
|
+# }
|
||||||
+# if {$res ne "$oldChar\n"} {
|
+# if {$res ne "$oldChar\n"} {
|
||||||
+# error "failed with byte $hex mismatch"
|
+# if {[llength $res] > 0} {
|
||||||
|
+# set got [format %02X [scan $res %c]]
|
||||||
|
+# } else {
|
||||||
|
+# set got <empty>
|
||||||
|
+# }
|
||||||
|
+# error "failed with byte $hex mismatch, got $got"
|
||||||
+# }
|
+# }
|
||||||
+# }
|
+# }
|
||||||
+#} {}
|
+#} {}
|
||||||
|
|
||||||
finish_test
|
# These test cases do not work on MinGW
|
||||||
|
if 0 {
|
||||||
|
@ -3,9 +3,9 @@
|
|||||||
%bcond_with static
|
%bcond_with static
|
||||||
%bcond_without check
|
%bcond_without check
|
||||||
|
|
||||||
%define realver 3120200
|
%define realver 3130000
|
||||||
%define docver 3120200
|
%define docver 3130000
|
||||||
%define rpmver 3.12.2
|
%define rpmver 3.13.0
|
||||||
|
|
||||||
Summary: Library that implements an embeddable SQL database engine
|
Summary: Library that implements an embeddable SQL database engine
|
||||||
Name: sqlite
|
Name: sqlite
|
||||||
@ -227,6 +227,9 @@ make test
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue May 24 2016 Jakub Dorňák <jdornak@redhat.com> - 3.13.0-1
|
||||||
|
- Updated to version 3.13.0 (https://sqlite.org/releaselog/3_13_0.html)
|
||||||
|
|
||||||
* Mon Apr 25 2016 Jakub Dorňák <jdornak@redhat.com> - 3.12.2-1
|
* Mon Apr 25 2016 Jakub Dorňák <jdornak@redhat.com> - 3.12.2-1
|
||||||
- Updated to version 3.12.2 (https://sqlite.org/releaselog/3_12_2.html)
|
- Updated to version 3.12.2 (https://sqlite.org/releaselog/3_12_2.html)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user