- update to 3.7.13 (http://www.sqlite.org/releaselog/3_7_13.html)
- drop no longer needed savepoint relase patch
This commit is contained in:
parent
9e4dd640a8
commit
d2196c88af
2
.gitignore
vendored
2
.gitignore
vendored
@ -17,3 +17,5 @@
|
|||||||
/sqlite-doc-3071000.zip
|
/sqlite-doc-3071000.zip
|
||||||
/sqlite-src-3071100.zip
|
/sqlite-src-3071100.zip
|
||||||
/sqlite-doc-3071100.zip
|
/sqlite-doc-3071100.zip
|
||||||
|
/sqlite-src-3071300.zip
|
||||||
|
/sqlite-doc-3071300.zip
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
73e2340ca2682ae914168d99c1f26e66 sqlite-src-3071100.zip
|
13bb3eaae94592ef3220ea23582763f5 sqlite-src-3071300.zip
|
||||||
c1fb48beff33612b2c7f5ae6ab17a601 sqlite-doc-3071100.zip
|
16a003d5a619a6c725e3d81cf5aaba2a sqlite-doc-3071300.zip
|
||||||
|
@ -1,22 +0,0 @@
|
|||||||
Index: src/vdbe.c
|
|
||||||
==================================================================
|
|
||||||
--- src/vdbe.c
|
|
||||||
+++ src/vdbe.c
|
|
||||||
@@ -2732,12 +2732,14 @@
|
|
||||||
}
|
|
||||||
db->isTransactionSavepoint = 0;
|
|
||||||
rc = p->rc;
|
|
||||||
}else{
|
|
||||||
iSavepoint = db->nSavepoint - iSavepoint - 1;
|
|
||||||
- for(ii=0; ii<db->nDb; ii++){
|
|
||||||
- sqlite3BtreeTripAllCursors(db->aDb[ii].pBt, SQLITE_ABORT);
|
|
||||||
+ if( p1==SAVEPOINT_ROLLBACK ){
|
|
||||||
+ for(ii=0; ii<db->nDb; ii++){
|
|
||||||
+ sqlite3BtreeTripAllCursors(db->aDb[ii].pBt, SQLITE_ABORT);
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
for(ii=0; ii<db->nDb; ii++){
|
|
||||||
rc = sqlite3BtreeSavepoint(db->aDb[ii].pBt, p1, iSavepoint);
|
|
||||||
if( rc!=SQLITE_OK ){
|
|
||||||
goto abort_due_to_error;
|
|
||||||
|
|
18
sqlite.spec
18
sqlite.spec
@ -3,14 +3,14 @@
|
|||||||
%bcond_with static
|
%bcond_with static
|
||||||
%bcond_without check
|
%bcond_without check
|
||||||
|
|
||||||
%define realver 3071100
|
%define realver 3071300
|
||||||
%define docver 3071100
|
%define docver 3071300
|
||||||
%define rpmver 3.7.11
|
%define rpmver 3.7.13
|
||||||
|
|
||||||
Summary: Library that implements an embeddable SQL database engine
|
Summary: Library that implements an embeddable SQL database engine
|
||||||
Name: sqlite
|
Name: sqlite
|
||||||
Version: %{rpmver}
|
Version: %{rpmver}
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: Public Domain
|
License: Public Domain
|
||||||
Group: Applications/Databases
|
Group: Applications/Databases
|
||||||
URL: http://www.sqlite.org/
|
URL: http://www.sqlite.org/
|
||||||
@ -28,9 +28,6 @@ Patch3: sqlite-3.7.10-pagecache-overflow-test.patch
|
|||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=801981
|
# https://bugzilla.redhat.com/show_bug.cgi?id=801981
|
||||||
# http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=665363
|
# http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=665363
|
||||||
Patch4: sqlite-3.7.11-no-malloc-usable-size.patch
|
Patch4: sqlite-3.7.11-no-malloc-usable-size.patch
|
||||||
# cherry-picked upstream fix fox #821642:
|
|
||||||
# http://www.sqlite.org/src/info/79a4a3a84f?sbs=0
|
|
||||||
Patch5: sqlite-3.7.11-savepoint-release.patch
|
|
||||||
BuildRequires: ncurses-devel readline-devel glibc-devel
|
BuildRequires: ncurses-devel readline-devel glibc-devel
|
||||||
%if %{with tcl}
|
%if %{with tcl}
|
||||||
BuildRequires: /usr/bin/tclsh
|
BuildRequires: /usr/bin/tclsh
|
||||||
@ -102,7 +99,6 @@ This package contains the tcl modules for %{name}.
|
|||||||
%patch2 -p1 -b .stupid-openfiles-test
|
%patch2 -p1 -b .stupid-openfiles-test
|
||||||
%patch3 -p1 -b .pagecache-overflow-test
|
%patch3 -p1 -b .pagecache-overflow-test
|
||||||
%patch4 -p1 -b .no-malloc-usable-size
|
%patch4 -p1 -b .no-malloc-usable-size
|
||||||
%patch5 -p0 -b .savepoint-release
|
|
||||||
|
|
||||||
# Remove cgi-script erroneously included in sqlite-doc-3070500
|
# Remove cgi-script erroneously included in sqlite-doc-3070500
|
||||||
rm -f %{name}-doc-%{realver}/search
|
rm -f %{name}-doc-%{realver}/search
|
||||||
@ -141,6 +137,8 @@ rm -f $RPM_BUILD_ROOT/%{_libdir}/*.{la,a}
|
|||||||
|
|
||||||
%if %{with check}
|
%if %{with check}
|
||||||
%check
|
%check
|
||||||
|
# XXX shell tests are broken due to loading system libsqlite3, work around...
|
||||||
|
export LD_LIBRARY_PATH=`pwd`/.libs
|
||||||
export MALLOC_CHECK_=3
|
export MALLOC_CHECK_=3
|
||||||
%ifarch s390 s390x ppc ppc64 %{sparc} %{arm}
|
%ifarch s390 s390x ppc ppc64 %{sparc} %{arm}
|
||||||
make test || :
|
make test || :
|
||||||
@ -189,6 +187,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 25 2012 Panu Matilainen <pmatilai@redhat.com> - 3.7.13-1
|
||||||
|
- update to 3.7.13 (http://www.sqlite.org/releaselog/3_7_13.html)
|
||||||
|
- drop no longer needed savepoint relase patch
|
||||||
|
|
||||||
* Fri Jun 01 2012 Panu Matilainen <pmatilai@redhat.com> - 3.7.11-3
|
* Fri Jun 01 2012 Panu Matilainen <pmatilai@redhat.com> - 3.7.11-3
|
||||||
- don't abort pending queries on release of nested savepoint (#821642)
|
- don't abort pending queries on release of nested savepoint (#821642)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user