- update to 3.7.14.1
This commit is contained in:
parent
7db5b83830
commit
d13a48a372
1
.gitignore
vendored
1
.gitignore
vendored
@ -21,3 +21,4 @@
|
||||
/sqlite-doc-3071300.zip
|
||||
/sqlite-doc-3071400.zip
|
||||
/sqlite-src-3071400.zip
|
||||
/sqlite-src-3071401.zip
|
||||
|
3
sources
3
sources
@ -1,2 +1 @@
|
||||
5eaeaa2d0aef3b2c980aa784846fd562 sqlite-doc-3071400.zip
|
||||
8d67486a003675f21f68014446e08748 sqlite-src-3071400.zip
|
||||
c594594be4c5353ceb43caade87ca7d6 sqlite-src-3071401.zip
|
||||
|
@ -1,24 +0,0 @@
|
||||
diff -up sqlite-src-3071100/configure.ac.malloc_usable_size sqlite-src-3071100/configure.ac
|
||||
--- sqlite-src-3071100/configure.ac.malloc_usable_size 2012-04-25 09:36:02.999684178 +0300
|
||||
+++ sqlite-src-3071100/configure.ac 2012-04-25 09:36:21.415584431 +0300
|
||||
@@ -127,7 +127,7 @@ AC_CHECK_HEADERS([sys/types.h stdlib.h s
|
||||
#########
|
||||
# Figure out whether or not we have these functions
|
||||
#
|
||||
-AC_CHECK_FUNCS([usleep fdatasync localtime_r gmtime_r localtime_s utime malloc_usable_size])
|
||||
+AC_CHECK_FUNCS([usleep fdatasync localtime_r gmtime_r localtime_s utime])
|
||||
|
||||
#########
|
||||
# By default, we use the amalgamation (this may be changed below...)
|
||||
diff -up sqlite-src-3071100/configure.malloc_usable_size sqlite-src-3071100/configure
|
||||
--- sqlite-src-3071100/configure.malloc_usable_size 2012-04-25 09:36:10.255643392 +0300
|
||||
+++ sqlite-src-3071100/configure 2012-04-25 09:36:37.684496632 +0300
|
||||
@@ -12148,7 +12148,7 @@ done
|
||||
|
||||
|
||||
|
||||
-for ac_func in usleep fdatasync localtime_r gmtime_r localtime_s utime malloc_usable_size
|
||||
+for ac_func in usleep fdatasync localtime_r gmtime_r localtime_s utime
|
||||
do
|
||||
as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
|
||||
{ $as_echo "$as_me:$LINENO: checking for $ac_func" >&5
|
24
sqlite-3.7.14.1-no-malloc-usable-size.patch
Normal file
24
sqlite-3.7.14.1-no-malloc-usable-size.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -up sqlite-src-3071401/configure.ac.no-malloc-usable-size sqlite-src-3071401/configure.ac
|
||||
--- sqlite-src-3071401/configure.ac.no-malloc-usable-size 2012-10-04 22:49:22.000000000 +0300
|
||||
+++ sqlite-src-3071401/configure.ac 2012-11-06 15:42:26.600210720 +0200
|
||||
@@ -127,7 +127,7 @@ AC_CHECK_HEADERS([sys/types.h stdlib.h s
|
||||
#########
|
||||
# Figure out whether or not we have these functions
|
||||
#
|
||||
-AC_CHECK_FUNCS([usleep fdatasync localtime_r gmtime_r localtime_s utime malloc_usable_size])
|
||||
+AC_CHECK_FUNCS([usleep fdatasync localtime_r gmtime_r localtime_s utime])
|
||||
|
||||
#########
|
||||
# By default, we use the amalgamation (this may be changed below...)
|
||||
diff -up sqlite-src-3071401/configure.no-malloc-usable-size sqlite-src-3071401/configure
|
||||
--- sqlite-src-3071401/configure.no-malloc-usable-size 2012-10-04 22:49:23.000000000 +0300
|
||||
+++ sqlite-src-3071401/configure 2012-11-06 15:44:51.278149624 +0200
|
||||
@@ -10293,7 +10293,7 @@ done
|
||||
#########
|
||||
# Figure out whether or not we have these functions
|
||||
#
|
||||
-for ac_func in usleep fdatasync localtime_r gmtime_r localtime_s utime malloc_usable_size
|
||||
+for ac_func in usleep fdatasync localtime_r gmtime_r localtime_s utime
|
||||
do :
|
||||
as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
|
||||
ac_fn_c_check_func "$LINENO" "$ac_func" "$as_ac_var"
|
@ -3,9 +3,9 @@
|
||||
%bcond_with static
|
||||
%bcond_without check
|
||||
|
||||
%define realver 3071400
|
||||
%define realver 3071401
|
||||
%define docver 3071400
|
||||
%define rpmver 3.7.14
|
||||
%define rpmver 3.7.14.1
|
||||
|
||||
Summary: Library that implements an embeddable SQL database engine
|
||||
Name: sqlite
|
||||
@ -27,7 +27,7 @@ Patch3: sqlite-3.7.10-pagecache-overflow-test.patch
|
||||
# sqlite >= 3.7.10 is buggy if malloc_usable_size() is detected, disable it:
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=801981
|
||||
# http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=665363
|
||||
Patch4: sqlite-3.7.11-no-malloc-usable-size.patch
|
||||
Patch4: sqlite-3.7.14.1-no-malloc-usable-size.patch
|
||||
BuildRequires: ncurses-devel readline-devel glibc-devel
|
||||
%if %{with tcl}
|
||||
BuildRequires: /usr/bin/tclsh
|
||||
@ -187,6 +187,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Nov 06 2012 Panu Matilainen <pmatilai@redhat.com> - 3.7.14.1-1
|
||||
- update to 3.7.14.1 (http://www.sqlite.org/releaselog/3_7_14_1.html)
|
||||
|
||||
* Wed Oct 03 2012 Panu Matilainen <pmatilai@redhat.com> - 3.7.14-1
|
||||
- update to 3.7.14 (http://www.sqlite.org/releaselog/3_7_14.html)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user