Updated to version 3.8.7 (http://sqlite.org/releaselog/3_8_7.html)
- Dropped patch for problem fixed upstream
This commit is contained in:
parent
7bea281fe2
commit
b275f4cd9b
2
.gitignore
vendored
2
.gitignore
vendored
@ -52,3 +52,5 @@
|
||||
/sqlite-doc-3080500.zip
|
||||
/sqlite-src-3080600.zip
|
||||
/sqlite-doc-3080600.zip
|
||||
/sqlite-src-3080700.zip
|
||||
/sqlite-doc-3080700.zip
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
ccac79fdcc5066b8221b606273142ae0 sqlite-src-3080600.zip
|
||||
e65b1a9569d3e3129538942255db0af1 sqlite-doc-3080600.zip
|
||||
a3a8a689c26bf99ba1dca78fb02c74c7 sqlite-src-3080700.zip
|
||||
d79dfd2505c57eff30df7b7395c2a0e9 sqlite-doc-3080700.zip
|
||||
|
@ -1,17 +0,0 @@
|
||||
diff -up sqlite-src-3071000/test/memsubsys1.test.testfail sqlite-src-3071000/test/memsubsys1.test
|
||||
--- sqlite-src-3071000/test/memsubsys1.test.testfail 2012-03-07 18:05:32.916081341 +0200
|
||||
+++ sqlite-src-3071000/test/memsubsys1.test 2012-03-07 18:06:43.354841101 +0200
|
||||
@@ -122,9 +122,10 @@ build_test_db memsubsys1-3.1 {PRAGMA pag
|
||||
do_test memsubsys1-3.1.3 {
|
||||
set pg_used [lindex [sqlite3_status SQLITE_STATUS_PAGECACHE_USED 0] 2]
|
||||
} 0
|
||||
-do_test memsubsys1-3.1.4 {
|
||||
- set overflow [lindex [sqlite3_status SQLITE_STATUS_PAGECACHE_OVERFLOW 0] 2]
|
||||
-} $max_pagecache
|
||||
+# The exact value returned here depends on compile options and whatnot, *shrug*
|
||||
+#do_test memsubsys1-3.1.4 {
|
||||
+# set overflow [lindex [sqlite3_status SQLITE_STATUS_PAGECACHE_OVERFLOW 0] 2]
|
||||
+#} $max_pagecache
|
||||
do_test memsubsys1-3.1.5 {
|
||||
set s_used [lindex [sqlite3_status SQLITE_STATUS_SCRATCH_USED 0] 2]
|
||||
} 0
|
25
sqlite.spec
25
sqlite.spec
@ -3,14 +3,14 @@
|
||||
%bcond_with static
|
||||
%bcond_without check
|
||||
|
||||
%define realver 3080600
|
||||
%define docver 3080600
|
||||
%define rpmver 3.8.6
|
||||
%define realver 3080700
|
||||
%define docver 3080700
|
||||
%define rpmver 3.8.7
|
||||
|
||||
Summary: Library that implements an embeddable SQL database engine
|
||||
Name: sqlite
|
||||
Version: %{rpmver}
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
License: Public Domain
|
||||
Group: Applications/Databases
|
||||
URL: http://www.sqlite.org/
|
||||
@ -21,16 +21,12 @@ Source1: http://www.sqlite.org/2013/sqlite-doc-%{docver}.zip
|
||||
Patch1: sqlite-3.6.23-lemon-system-template.patch
|
||||
# Shut up stupid tests depending on system settings of allowed open fd's
|
||||
Patch2: sqlite-3.7.7.1-stupid-openfiles-test.patch
|
||||
# Shut up pagecache overflow test whose expected result depends on compile
|
||||
# options and whatnot. Dunno why this started failing in 3.7.10 but
|
||||
# doesn't seem particularly critical...
|
||||
Patch3: sqlite-3.7.10-pagecache-overflow-test.patch
|
||||
# sqlite >= 3.7.10 is buggy if malloc_usable_size() is detected, disable it:
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=801981
|
||||
# http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=665363
|
||||
Patch4: sqlite-3.7.15-no-malloc-usable-size.patch
|
||||
Patch3: sqlite-3.7.15-no-malloc-usable-size.patch
|
||||
# Temporary workaround for failed percentile test, see patch for details
|
||||
Patch5: sqlite-3.8.0-percentile-test.patch
|
||||
Patch4: sqlite-3.8.0-percentile-test.patch
|
||||
|
||||
BuildRequires: ncurses-devel readline-devel glibc-devel
|
||||
BuildRequires: autoconf
|
||||
@ -115,9 +111,8 @@ This package contains the analysis program for %{name}.
|
||||
%setup -q -a1 -n %{name}-src-%{realver}
|
||||
%patch1 -p1 -b .lemon-system-template
|
||||
%patch2 -p1 -b .stupid-openfiles-test
|
||||
%patch3 -p1 -b .pagecache-overflow-test
|
||||
%patch4 -p1 -b .no-malloc-usable-size
|
||||
%patch5 -p1 -b .nonprecise-percentile-test
|
||||
%patch3 -p1 -b .no-malloc-usable-size
|
||||
%patch4 -p1 -b .nonprecise-percentile-test
|
||||
|
||||
# Remove cgi-script erroneously included in sqlite-doc-3070500
|
||||
rm -f %{name}-doc-%{realver}/search
|
||||
@ -209,6 +204,10 @@ make test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Oct 21 2014 Jan Stanek <jstanek@redhat.com> - 3.8.7-1
|
||||
- Updated to version 3.8.7 (http://sqlite.org/releaselog/3_8_7.html)
|
||||
- Dropped patch for problem fixed upstream
|
||||
|
||||
* Tue Aug 19 2014 Jan Stanek <jstanek@redhat.com> - 3.8.6-2
|
||||
- Added auto-selection of Tcl version based on Fedora version
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user