- update to 3.7.15
This commit is contained in:
parent
9b7e5c5bbd
commit
a795cf9dfc
2
.gitignore
vendored
2
.gitignore
vendored
@ -22,3 +22,5 @@
|
||||
/sqlite-doc-3071400.zip
|
||||
/sqlite-src-3071400.zip
|
||||
/sqlite-src-3071401.zip
|
||||
/sqlite-src-3071500.zip
|
||||
/sqlite-doc-3071500.zip
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
c594594be4c5353ceb43caade87ca7d6 sqlite-src-3071401.zip
|
||||
5eaeaa2d0aef3b2c980aa784846fd562 sqlite-doc-3071400.zip
|
||||
74797e4ba892862198a1a303a9cc5abd sqlite-src-3071500.zip
|
||||
8f936a1715ec6bbc65e95e0a4f127623 sqlite-doc-3071500.zip
|
||||
|
@ -1,24 +0,0 @@
|
||||
diff -up sqlite-src-3071401/configure.ac.no-malloc-usable-size sqlite-src-3071401/configure.ac
|
||||
--- sqlite-src-3071401/configure.ac.no-malloc-usable-size 2012-10-04 22:49:22.000000000 +0300
|
||||
+++ sqlite-src-3071401/configure.ac 2012-11-06 15:42:26.600210720 +0200
|
||||
@@ -127,7 +127,7 @@ AC_CHECK_HEADERS([sys/types.h stdlib.h s
|
||||
#########
|
||||
# Figure out whether or not we have these functions
|
||||
#
|
||||
-AC_CHECK_FUNCS([usleep fdatasync localtime_r gmtime_r localtime_s utime malloc_usable_size])
|
||||
+AC_CHECK_FUNCS([usleep fdatasync localtime_r gmtime_r localtime_s utime])
|
||||
|
||||
#########
|
||||
# By default, we use the amalgamation (this may be changed below...)
|
||||
diff -up sqlite-src-3071401/configure.no-malloc-usable-size sqlite-src-3071401/configure
|
||||
--- sqlite-src-3071401/configure.no-malloc-usable-size 2012-10-04 22:49:23.000000000 +0300
|
||||
+++ sqlite-src-3071401/configure 2012-11-06 15:44:51.278149624 +0200
|
||||
@@ -10293,7 +10293,7 @@ done
|
||||
#########
|
||||
# Figure out whether or not we have these functions
|
||||
#
|
||||
-for ac_func in usleep fdatasync localtime_r gmtime_r localtime_s utime malloc_usable_size
|
||||
+for ac_func in usleep fdatasync localtime_r gmtime_r localtime_s utime
|
||||
do :
|
||||
as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
|
||||
ac_fn_c_check_func "$LINENO" "$ac_func" "$as_ac_var"
|
24
sqlite-3.7.15-no-malloc-usable-size.patch
Normal file
24
sqlite-3.7.15-no-malloc-usable-size.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -up sqlite-src-3071500/configure.ac.malloc-usable-size sqlite-src-3071500/configure.ac
|
||||
--- sqlite-src-3071500/configure.ac.malloc-usable-size 2012-12-13 14:00:32.685869844 +0200
|
||||
+++ sqlite-src-3071500/configure.ac 2012-12-13 14:00:43.321830496 +0200
|
||||
@@ -127,7 +127,7 @@ AC_CHECK_HEADERS([sys/types.h stdlib.h s
|
||||
#########
|
||||
# Figure out whether or not we have these functions
|
||||
#
|
||||
-AC_CHECK_FUNCS([usleep fdatasync localtime_r gmtime_r localtime_s utime malloc_usable_size])
|
||||
+AC_CHECK_FUNCS([usleep fdatasync localtime_r gmtime_r localtime_s utime])
|
||||
|
||||
#########
|
||||
# By default, we use the amalgamation (this may be changed below...)
|
||||
diff -up sqlite-src-3071500/configure.malloc-usable-size sqlite-src-3071500/configure
|
||||
--- sqlite-src-3071500/configure.malloc-usable-size 2012-12-13 14:00:28.552884276 +0200
|
||||
+++ sqlite-src-3071500/configure 2012-12-13 14:00:54.720788024 +0200
|
||||
@@ -12147,7 +12147,7 @@ done
|
||||
|
||||
|
||||
|
||||
-for ac_func in usleep fdatasync localtime_r gmtime_r localtime_s utime malloc_usable_size
|
||||
+for ac_func in usleep fdatasync localtime_r gmtime_r localtime_s utime
|
||||
do
|
||||
as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
|
||||
{ $as_echo "$as_me:$LINENO: checking for $ac_func" >&5
|
11
sqlite.spec
11
sqlite.spec
@ -3,9 +3,9 @@
|
||||
%bcond_with static
|
||||
%bcond_without check
|
||||
|
||||
%define realver 3071401
|
||||
%define docver 3071400
|
||||
%define rpmver 3.7.14.1
|
||||
%define realver 3071500
|
||||
%define docver 3071500
|
||||
%define rpmver 3.7.15
|
||||
|
||||
Summary: Library that implements an embeddable SQL database engine
|
||||
Name: sqlite
|
||||
@ -27,7 +27,7 @@ Patch3: sqlite-3.7.10-pagecache-overflow-test.patch
|
||||
# sqlite >= 3.7.10 is buggy if malloc_usable_size() is detected, disable it:
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=801981
|
||||
# http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=665363
|
||||
Patch4: sqlite-3.7.14.1-no-malloc-usable-size.patch
|
||||
Patch4: sqlite-3.7.15-no-malloc-usable-size.patch
|
||||
BuildRequires: ncurses-devel readline-devel glibc-devel
|
||||
%if %{with tcl}
|
||||
BuildRequires: /usr/bin/tclsh
|
||||
@ -187,6 +187,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Dec 13 2012 Panu Matilainen <pmatilai@redhat.com> - 3.7.15-1
|
||||
- update to 3.7.15 (http://www.sqlite.org/releaselog/3_7_15.html)
|
||||
|
||||
* Tue Nov 06 2012 Panu Matilainen <pmatilai@redhat.com> - 3.7.14.1-1
|
||||
- update to 3.7.14.1 (http://www.sqlite.org/releaselog/3_7_14_1.html)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user