Update to 3.8.2 (http://www.sqlite.org/releaselog/3_8_2.html)
Removed patch already integrated into upstream
This commit is contained in:
parent
6ac28fc9c6
commit
3ccd3fa483
2
.gitignore
vendored
2
.gitignore
vendored
@ -38,3 +38,5 @@
|
|||||||
/sqlite-doc-3080002.zip
|
/sqlite-doc-3080002.zip
|
||||||
/sqlite-src-3080100.zip
|
/sqlite-src-3080100.zip
|
||||||
/sqlite-doc-3080100.zip
|
/sqlite-doc-3080100.zip
|
||||||
|
/sqlite-src-3080200.zip
|
||||||
|
/sqlite-doc-3080200.zip
|
||||||
|
@ -1,29 +0,0 @@
|
|||||||
From c098d918e1e19088be9659c409f1a6fa32b0efe6 Mon Sep 17 00:00:00 2001
|
|
||||||
From: "D. Richard Hipp" <drh@hwaci.com>
|
|
||||||
Date: Mon, 28 Oct 2013 20:15:56 +0000
|
|
||||||
Subject: [PATCH] Do not use transitive WHERE-clause constraints on LEFT JOINs.
|
|
||||||
Fix for ticket [c620261b5b5dc].
|
|
||||||
|
|
||||||
---
|
|
||||||
src/where.c | 5 ++++-
|
|
||||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/where.c b/src/where.c
|
|
||||||
index 266dc92..4868a7a 100644
|
|
||||||
--- a/src/where.c
|
|
||||||
+++ b/src/where.c
|
|
||||||
@@ -878,7 +878,10 @@ static WhereTerm *whereScanNext(WhereScan *pScan){
|
|
||||||
iColumn = pScan->aEquiv[pScan->iEquiv-1];
|
|
||||||
while( (pWC = pScan->pWC)!=0 ){
|
|
||||||
for(pTerm=pWC->a+k; k<pWC->nTerm; k++, pTerm++){
|
|
||||||
- if( pTerm->leftCursor==iCur && pTerm->u.leftColumn==iColumn ){
|
|
||||||
+ if( pTerm->leftCursor==iCur
|
|
||||||
+ && pTerm->u.leftColumn==iColumn
|
|
||||||
+ && (pScan->iEquiv<=2 || !ExprHasProperty(pTerm->pExpr, EP_FromJoin))
|
|
||||||
+ ){
|
|
||||||
if( (pTerm->eOperator & WO_EQUIV)!=0
|
|
||||||
&& pScan->nEquiv<ArraySize(pScan->aEquiv)
|
|
||||||
){
|
|
||||||
--
|
|
||||||
1.8.4.2
|
|
||||||
|
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
f05e46a9bea9f4be2165de2b425d0eed sqlite-src-3080100.zip
|
1d3c1046bcdb07d24a2c452ec2072199 sqlite-src-3080200.zip
|
||||||
283ae3e6cf78f0bb0c7a17b67129ef68 sqlite-doc-3080100.zip
|
4790bac23e7e4cbf6c1c040eee1bfdcc sqlite-doc-3080200.zip
|
||||||
|
14
sqlite.spec
14
sqlite.spec
@ -3,14 +3,14 @@
|
|||||||
%bcond_with static
|
%bcond_with static
|
||||||
%bcond_without check
|
%bcond_without check
|
||||||
|
|
||||||
%define realver 3080100
|
%define realver 3080200
|
||||||
%define docver 3080100
|
%define docver 3080200
|
||||||
%define rpmver 3.8.1
|
%define rpmver 3.8.2
|
||||||
|
|
||||||
Summary: Library that implements an embeddable SQL database engine
|
Summary: Library that implements an embeddable SQL database engine
|
||||||
Name: sqlite
|
Name: sqlite
|
||||||
Version: %{rpmver}
|
Version: %{rpmver}
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: Public Domain
|
License: Public Domain
|
||||||
Group: Applications/Databases
|
Group: Applications/Databases
|
||||||
URL: http://www.sqlite.org/
|
URL: http://www.sqlite.org/
|
||||||
@ -32,8 +32,6 @@ Patch4: sqlite-3.7.15-no-malloc-usable-size.patch
|
|||||||
Patch5: sqlite-3.7.16-man-missing-options.patch
|
Patch5: sqlite-3.7.16-man-missing-options.patch
|
||||||
# Temporary workaround for failed percentile test, see patch for details
|
# Temporary workaround for failed percentile test, see patch for details
|
||||||
Patch6: sqlite-3.8.0-percentile-test.patch
|
Patch6: sqlite-3.8.0-percentile-test.patch
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1034714
|
|
||||||
Patch7: 0001-Do-not-use-transitive-WHERE-clause-constraints-on-LE.patch
|
|
||||||
|
|
||||||
BuildRequires: ncurses-devel readline-devel glibc-devel
|
BuildRequires: ncurses-devel readline-devel glibc-devel
|
||||||
BuildRequires: autoconf
|
BuildRequires: autoconf
|
||||||
@ -109,7 +107,6 @@ This package contains the tcl modules for %{name}.
|
|||||||
%patch4 -p1 -b .no-malloc-usable-size
|
%patch4 -p1 -b .no-malloc-usable-size
|
||||||
%patch5 -p1 -b .man-missing-options
|
%patch5 -p1 -b .man-missing-options
|
||||||
%patch6 -p1 -b .nonprecise-percentile-test
|
%patch6 -p1 -b .nonprecise-percentile-test
|
||||||
%patch7 -p1 -b .transitive-where-clause-constraints
|
|
||||||
|
|
||||||
# Remove cgi-script erroneously included in sqlite-doc-3070500
|
# Remove cgi-script erroneously included in sqlite-doc-3070500
|
||||||
rm -f %{name}-doc-%{realver}/search
|
rm -f %{name}-doc-%{realver}/search
|
||||||
@ -200,6 +197,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Dec 10 2013 Jan Stanek <jstanek@redhat.com> - 3.8.2-1
|
||||||
|
- Update to 3.8.2 (http://www.sqlite.org/releaselog/3_8_2.html)
|
||||||
|
|
||||||
* Tue Nov 26 2013 Debarshi Ray <rishi@fedoraproject.org> - 3.8.1-2
|
* Tue Nov 26 2013 Debarshi Ray <rishi@fedoraproject.org> - 3.8.1-2
|
||||||
- Do not use transitive WHERE-clause constraints on LEFT JOINs (#1034714)
|
- Do not use transitive WHERE-clause constraints on LEFT JOINs (#1034714)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user