Update to 3.8.3 (http://www.sqlite.org/releaselog/3_8_3.html)
- Dropped man-page patch - included upstream
This commit is contained in:
parent
c79a6e8a65
commit
34d3e20fb9
2
.gitignore
vendored
2
.gitignore
vendored
@ -40,3 +40,5 @@
|
||||
/sqlite-doc-3080100.zip
|
||||
/sqlite-src-3080200.zip
|
||||
/sqlite-doc-3080200.zip
|
||||
/sqlite-src-3080300.zip
|
||||
/sqlite-doc-3080300.zip
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
1d3c1046bcdb07d24a2c452ec2072199 sqlite-src-3080200.zip
|
||||
4790bac23e7e4cbf6c1c040eee1bfdcc sqlite-doc-3080200.zip
|
||||
bdcac4ea67646e7d5a659b635f0639be sqlite-src-3080300.zip
|
||||
627f0a147e06be8b8205bc36151d7ae0 sqlite-doc-3080300.zip
|
||||
|
@ -1,59 +0,0 @@
|
||||
diff -up sqlite-src-3071602/sqlite3.1.broken sqlite-src-3071602/sqlite3.1
|
||||
--- sqlite-src-3071602/sqlite3.1.broken 2013-05-16 14:30:05.985387506 +0200
|
||||
+++ sqlite-src-3071602/sqlite3.1 2013-05-16 14:43:37.434861289 +0200
|
||||
@@ -147,7 +147,7 @@ sqlite>
|
||||
.B sqlite3
|
||||
has the following options:
|
||||
.TP
|
||||
-.BI \-init\ file
|
||||
+.BI \-init\ file
|
||||
Read and execute commands from
|
||||
.I file
|
||||
, which can contain a mix of SQL statements and meta-commands.
|
||||
@@ -158,11 +158,28 @@ Print commands before execution.
|
||||
.B \-[no]header
|
||||
Turn headers on or off.
|
||||
.TP
|
||||
+.B \-bail
|
||||
+Stop after hitting an error.
|
||||
+.TP
|
||||
+.B \-interactive
|
||||
+Force interactive I/O.
|
||||
+.TP
|
||||
+.B \-batch
|
||||
+Force batch I/O.
|
||||
+.TP
|
||||
.B \-column
|
||||
Query results will be displayed in a table like form, using
|
||||
whitespace characters to separate the columns and align the
|
||||
output.
|
||||
.TP
|
||||
+.BI \-cmd\ command
|
||||
+Run
|
||||
+.I command
|
||||
+before reading stdin.
|
||||
+.TP
|
||||
+.B \-csv
|
||||
+Set output mode to CSV (comma separated values).
|
||||
+.TP
|
||||
.B \-html
|
||||
Query results will be output as simple HTML tables.
|
||||
.TP
|
||||
@@ -182,9 +199,17 @@ Set output field separator. Default is
|
||||
Set string used to represent NULL values. Default is ''
|
||||
(empty string).
|
||||
.TP
|
||||
+.B \-stats
|
||||
+Print memory stats before each finalize.
|
||||
+.TP
|
||||
.B \-version
|
||||
Show SQLite version.
|
||||
.TP
|
||||
+.BI \-vfs\ name
|
||||
+Use
|
||||
+.I name
|
||||
+as the default VFS.
|
||||
+.TP
|
||||
.B \-help
|
||||
Show help on options and exit.
|
||||
|
19
sqlite.spec
19
sqlite.spec
@ -3,14 +3,14 @@
|
||||
%bcond_with static
|
||||
%bcond_without check
|
||||
|
||||
%define realver 3080200
|
||||
%define docver 3080200
|
||||
%define rpmver 3.8.2
|
||||
%define realver 3080300
|
||||
%define docver 3080300
|
||||
%define rpmver 3.8.3
|
||||
|
||||
Summary: Library that implements an embeddable SQL database engine
|
||||
Name: sqlite
|
||||
Version: %{rpmver}
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
License: Public Domain
|
||||
Group: Applications/Databases
|
||||
URL: http://www.sqlite.org/
|
||||
@ -28,10 +28,8 @@ Patch3: sqlite-3.7.10-pagecache-overflow-test.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=801981
|
||||
# http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=665363
|
||||
Patch4: sqlite-3.7.15-no-malloc-usable-size.patch
|
||||
# Man page completion
|
||||
Patch5: sqlite-3.7.16-man-missing-options.patch
|
||||
# Temporary workaround for failed percentile test, see patch for details
|
||||
Patch6: sqlite-3.8.0-percentile-test.patch
|
||||
Patch5: sqlite-3.8.0-percentile-test.patch
|
||||
|
||||
BuildRequires: ncurses-devel readline-devel glibc-devel
|
||||
BuildRequires: autoconf
|
||||
@ -105,8 +103,7 @@ This package contains the tcl modules for %{name}.
|
||||
%patch2 -p1 -b .stupid-openfiles-test
|
||||
%patch3 -p1 -b .pagecache-overflow-test
|
||||
%patch4 -p1 -b .no-malloc-usable-size
|
||||
%patch5 -p1 -b .man-missing-options
|
||||
%patch6 -p1 -b .nonprecise-percentile-test
|
||||
%patch5 -p1 -b .nonprecise-percentile-test
|
||||
|
||||
# Remove cgi-script erroneously included in sqlite-doc-3070500
|
||||
rm -f %{name}-doc-%{realver}/search
|
||||
@ -197,6 +194,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Feb 11 2014 Jan Stanek <jstanek@redhat.com> 3.8.3-1
|
||||
- Update to 3.8.3 (http://www.sqlite.org/releaselog/3_8_3.html)
|
||||
- Dropped man-page patch - included upstream
|
||||
|
||||
* Mon Jan 6 2014 Peter Robinson <pbrobinson@fedoraproject.org> 3.8.2-2
|
||||
- Add aarch64 to all the other arch excludes for tests
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user