- update to 3.7.7.1
- autoconf no longer needed for build, libdl check finally upstreamed - nodirsync test-suite fiddling no longer seems necessary - update the broken oserror test patch to apply
This commit is contained in:
parent
cec0a298b8
commit
30d0e9aa29
2
.gitignore
vendored
2
.gitignore
vendored
@ -7,3 +7,5 @@
|
||||
/sqlite-src-3070602.zip
|
||||
/sqlite-doc-3070600.zip
|
||||
/sqlite-src-3070603.zip
|
||||
/sqlite-src-3070701.zip
|
||||
/sqlite-doc-3070701.zip
|
||||
|
2
sources
2
sources
@ -1,3 +1,5 @@
|
||||
1ee582b962d3408b5825bffd404b3d33 sqlite-src-3070602.zip
|
||||
1c9b9da6f98f1da2d8958254662c393c sqlite-doc-3070600.zip
|
||||
f8e22ec0931c91f029d539fe3f5ef0f9 sqlite-src-3070603.zip
|
||||
9162803d0a82421a2df9d907e721a758 sqlite-src-3070701.zip
|
||||
2bca5613abf9352bc525b6a8fd80156e sqlite-doc-3070701.zip
|
||||
|
@ -1,11 +0,0 @@
|
||||
diff -up sqlite-3.6.4/configure.ac.orig sqlite-3.6.4/configure.ac
|
||||
--- sqlite-3.6.4/configure.ac.orig 2008-11-08 11:37:15.000000000 +0200
|
||||
+++ sqlite-3.6.4/configure.ac 2008-11-08 11:35:50.000000000 +0200
|
||||
@@ -606,6 +606,7 @@ AC_ARG_ENABLE(load-extension, AC_HELP_ST
|
||||
[use_loadextension=$enableval],[use_loadextension=no])
|
||||
if test "${use_loadextension}" = "yes" ; then
|
||||
OPT_FEATURE_FLAGS=""
|
||||
+ AC_SEARCH_LIBS(dlopen, [dl])
|
||||
else
|
||||
OPT_FEATURE_FLAGS="-DSQLITE_OMIT_LOAD_EXTENSION=1"
|
||||
fi
|
@ -1,16 +0,0 @@
|
||||
diff -up sqlite-src-3070400/test/wal2.test.nodirsync sqlite-src-3070400/test/wal2.test
|
||||
--- sqlite-src-3070400/test/wal2.test.nodirsync 2010-12-09 13:49:43.000000000 +0200
|
||||
+++ sqlite-src-3070400/test/wal2.test 2010-12-09 13:57:57.000000000 +0200
|
||||
@@ -1160,9 +1160,9 @@ if {$::tcl_platform(platform) == "unix"}
|
||||
# Test that "PRAGMA checkpoint_fullsync" appears to be working.
|
||||
#
|
||||
foreach {tn sql reslist} {
|
||||
- 1 { } {8 0 3 0 5 0}
|
||||
- 2 { PRAGMA checkpoint_fullfsync = 1 } {8 4 3 2 5 2}
|
||||
- 3 { PRAGMA checkpoint_fullfsync = 0 } {8 0 3 0 5 0}
|
||||
+ 1 { } {7 0 3 0 5 0}
|
||||
+ 2 { PRAGMA checkpoint_fullfsync = 1 } {7 4 3 2 5 2}
|
||||
+ 3 { PRAGMA checkpoint_fullfsync = 0 } {7 0 3 0 5 0}
|
||||
} {
|
||||
faultsim_delete_and_reopen
|
||||
|
@ -1,10 +1,11 @@
|
||||
diff -up sqlite-src-3070602/test/oserror.test.openfiles sqlite-src-3070602/test/oserror.test
|
||||
--- sqlite-src-3070602/test/oserror.test.openfiles 2011-04-29 13:23:00.000000000 +0300
|
||||
+++ sqlite-src-3070602/test/oserror.test 2011-04-29 13:24:26.000000000 +0300
|
||||
@@ -51,18 +51,18 @@ proc do_re_test {tn script expression} {
|
||||
diff -up sqlite-src-3070701/test/oserror.test.openfiles sqlite-src-3070701/test/oserror.test
|
||||
--- sqlite-src-3070701/test/oserror.test.openfiles 2011-07-13 09:56:46.025857411 +0300
|
||||
+++ sqlite-src-3070701/test/oserror.test 2011-07-13 09:57:11.634759798 +0300
|
||||
@@ -51,19 +51,19 @@ proc do_re_test {tn script expression} {
|
||||
# a call to getcwd() may fail if there are no free file descriptors. So
|
||||
# an error may be reported for either open() or getcwd() here.
|
||||
#
|
||||
-puts "Possible valgrind error about invalid file descriptor follows:"
|
||||
-do_test 1.1.1 {
|
||||
- set ::log [list]
|
||||
- list [catch {
|
||||
@ -17,6 +18,7 @@ diff -up sqlite-src-3070602/test/oserror.test.openfiles sqlite-src-3070602/test/
|
||||
-do_re_test 1.1.3 {
|
||||
- lindex $::log 0
|
||||
-} {^os_unix.c:\d+: \(\d+\) (open|getcwd)\(.*test.db\) - }
|
||||
+#puts "Possible valgrind error about invalid file descriptor follows:"
|
||||
+#do_test 1.1.1 {
|
||||
+# set ::log [list]
|
||||
+# list [catch {
|
25
sqlite.spec
25
sqlite.spec
@ -3,8 +3,8 @@
|
||||
%bcond_with static
|
||||
%bcond_without check
|
||||
|
||||
%define realver 3070603
|
||||
%define docver 3070600
|
||||
%define realver 3070701
|
||||
%define docver 3070701
|
||||
%define rpmver %(echo %{realver}|sed -e "s/00//g" -e "s/0/./g")
|
||||
|
||||
Summary: Library that implements an embeddable SQL database engine
|
||||
@ -16,17 +16,11 @@ Group: Applications/Databases
|
||||
URL: http://www.sqlite.org/
|
||||
Source0: http://www.sqlite.org/sqlite-src-%{realver}.zip
|
||||
Source1: http://www.sqlite.org/sqlite-doc-%{docver}.zip
|
||||
# Fix build with --enable-load-extension, upstream ticket #3137
|
||||
Patch1: sqlite-3.6.12-libdl.patch
|
||||
# Support a system-wide lemon template
|
||||
Patch2: sqlite-3.6.23-lemon-system-template.patch
|
||||
# Fixup test-suite expectations wrt SQLITE_DISABLE_DIRSYNC
|
||||
Patch3: sqlite-3.7.4-wal2-nodirsync.patch
|
||||
Patch1: sqlite-3.6.23-lemon-system-template.patch
|
||||
# Shut up stupid tests depending on system settings of allowed open fd's
|
||||
Patch4: sqlite-3.7.6-stupid-openfiles-test.patch
|
||||
Patch2: sqlite-3.7.7.1-stupid-openfiles-test.patch
|
||||
BuildRequires: ncurses-devel readline-devel glibc-devel
|
||||
# libdl patch needs
|
||||
BuildRequires: autoconf
|
||||
%if %{with tcl}
|
||||
BuildRequires: /usr/bin/tclsh
|
||||
BuildRequires: tcl-devel
|
||||
@ -93,16 +87,13 @@ This package contains the tcl modules for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q -a1 -n %{name}-src-%{realver}
|
||||
%patch1 -p1 -b .libdl
|
||||
%patch2 -p1 -b .lemon-system-template
|
||||
%patch3 -p1 -b .wal2-nodirsync
|
||||
%patch4 -p1 -b .stupid-openfiles-test
|
||||
%patch1 -p1 -b .lemon-system-template
|
||||
%patch2 -p1 -b .stupid-openfiles-test
|
||||
|
||||
# Remove cgi-script erroneously included in sqlite-doc-3070500
|
||||
rm -f %{name}-doc-%{realver}/search
|
||||
|
||||
%build
|
||||
autoconf
|
||||
export CFLAGS="$RPM_OPT_FLAGS -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1 -DSQLITE_SECURE_DELETE=1 -DSQLITE_ENABLE_UNLOCK_NOTIFY=1 -Wall -fno-strict-aliasing"
|
||||
%configure %{!?with_tcl:--disable-tcl} \
|
||||
--enable-threadsafe \
|
||||
@ -183,6 +174,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Jul 13 2011 Panu Matilainen <pmatilai@redhat.com> - 3.7.7.1-1
|
||||
- update to 3.7.7.1 (http://www.sqlite.org/releaselog/3_7_7_1.html)
|
||||
- autoconf no longer needed for build, libdl check finally upstreamed
|
||||
|
||||
* Wed May 25 2011 Panu Matilainen <pmatilai@redhat.com> - 3.7.6.3-1
|
||||
- update to 3.7.6.3 (http://www.sqlite.org/releaselog/3_7_6_3.html)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user