Updated to version 3.29.0 (https://sqlite.org/releaselog/3_29_0.html)
Remove stupid-openfiles-test patch as the upstream test should now work properly even on systems with larger number of file descriptors Related: https://sqlite.org/src/info/a27b0b880d76c683
This commit is contained in:
parent
709ff94d3e
commit
2474f1a528
6
sources
6
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (sqlite-src-3280000.zip) = 49c35c65fa686a2326e13218db583c54fa5fe8f48f0caddd11a942601803b3023f7d32ffbab16641e0d72dc9ed288ad26eaa7226c865ac54e1f181859125651f
|
SHA512 (sqlite-src-3290000.zip) = 575398fbe20c6471ee2abcbde170b8d48efbb3cb2716a65f42f05c52429a45d14e8046e50c59bbf75bfe2d8f151c34abd50b440c50af571f19e19f3290b230df
|
||||||
SHA512 (sqlite-doc-3280000.zip) = 83e23dff00614d31d501c66c29d8d4aa780b38859242b58937243235d185fe3db2f9f3c1accf9bf2df0b457a6e32612a00e82f503a8665aad4f19602e2b36396
|
SHA512 (sqlite-doc-3290000.zip) = ca856cf250e395d9c7e9817337adb5a16b1d96a20548a4010f5137188d35bb9d49a4a6da47bf2a696deffa68d2976dbb35a036adce19b8320e0e286876ac094f
|
||||||
SHA512 (sqlite-autoconf-3280000.tar.gz) = e800c0d9e6c8c01ccf1d714c6c4da4b98e9610c4c06557dda6393d0792a8ae09788703d4a74dcb21844c49b3629ff7ed95a4a86ff79872aafd2b49c672c7a570
|
SHA512 (sqlite-autoconf-3290000.tar.gz) = 85dcaa72cc2476c628e801d4ce46cf10ed8997f56cb0334062df5553f18c29d607883a1049bf75258204f2f53a29a02a01f014dcca383b05dfac1e2123778024
|
||||||
|
@ -1,37 +0,0 @@
|
|||||||
--- sqlite-src-3240000/test/oserror.test.old 2018-06-05 08:40:35.656122573 +0200
|
|
||||||
+++ sqlite-src-3240000/test/oserror.test 2018-06-05 08:40:45.614935197 +0200
|
|
||||||
@@ -51,20 +51,20 @@
|
|
||||||
# a call to getcwd() may fail if there are no free file descriptors. So
|
|
||||||
# an error may be reported for either open() or getcwd() here.
|
|
||||||
#
|
|
||||||
-if {![clang_sanitize_address]} {
|
|
||||||
- do_test 1.1.1 {
|
|
||||||
- set ::log [list]
|
|
||||||
- list [catch {
|
|
||||||
- for {set i 0} {$i < 20000} {incr i} { sqlite3 dbh_$i test.db -readonly 1 }
|
|
||||||
- } msg] $msg
|
|
||||||
- } {1 {unable to open database file}}
|
|
||||||
- do_test 1.1.2 {
|
|
||||||
- catch { for {set i 0} {$i < 20000} {incr i} { dbh_$i close } }
|
|
||||||
- } {1}
|
|
||||||
- do_re_test 1.1.3 {
|
|
||||||
- lindex $::log 0
|
|
||||||
- } {^os_unix.c:\d+: \(\d+\) (open|getcwd)\(.*test.db\) - }
|
|
||||||
-}
|
|
||||||
+#if {![clang_sanitize_address]} {
|
|
||||||
+# do_test 1.1.1 {
|
|
||||||
+# set ::log [list]
|
|
||||||
+# list [catch {
|
|
||||||
+# for {set i 0} {$i < 20000} {incr i} { sqlite3 dbh_$i test.db -readonly 1 }
|
|
||||||
+# } msg] $msg
|
|
||||||
+# } {1 {unable to open database file}}
|
|
||||||
+# do_test 1.1.2 {
|
|
||||||
+# catch { for {set i 0} {$i < 20000} {incr i} { dbh_$i close } }
|
|
||||||
+# } {1}
|
|
||||||
+# do_re_test 1.1.3 {
|
|
||||||
+# lindex $::log 0
|
|
||||||
+# } {^os_unix.c:\d+: \(\d+\) (open|getcwd)\(.*test.db\) - }
|
|
||||||
+#}
|
|
||||||
|
|
||||||
|
|
||||||
# Test a failure in open() due to the path being a directory.
|
|
21
sqlite.spec
21
sqlite.spec
@ -3,9 +3,9 @@
|
|||||||
%bcond_with static
|
%bcond_with static
|
||||||
%bcond_without check
|
%bcond_without check
|
||||||
|
|
||||||
%define realver 3280000
|
%define realver 3290000
|
||||||
%define docver 3280000
|
%define docver 3290000
|
||||||
%define rpmver 3.28.0
|
%define rpmver 3.29.0
|
||||||
|
|
||||||
Summary: Library that implements an embeddable SQL database engine
|
Summary: Library that implements an embeddable SQL database engine
|
||||||
Name: sqlite
|
Name: sqlite
|
||||||
@ -14,13 +14,11 @@ Release: 1%{?dist}
|
|||||||
License: Public Domain
|
License: Public Domain
|
||||||
URL: http://www.sqlite.org/
|
URL: http://www.sqlite.org/
|
||||||
|
|
||||||
Source0: http://www.sqlite.org/2018/sqlite-src-%{realver}.zip
|
Source0: http://www.sqlite.org/2019/sqlite-src-%{realver}.zip
|
||||||
Source1: http://www.sqlite.org/2018/sqlite-doc-%{docver}.zip
|
Source1: http://www.sqlite.org/2019/sqlite-doc-%{docver}.zip
|
||||||
Source2: http://www.sqlite.org/2018/sqlite-autoconf-%{realver}.tar.gz
|
Source2: http://www.sqlite.org/2019/sqlite-autoconf-%{realver}.tar.gz
|
||||||
# Support a system-wide lemon template
|
# Support a system-wide lemon template
|
||||||
Patch1: sqlite-3.6.23-lemon-system-template.patch
|
Patch1: sqlite-3.6.23-lemon-system-template.patch
|
||||||
# Shut up stupid tests depending on system settings of allowed open fd's
|
|
||||||
Patch2: sqlite-3.7.7.1-stupid-openfiles-test.patch
|
|
||||||
# sqlite >= 3.7.10 is buggy if malloc_usable_size() is detected, disable it:
|
# sqlite >= 3.7.10 is buggy if malloc_usable_size() is detected, disable it:
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=801981
|
# https://bugzilla.redhat.com/show_bug.cgi?id=801981
|
||||||
# http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=665363
|
# http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=665363
|
||||||
@ -121,7 +119,6 @@ This package contains the analysis program for %{name}.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -a1 -n %{name}-src-%{realver}
|
%setup -q -a1 -n %{name}-src-%{realver}
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
|
||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
%patch4 -p1
|
%patch4 -p1
|
||||||
%ifarch %{ix86}
|
%ifarch %{ix86}
|
||||||
@ -232,6 +229,12 @@ make test
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 16 2019 Petr Kubat <pkubat@redhat.com> - 3.29.0-1
|
||||||
|
- Updated to version 3.29.0 (https://sqlite.org/releaselog/3_29_0.html)
|
||||||
|
- Remove stupid-openfiles-test patch as the upstream test should now
|
||||||
|
work properly even on systems with larger number of file descriptors
|
||||||
|
Related: https://sqlite.org/src/info/a27b0b880d76c683
|
||||||
|
|
||||||
* Mon May 13 2019 Petr Kubat <pkubat@redhat.com> - 3.28.0-1
|
* Mon May 13 2019 Petr Kubat <pkubat@redhat.com> - 3.28.0-1
|
||||||
- Updated to version 3.28.0 (https://sqlite.org/releaselog/3_28_0.html)
|
- Updated to version 3.28.0 (https://sqlite.org/releaselog/3_28_0.html)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user