Update to version 3.8.5 (http://www.sqlite.org/releaselog/3_8_5.html)
- Dropped patch already included upstream
This commit is contained in:
parent
052da49995
commit
129d97d351
2
.gitignore
vendored
2
.gitignore
vendored
@ -48,3 +48,5 @@
|
||||
/sqlite-doc-3080402.zip
|
||||
/sqlite-src-3080403.zip
|
||||
/sqlite-doc-3080403.zip
|
||||
/sqlite-src-3080500.zip
|
||||
/sqlite-doc-3080500.zip
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
34cd453499e4b4564560accf24a9a70e sqlite-src-3080403.zip
|
||||
22e623b68930d0e30ab82614a6ae832b sqlite-doc-3080403.zip
|
||||
b44d4f66345ac34a880cbb4a68108ae6 sqlite-src-3080500.zip
|
||||
9c5771e654ca21a9023bc330b379e793 sqlite-doc-3080500.zip
|
||||
|
@ -1,41 +0,0 @@
|
||||
Upstream fix for the issue that caused nautilus to crash.
|
||||
RHBZ: #1075889
|
||||
|
||||
--- src/where.c
|
||||
+++ src/where.c
|
||||
@@ -4855,18 +4855,10 @@
|
||||
** rowid appears in the ORDER BY clause, the corresponding WhereLoop is
|
||||
** automatically order-distinct.
|
||||
*/
|
||||
|
||||
assert( pOrderBy!=0 );
|
||||
-
|
||||
- /* Sortability of virtual tables is determined by the xBestIndex method
|
||||
- ** of the virtual table itself */
|
||||
- if( pLast->wsFlags & WHERE_VIRTUALTABLE ){
|
||||
- testcase( nLoop>0 ); /* True when outer loops are one-row and match
|
||||
- ** no ORDER BY terms */
|
||||
- return pLast->u.vtab.isOrdered;
|
||||
- }
|
||||
if( nLoop && OptimizationDisabled(db, SQLITE_OrderByIdxJoin) ) return 0;
|
||||
|
||||
nOrderBy = pOrderBy->nExpr;
|
||||
testcase( nOrderBy==BMS-1 );
|
||||
if( nOrderBy>BMS-1 ) return 0; /* Cannot optimize overly large ORDER BYs */
|
||||
@@ -4875,11 +4867,14 @@
|
||||
orderDistinctMask = 0;
|
||||
ready = 0;
|
||||
for(iLoop=0; isOrderDistinct && obSat<obDone && iLoop<=nLoop; iLoop++){
|
||||
if( iLoop>0 ) ready |= pLoop->maskSelf;
|
||||
pLoop = iLoop<nLoop ? pPath->aLoop[iLoop] : pLast;
|
||||
- assert( (pLoop->wsFlags & WHERE_VIRTUALTABLE)==0 );
|
||||
+ if( pLoop->wsFlags & WHERE_VIRTUALTABLE ){
|
||||
+ if( pLoop->u.vtab.isOrdered ) obSat = obDone;
|
||||
+ break;
|
||||
+ }
|
||||
iCur = pWInfo->pTabList->a[pLoop->iTab].iCursor;
|
||||
|
||||
/* Mark off any ORDER BY term X that is a column in the table of
|
||||
** the current loop for which there is term in the WHERE
|
||||
** clause of the form X IS NULL or X=? that reference only outer
|
||||
|
14
sqlite.spec
14
sqlite.spec
@ -3,14 +3,14 @@
|
||||
%bcond_with static
|
||||
%bcond_without check
|
||||
|
||||
%define realver 3080403
|
||||
%define docver 3080403
|
||||
%define rpmver 3.8.4.3
|
||||
%define realver 3080500
|
||||
%define docver 3080500
|
||||
%define rpmver 3.8.5
|
||||
|
||||
Summary: Library that implements an embeddable SQL database engine
|
||||
Name: sqlite
|
||||
Version: %{rpmver}
|
||||
Release: 5%{?dist}
|
||||
Release: 1%{?dist}
|
||||
License: Public Domain
|
||||
Group: Applications/Databases
|
||||
URL: http://www.sqlite.org/
|
||||
@ -31,7 +31,6 @@ Patch3: sqlite-3.7.10-pagecache-overflow-test.patch
|
||||
Patch4: sqlite-3.7.15-no-malloc-usable-size.patch
|
||||
# Temporary workaround for failed percentile test, see patch for details
|
||||
Patch5: sqlite-3.8.0-percentile-test.patch
|
||||
Patch6: sqlite-bug1075889.patch
|
||||
|
||||
BuildRequires: ncurses-devel readline-devel glibc-devel
|
||||
BuildRequires: autoconf
|
||||
@ -114,7 +113,6 @@ This package contains the analysis program for %{name}.
|
||||
%patch3 -p1 -b .pagecache-overflow-test
|
||||
%patch4 -p1 -b .no-malloc-usable-size
|
||||
%patch5 -p1 -b .nonprecise-percentile-test
|
||||
%patch6 -b .bug1075889
|
||||
|
||||
# Remove cgi-script erroneously included in sqlite-doc-3070500
|
||||
rm -f %{name}-doc-%{realver}/search
|
||||
@ -206,6 +204,10 @@ make test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Jun 10 2014 Jan Stanek <jstanek@redhat.com> - 3.8.5-1
|
||||
- Update to version 3.8.5 (http://www.sqlite.org/releaselog/3_8_5.html)
|
||||
- Dropped patch already included upstream
|
||||
|
||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.8.4.3-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user