Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/sqlite.git#ee088db164d9767dab3e4bb58ef39cbb053986a6
This commit is contained in:
parent
9ec1bf0701
commit
0fd3682e46
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (sqlite-src-3330000.zip) = 3260e3e03ee2f6a4ff2bc4ea4bada5a1497afeca33878c155a8005824970c6c1eb8a2db58eb3023cab084af475fadb81d1c3c9892ae92c07f884881e6602e173
|
||||
SHA512 (sqlite-doc-3330000.zip) = 14a3cccb4ff6af57738990eeadd37a1b827f89c9c1b16201c62ca5bb9301d39223d48677b9c269ce332210e5c9ae3f42aa0f9de7d79b38acb9809c732d038368
|
||||
SHA512 (sqlite-autoconf-3330000.tar.gz) = c0d79d4012a01f12128ab5044b887576a130663245b85befcc0ab82ad3a315dd1e7f54b6301f842410c9c21b73237432c44a1d7c2fe0e0709435fec1f1a20a11
|
||||
SHA512 (sqlite-src-3340000.zip) = 520fbca59da02452e2861a140bde891aedfc8254eafaa6894e8d845369d60d6a921595a411efb2611c0f7b0cadd69a713dcdaaeaad1e4254e9fd9a6efde07f91
|
||||
SHA512 (sqlite-doc-3340000.zip) = 1bdf20030e656ec4ce38a264c8ef7a95c9f2731cd7d756a44b35b6c68827e8aba92018007139ee09d1c27b34bcd72bff1a201dc3f30aa13e96120af5d58e835e
|
||||
SHA512 (sqlite-autoconf-3340000.tar.gz) = 75a1a2d86ab41354941b8574e780b1eae09c3c01f8da4b08f606b96962b80550f739ec7e9b1ceb07bba1cedced6d18a1408e4c10ff645eb1829d368ad308cf2f
|
||||
|
@ -1,21 +1,13 @@
|
||||
diff -up sqlite-3.6.23/tool/lemon.c.system-template sqlite-3.6.23/tool/lemon.c
|
||||
--- sqlite-3.6.23/tool/lemon.c.system-template 2010-03-10 16:40:35.000000000 +0200
|
||||
+++ sqlite-3.6.23/tool/lemon.c 2010-03-10 16:40:39.000000000 +0200
|
||||
@@ -3363,6 +3363,8 @@ PRIVATE FILE *tplt_open(struct lemon *le
|
||||
diff --git a/tool/lemon.c b/tool/lemon.c
|
||||
index 54c8946..ac14a06 100644
|
||||
--- a/tool/lemon.c
|
||||
+++ b/tool/lemon.c
|
||||
@@ -3668,6 +3668,8 @@ PRIVATE FILE *tplt_open(struct lemon *lemp)
|
||||
tpltname = buf;
|
||||
}else if( access(templatename,004)==0 ){
|
||||
tpltname = templatename;
|
||||
+ }else if( access("/usr/share/lemon/lempar.c", R_OK)==0){
|
||||
+ tpltname = "/usr/share/lemon/lempar.c";
|
||||
}else{
|
||||
tpltname = pathsearch(lemp->argv0,templatename,0);
|
||||
}
|
||||
@@ -3374,7 +3376,7 @@ PRIVATE FILE *tplt_open(struct lemon *le
|
||||
}
|
||||
in = fopen(tpltname,"rb");
|
||||
if( in==0 ){
|
||||
- fprintf(stderr,"Can't open the template file \"%s\".\n",templatename);
|
||||
+ fprintf(stderr,"Can't open the template file \"%s\".\n",tpltname);
|
||||
lemp->errorcnt++;
|
||||
return 0;
|
||||
toFree = tpltname = pathsearch(lemp->argv0,templatename,0);
|
||||
}
|
||||
|
16
sqlite.spec
16
sqlite.spec
@ -4,15 +4,15 @@
|
||||
%bcond_with static
|
||||
%bcond_without check
|
||||
|
||||
%define realver 3330000
|
||||
%define docver 3330000
|
||||
%define rpmver 3.33.0
|
||||
%define realver 3340000
|
||||
%define docver 3340000
|
||||
%define rpmver 3.34.0
|
||||
%define year 2020
|
||||
|
||||
Summary: Library that implements an embeddable SQL database engine
|
||||
Name: sqlite
|
||||
Version: %{rpmver}
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
License: Public Domain
|
||||
URL: http://www.sqlite.org/
|
||||
|
||||
@ -212,10 +212,6 @@ export MALLOC_CHECK_=3
|
||||
rm test/csv01.test
|
||||
%endif
|
||||
|
||||
%ifarch s390x ppc64
|
||||
rm test/fts3conf.test
|
||||
%endif
|
||||
|
||||
make test
|
||||
%endif #with check
|
||||
|
||||
@ -259,6 +255,10 @@ make test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Dec 02 2020 Ondrej Dubaj <odubaj@redhat.com> - 3.34.0-1
|
||||
- Updated to version 3.34.0 (https://sqlite.org/releaselog/3_34_0.html)
|
||||
- Enabled fts3conf.test on s390x and ppc64 architectures
|
||||
|
||||
* Fri Oct 09 2020 Sheng Mao <shngmao@gmail.com> - 3.33.0-2
|
||||
- Enable FTS4 extensions (rhbz#1887106)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user