Update to 0.22.0
Signed-off-by: Victor Toso <victortoso@redhat.com>
This commit is contained in:
parent
a3cda27118
commit
5474c84190
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@
|
||||
/victortoso-E37A484F.keyring
|
||||
/jrope-7FDAB9AF.keyring
|
||||
/spice-vdagent-0.21.0.tar.bz2.sig
|
||||
/spice-vdagent-0.22.0.tar.bz2.sig
|
||||
|
@ -1,63 +0,0 @@
|
||||
From 2574422c8459daa063e8b3768bffe0da8fe347b5 Mon Sep 17 00:00:00 2001
|
||||
From: Rex Dieter <rdieter@gmail.com>
|
||||
Date: Fri, 16 Jul 2021 11:03:54 -0500
|
||||
Subject: [PATCH 4/4] Provide systemd user spice-vdagent.service
|
||||
|
||||
---
|
||||
Makefile.am | 5 +++++
|
||||
configure.ac | 2 ++
|
||||
data/spice-vdagent.service | 5 +++++
|
||||
3 files changed, 12 insertions(+)
|
||||
create mode 100644 data/spice-vdagent.service
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index e8fa4a6..9c30bae 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -167,6 +167,10 @@ systemdunit_DATA = \
|
||||
$(top_srcdir)/data/spice-vdagentd.service \
|
||||
$(top_srcdir)/data/spice-vdagentd.socket
|
||||
|
||||
+userunitdir = $(SYSTEMDUSERUNITDIR)
|
||||
+userunit_DATA = \
|
||||
+ $(top_srcdir)/data/spice-vdagent.service
|
||||
+
|
||||
udevrulesdir = $(udevdir)/rules.d
|
||||
udevrules_DATA = $(top_srcdir)/data/70-spice-vdagentd.rules
|
||||
|
||||
@@ -185,6 +189,7 @@ EXTRA_DIST = \
|
||||
CHANGELOG.md \
|
||||
data/70-spice-vdagentd.rules \
|
||||
data/spice-vdagent.desktop \
|
||||
+ data/spice-vdagent.service \
|
||||
data/spice-vdagentd \
|
||||
data/spice-vdagentd.service \
|
||||
data/spice-vdagentd.socket \
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 3de9b9b..f6abf3d 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -64,7 +64,9 @@ AC_MSG_RESULT($with_init_script)
|
||||
|
||||
if test "x$init_systemd" = "xyes"; then
|
||||
SYSTEMDSYSTEMUNITDIR=`${PKG_CONFIG} systemd --variable=systemdsystemunitdir`
|
||||
+ SYSTEMDUSERUNITDIR=`${PKG_CONFIG} systemd --variable=systemduserunitdir`
|
||||
AC_SUBST(SYSTEMDSYSTEMUNITDIR)
|
||||
+ AC_SUBST(SYSTEMDUSERUNITDIR)
|
||||
# earlier versions of systemd require a separate libsystemd-daemon library
|
||||
PKG_CHECK_MODULES([LIBSYSTEMD_DAEMON],
|
||||
[libsystemd >= 209],
|
||||
diff --git a/data/spice-vdagent.service b/data/spice-vdagent.service
|
||||
new file mode 100644
|
||||
index 0000000..09590b9
|
||||
--- /dev/null
|
||||
+++ b/data/spice-vdagent.service
|
||||
@@ -0,0 +1,5 @@
|
||||
+[Unit]
|
||||
+Description=Spice guest session agent
|
||||
+
|
||||
+[Service]
|
||||
+ExecStart=/usr/bin/spice-vdagent -x
|
||||
--
|
||||
2.31.1
|
||||
|
@ -1,112 +0,0 @@
|
||||
From 8348ef3c6121247e2b8be0641bbf3df3d55d9bff Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Marc-Andr=C3=A9=20Lureau?= <marcandre.lureau@redhat.com>
|
||||
Date: Tue, 4 May 2021 13:20:47 +0400
|
||||
Subject: [PATCH] Fix g_memdup deprecation warning with glib >= 2.68
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Related to:
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1943059
|
||||
|
||||
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
|
||||
---
|
||||
configure.ac | 4 ++++
|
||||
src/vdagent/vdagent.c | 4 ++--
|
||||
src/vdagent/x11-randr.c | 2 +-
|
||||
src/vdagentd/vdagentd.c | 8 ++++----
|
||||
4 files changed, 11 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 7b2a99c..3de9b9b 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -124,6 +124,10 @@ PKG_CHECK_MODULES(ALSA, [alsa >= 1.0.22])
|
||||
PKG_CHECK_MODULES([DBUS], [dbus-1])
|
||||
PKG_CHECK_MODULES([DRM], [libdrm])
|
||||
|
||||
+PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.68], [], [
|
||||
+ AC_DEFINE(g_memdup2, g_memdup, [GLib2 < 2.68 compatibility])
|
||||
+])
|
||||
+
|
||||
if test "$with_session_info" = "auto" || test "$with_session_info" = "systemd"; then
|
||||
PKG_CHECK_MODULES([LIBSYSTEMD_LOGIN],
|
||||
[libsystemd >= 209],
|
||||
diff --git a/src/vdagent/vdagent.c b/src/vdagent/vdagent.c
|
||||
index 0c69907..fd08522 100644
|
||||
--- a/src/vdagent/vdagent.c
|
||||
+++ b/src/vdagent/vdagent.c
|
||||
@@ -228,7 +228,7 @@ static void daemon_read_complete(UdscsConnection *conn,
|
||||
break;
|
||||
case VDAGENTD_AUDIO_VOLUME_SYNC: {
|
||||
VDAgentAudioVolumeSync *avs = (VDAgentAudioVolumeSync *)data;
|
||||
- uint16_t *volume = g_memdup(avs->volume, sizeof(uint16_t) * avs->nchannels);
|
||||
+ uint16_t *volume = g_memdup2(avs->volume, sizeof(uint16_t) * avs->nchannels);
|
||||
|
||||
if (avs->is_playback) {
|
||||
vdagent_audio_playback_sync(avs->mute, avs->nchannels, volume);
|
||||
@@ -414,7 +414,7 @@ int main(int argc, char *argv[])
|
||||
GOptionContext *context;
|
||||
GError *error = NULL;
|
||||
VDAgent *agent;
|
||||
- char **orig_argv = g_memdup(argv, sizeof(char*) * (argc+1));
|
||||
+ char **orig_argv = g_memdup2(argv, sizeof(char*) * (argc+1));
|
||||
orig_argv[argc] = NULL; /* To avoid clang analyzer false-positive */
|
||||
|
||||
context = g_option_context_new(NULL);
|
||||
diff --git a/src/vdagent/x11-randr.c b/src/vdagent/x11-randr.c
|
||||
index 27404a1..037aded 100644
|
||||
--- a/src/vdagent/x11-randr.c
|
||||
+++ b/src/vdagent/x11-randr.c
|
||||
@@ -982,7 +982,7 @@ void vdagent_x11_set_monitor_config(struct vdagent_x11 *x11,
|
||||
fullscreen it will keep sending the failing config. */
|
||||
g_free(x11->randr.failed_conf);
|
||||
x11->randr.failed_conf =
|
||||
- g_memdup(mon_config, config_size(mon_config->num_of_monitors));
|
||||
+ g_memdup2(mon_config, config_size(mon_config->num_of_monitors));
|
||||
return;
|
||||
}
|
||||
}
|
||||
diff --git a/src/vdagentd/vdagentd.c b/src/vdagentd/vdagentd.c
|
||||
index 78378aa..3e59331 100644
|
||||
--- a/src/vdagentd/vdagentd.c
|
||||
+++ b/src/vdagentd/vdagentd.c
|
||||
@@ -216,7 +216,7 @@ static void do_client_monitors(VirtioPort *vport, int port_nr,
|
||||
vdagentd_write_xorg_conf(new_monitors);
|
||||
|
||||
g_free(mon_config);
|
||||
- mon_config = g_memdup(new_monitors, size);
|
||||
+ mon_config = g_memdup2(new_monitors, size);
|
||||
|
||||
/* Send monitor config to currently active agent */
|
||||
if (active_session_conn)
|
||||
@@ -249,7 +249,7 @@ static void do_client_capabilities(VirtioPort *vport,
|
||||
{
|
||||
capabilities_size = VD_AGENT_CAPS_SIZE_FROM_MSG_SIZE(message_header->size);
|
||||
g_free(capabilities);
|
||||
- capabilities = g_memdup(caps->caps, capabilities_size * sizeof(uint32_t));
|
||||
+ capabilities = g_memdup2(caps->caps, capabilities_size * sizeof(uint32_t));
|
||||
|
||||
if (caps->request) {
|
||||
/* Report the previous client has disconnected. */
|
||||
@@ -647,7 +647,7 @@ static void virtio_port_read_complete(
|
||||
case VD_AGENT_GRAPHICS_DEVICE_INFO: {
|
||||
// store device info for re-sending when a session agent reconnects
|
||||
g_free(device_info);
|
||||
- device_info = g_memdup(data, message_header->size);
|
||||
+ device_info = g_memdup2(data, message_header->size);
|
||||
device_info_size = message_header->size;
|
||||
forward_data_to_session_agent(VDAGENTD_GRAPHICS_DEVICE_INFO, data, message_header->size);
|
||||
break;
|
||||
@@ -1090,7 +1090,7 @@ static void do_agent_xorg_resolution(UdscsConnection *conn,
|
||||
}
|
||||
|
||||
g_free(agent_data->screen_info);
|
||||
- agent_data->screen_info = g_memdup(data, header->size);
|
||||
+ agent_data->screen_info = g_memdup2(data, header->size);
|
||||
agent_data->width = header->arg1;
|
||||
agent_data->height = header->arg2;
|
||||
agent_data->screen_count = n;
|
||||
--
|
||||
GitLab
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (jrope-7FDAB9AF.keyring) = 5d12e4eca58ac9895c6e4d5df6a17cdba583994d7cb628dbf669bbb6aa19c31621ebb0bd555780bdd5553d062ba658243a47ea470fdb2ae16e1f0859499e27a0
|
||||
SHA512 (spice-vdagent-0.21.0.tar.bz2) = 1ff1a89e75301b1c2c89f26ba4bce8d4df29bbff6387ade128ce847ca30162a2bc731c70c10a8d129518e64bbca6b8271fd11ff3e340899182a65a5295051bff
|
||||
SHA512 (spice-vdagent-0.21.0.tar.bz2.sig) = 877a6ff30c01bcc881dc609b5f96cb0cbd9f4b158bc37aceb09479cc02a88775695fc9399428fa68db73e6ea7e44a9f6f04fedbd1d7d731d19b1cbf9216ac7a6
|
||||
SHA512 (spice-vdagent-0.22.0.tar.bz2) = 959b218da440f54a29179b6c376c870afc54eda9763048953484b834f300be4ece78acbaf0c834a7252932deaa0bd62fcf13347694d2d0eda9dd031eaa945058
|
||||
SHA512 (spice-vdagent-0.22.0.tar.bz2.sig) = 6f32aa998aa6854e7c082f4a1cbcd04986427dc1fca60955b12180acd98364f4214ff5634b46d1caf83a6e8159d6ad0548c1b3e14e52183f7317861179587564
|
||||
SHA512 (victortoso-E37A484F.keyring) = 091755da8a358c8c8ebd3b5443b4b5eb3c260afed943454c085d48c973de6a42763547c321c64e4da5c1b2983ad0c5146aaeddeb1d54ef414f7e6a530a3bf14a
|
||||
|
@ -1,12 +1,12 @@
|
||||
Name: spice-vdagent
|
||||
Version: 0.21.0
|
||||
Release: 7%{?dist}
|
||||
Version: 0.22.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Agent for Spice guests
|
||||
License: GPLv3+
|
||||
URL: https://spice-space.org/
|
||||
Source0: https://spice-space.org/download/releases/%{name}-%{version}.tar.bz2
|
||||
Source1: https://spice-space.org/download/releases/%{name}-%{version}.tar.bz2.sig
|
||||
Source2: jrope-7FDAB9AF.keyring
|
||||
Source2: victortoso-E37A484F.keyring
|
||||
BuildRequires: make
|
||||
BuildRequires: systemd-devel
|
||||
BuildRequires: glib2-devel >= 2.50
|
||||
@ -19,13 +19,6 @@ BuildRequires: automake autoconf
|
||||
BuildRequires: gnupg2
|
||||
%{?systemd_requires}
|
||||
|
||||
# https://gitlab.freedesktop.org/spice/linux/vd_agent/-/merge_requests/37/
|
||||
Patch1: 0004-Provide-systemd-user-spice-vdagent.service.patch
|
||||
|
||||
# Upstream patch:
|
||||
# https://gitlab.freedesktop.org/spice/linux/vd_agent/-/commit/8348ef3c6121247e2b8be0641bbf3df3d55d9bff
|
||||
Patch2: 0005-fix_g_dupmem_deprecation.patch
|
||||
|
||||
%description
|
||||
Spice agent for Linux guests offering the following features:
|
||||
|
||||
@ -82,6 +75,9 @@ autoreconf -fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Feb 10 2022 Victor Toso <victortoso@redhat.com> 0.22.0-1
|
||||
- Update to spice-vdagent 0.22.0
|
||||
|
||||
* Mon Feb 07 2022 Stephen Gallagher <sgallagh@redhat.com> - 0.21.0-7
|
||||
- Fix build against GLib >= 2.68
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user