import spice-vdagent-0.18.0-3.el8
This commit is contained in:
commit
062df9f836
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/spice-vdagent-0.18.0.tar.bz2
|
1
.spice-vdagent.metadata
Normal file
1
.spice-vdagent.metadata
Normal file
@ -0,0 +1 @@
|
||||
2e18fc918c46cdca1f00a3ce3c139c93f68ab166 SOURCES/spice-vdagent-0.18.0.tar.bz2
|
@ -0,0 +1,40 @@
|
||||
From 44592b47a60b943b0e0990ad82644e7b9a2091ad Mon Sep 17 00:00:00 2001
|
||||
From: Victor Toso <me@victortoso.com>
|
||||
Date: Thu, 15 Nov 2018 16:47:33 +0100
|
||||
Subject: [PATCH] vdagent: Do not send empty screen resolution messages
|
||||
|
||||
Easier to trigger on Wayland guest by running
|
||||
|
||||
> xrandr --output XWAYLAND0 --rotate left
|
||||
|
||||
In current master, this causes the spice-vdagentd to disconnect from
|
||||
the client. In 0.18 branch (latest release), mouse becomes unusable as
|
||||
mentioned in the referred bug below.
|
||||
|
||||
Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1641723
|
||||
|
||||
Signed-off-by: Victor Toso <victortoso@redhat.com>
|
||||
---
|
||||
src/vdagent/x11-randr.c | 6 ++++++
|
||||
1 file changed, 6 insertions(+)
|
||||
|
||||
diff --git a/src/vdagent/x11-randr.c b/src/vdagent/x11-randr.c
|
||||
index 803cf73..708f060 100644
|
||||
--- a/src/vdagent/x11-randr.c
|
||||
+++ b/src/vdagent/x11-randr.c
|
||||
@@ -974,6 +974,12 @@ no_info:
|
||||
}
|
||||
}
|
||||
|
||||
+ if (screen_count == 0) {
|
||||
+ syslog(LOG_DEBUG, "Screen count is zero, are we on wayland?");
|
||||
+ g_free(res);
|
||||
+ return;
|
||||
+ }
|
||||
+
|
||||
if (x11->debug) {
|
||||
for (i = 0; i < screen_count; i++)
|
||||
syslog(LOG_DEBUG, "Screen %d %dx%d%+d%+d", i, res[i].width,
|
||||
--
|
||||
2.19.1
|
||||
|
29
SOURCES/0002-udscs-Avoid-file-descriptor-leak.patch
Normal file
29
SOURCES/0002-udscs-Avoid-file-descriptor-leak.patch
Normal file
@ -0,0 +1,29 @@
|
||||
From 248fb075d8b74ed2d2448822bbc69da4a2c1bb36 Mon Sep 17 00:00:00 2001
|
||||
From: Frediano Ziglio <fziglio@redhat.com>
|
||||
Date: Thu, 15 Nov 2018 21:55:11 +0000
|
||||
Subject: [PATCH] udscs: Avoid file descriptor leak
|
||||
|
||||
If connection fails the socket descriptor is not closed causing
|
||||
a leak.
|
||||
|
||||
Signed-off-by: Frediano Ziglio <fziglio@redhat.com>
|
||||
Acked-by: Victor Toso <victortoso@redhat.com>
|
||||
---
|
||||
src/udscs.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/udscs.c b/src/udscs.c
|
||||
index c439f23..0c52af3 100644
|
||||
--- a/src/udscs.c
|
||||
+++ b/src/udscs.c
|
||||
@@ -109,6 +109,7 @@ struct udscs_connection *udscs_connect(const char *socketname,
|
||||
if (conn->debug) {
|
||||
syslog(LOG_DEBUG, "connect %s: %m", socketname);
|
||||
}
|
||||
+ close(conn->fd);
|
||||
free(conn);
|
||||
return NULL;
|
||||
}
|
||||
--
|
||||
2.19.2
|
||||
|
203
SPECS/spice-vdagent.spec
Normal file
203
SPECS/spice-vdagent.spec
Normal file
@ -0,0 +1,203 @@
|
||||
Name: spice-vdagent
|
||||
Version: 0.18.0
|
||||
Release: 3%{?dist}
|
||||
Summary: Agent for Spice guests
|
||||
Group: Applications/System
|
||||
License: GPLv3+
|
||||
URL: https://spice-space.org/
|
||||
Source0: https://spice-space.org/download/releases/%{name}-%{version}.tar.bz2
|
||||
Patch00001: 0001-vdagent-Do-not-send-empty-screen-resolution-messages.patch
|
||||
Patch00002: 0002-udscs-Avoid-file-descriptor-leak.patch
|
||||
BuildRequires: git-core
|
||||
BuildRequires: systemd-devel glib2-devel spice-protocol >= 0.12.13
|
||||
BuildRequires: libpciaccess-devel libXrandr-devel libXinerama-devel
|
||||
BuildRequires: libXfixes-devel systemd desktop-file-utils libtool
|
||||
BuildRequires: alsa-lib-devel dbus-devel
|
||||
%{?systemd_requires}
|
||||
|
||||
%description
|
||||
Spice agent for Linux guests offering the following features:
|
||||
|
||||
Features:
|
||||
* Client mouse mode (no need to grab mouse by client, no mouse lag)
|
||||
this is handled by the daemon by feeding mouse events into the kernel
|
||||
via uinput. This will only work if the active X-session is running a
|
||||
spice-vdagent process so that its resolution can be determined.
|
||||
* Automatic adjustment of the X-session resolution to the client resolution
|
||||
* Support of copy and paste (text and images) between the active X-session
|
||||
and the client
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -S git_am
|
||||
#autoreconf -fi
|
||||
|
||||
|
||||
%build
|
||||
%configure --with-session-info=systemd --with-init-script=systemd
|
||||
make %{?_smp_mflags} V=2
|
||||
|
||||
|
||||
%install
|
||||
make install DESTDIR=$RPM_BUILD_ROOT V=2
|
||||
|
||||
|
||||
%post
|
||||
%systemd_post spice-vdagentd.service spice-vdagentd.socket
|
||||
|
||||
%preun
|
||||
%systemd_preun spice-vdagentd.service spice-vdagentd.socket
|
||||
|
||||
%postun
|
||||
%systemd_postun_with_restart spice-vdagentd.service spice-vdagentd.socket
|
||||
|
||||
|
||||
%files
|
||||
%doc COPYING ChangeLog README TODO
|
||||
/usr/lib/udev/rules.d/70-spice-vdagentd.rules
|
||||
%{_unitdir}/spice-vdagentd.service
|
||||
%{_unitdir}/spice-vdagentd.socket
|
||||
%{_prefix}/lib/tmpfiles.d/spice-vdagentd.conf
|
||||
%{_bindir}/spice-vdagent
|
||||
%{_sbindir}/spice-vdagentd
|
||||
%{_var}/run/spice-vdagentd
|
||||
%{_sysconfdir}/xdg/autostart/spice-vdagent.desktop
|
||||
# For /usr/share/gdm/autostart/LoginWindow/spice-vdagent.desktop
|
||||
# We own the dir too, otherwise we must Require gdm
|
||||
%{_datadir}/gdm
|
||||
%{_mandir}/man1/%{name}*.1*
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Dec 18 2018 Victor Toso <victortoso@redhat.com> 0.18.0-3
|
||||
- Fix leak of unix sockets.
|
||||
Resolves: rhbz#1660108
|
||||
|
||||
* Thu Nov 15 2018 Victor Toso <victortoso@redhat.com> 0.18.0-2
|
||||
- Fix unusable mouse on xorg resolution event in wayland
|
||||
Resolves: rhbz#1641723
|
||||
|
||||
* Tue Jun 12 2018 Victor Toso <victortoso@redhat.com> 0.18.0-1
|
||||
- Update to spice-vdagent 0.18.0
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.17.0-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Jan 25 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.17.0-5
|
||||
- Fix systemd executions/requirements
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.17.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.17.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.17.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Tue Nov 22 2016 Christophe Fergeau <cfergeau@redhat.com> 0.17.0-1
|
||||
- Update to spice-vdagent 0.17.0
|
||||
|
||||
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.16.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Mon Oct 05 2015 Christophe Fergeau <cfergeau@redhat.com> 0.16.0-2
|
||||
- Add upstream patch fixing a memory corruption bug (double free)
|
||||
Resolves: rhbz#1268666
|
||||
Exit with a non-0 exit code when the virtio device cannot be opened by the
|
||||
agent
|
||||
|
||||
* Tue Jun 30 2015 Christophe Fergeau <cfergeau@redhat.com> 0.16.0-1
|
||||
- Update to 0.16.0 release
|
||||
|
||||
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.15.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sat Feb 21 2015 Till Maas <opensource@till.name> - 0.15.0-4
|
||||
- Rebuilt for Fedora 23 Change
|
||||
https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
|
||||
|
||||
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.15.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.15.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Mon Oct 14 2013 Alon Levy <alevy@redhat.com> - 0.15.0-1
|
||||
- New upstream release 0.15.0
|
||||
|
||||
* Tue Sep 10 2013 Hans de Goede <hdegoede@redhat.com> - 0.14.0-5
|
||||
- Silence session agent error logging when not running in a vm (rhbz#999804)
|
||||
- Release guest clipboard ownership on client disconnect (rhbz#1003977)
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.14.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Wed Jul 3 2013 Hans de Goede <hdegoede@redhat.com> - 0.14.0-3
|
||||
- Advertise clipboard line-endings for copy and paste line-ending conversion
|
||||
- Build spice-vdagentd as pie + relro
|
||||
|
||||
* Mon May 20 2013 Hans de Goede <hdegoede@redhat.com> - 0.14.0-2
|
||||
- Drop the no longer needed /etc/modules-load.d/spice-vdagentd.conf (#963201)
|
||||
|
||||
* Fri Apr 12 2013 Hans de Goede <hdegoede@redhat.com> - 0.14.0-1
|
||||
- New upstream release 0.14.0
|
||||
- Adds support for file transfers from client to guest
|
||||
- Adds manpages for spice-vdagent and spice-vdagentd
|
||||
|
||||
* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Tue Jan 8 2013 Hans de Goede <hdegoede@redhat.com> - 0.12.1-1
|
||||
- New upstream release 0.12.1
|
||||
- Fixes various issues with dynamic monitor / resolution support
|
||||
|
||||
* Mon Nov 12 2012 Hans de Goede <hdegoede@redhat.com> - 0.12.0-2
|
||||
- Fix setting of mode on non arbitrary resolution capable X driver
|
||||
- Fix wrong mouse coordinates on vms with multiple qxl devices
|
||||
|
||||
* Sat Sep 1 2012 Hans de Goede <hdegoede@redhat.com> - 0.12.0-1
|
||||
- New upstream release 0.12.0
|
||||
- This moves the tmpfiles.d to /usr/lib/tmpfiles.d (rhbz#840194)
|
||||
- This adds a systemd .service file (rhbz#848102)
|
||||
|
||||
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Tue Mar 27 2012 Hans de Goede <hdegoede@redhat.com> - 0.10.1-1
|
||||
- New upstream release 0.10.1
|
||||
|
||||
* Thu Mar 22 2012 Hans de Goede <hdegoede@redhat.com> - 0.10.0-1
|
||||
- New upstream release 0.10.0
|
||||
- This supports using systemd-logind instead of console-kit (rhbz#756398)
|
||||
|
||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Mon Jul 18 2011 Hans de Goede <hdegoede@redhat.com> 0.8.1-1
|
||||
- New upstream release 0.8.1
|
||||
|
||||
* Fri Jul 15 2011 Hans de Goede <hdegoede@redhat.com> 0.8.0-2
|
||||
- Make the per session agent process automatically reconnect to the system
|
||||
spice-vdagentd when the system daemon gets restarted
|
||||
|
||||
* Tue Apr 19 2011 Hans de Goede <hdegoede@redhat.com> 0.8.0-1
|
||||
- New upstream release 0.8.0
|
||||
|
||||
* Mon Mar 07 2011 Hans de Goede <hdegoede@redhat.com> 0.6.3-6
|
||||
- Fix setting of the guest resolution from a multi monitor client
|
||||
|
||||
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.3-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Mon Jan 10 2011 Hans de Goede <hdegoede@redhat.com> 0.6.3-4
|
||||
- Make sysvinit script exit cleanly when not running on a spice enabled vm
|
||||
|
||||
* Fri Nov 19 2010 Hans de Goede <hdegoede@redhat.com> 0.6.3-3
|
||||
- Put the pid and log files into their own subdir (#648553)
|
||||
|
||||
* Mon Nov 8 2010 Hans de Goede <hdegoede@redhat.com> 0.6.3-2
|
||||
- Fix broken multiline description in initscript lsb header (#648549)
|
||||
|
||||
* Sat Oct 30 2010 Hans de Goede <hdegoede@redhat.com> 0.6.3-1
|
||||
- Initial Fedora package
|
Loading…
Reference in New Issue
Block a user