import spice-protocol-0.12.14-1.el8
This commit is contained in:
commit
81832b6186
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/spice-protocol-0.12.14.tar.bz2
|
1
.spice-protocol.metadata
Normal file
1
.spice-protocol.metadata
Normal file
@ -0,0 +1 @@
|
||||
7c28a17a11d5c4ccd93fcae959a5f7ef2ee19ba7 SOURCES/spice-protocol-0.12.14.tar.bz2
|
75
SOURCES/0001-qxl_dev-Align-QXLRam-to-4-bytes.patch
Normal file
75
SOURCES/0001-qxl_dev-Align-QXLRam-to-4-bytes.patch
Normal file
@ -0,0 +1,75 @@
|
||||
From beda5ec7a6848be20c0cac2a9a8ef2a41e8069c1 Mon Sep 17 00:00:00 2001
|
||||
From: Frediano Ziglio <fziglio@redhat.com>
|
||||
Date: Thu, 28 Jun 2018 21:30:21 +0100
|
||||
Subject: [PATCH] qxl_dev: Align QXLRam to 4 bytes
|
||||
|
||||
This avoids compilers detect misaligned access which can lead to
|
||||
warnings.
|
||||
In QEMU the structure is allocated at the beginning of a 4Kb page,
|
||||
in Xspice is allocated with a calloc, so the structure will end up 4
|
||||
bytes aligned as well with these users. We are not aware of other users
|
||||
of QXLRam, but if there was, it's likely the struct would be at least
|
||||
naturally aligned, so this change should not impact anyone.
|
||||
Aligning to 4 bytes maintains the size of the structure unchanged
|
||||
avoiding possible ABI changes.
|
||||
clang currently generates an invalid function call if a misaligned
|
||||
4 byte atomic operation is detected.
|
||||
|
||||
This fixes https://bugzilla.redhat.com/show_bug.cgi?id=1565766
|
||||
|
||||
Signed-off-by: Frediano Ziglio <fziglio@redhat.com>
|
||||
Acked-by: Christophe Fergeau <cfergeau@redhat.com>
|
||||
---
|
||||
spice/end-packed.h | 1 +
|
||||
spice/qxl_dev.h | 2 +-
|
||||
spice/start-packed.h | 2 ++
|
||||
3 files changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/spice/end-packed.h b/spice/end-packed.h
|
||||
index 1acea18..0efd588 100644
|
||||
--- a/spice/end-packed.h
|
||||
+++ b/spice/end-packed.h
|
||||
@@ -32,6 +32,7 @@
|
||||
/* See start-packed.h for details */
|
||||
|
||||
#undef SPICE_ATTR_PACKED
|
||||
+#undef SPICE_ATTR_ALIGNED
|
||||
|
||||
#if defined(__MINGW32__) || !defined(__GNUC__)
|
||||
#pragma pack(pop)
|
||||
diff --git a/spice/qxl_dev.h b/spice/qxl_dev.h
|
||||
index 9e753c4..a9cc4f4 100644
|
||||
--- a/spice/qxl_dev.h
|
||||
+++ b/spice/qxl_dev.h
|
||||
@@ -253,7 +253,7 @@ SPICE_RING_DECLARE(QXLReleaseRing, uint64_t, QXL_RELEASE_RING_SIZE);
|
||||
#define QXL_INTERRUPT_CLIENT_MONITORS_CONFIG (1 << 5)
|
||||
|
||||
/* qxl-1 compat: append only */
|
||||
-typedef struct SPICE_ATTR_PACKED QXLRam {
|
||||
+typedef struct SPICE_ATTR_ALIGNED(4) SPICE_ATTR_PACKED QXLRam {
|
||||
uint32_t magic;
|
||||
uint32_t int_pending;
|
||||
uint32_t int_mask;
|
||||
diff --git a/spice/start-packed.h b/spice/start-packed.h
|
||||
index ab3fa98..de0c595 100644
|
||||
--- a/spice/start-packed.h
|
||||
+++ b/spice/start-packed.h
|
||||
@@ -48,6 +48,7 @@
|
||||
#ifdef __GNUC__
|
||||
|
||||
#define SPICE_ATTR_PACKED __attribute__ ((__packed__))
|
||||
+#define SPICE_ATTR_ALIGNED(n) __attribute__ ((__aligned__ (n)))
|
||||
|
||||
#ifdef __MINGW32__
|
||||
#pragma pack(push,1)
|
||||
@@ -58,6 +59,7 @@
|
||||
#pragma pack(push)
|
||||
#pragma pack(1)
|
||||
#define SPICE_ATTR_PACKED
|
||||
+#define SPICE_ATTR_ALIGNED(n) __declspec (align (n))
|
||||
#pragma warning(disable:4200)
|
||||
#pragma warning(disable:4103)
|
||||
|
||||
--
|
||||
2.17.1
|
||||
|
165
SPECS/spice-protocol.spec
Normal file
165
SPECS/spice-protocol.spec
Normal file
@ -0,0 +1,165 @@
|
||||
Name: spice-protocol
|
||||
Version: 0.12.14
|
||||
Release: 1%{?dist}
|
||||
Summary: Spice protocol header files
|
||||
Group: Development/Libraries
|
||||
# Main headers are BSD, controller / foreign menu are LGPL
|
||||
License: BSD and LGPLv2+
|
||||
URL: http://www.spice-space.org/
|
||||
Source0: http://www.spice-space.org/download/releases/%{name}-%{version}.tar.bz2
|
||||
Patch0001: 0001-qxl_dev-Align-QXLRam-to-4-bytes.patch
|
||||
BuildArch: noarch
|
||||
|
||||
BuildRequires: git-core
|
||||
|
||||
%description
|
||||
Header files describing the spice protocol
|
||||
and the para-virtual graphics card QXL.
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -S git_am
|
||||
|
||||
%build
|
||||
%configure
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
make DESTDIR=%{buildroot} install
|
||||
|
||||
|
||||
%files
|
||||
%doc COPYING NEWS
|
||||
%{_includedir}/spice-1
|
||||
%{_datadir}/pkgconfig/spice-protocol.pc
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jul 30 2018 Victor Toso <victortoso@redhat.com> - 0.12.14-1
|
||||
- Update to 0.12.14
|
||||
- Fix misaligned warnings - Resolves: rhbz#1565766
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.13-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.13-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Wed Jul 12 2017 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.12.13-1
|
||||
- Update to 0.12.13 release
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.12-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Fri Aug 05 2016 Christophe Fergeau <cfergeau@redhat.com> - 0.12.12-1
|
||||
- Update to 0.12.12 release
|
||||
|
||||
* Fri Mar 11 2016 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.12.11-1
|
||||
- Update to 0.12.11 release
|
||||
|
||||
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.10-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Thu Oct 01 2015 Christophe Fergeau <cfergeau@redhat.com> 0.12.10-1
|
||||
- Update to 0.12.10 - Add python scripts and .proto files used
|
||||
to generate spice-gtk/spice-server marshalling C code
|
||||
|
||||
* Wed Jul 29 2015 Christophe Fergeau <cfergeau@redhat.com> 0.12.9-1
|
||||
- Update to 0.12.9 - Fixes QEMU build failures when using 0.12.8 with
|
||||
spice-server 0.12.5
|
||||
|
||||
* Tue Jun 30 2015 Christophe Fergeau <cfergeau@redhat.com> 0.12.8-1
|
||||
- Update to 0.12.8
|
||||
|
||||
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12.7-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12.7-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Mon May 19 2014 Christophe Fergeau <cfergeau@redhat.com> 0.12.7-1
|
||||
- Update to 0.12.7
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Wed Jul 3 2013 Hans de Goede <hdegoede@redhat.com> - 0.12.6-1
|
||||
- Update to 0.12.6
|
||||
|
||||
* Thu Mar 7 2013 Hans de Goede <hdegoede@redhat.com> - 0.12.5-1
|
||||
- Update to 0.12.5
|
||||
|
||||
* Fri Feb 1 2013 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.12.4-1
|
||||
- Update to 0.12.4
|
||||
|
||||
* Thu Dec 20 2012 Hans de Goede <hdegoede@redhat.com> - 0.12.3-1
|
||||
- Update to 0.12.3
|
||||
|
||||
* Fri Sep 28 2012 Hans de Goede <hdegoede@redhat.com> - 0.12.2-1
|
||||
- Update to 0.12.2
|
||||
|
||||
* Thu Sep 6 2012 Soren Sandmann <ssp@redhat.com> - 0.12.1-1
|
||||
- Add patch1 and patch2 to support capability bits
|
||||
|
||||
* Thu Sep 6 2012 Soren Sandmann <ssp@redhat.com> - 0.12.1-1
|
||||
- Update to 0.12.1
|
||||
|
||||
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Mon Jan 16 2012 Hans de Goede <hdegoede@redhat.com> - 0.10.1-1
|
||||
- Update to 0.10.1
|
||||
|
||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Sun Nov 13 2011 Alon Levy <alevy@redhat.com> - 0.10.0-1
|
||||
- Update to 0.10.0
|
||||
|
||||
* Sun Oct 23 2011 Alon Levy <alevy@redhat.com> - 0.9.1-1
|
||||
- Update to 0.9.1
|
||||
|
||||
* Thu Aug 25 2011 Hans de Goede <hdegoede@redhat.com> - 0.9.0-1
|
||||
- Update to 0.9.0
|
||||
|
||||
* Mon Jul 25 2011 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.8.1-2
|
||||
- Added spice-protocol-0.8.1-define-INLINE.patch
|
||||
|
||||
* Tue Jul 19 2011 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.8.1-1
|
||||
- Update to 0.8.1
|
||||
|
||||
* Tue Mar 1 2011 Hans de Goede <hdegoede@redhat.com> - 0.8.0-1
|
||||
- Update to 0.8.0
|
||||
|
||||
* Fri Feb 11 2011 Hans de Goede <hdegoede@redhat.com> - 0.7.1-1
|
||||
- Update to 0.7.1
|
||||
|
||||
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Wed Jan 12 2011 Hans de Goede <hdegoede@redhat.com> - 0.7.0-2
|
||||
- Update License tag (controller and foreign menu headers are LGPL)
|
||||
|
||||
* Fri Dec 17 2010 Hans de Goede <hdegoede@redhat.com> - 0.7.0-1
|
||||
- Update to 0.7.0
|
||||
|
||||
* Mon Oct 18 2010 Hans de Goede <hdegoede@redhat.com> - 0.6.3-1
|
||||
- Update to 0.6.3
|
||||
|
||||
* Thu Sep 30 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.6.1-1
|
||||
- Update to 0.6.1.
|
||||
|
||||
* Tue Aug 31 2010 Alexander Larsson <alexl@redhat.com> - 0.6.0-1
|
||||
- Update to 0.6.0 (stable release)
|
||||
|
||||
* Tue Jul 20 2010 Alexander Larsson <alexl@redhat.com> - 0.5.3-1
|
||||
- Update to 0.5.3
|
||||
|
||||
* Mon Jul 12 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.5.2-2
|
||||
- Fix license: It is BSD, not GPL.
|
||||
- Cleanup specfile, drop bits not needed any more with
|
||||
recent rpm versions (F13+).
|
||||
|
||||
* Fri Jul 9 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.5.2-1
|
||||
- initial package.
|
||||
|
Loading…
Reference in New Issue
Block a user