Update to 0.12.11 release
This commit is contained in:
parent
e795910f7e
commit
4b9e428c71
1
.gitignore
vendored
1
.gitignore
vendored
@ -21,3 +21,4 @@ spice-protocol-0.5.3.tar.bz2
|
|||||||
/spice-protocol-0.12.8.tar.bz2
|
/spice-protocol-0.12.8.tar.bz2
|
||||||
/spice-protocol-0.12.9.tar.bz2
|
/spice-protocol-0.12.9.tar.bz2
|
||||||
/spice-protocol-0.12.10.tar.bz2
|
/spice-protocol-0.12.10.tar.bz2
|
||||||
|
/spice-protocol-0.12.11.tar.bz2
|
||||||
|
@ -1,55 +0,0 @@
|
|||||||
From c84d867e3c2a7393ff50bac8c6a806c39b8a5896 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Christophe Fergeau <cfergeau@redhat.com>
|
|
||||||
Date: Thu, 1 Oct 2015 18:21:56 +0200
|
|
||||||
Subject: [spice-protocol] build-sys: Use $datadir for .proto files/codegen
|
|
||||||
scripts
|
|
||||||
|
|
||||||
They are not arch-specific, so installing them in $libdir is not needed.
|
|
||||||
---
|
|
||||||
Makefile.am | 2 +-
|
|
||||||
python_modules/Makefile.am | 2 +-
|
|
||||||
spice-protocol.pc.in | 4 ++--
|
|
||||||
3 files changed, 4 insertions(+), 4 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/Makefile.am b/Makefile.am
|
|
||||||
index 53e87be..4af20db 100644
|
|
||||||
--- a/Makefile.am
|
|
||||||
+++ b/Makefile.am
|
|
||||||
@@ -2,7 +2,7 @@ NULL =
|
|
||||||
ACLOCAL_AMFLAGS = -I m4
|
|
||||||
SUBDIRS = python_modules spice
|
|
||||||
|
|
||||||
-codegendir = $(libdir)/spice-protocol
|
|
||||||
+codegendir = $(datadir)/spice-protocol
|
|
||||||
dist_codegen_DATA = \
|
|
||||||
spice.proto \
|
|
||||||
spice1.proto \
|
|
||||||
diff --git a/python_modules/Makefile.am b/python_modules/Makefile.am
|
|
||||||
index 3a4515a..98ab41f 100644
|
|
||||||
--- a/python_modules/Makefile.am
|
|
||||||
+++ b/python_modules/Makefile.am
|
|
||||||
@@ -1,6 +1,6 @@
|
|
||||||
NULL =
|
|
||||||
|
|
||||||
-python_codegendir = $(libdir)/spice-protocol/python_modules
|
|
||||||
+python_codegendir = $(datadir)/spice-protocol/python_modules
|
|
||||||
dist_python_codegen_DATA = \
|
|
||||||
__init__.py \
|
|
||||||
codegen.py \
|
|
||||||
diff --git a/spice-protocol.pc.in b/spice-protocol.pc.in
|
|
||||||
index 173781a..a55574f 100644
|
|
||||||
--- a/spice-protocol.pc.in
|
|
||||||
+++ b/spice-protocol.pc.in
|
|
||||||
@@ -1,7 +1,7 @@
|
|
||||||
prefix=@prefix@
|
|
||||||
-exec_prefix=@exec_prefix@
|
|
||||||
includedir=@includedir@
|
|
||||||
-codegendir=@libdir@/spice-protocol
|
|
||||||
+datadir=${prefix}/share
|
|
||||||
+codegendir=${datadir}/spice-protocol
|
|
||||||
|
|
||||||
Name: spice-protocol
|
|
||||||
Description: SPICE protocol headers
|
|
||||||
--
|
|
||||||
2.5.0
|
|
||||||
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
1fb9d0dcdd42dce1b476ae8aa7569bcc spice-protocol-0.12.10.tar.bz2
|
422bf0bc1eb34c8af3479a78b28e969b spice-protocol-0.12.11.tar.bz2
|
||||||
|
@ -1,17 +1,13 @@
|
|||||||
Name: spice-protocol
|
Name: spice-protocol
|
||||||
Version: 0.12.10
|
Version: 0.12.11
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Spice protocol header files
|
Summary: Spice protocol header files
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
# Main headers are BSD, controller / foreign menu are LGPL
|
# Main headers are BSD, controller / foreign menu are LGPL
|
||||||
License: BSD and LGPLv2+
|
License: BSD and LGPLv2+
|
||||||
URL: http://www.spice-space.org/
|
URL: http://www.spice-space.org/
|
||||||
Source0: http://www.spice-space.org/download/releases/%{name}-%{version}.tar.bz2
|
Source0: http://www.spice-space.org/download/releases/%{name}-%{version}.tar.bz2
|
||||||
Patch1: 0001-build-sys-Use-datadir-for-.proto-files-codegen-scrip.patch
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
BuildRequires: autoconf
|
|
||||||
BuildRequires: automake
|
|
||||||
BuildRequires: libtool
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Header files describing the spice protocol
|
Header files describing the spice protocol
|
||||||
@ -21,16 +17,10 @@ and the para-virtual graphics card QXL.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
# http://cgit.freedesktop.org/spice/spice-protocol/commit/?id=95b5617
|
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoreconf -fi
|
|
||||||
%configure
|
%configure
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
make DESTDIR=%{buildroot} install
|
make DESTDIR=%{buildroot} install
|
||||||
|
|
||||||
@ -39,10 +29,12 @@ make DESTDIR=%{buildroot} install
|
|||||||
%doc COPYING NEWS
|
%doc COPYING NEWS
|
||||||
%{_includedir}/spice-1
|
%{_includedir}/spice-1
|
||||||
%{_datadir}/pkgconfig/spice-protocol.pc
|
%{_datadir}/pkgconfig/spice-protocol.pc
|
||||||
%{_datadir}/spice-protocol
|
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Mar 11 2016 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.12.11-1
|
||||||
|
- Update to 0.12.11 release
|
||||||
|
|
||||||
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.10-2
|
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.10-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user