Merge branch 'master' into f20

Conflicts:
	spice-gtk.spec
This commit is contained in:
Marc-André Lureau 2013-09-18 19:08:10 +02:00
commit 9e227d54bf
4 changed files with 11 additions and 111 deletions

1
.gitignore vendored
View File

@ -20,3 +20,4 @@
/spice-gtk-0.18.tar.bz2
/spice-gtk-0.19.tar.bz2
/spice-gtk-0.20.tar.bz2
/spice-gtk-0.21.tar.bz2

View File

@ -1,91 +0,0 @@
From b85ca792af72d5f1e10aa6af9515eb96a044fc5c Mon Sep 17 00:00:00 2001
From: Hans de Goede <hdegoede@redhat.com>
Date: Wed, 26 Jun 2013 17:39:39 +0200
Subject: [PATCH spice-gtk] Add spice_channel_string_to_type to map files
And document both spice_channel_string_to_type and
spice_channel_type_to_string.
Signed-off-by: Hans de Goede <hdegoede@redhat.com>
---
doc/reference/spice-gtk-sections.txt | 1 +
gtk/map-file | 1 +
gtk/spice-channel.c | 18 ++++++++++++++++++
gtk/spice-glib-sym-file | 1 +
4 files changed, 21 insertions(+)
diff --git a/doc/reference/spice-gtk-sections.txt b/doc/reference/spice-gtk-sections.txt
index e1e2833..8d61aa9 100644
--- a/doc/reference/spice-gtk-sections.txt
+++ b/doc/reference/spice-gtk-sections.txt
@@ -98,6 +98,7 @@ spice_channel_disconnect
spice_channel_test_capability
spice_channel_test_common_capability
spice_channel_type_to_string
+spice_channel_string_to_type
spice_channel_set_capability
spice_channel_flush_async
spice_channel_flush_finish
diff --git a/gtk/map-file b/gtk/map-file
index a0b7330..a69eb40 100644
--- a/gtk/map-file
+++ b/gtk/map-file
@@ -11,6 +11,7 @@ spice_channel_get_type;
spice_channel_new;
spice_channel_open_fd;
spice_channel_set_capability;
+spice_channel_string_to_type;
spice_channel_test_capability;
spice_channel_test_common_capability;
spice_channel_type_to_string;
diff --git a/gtk/spice-channel.c b/gtk/spice-channel.c
index 0a32d6c..093b292 100644
--- a/gtk/spice-channel.c
+++ b/gtk/spice-channel.c
@@ -1884,6 +1884,15 @@ static const char *to_string[] = {
[ SPICE_CHANNEL_PORT ] = "port",
};
+/**
+ * spice_channel_type_to_string:
+ * @type: a channel-type property value
+ *
+ * Convert a channel-type property value to a string.
+ *
+ * Returns: string representation of @type.
+ * Since: 0.20
+ **/
const gchar* spice_channel_type_to_string(gint type)
{
const char *str = NULL;
@@ -1895,6 +1904,15 @@ const gchar* spice_channel_type_to_string(gint type)
return str ? str : "unknown channel type";
}
+/**
+ * spice_channel_string_to_type:
+ * @str: a string representation of the channel-type property
+ *
+ * Convert a channel-type property value to a string.
+ *
+ * Returns: the channel-type property value for a @str channel
+ * Since: 0.21
+ **/
gint spice_channel_string_to_type(const gchar *str)
{
int i;
diff --git a/gtk/spice-glib-sym-file b/gtk/spice-glib-sym-file
index 2b172d0..8540307 100644
--- a/gtk/spice-glib-sym-file
+++ b/gtk/spice-glib-sym-file
@@ -14,6 +14,7 @@ spice_channel_set_capability
spice_channel_test_capability
spice_channel_test_common_capability
spice_channel_type_to_string
+spice_channel_string_to_type
spice_client_error_quark
spice_cursor_channel_get_type
spice_display_channel_get_type
--
1.8.3.rc1.49.g8d97506

View File

@ -1 +1 @@
9ef6b7f2f368b7966029b7834b7c2bec spice-gtk-0.20.tar.bz2
290d1ad5ab8f1e5708fa2549dde2e024 spice-gtk-0.21.tar.bz2

View File

@ -12,8 +12,8 @@
#define _version_suffix
Name: spice-gtk
Version: 0.20
Release: 6%{?dist}
Version: 0.21
Release: 1%{?dist}
Summary: A GTK+ widget for SPICE clients
Group: System Environment/Libraries
@ -21,13 +21,6 @@ License: LGPLv2+
URL: http://spice-space.org/page/Spice-Gtk
#VCS: git:git://anongit.freedesktop.org/spice/spice-gtk
Source0: http://www.spice-space.org/download/gtk/%{name}-%{version}%{?_version_suffix}.tar.bz2
Patch1: 0001-Add-spice_channel_string_to_type-to-map-files.patch
Patch2: 0002-smartcard-Handle-VCARD_EMUL_INIT_ALREADY_INITED.patch
Patch3: 0003-channel-main-Convert-text-line-endings-if-necessary-.patch
Patch4: 0004-usb-widget-fix-gtk2-Python-bindings.patch
Patch5: 0005-glib-compat-g_slist_free_full-pass-the-right-ptr-to-.patch
Patch6: 0006-gtk-channel-cursor.c-add-cursor_type_to_string-for-d.patch
Patch7: 0007-gtk-channel-cursor-copy-spicec-hack-RHBZ-998529.patch
BuildRequires: intltool
BuildRequires: gtk2-devel >= 2.14
@ -153,16 +146,10 @@ if [ -n '%{?_version_suffix}' ]; then
mv spice-gtk-%{version}%{?_version_suffix} spice-gtk-%{version}
fi
pushd spice-gtk-%{version}
%patch0001 -p1
%patch0002 -p1
%patch0003 -p1
%patch0004 -p1
%patch0005 -p1
%patch0006 -p1
%patch0007 -p1
find . -name '*.stamp' | xargs touch
popd
#pushd spice-gtk-%{version}
#%patch1 -p1
#find . -name '*.stamp' | xargs touch
#popd
%if %{with_gtk3}
cp -a spice-gtk-%{version} spice-gtk3-%{version}
@ -282,6 +269,9 @@ rm -rf %{buildroot}%{_datadir}/pkgconfig/spice-protocol.pc
%{_bindir}/spicy-stats
%changelog
* Wed Sep 18 2013 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.21-1
- Update to spice-gtk 0.21
* Fri Sep 13 2013 Christophe Fergeau <cfergeau@redhat.com> 0.20-6
- Add misc upstream patches fixing various 0.20 bugs